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ABSTRACT

This document is a user guide for the software product, the Scenario Analysis
Tool Suite (version 1.5). The tool suite implements several scenario analy-
sis techniques, Morphological analysis, Field Anomaly Relaxation analysis,
Battelle approach, Bayesian approach, as well as an extended approach of
combining methods. Thus the tool provides the opportunity to compare these
techniques using a specific strategic question and provides computer support
for the new combined technique.
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1 Introduction

The Scenario Analysis Tool Suite (version 1.5) which is comprised of both the Morpho-
logical Analysis Tool and the Combined Approach Tool, has been created as a practical
companion to the report on Scenario Analysis Methods in Defence Strategic Planning [6].
The report itself compares several techniques used in scenario analysis and identifies
their usefulness and limitations.

Noticeably, non-Bayesian method (e.g. Morphological Analysis (MA) [17], Battelle
approach [16], Field Anomaly Relaxation (FAR) [1, 2, 8, 9, 10]} does not consider the
probabilities of influencing factors on the problem investigated, therefore, the selected
scenarios may have very small probabilities and could not practically be a basis of a
meaningful planning effort. While the Bayesian method (e.g. Cross-Impact Analysis
using System of Equations [11, 12], or Goal Programming (GP) [3]) requires marginal
and conditional probabilities for the pairs of factors as input. High demands are therefore
placed on the expert’s ability and willingness to make these estimates. Furthermore, the
Bayesian method takes all scenarios into consideration. In consequence, the scenario
probabilities are often very small.

The purpose of the strategic planning process is to reflect possible alternative devel-
opments which are constructed using quantitative data as well as the experience and
intuition of experts and stakeholders. However, they are unlikely to be interested in the
mathematical aspects of the scenario analysis. Hence the information required from them
should be kept as simple as possible. A new technique which combines all the above
methods in light of these requirements is created and the tool provides the opportunity
to compare these techniques using a specific strategic question and provides computer
support for this new technique.

Scenario development is a function carried outby many groups within Defence. Many of
these groups have been supported by analysis from DSTO and other organisations and
some have had associated software developed [7, 13, 15]. This tool differs from past work
by incorporating various methods within a single program.

The Tool Suite is a software product which has the capability to conduct the follow-
ing techniques: Morphological Analysis and Combined approach (thus including the
Field Anomaly Relaxation, Battelle approach, Bayesian approach, and some extended
methods: Cluster analysis, Integer Programming). Its aim is to remove the limitation
on scenario development by the use of manual methods as described in Rhyne [10]
which states that the vast number of configurations, makes removing an incompatible
pair “... a tedious, errcr-prone task when done by hand’. The system will provide a means
of implementing the manual steps, through the use of software and provide capture
(by means of saving and allowing the user to go back) of the process so that it may be
exported for scenario composition. The capture must be ‘whole’ in the sense that the
system may be exported at any stage and continued manually.

The free, open-source integrated development environment (IDE) NetBeans [14] was
used in the creation of Graphical User Interface (GUI) for the tool suite. External
mathematical programming solver GLPK [5] and Statistical Package R [4] are the main
engines for solving mathematical models and analysing results.



and Justin Beck both of Joint Operations Division.

2  Getting Started

2.1 Installation of the Scenario Analysis Tool Suite

To install the Scenario Analysis Tool Suite!, follow the steps below:

1. Download a zip file? “ScenarioAnalysis ToolSuite-v1.5.2ip".
2. Unzip it to get the executable file “ScenarioAnalysis Tool Suite-v1.5.exe"

3. Double-click the executable file to start the installation process. The screen shown
in Figure 1 is the screen which the user will be prompted with.

ﬂ_,' Scenario Analysis Tool Suite 1.5 - Excelsior Installer o |EI|1|

| Welcome to Excelsior Installer for Scengrio
| Analysis Tool Suite 1.5 1}\

Excelsior Installer will guide you through installation of the
software on your computer, To proceed, click Mext,

Cancel |

Figure 1: Installation of the Scenario Analysis Tool Suite

1This doctmentation refers to the installation of the version 1.5 of Scenario Analysis Tool Suite released
on the 20-03-2008,

IThe exact location of the file on the DSTO Community Portal can be cbtained by contacting M.-T.
Nguyen, minh-tuan.nguyen@dsto.defence.govau.
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4. Clicking the Next > button and following the instructions detailed in the panels will
install the software. It will then be available from the Start Menu in the directory
which has been specified.

It should be noted that the two external tools, the mathematical programming solver
GLPK [5] and the Statistical Package R [4] have been packaged into the above installation
program.

2.2 Installation of Java Runtime Environment (JRE)

JRE 1.6 is used for running the Tool Suite, thus it is recommended that this version is
installed on the machine on which the executable will be run on. Java JRE 1.6 can be
downloaded from http://java.sun.com .

3 Exploring the Morphological Analysis Tool
Environment

This section of the document aims to guide the user® through the Morphological Analysis
Tool, referred to from now as the MA Tool. It supports a brainstorming process that
ultimately produces amongst other things a matrix of pairs of factors* (also referred to
as a morphological space in literature) thereby helping to explore a strategic question®.
The tool and the documentation assume that the user using the tool is familiar with the
morphological analysis method® [17].

The MA Tool is a standalone tool that can be used to perform a complete morphological
analysis. It was designed with the intent that it would normally be used in combination
with the Combined Analysis Tool that is described in Section 4 and 6 of this report.

3.1 Running MA Tool
To run the MA Tool:

1. From the Start Menu navigate to the directory in which the Scenario Analysis Tool
Suite has been installed.

2. Click "Morphological Analysis Tool”. This will run the tool and display the screen
shown in Figure 2.

3The user has been identified as a decision maker in the field of strategic planning who is familiar with
the morphological analysis technique and does not require familiarization with the technique.

#The MA Tool employs the terminology used in the Field Anomaly Relaxation method [10] by replacing
the word component with sector and configuration with factor.

5The question being explored does not need to be one specific to strategy. The method allows exploration
of any qualitative problem space.

&1t is also presumed that the user is familiar with the terminology of the Field Anomaly Relaxation.
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EMulphulugical Analygis Tool 1.0 o = | _55]

File Morphological Analysis  Help

=]

-Getting Started Morphological lysi: —
| Open an existing Morphological Analysis. .. B
- . Usefulness and Limitations
| Create & new Morphological Analysis... Morphological analysis stimulates the imaginstion and enables one to scan the Field of possibilities systematically, The: First limitation of MA& stems
User Docurmentation From the choice of components, By leaving out a compaonent or simply a configuration that is essential for the fture,; one runs the risk of lsaving

ouk one complete Facet fromthe range of possibilities - 3 range which is not restricted but evaolves through time. The second imikation, of
course, stems from the sheer bulk, of combinations which can rapidly submerge the user,

Input
The techrique requires that the user identifies and breaks downithe system under analysis into descriptors and figlds.

Output %

The techrique derives a matrix of figlds, ready For comparative analysis,

Bacl Mext

Figure 2: Morphological Analysis Tool Welcome Screen

3.2 Navigation

MA Teol interface as seen in Figure 2 allows the user to progress through the morpholog-
ical analysis method by providing the use of Back and Next buttons located at the bottom
right of each step (the welcome screen can be accessed from any stage of the method by
choosing Help > Welcome screen). There are three steps in the morphological analvsis:
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1. Choose File > New Analysis

2. You will then be prompted to save the current analysis. Click Yes, to save the
analysis and follow the steps in Section 3.4.2. Click Ng, to continue without saving
the current analysis and this will take you to the first phase of the analysis. Clicking
Cancel will dismiss the action and return to the previous state of the program.

Alternatively, click Create a new Morphological Analysis when on the Welcome screen.
This action will also prompt to save and go through the same procedure described in
Section 3.4.2.

3.4.2 Save Analysis

An analysis that has been completed can be saved for future use and an incomplete one
can be saved so that it can be completed later. To save the current analysis:

1. Choose File > Save Analysis.

2. At the Save prompt, choose a directory and enter a file name for the analysis in the
standard windows interface.

3. Click Save to continue saving the analysis, or click Cancel to return to the program.

3.4.3 Open a Morphological Analysis

A previously saved file can be loaded for reference, completion or to be modified. An
example save file is include in the base directory of the default package and is called
‘exampie.ma’. To open this or another existing morphological analysis:

1. Choose File > Open Morphological Analysis.
2. Select the file from the standard windows interface. By convention files that are
able to be loaded should have the .ma extension.

3.4.4 Export Analysis

To export the current analysis: Choose File > Export Analysis. A readable form of the
analysis will be available in the default directory indicated by the message box. The
readable form can be opened in an internet browser program. It can then be printed from
there.

3.4.5 Exit Program

To exit the program: Choose File > Exit. A prompt to save the current analysis will appear,
and the same procedure described in Section 3.4.2 can be followed to guide through this
process.
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4 Exploring the Combined Approach Tool

Environment

This section of the document aims to guide the user through the Combined Approach Tool.
It supperts the importation of a moerphological analysis created with the MA Tool, and
allows the user to step through the Battelle, Bayesian, Cluster Analysis and Integer Linear
Programming techniques. The tool can be stopped and exported at any stage of the
Combined Approach if enly a portion of the techniques were of interest.

4.1 Running Combined Approach Tool

To run the Combined Approach Tool:

1. From the Start menu, navigate te the directory in which the Scenario Analysis Tool
Suite is installed.

2. Click the Combined Approach Tool torun it. This action will display the screen shown
in Figure 3.

B3 Combined Approach Tool 1.5 =10 x|
File Combined Analysis  -elp

FIE

-Getting Started -Combined Approach

Upen an existing Morphological Analysis. ..
usefulness and Limitations

Create a new Morpholocical Analysis...

User Docurmentation The Combined Approach offers 5 promisingly aspect of the scenario analysis as starking with relatively simple information demanded From
Decision Makers and car determine possible main scenarios and their probabilities, as wel as a balanced mix of these plausible Futures for
scenario development,

Input
This technigue requires the existance of a matrix of pairs from & Maorphological Analysis, compatibility ratings of Factor pairs, and marginal
probabiliy values of all factors,

DOutput

The technique generates a list of compatible scenarios with their average compatibility walus and probabilicy. It then groups these scenarios
into dusters to evaluate the average compatibilicy; probabilicy of the clusters, Statistical nformation {mean, mode; median, maximum and
minimumy is also determined for each sector of each cluster,

Mext

Figure 3: Combined Approach Tool Welcome Screen

4.2 Navigation

The Combined Approach Tool provides the same navigation functionality as the MA Tool;
the use of Back and Next buttons located at the bottom right corner of the screen, or by
selecting the desired panel from the Combined Aralysis menu option located at the top of
the program. The tool has been split into the following panels: Matrix of Pairs & Marginal
Probabilities, Selected Compatible Scenarios, Scenario Probabilities, Cluster Analysis and integer
Lingar Programming.
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4.3 User Help

The user may retrieve assistance in using the program by choosing

Help > User Documentation. This will open the user documentation for reference whilst
using the tool. Or alternatively, click on User Documentation via the Welcome screen
shown in Figure 3.

4.4 Basic Functionality
4.4.1 Creating a New Combined Approach Analysis

A Combined Approach analysis requires the existence of a morphological analysis, thus a
combined approach analysis cannot be created without first conducting a morphological
analysis. To create a morphological analysis, see Section 5, or follow the steps in
Section 4.4.3. If a morphological analysis already exists, steps in Section 4.4.2 can
be followed to open the analysis. After which analysis can be saved as a Combined
Approach analysis.

An example morphological analysis named ‘example.ma’ is provided with the tool and
can be found in the base directory.

4.4.2 Opening a Morphological Analysis

To open a morphological analysis, implement the following steps:
1. Click File > Open Analysis. This will display a standard windows Open Dialog box.
2. Locate the directory in which the morphological analysis file is located.
3. Locate the analysis file with the .ma extension, and click on the filename. This will

update the File Name input field with the name of the file.
4. Click the Open button.

4.4.3 Create a New Morphological Analysis
To create a new morphological analysis, either follow the steps in Section 5 or on the

Welcome screen, click Create a new Morphological AnalysisE text on the left-hand Getting
Started category. This will launch the MA Tool.

5 Creating a Morphological Analysis

5.1 Brainstorming a Question

The user may brainstorm a question and record this by entering the question into the
text area adjacent to the question indicator in the Brainstorm Question step, as seen in
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Figure 4. This may be revised later even if the user has progressed to later screens by
using the back button.

Mnlphnlngical Analysis Tool 1.0 oy ]

File  Morphological Analysiz  Help

BEE

Brainstorm Question i

Question! lustralia's Joint Operations for the 21st century states regional factors (such as state

fragility, poor governance and economic underdevelopment) may affect Australia's security
interests, both directly and indirectly. iz = result, = ket task for Australia's Defence
Force is to contribute to a stable reglanlal EnvVironment .

I

|Chck to start entering analysis guestion |

Brainstorm Sector

New Sector: | Create | Renave Edt

| select & sactor to mchude in analyss: Economic Growth

Social Cohesion

{imphcations of S&T

{Health and Habitat

Type of Operation required by ADF
lADF Concurrent Obligations

< Remove
[List of sectors to be inchuded in the analysis |
<< Remave All [

Description;

[ Mext

Figure 4: Brainstorm Question & Selecting Sectors

5.2 Sectors

The analysis technique requires that the problem be breken down into sub-systems or
components, which are referred to as sectors. These sectors could be brainstormed using
the tool, or entered into the tool after a “white board” brainstorming session. Instructions
in the next subsection refer to the sector screen shown in Figure 4.

5.21 Creating a New Sector

To create a new sector: Enter a sector name into the New Sector field and click the Create
button adjacent to the field, as shown in Figure 4. This will add the newly created sector
to the list of brainstorm sectors on the left hand side. Additional sectors are created by
repeating this step.



DSTO-GD-0560

5.2.2 Editing an Existing Sector

To edit the name of an existing sector:

1. Select the sector and click the Edit button. This will display the input dialog box.
2. Enter anew name into the input field and click the OK button. The changes will be
reflected in the list.

5.2.3 Attaching a Description to the Sector

To record a description or details of the sector:

1. Select the sector in either list. This will enable input into the description input field.
2. Enter a description or details into the field. The text will be saved, when the cursor
is moved to another input field.

5.2.4 Selecting a Sector to be Used in the Analysis

To include a sector in the analysis:

1. Select a sector from the brainstorm sector list, which will highlight the sector.

2. Click the include> button. This will add the brainstorm sector to the selected list
on the right hand side of the window. This step can be repeated for each desired
sector.

5.2.5 Including all the Brainstormed Sectors in the Analysis

1. Click on any brainstorm sector. This will enable both the Include>> and Include All>>
buttons for use.

2. Click the Include All>> button. This will include all the sectors as selected sectors
that will be used for further analysis.

5.2.6 Removing a Selected Sector from the Analysis

To remove a sector from the analysis:

1. Click on a sector in the selected list.

2. Click the Remove button. This will result in the sector being removed from the
selected list and added to the brainstorm list. This step can be repeated to remove
the desired sectors from the analysis.
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5.2.7 Removing all Selected Sectors from the Analysis

To remove all the sectors from the analysis back to the brainstorm list:

1. Click on a sector in the selected sector. This will enable the <Remove and
<<Remove All button.

2. Click the <<Remove All button to remove all the sectors from the selected list to the
brainstorm list.

5.2.8 Removing an Existing Sector Permanently

To remove a sector:

1. Click on a sector in either the brainstorm list or the selected list. This will highlight
the chosen sector
2. Click the Remove button. This action will result in the removal of the sector.

5.3 Factors

Many of the functions on the factors screen are identical to those on the sectors screen.
This should aid the user to quickly become familiar with the tool.

5.3.1 Purpose of Screen

This screen allows the creation of factors for each sector. The factors describe possible
states of the sector and should be entered in a sequential order. The screen itself is similar
to the sectors screen. An example is shown in Figure 5.

5.3.2 Specifying a Letter Index for the Selected Sectors

A letter index for each sector is assigned initially by default’ and displayed in the
‘Current Letter’ box. This may be changed by entering a New Letter. These letters will
use as a symbolic name for the analysis.

1. If in the Brainstorm Question step, click the Next button to move to the Breakdown
Components step (or wait until you naturally progress to this stage).

2. You must select a sector from the drop-down Select Sector box. Selecting the
first sector Political Governance from the list (Figure 5), shows that the letter index
assigned by default is P.

"By default the sector is assigned a letter index of the first letter of the sector name. If however, another
sector of the same first letter already exists in either the brainstorm or selected list, then it is given a letter
index of the same letter occurring multiple times.

10
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3. Enter a new name for the factor and click the OK button. This will change the name
of the factor.

5.3.5 Selecting a Factor to be Used in the Analysis

In order for a factor to be used in the analysis, it must be moved from the brainstorm
factor list to the selected factor list for the selected sector. A factor can be moved to the
selected factor list by:

1. Selecting a factor from the Brainstorm Factor list, so it is highlighted.
2. Click the Include> button to remove the factor from the brainstorm factor list and
add it to the selected factor list on the right hand side.

5.3.6 Attaching a Description to the Factor

A description or note can be attached to the factor to record the ideas which were
discussed and present in the brainstorming session. This can be done by:

1. Selecting a factor by clicking on it, whether it is in the brainstorm factor list or the
selected factor list. The selected factor will become highlighted, and enabled entry
into the input field labelled as Description.

2. Enter a description into this field.

3. Selecting another factor or placing the cursor into another input field such as the
New Factor field will automatically save the description. After which point, the
description of a factor may be viewed (or edited) by selecting that factor.

5.3.7 Selecting all Brainstormed Factors to be Used in the Analysis

If all the factors in the brainstorm list need to be added to the selected list follow the steps:

1. Select any factor in the brainstorm list so that the Include All>> button can become
active.

2. Once the Include All>>> button is active, click on the button. This will then remove
all brainstorm factors from the Brainstorm Factor list and add it to the selected
factor list.

5.3.8 Removing a Selected Factor from the Analysis

To remove a single factor from the selected factor list and return it to the brainstorm factor
list, follow the steps below:

1. Click on the factor to remove in the selected factor list. This will highlight the factor,
and enable the <Remove button.
2. Click on the <Remove button.
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5.3.9 Removing all Selected Factors from the Analysis

To remove all the selected factors from the selected factor list follow the steps below:

1. Click on any factor in the selected list. This will enabled the use of the << Remove All
button.

2. Click the <<Remove All button. This will remove all the selected factors from the
selected list and add them to the brainstorm factor list so they may be added again
if they are required. The tool allows the keeping a record of the factors that are not
to be used in further analysis.

5.3.10 Removing an Existing Factor

A factor may be in either the brainstorm list or the selected list to be removed. It can be
removed by:

1. Selecting the factor to be removed by clicking on it from the required list.
2. Click the Remove button adjacent to the Create button. This action will result in the
complete removal of the factor from both lists of factors.

54 Matrix of Pairs
5.4.1 Viewing the Matrix of Pairs

A matrix may be viewed at any point. The matrix will display only those selected factors
and sectors. In order to do this, follow the following steps:

1. Create sectors to be included in the analysis by creating a sector and moving it to
the selected sector list.

2. To those sectors attach selected factors.

3. Click the Next button from the Breakdown Components panel to move to the Matrix
of Pairs panel.

13
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==
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Figure 6: Matrix of Pairs
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6 Using Combined Approach

When a morphological analysis is loaded into the combined approach tool the informa-
tion it contains is displayed as in Figure 9. This section of the report guides the user
through the functionality of the combined approach tool.

ombined Approach Tool 1.5

File Combined Snalysis:  Help

n:  Factor Descriptions

&g -

Matrix of Pairs

Enter the compatibiity rating for matrix pairs in the table below, &fter each entry press the ENTER key,

F1 P2 |P3 E1 [EZ E3 |31 |52 |53 [TL T2 T3 |H1 HZ H3 |1 (A2 (A3 A4 (O |C2 |C3
PL L 1 |t R - i i R - i o -
P2 |1 ic 1
P3 |1 1 1

T
5]

C1 | 1
2 | L
C3 1 1 1

Matrix of Pairs Tablelegend

The compatibility: rating range Is from

1ta 5, where 1 is incompatible; inbetween
2,3 and 4 represents increasing
compatibility and 5 is very compatible,

~Gcenario Selection —

i Criteria-

Maximum number
v of Rating 2:

—

& oR

O AMD

Minimum average
v compatibility rating value: ID'D

Click on a cell to enter compatability of factor pair.<himl=1

Incompatableshr=2=hr=3=br=4<br=5 Compstable=html= |

~Marginal Probabilities — =i

Enter Estimated Marginal Probability for individual outcomes (Factors) in the table below, The sum of
probabilities of Factors in the same sector should be equal to 1.0, After each entry press the ENTER key.

[Pt Pz P3 [EL Ez [E3 51 |52 |53 |TL (T2 [T3 [H1 HZ H3 [l |a2 [A3 |a4 [C1 [C2 G5 |

| Default Criteria

The scenario has number of rating 2
less than or equal to the maxdnm
number of rating 2 OR, the average
compatibility is greater than or egual
tothe minimun average compatibilicy
rating walue

Back Next |

Figure 9: Malrix of Pairs & Marginal Provabilities Panel

6.1 Initial Data Input

6.1.1 Entering a Compatibility Rating of a Pair of Factors

Once a merphological analysis is open and the Matrix of Pairs and Marginal Probabilities
table have both been created as seen in Figure 9, the compatibility ratings of pairs of
factors can be entered. To do this, click on a cell referenced by the two factors for which
youwould like to give the rating of and enter a value. An input value of 1 to 5 inclusive
is accepted (refer to the Matrix of Pairs Table Legend). Once a value has been entered, the

Enter key must be pressed.

Please note, the Matrix of Pairs will populate the table with an incompatibility of 1’
where the factors belong to the same sector. A -" will be assigned to redundant cells.
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Although all these cells should not be editable, the bottom left outer ‘1" values are. These
values mustnotbe changed and mosthave been disabled to prevent this from happening.

6.1.2 Entering a Marginal Probability for a Factor

The marginal probability of a factor can be entered by double-clicking the cell in the
Marginal Probabilities table and entering a value. When a value has been entered the enter
key must be pressed. The factors in the sector should sum to equal to or less than 1. A
warning message will be displayed if they sum to something greater than one.

6.1.3 Scenario Selection

The scenarios can be filtered by using a selection criteria based on the maximum number
of rating 2 values and/or the minimum average compatibility rating value® allowed.

e Entering a maximum number of rating 2 value:

The maximum number of rating 2 criteria works by disallowing scenarios that have
more pair-wise rating 2 than this value. This value can be entered by entering an
integer in the Maximum number of Rating 2 input field. After a value has been
entered, the cursor must be placed in Minimum average compatibility rating value
input field to register the rating 2 value criteria.

o Entering a minisum average compatibility rating value:

The minimum average compatibility rating value works by selecting those scenar-
ios which have an average compatibility rating of the value or higher. To enter a
minimum average compatibility rating value, by entering a value in the minimum
average compatibility rating input field. After the value has been entered, the cursor
must be placed in the maximum number of rating 2 input field. The input field accepts
real (decimal} numbers between 1 and 5 inclusive.

o Specifying scenario selection filter technigue: the first or the second criteria can be
applied, or both.

To specify only the first criteria: Ensure that the maximum number of rating 2 criteria
is checked and the minimum average compatibility rating is not, regardless of whether
the Or or And button is selected.

To specify only the second criteria: Ensure that the minimum average compatibility
rating criteria is checked and the maximum number of rating 2 is not, regardless of
whether the Or or And button is selected.

To specify if either the first or the second criteria is met then the scenario should
be included: Ensure that the minimum average compatibility rating criteria and the
maximum number of rating 2 is checked, and select the Or button.

9The terminclogy of “‘upper-bound value” and ‘lower-bound value’ are used for the maximum number of
rating 2 values and the minimum average compatibility rating value respectively in the companicn report [6,
Section 6.2.3].

17



DSTO-GD-0560

To specify that a scenario must meet the first and the second criteria: Ensure that
the minimum average compatibility rating criteria and the maximum number of rating 2
is checked, and select the And button.

mbined Approach Tool 1.5 Pl T o =] 3]

File Combined Analysis  Help

Ilg g Seenario Descriptions Fackor Descriptions

~Matrix of Pairs ~Matrix of Pairs Table Legend
Enter the compatibility rating For matrix pairs in the table below, After each entry press the ENTER key. The compatibility rating range is From
1 to 5, whers 1 is incompatible; inbetween
PL Pz 3 L [E2 [E3 |51 |52 (33 Tt [Tz T3 |HL Hz H3 |a1 |az [A3 |a4 [C1 [C2 [c3 2,3 and 4 represents increasing
Pt b F O F O OE B B O B Ok ke ke i s B compatibility and 5 is very compatible,
Pz 1 1 |1 - FFEFFEFEEFEFEFRFEFEEEEEREEE
EET i Gl Tl hE e Gl i@ e R R R B Ok ik ke g da b -Scenatio Selection
EE R W B it Bk ok el e R EEE B d g b =i
ezt 5 0t 00 FFEFEFEFEEFEEEEEEEFEFEETFEF ) -
e R L FEEE Pl EEEEEEFEEF F pna'g;t";“;;f'm.er F
st B Rl ppkFEFEEFEFEFEEEEFEETETF
2+ B B R R EEEFEEFEFEEEFEFEETFET )
S oo EEEEFEEFEREFEF & or
npFE PR RRIREBREREREFREEFEFEEEFEEFETFTF i
2zt BB g R B FFFFEFEEEEE
e Bl P 0 B FFFEFFEFEEETFEFEF Minimum average I_
HL iz B B B B |z B | I & 1B 12z It T 1t F F - F F F F i compatibility rating value; 3.285
e 4+ B B3l i FFFFEFTF
i TR R B EFEFEEFEFETF [}\
Al lz B B 2 @ [ F 0L 2 5 Bt FOF |
b2+ BB g B g Wt B it g B B R FF F
Az Bt Bt 2 i B R R ] - |
FAIRETEEE R EENE EREE R EREEEEEEETN
e B el el B i b
e B R RERERRBERRBERRBERBEREREREREIRTRI|
G314 B B # 2 |z |2 2 |3 |3 1 |4 P 1 5 [t |t 1 & [t
~Marginal Probabilities - Drefaulk Criteria
Enter Estimated Marginal Probability For individual outcomes (Fackors) in the kable below, The sum of The scenario has number of rating 2
probabilities of factars in the same sector should be equal to 1.0, After each entry press the ENTER key, less than or equal to the maximum
number of rating 2 OR the averages
Pl [Pz [P35 [E1 [E2 [E3 |51 |52 |53 |1 [T2 T3 |H1 [H2 H3 a1 [az |a3 a4 [l |2 |3 | compatibility is greater than or equal
0.3 0.z 0.5 0.5 [0.4 [0.1 [0 [0.4 [ou1 (06 0.3 0.l 0.8 0l ol o @7 joul fol 0 jos oz | to the minimum average compatibility
rating value
Hatl hext

Figure 10: Inilial Data Input Complete
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6.2 Selecting Compatible Scenarios Using Battelle Approach

Once the initial input data has been entered (as in Figure 10), the Next button can be
clicked to display the results of using the Battelle Approach (see Figure 11).

EComhined Approach Tool 1.5 - 1 ;IQ'_E!

File Combined Analvsis  Help

I[g g Seenario Bescriptions Factor Descriptions

-Selected Compatible Scenarios
The result of the selection process is shown in the table below:
Senario Mo Scenario Mumber of Rating 2 Average compatibiliy Value
1 PLEISZTIHIAZCL & 3,286
2 PLEIS2TIHIAZCZ 2 3,381
3 FLE1S2TIHZAZCL 4 3,524
4 PLE1SZTIHZAZCZ 1 3,524
5 PZEZS1T2HIALCZ o 3,667
6 P2E251T2ZHIALCS 1 3.81
7 PZEZS1TZHIAZCL 4 3,286
3 PZEZS1TZHIAZCZ 2 3,238
9 PZEZS1TZHIAZCZ 2 3,238
1 PZEZ52TIH1AZCL 4 3,333
11 P2EZS2TIHLIAZCZ 2 3,286
12 P2E2S2TIHZAZCL 4 3,333
13 P2EZ52TIH2AZC2 3 319
14 PZE252T2H1AZCZ 3 3,095
15 PZEZS2TZHZAZCL 3 3,333
16 P2E252T2HZAZC2 3 3,095
17 P3E1S1T2ZHIALCZ 1 3,524
15 P3ELISITZHIALCS 1 3,714
19 P3ELIS1TZHIAZCZ 1 3,256
20 P3ELIS1TZHZAZCZ 2 3,143
21 PIEIS2TIHIAZCZ 3 3,095
22 PIEISZTIHZAZCZ 3 3,143
23 PIE1S2TZHIAZCZ 3 3,048
24 P3EL1S2TZHZAZCZ 2 319
25 P3EZS1TZHIALCZ o 3.619
26 P3E251T2ZHIALCS 1 3.714
27 P3E251T2HIAZCZ 1 3,286
28 P3E251T2HIASCZ 1 3,286
29 PIE2S1T2HZAZC2 2 13,143
30 P3EZS2TIHIAZCZ 3 3,095
31 PIEZSZTIHZAZCZ 3 3,143
32 P3EZSZTZHIAZCZ 3 3.048
33 PIE252T2HZAZCL 3 13,333
34 PIE2S2T2HZAZC2 2 3.19
Back.

Figure 11: Results using Battelle Approach

A table of scenarios remaining, their number of rating 2 value and average compatibility
value are shown. The user at this stage may like to go back and review their input data or
progress to the next stage.

6.3 Projecting Scenario Distribution Using Bayesian Approach

Combined Approach Teol 1.5 i x|

Please wait while the computation takes approximately 58 seconds.

Figure 12: Computation Time for Bayesian Approach
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Once the user has finalized the scenarios retrieved from conducting the Battelle Ap-
proach, the user can click the Next button to progress to the results of conducting the
Bayesian Approach. A message prompt estimating how long the calculation will take
is then display (Figure 12). When this has been acknowledged the calculations will
start. The results are shown in a table, where each scenaric has its configuration and
its probability displaved.

L=
File Combined Analysis  Help
| [g g Scenario Descripkions Factor Descriptions
Scenario Probabilities
The probabilities of the selected scenarios are shown in the kable below, Indicake which scenarios will be removed From Further consideration
by entering ¥ in the "Remove Scenario?” column, :
Scenatio Mo Scenario Probability (%) Remowve Scenario?
1 PLEISZTIHIAZCL 5.9 M -~
2 PLE1SZTIHIAZCZ 8.55 M
3 PLEISZTIHZAZCL 3.24 M
4 F1ELS2TIHZAZCZ 2.95 i)
5 PEEZSITZHIALCE 2.95 M
6 FP2E2S1TZHIALCS 2,36 i)
7 P2E251TZHIAZC L 3.54 M
8 P2ZE2S1TZH1IAZCZ 3,54 M
9 PEEZSITEZHIASCE 1.77 M
1 PEEZSZTIHIAZCL 5.31 M
11 PEEZS2TIHLAZCZ 5.31 i)
12 P2E252T IHZ2A2C 1 o i
13 P2E252T1H2AZCZ o ¥
14 PEEZ52TZH1AZCZ 1.18 M
15 PEEZS2TZHZAZCL o ¥
16 PEEZ52TZH2AZC2 o ¥ b
17 F3EIS1TZHIALCZ .36 i)
13 PSEISITZHIALCS 236 M
19 PSELISITZHIAZCZ 5,85 M
20 PSEISITZHZAZCZ o ¥
21 FIELS2TIHLAZCZ .49 i)
2z P3E1S2TIHZAZCZ 2.95 i)
23 P3E1S2T2HIAZCEZ 1.15 M LI
~Final Stag;
For the final stage of the-combined analysis, Cluster Analysis can be performed to choose tepresentative scenariosor Integer Programming can be used for a balanced mix of plausible
scenarios, Choose the analysis which will be used in the final stage;
& Cluster Analysis
" Integer Pragramming

6.4 Confirming Selected Compatible Scenarios

Figure 13: Outputs from Conducting Bayesian Approach

By default, those scenarios which have a probability of zero have been set to be excluded
from the next stage of the analysis.

e 1o vemove additional scenarios from the analysis: enter a value of Y’ in the Remove

Scenario? column for the scenario which is to be removed.

o 1o not remove a scenario from the analysis: enter a value of ‘N in the Remove Scenario?

column for the scenario which is not to be removed.

20
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Once the scenarios to be removed or included have been specified, the user may either
conduct a Cluster Analysis of the results, or Integer Linear Programming,.

In order to conduct a Cluster Analysis, select the Cluster Analysis option in the Final Stage
options. Otherwise, select the Integer Programming option. After the selection has been
made, click the Next button to ensure that the appropriate screen is displayed.

6.5 Cluster Analysis

Assuming that the user has selected to conduct a cluster analysis as the final stage
of the combined approach analysis, the screen displayed in Figure 14 will be shown.
The figure shows that all the Show buttons corresponding to the number of clusters are
enabled ', this indicates that the group of selected scenarios could be grouped into up to
five clusters. A Show button which is disabled indicates that the scenarios could not be
grouped into the number of clusters for which it is disabled !,

Cumhined Approach Tool 1.5 [ d l _.-.lgj.?ﬁ

File Comhined Analysiz  Help

|hi:ﬁl g Scenario Descriptions Factor Descriptions

-Cluster Analysis -
All scenarios wikh " entry will be remaoved From the analysis.
Results Image -
Cluster Results Click: the 'Display’ button to display the Cluster Image

= Show Display
i Shiw
4 Shiwy
= Shaw

Back

Figure 14: Cluster Analysis Panel

6.5.1 Viewing Cluster Information

To view the scenarios and their statistics as mentioned in the companion report [6]: click
the Show button adjacent to the corresponding number of clusters of interest. This action
will result in displaying another screen which shows statistical data corresponding to the
grouping of scenarios into clusters (see Figure 15).

6.5.2 Viewing Cluster Image

To view the cluster image that has been generated by the Statistical R package: click the
Display button on the right-panel. This action will display a separate window displaying

Ymeans that clicking the button will execute a function.
Umeans that clicking the button will not make changes to the program or perform any function.
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“Cluster Analysi

luster Information

Cluster No

Scenario

iwerage Compatibiliy yalie

Probability

1,2,4,57,8,5,10,11,14,17,18,19,2... [3.31

94,4

E

3667

5.6

luster Statistics and Representative Scenarios

Cluster No

Sector

Mean

IMazimurm

Minimurn

Representative Scenario

2.5

1.62

1.58

1.65

1.23

1.83

1.92

TP T T 13| 10| | | | e | [ ] 7]

T a2 | o

S S S e

NN EEEEE]

FNEEEEEEEEEEEE

T T e e e e e e e e T
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Figure 15: Cluster Information
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Eﬁnmhined Appioach Tool 1.5 c _ O x|

File  Combined Analysiz  Help

I L% g Scenario Descriptions  Factor Descriptions

-Search for a balanced mix of plausible scenarios using Integer Progr
Enter walues For N and P in the table below and press the ENTER key. N represents the number of factor occurences in the scenatio sat,
whereas P is the probahility of the Fackor outcome.,
Factor N P
Pl 2 0,045454545454545456
Pz 2 ]
P3 o 0.045454545454545456
El z 0.045454545454545456
E2 2 (1]
E3 ) 0
=3 2 0.045454545454545456
52 2 0.045454545454545456
53 o o
T 2 0.045454545454545456
L= 2 0,045454545454545456
T3 o ]
H1 2 0.045454545454545456
Hz z 0.045454545454545456
H3 a (1]
Al 2 0.045454545454545456
A2 2 0,045454545454545456
AT ] o
Ad o o
IC1 2 0.045454545454545456
2 2 454 S6
c3 ]
"Pre-se\ected Scenarios (e.g. 2, 7 113 i Results
[14,24,32 ‘
|
|

Back,

Figure 16: Integer Programming Panel

e If a feasible solution can be found, the scenatio set and the values for N and P will
be shown in a table.

e If however, there is no feasible solution, there will be no output displayed in the
panel and the user will be prompted to re-enter input data in Figure 16.

7 Summary

This documment has described, in detail, how to use the Morphological Analysis Tool and
the Combined Approach Tool that forms the Scenaric Analysis Tool Sutite.

As with any piece of software, there may be bugs remaining in the code. To date
the program has not undergone extensive verification and validation due to a lack of
available resources, in particular the end of the primary programmer’s contract at DSTO.

Together with this user manual and the companion report on the scenario analysis
methods, this tool provides an excellent resource for the conduct of strategic analysis.
However, by itself the tool will not perform this analysis. Trained staff should still be
used to interpret the inputs and the results of the model.



DSTO-GD-0560

24

10.
11.
12.

13.

14.

15.

16.

17.

References

. Coyle, R. G. & McGlone, G. R. (1995) Projecting Scenarios for South-east Asia and the

South-west Pacific, Futures 27(1), 65-79.

Coyle, R. G., Crawshay, R. & Sutton, L. (1994) Futures Assessment by Field Anomaly
Relaxation, Futures 26(1), 25-43.

. De Kluyver, C. A. & Moskowitz, H. (1984) Assessing Scenario Probabilities via

Interactive Goal Programming, Management Science 30(3), 273-278.
Hornik, K. (2007) The R FAQ, http://CRAN.R-project.org/doc/FAQ/R-FAQ. html.

Malkhorin, A, {(20006) GLPK  (GNU  Linear  Programming  Kit),
hitp:/ fwww gnu.org/software/glpk/glpk.html.

Nguyen, M.-T. & Dunn, M. (2009) Some Methods for Scenaric Analysis in Defence
Strategic Planning, Technical Report Series DSTO-TR-2242, Defence Science and
Technology Organisation, Australia.

. Nicholson, J. A. (2005) Scenario based planning and strategic risk management

applied to the defence environment, in1 Proceedings of the Land Warfare Conference, Gold
Coast, Australia.

Rhyne, R. (1974) Technological forecasting within alternative whole futures
projections, Technological Forecasting and Social Change 6, 133-162.

Rhyne, R. (1981) Whole-Pattern Futures Projection, Using Field Anomaly Relaxation,
Technological Forecasting and Secial Change 19, 331-360.

Rhyne, R. (1995) Field anomaly relaxation: the art of usage, Futures 27, 657-674.
Sarin, R. K. (1978) A sequential approach to cross impact analysis, Futures 10, 53-62.

Sarin, R. K. {1979) An approach for long-term forecasting with an application to solar
electric energy, Management Science 25, 543-554.

Stephens, A. K. (2006) Future Urban States: a Field Anomaly Relaxation Study, Technical
Report Series DSTO-TR-1910, Defence Science and Technology Organisation,
Australia.

Sun Microsystems & CollabNet (2008) NetBeans IDE 6.0, http:/ /www.netbeans org.

Tri, N., Boswell, S. & Dortmans, P. (2004) Developing Possible Future Contexts using
the Field Ancmaly Relaxation Process, Technical Report Series DSTO-TIN-0604, Defence
Science and Technology Organisation, Australia.

von Reibnitz, U. (1985) Scenarie Techniques, McGraw Hill, New York, USA.

Zwicky, F. (1967) Discovery, Invention, Research through the Morphological Approach,
Macmillan, New York, USA.



Page classification: UNCLASSIFIED

DEFENCE SCIENCE AND TECHNOLOGY ORGANISATION 1. CAVEAT /PRIVACY MARKING
DOCUMENT CONTROL DATA

2. TITLE 3. SECURITY CLASSIFICATION
The Scenario Analysis Tool Suite: A User’s | Document {8)]
Guide Title ()]
Abstract (L)
4. AUTHORS 5. CORPORATE AUTHOR
Cigdem Dilek Defence Science and Technology Organisation

Fairbairn Business Park,
Department of Defence, Canberra, ACT 2600.

6a. DSTO NUMBER 6b. AR NUMBER 6c. TYPE OF REFORT 7. DOCUMENT DATE
DSTO-GD-0560 AR 014-360 General Document January 2009
8. FILE NUMBER 9. TASK NUMBER 10. SPONSOR 11. No OF PAGES 12. No OF REFS
2008/1041544 /1 07 /064 Strategic  Policy | 24 17
(Branch)

13. URL OF ELECTRONIC VERSION 14. RELEASE AUTHORITY
http:/ /www.dsto.defence.gov.au/corporate / Chief, Joint Operations Division

reports / DSTO-GD-0560.pdf

15. SECONDARY RELEASE STATEMENT OF THIS DOCUMENT

Approved For Public Release

OVERSEAS ENQUIRIES OUTEIDE STATED LIMITATIONS SHOULD BE REFERRED THROUGH DOCUMENT EXCHANGE, PO BOX 1500, EDINBURGH, SOUTH AUSTRALIA 5111

16. DELIBERATE ANNOUNCEMENT

No Limitations

17. CITATION IN OTHER DOCUMENTS

No Limitations

18. DSTO RESEARCH LIBRARY THESAURUS

Strategic Analysis,

Scenario,

Operations Research,

Application Software,

Java,

Department of Defence (Australia)

19. ABSTRACT

This document is a user guide for the software product, the Scenario Analysis Tool Suite (version 1.5).
The tool suite implements several scenario analysis techniques, Morphological analysis, Field
Anomaly Relaxation analysis, Battelle approach, Bayesian approach, as well as an extended approach
of combining methods. Thus the tool provides the opportunity to compare these techniques using a
specific strategic question and provides computer support for the new combined technique.

Page classification: UNCLASSIFIED




