A Graphical Method for Running the ARL Secure Link Middleware

by Binh Q. Nguyen

ARL-TR-4353

January 2008

Approved for public release; distribution is unlimited.
NOTICES

Disclaimers

The findings in this report are not to be construed as an official Department of the Army position unless so designated by other authorized documents.

Citation of manufacturer’s or trade names does not constitute an official endorsement or approval of the use thereof.

Destroy this report when it is no longer needed. Do not return it to the originator.
A Graphical Method for Running the ARL
Secure Link Middleware

Binh Q. Nguyen
Computational and Information Sciences Directorate, ARL
This report documents the results of the development of a graphical method for running the U.S. Army Research Laboratory (ARL) Secure Link middleware. It describes the internal implementation of the graphical user interface (GUI) and the methods for running the ARL Secure Link middleware. The report also includes the screen shots of the GUI and describes the functionality of the interfaces.
Contents

List of Figures iv

1. Introduction 1

2. Methods 1

3. Graphical User Interfaces 3

4. Results and Discussion 9

5. Conclusions 10

Appendix A. The Contents of the Configuration File 11

Appendix B. An Example of the Log File 13

Appendix C. The Appearance of the GUI in Microsoft Windows Environments 15

Acronyms 17

Distribution List 18
List of Figures

Figure 1. The initial appearance of the GUI of the ARL Secure Link middleware ..................... 3
Figure 2. Tkinter widgets ........................................................................................................ 4
Figure 3. The pull-down menus .......................................................................................... 5
Figure 4. Configuration parameters .................................................................................. 5
Figure 5. The Help menu and its contents ........................................................................ 6
Figure 6. The appearance of the GUI during operation ...................................................... 7
Figure 7. The dialog showing missing files ........................................................................ 8
1. Introduction

To support the National Archives and Records Administration (NARA) in its effort to establish a secure distributed processing of electronic records archives (ERA), the U.S. Army Research Laboratory (ARL) developed an experimental information-assurance product, ARL Secure Link middleware\textsuperscript{1}, which is capable of providing data confidentiality between two networked computers. ARL has also developed a convenient method for running the middleware using a set of graphical user interfaces (GUIs).

This report documents the results of the development of the GUI, describes its features, and reveals its internal operations. The intended readers of this report include technical and managerial personnel as well as anyone who is interested in using the ARL Secure Link middleware or finding out how the GUI was built.

Section 2 describes the internal implementation of the GUI and the methods for running the ARL Secure Link middleware. Section 3 includes the screen shots of the GUI and describes the functionality of the interfaces. Section 4 discusses the development of the tool. Section 5 concludes the report.

2. Methods

The GUI developed for running the ARL Secure Link middleware was created using the Python programming language\textsuperscript{2}, its standard Tkinter module, and the Popen class of the subprocess module. The Popen class facilitates the interaction between the GUI and its execution environment by providing a means to control the operation of the middleware and its associated firewall. The paragraphs that follow describe the use of the Popen class in the GUI.

- Starting and stopping the ARL Secure Link middleware. The middleware was designed to run in the background as a daemon; hence it was named sld to stand for Secure Link daemon. A daemon is a computer program running in the background and requires no user interactions. Upon a successful execution of the sld, its running process identification (pid) is captured and saved for subsequent uses such as sending a signal to the running process:

\[
\text{pid} = \text{Popen(sld).pid}
\]

\textsuperscript{1} Luu, Brian. *Functional Requirements Assessment of Secure Link*, ARL-MR-663; U.S. Army Research Laboratory:, Adelphi, MD, March 2007.

To stop a running sld, the GUI can send the `kill -s SIGKILL pid` or the `killall sld` command. The latter is the more preferable method for gracefully stopping all active sld processes because the `killall` command sends the SIGTERM signal (by default) that can be caught by the running processes. Upon receiving the SIGTERM signal, each sld process would clean up its work before terminating. Whereas, using the SIGKILL signal terminates sld processes abruptly, giving them no chance to close an opened file or a network communication socket, and thus leaving behind the system at an undetermined state.

- Enabling and disabling the firewall. The `iptables` command is used as the firewall with which the ARL Secure Link middleware operates. The command is often executed with specific instructions and options. To monitor the internal tables of the command (the state of the firewall), the GUI connects and redirects its outputs, including error messages, to an internal storage, s, by executing the following two statements:

  Statement 1. \( p = \text{Popen(<iptables-command>, shell=True, stdout=PIPE, stderr=STDOUT, close_fds=True).stdout} \)

  Statement 2. \( s = p.\text{read}() \)

Statement 1 executes a specific `iptables` command, and statement 2 retrieves the outputs of the executed command. The outputs are immediately displayed in the GUI.
3. Graphical User Interfaces

The GUI of the ARL Secure Link middleware was built using the standard widgets readily available in the Tkinter library, which is a Python extension to the tcl programming language and the tk GUI toolkit.\(^3\) When the GUI is executed, it appears on the computer screen as shown in figure 1.

![The ARL SecureLink Middleware](image_url)

Figure 1. The initial appearance of the GUI of the ARL Secure Link middleware.

Important widgets that were used to build the GUI include the Frame, Menubar, Button, Entry, Text, Scrollbar, and Label widgets. The Frame widget contains other widgets, including other Frame widgets. Figure 2 shows the Tkinter widgets that were used to build the GUI.

![GUI Diagram]

Figure 2. Tkinter widgets.
On the top of the GUI is the Menubar with three pull-down menus containing features infrequently used during the operation of the ARL Secure Link middleware. However, the user has an option to “tear off” the menus to make them permanently displayed until they are manually destroyed. The torn-off menus are depicted in figure 3.

The three pull-down menus include two menus for the users (File and Help) and one menu for the developer (Test). The File menu has three menu items: Config…, Save, and Exit. Selecting the Exit menu item shuts down the operation of the ARL Secure Link middleware, resets the state of the firewall, closes the log file, and destroys the GUI. Selecting the Save menu item stores the currently configured options to a file whose name is a configuration parameter. Selecting the Config… menu item displays a table of configuration parameters and their current values as shown in figure 4. A new value can be entered in the Entry box of the parameter. Pressing the OK button confirms the change. Pressing the Cancel button closes the window and abandons the change.

Figure 3. The pull-down menus.

Figure 4. Configuration parameters.
The **Test** pull-down menu is used during the development of the GUI to experiment with new features. Selecting any item of the **Test** menu does not affect the operation of the ARL Secure Link middleware.

The **Help** pull-down menu has four different informational types: **Usage**, **Syntax**, **Version**, and **About** as shown in figure 5. Selecting the **Usage** menu item gives a short set of instructions on how to run the ARL Secure Link middleware using the GUI. Selecting the **Syntax** menu item displays the ordered list of required parameters for running the middleware. Selecting the **Version** menu item shows the version and the date of the GUI. Selecting the **About** menu item shows a blurb about the tool.

![Image of Help menu and its contents]

Figure 5. The Help menu and its contents.

Below the pull-down menus, the GUI is divided into three sections. The first section provides the user a way to interact with the ARL Secure Link middleware. It has five action buttons and their related **Entry** boxes. The buttons are labeled **Start/Stop**, **Protect**, **Unprotect**, **Enable/Disable**, and **Reset**. Pressing the **Reset** button terminates the running ARL Secure Link middleware, clears the internal tables of the firewall, and erases the display area of the GUI. Pressing the **Enable** button initializes the state of the firewall and changes its label from **Enable** to **Disable**. Pressing the **Disable** button resets the firewall and changes its label back to **Enable**.
The **Unprotect** button requires a list of one or more internet protocol (IP) addresses to be entered and displayed in its corresponding **Entry** box, located on the right side of the button. Pressing the **Unprotect** button or pressing the **Enter** key while the mouse cursor is in the **Entry** box instructs the ARL Secure Link middleware to stop providing confidentiality services to the host(s) having their addresses displayed in the **Entry** box. Similarly, the **Protect** button is used to instruct the middleware to provide confidentiality services to the host(s) having their addresses displayed in the corresponding **Entry** box. The lists of unprotected and protected hosts need not be identical. In order for the two buttons to function properly, the **sld** daemon must be running and the firewall must be enabled.

The **Start** button is used to run the **sld** daemon with its predetermined configuration parameters or running it with a different set of cryptographic certificates shown in its corresponding **Entry** box. Once the **sld** daemon has been executed, the button changes its label from **Start** to **Stop** and then enables the firewall as if the **Enable** button were pressed by the user as shown in figure 6.

![The ARL SecureLink Middleware GUI](image)

### The ARL SecureLink Middleware

<table>
<thead>
<tr>
<th>File</th>
<th>Test</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stop</td>
<td>Unprotect</td>
<td>Protect</td>
</tr>
<tr>
<td>Disable</td>
<td>Stop</td>
<td>Reset</td>
</tr>
</tbody>
</table>

```bash
/usr/local/sbin/iptables -A OUTPUT -t mangle -p tcp --sport 3838 -j ACCEPT
/usr/local/sbin/iptables -A OUTPUT -t mangle -p tcp --dport 3838 -j ACCEPT
/usr/local/sbin/iptables -t mangle -NL
Chain PREROUTING (policy ACCEPT)
  target prot opt source          destination
  Chain INPUT (policy ACCEPT)
  target prot opt source          destination
  Chain FORWARD (policy ACCEPT)
  target prot opt source          destination
  Chain OUTPUT (policy ACCEPT)
  target prot opt source          destination
  ACCEPT  udp -- 0.0.0.0/0 0.0.0.0/0 udp dpt:3838
  ACCEPT  tcp -- 0.0.0.0/0 0.0.0.0/0 tcp spt:3838
  ACCEPT  tcp -- 0.0.0.0/0 0.0.0.0/0 tcp dpt:3838
Chain POSTROUTING (policy ACCEPT)
  target prot opt source          destination
```

*Figure 6. The appearance of the GUI during operation.*
The second section of the GUI is the largest area that uses the Text and Scrollbar widgets to display the executed commands and their outputs, which provides the user a way to visually monitor the status of the firewall immediately after every execution of a command. In addition to displaying the history and outputs of the executed commands, the GUI also writes to a log file the date and time of an executed command and its outputs. Pressing the Reset button clears the display area, but does not clear the log file. The contents of the log file are subsequently used for post-analysis of user-initiated events and the status of the firewall to support the development and improvement of the ARL Secure Link middleware. If a log file is unwanted, then the name /dev/null must be set as its name. The GUI will continue sending logged messages to /dev/null, but the user will not be able to see and keep them.

The third section is a thin strip located at the bottom of the GUI used to provide user-feedback messages. It is often known as the status bar.

The operation of the GUI consists of two sequential steps: (1) initialization, and (2) waiting for a user-initiated event. During the initialization phrase, the GUI checks for the existence of the given configuration file, which has specifications of paths to the vital files that ARL Secure Link middleware needs to function. (Appendix A provides an example of the configuration file.) If the given configuration file exists and is readable, then the GUI reads in its contents to parse and extract the configured parameter values. If the configuration file does not exist, the GUI uses its default values that can be subsequently changed by the user. The GUI then verifies the existence of the configured values by checking the specified paths to the files and creating a list of invalid paths. At the end of the verification, if the list is non-empty, the GUI opens a dialog window showing the invalid paths and asking the user to decide whether the GUI should exit or continue running. Figure 7 depicts the dialog showing the name of the configuration file that does not exist during the initialization phase. Pressing the No button terminates the GUI. Pressing the Yes button lets the GUI continue running (mainly for exploration and learning purposes).

Figure 7. The dialog showing missing files.
Throughout the session, the GUI simply waits for the user to select one of its built-in features. Each selected feature creates an event that drives the GUI into action. The following events are suggested for running the GUI-equipped ARL Secure Link middleware.

- Verify that all values of the configuration parameters are correct by selecting the pull-down menu item **File:Config...**.
- Start the ARL Secure Link middleware and enable its associated firewall by pressing the **Start** button.
- Provide confidentiality services to a set of hosts by entering their IP addresses into the **Entry** box of the **Protect** button and pressing the **Enter** key or **Protect** button.
- Deprive one or more hosts of confidentiality services by entering their IP addresses into the **Entry** box of the **Unprotect** button and pressing the **Enter** key or **Unprotect** button.
- Terminate the ARL Secure Link middleware without leaving the GUI by pressing the **Stop** or **Reset** button.

### 4. Results and Discussion

Using the GUI to run the ARL Secure Link middleware was simple. Learning how to use it could be completed in about 5 minutes. The GUI simplifies the learning, training, and operating purposes. All the configuration parameters are readily available to its users to view and to change, if necessary. All the locations of the vital files needed for a successful session were clearly specified and presented to the user. The whole process of creating a secure communications among the participating networked computers consists of three major steps: (1) running the middleware, (2) deciding the hosts that will receive the confidentiality services and the hosts that will not, and (3) terminating the middleware and reset the system.

The GUI was successfully built and run on Linux environments where the ARL Secure Link middleware and the **iptables** packet-filtering system operate. Besides providing convenient methods for running the two system tools, the GUI offers a way to edit and manage important configuration parameters. It also automatically counts and records user-initiated commands, captures the outputs of the executed commands, and creates a log file storing historical events in a session (Appendix B) for subsequent analysis, debugging, training, or reporting purposes.

The use of the **Python** programming language enables the GUI to run in any operating system that hosts a current **Python** interpreter. In fact, ARL developed the GUI in a Microsoft Windows environment, but tested it in a Linux environment where the ARL Secure Link operates. Appendix C shows the appearance of the GUI in a Microsoft Windows environment.
The use of the **Python** programming language and its **Tkinter** modules saves resources that would have been spent to develop a separate GUI for each operating system.

Had a version of the ARL Secure Link middleware been developed to run in a Microsoft Windows environment, then the GUI would have been ready to interact with the middleware, requiring no changes to the core structural components of the GUI and a few changes to the system interfaces to accommodate the idiosyncrasy between the two different operating systems.

---

### 5. Conclusions

The GUI and the methods for running the ARL Secure Link middleware represent a convenient way for dealing with system and application software. The use of the **Python** programming language really expedites the development process, thereby increasing programming productivities and shortening development time. Its standard built-in GUI modules were easy to integrate into a complete system, thereby voiding the need of a GUI development tool. This source code of the GUI can serve as a template for designing the GUI for other applications.
Appendix A. The Contents of the Configuration File

#This file is automatically generated by the
#GUI of the ARL Secure Link Middleware
#
#====================================
#@Path to the ARL SecureLink Configuration File:=sld.conf  
#@Path to the ARL SecureLink Log File:=sld.log
#@Path to the ARL SecureLink Key:=/local/pki/certp2p/peer1-p2p.key
#@Path to the "killall" Command:=/usr/bin/killall
#@Path to the "iptables" Firewall:/usr/local/sbin/iptables
#@Path to the ARL SecureLink Middleware:=/usr/local/sbin/sld
#@Path to the ARL SecureLink CA Certificate:=/local/pki/certp2p/era-ca-p2p.crt
#@Path to the ARL SecureLink Certificate:=/local/pki/certp2p/peer1-p2p.crt
#@Protected IP addresses:=192.168.1.6 192.168.1.254
#
#==== requested variables:
#
#syskey="/local/pki/certp2p/peer1-p2p.key"
syscacert="/local/pki/certp2p/era-ca-p2p.crt"
syscert="/local/pki/certp2p/peer1-p2p.crt"
protect="192.168.1.6 192.168.1.254"
#Mon Oct 15 10:52:30 2007
INTENTIONALLY LEFT BLANK.
Appendix B. An Example of the Log File


Chain PREROUTING (policy ACCEPT)
  target  prot opt source               destination
Chain INPUT (policy ACCEPT)
  target  prot opt source               destination
Chain FORWARD (policy ACCEPT)
  target  prot opt source               destination
Chain OUTPUT (policy ACCEPT)
  target  prot opt source               destination
  ACCEPT  udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:3838
  ACCEPT  tcp  --  0.0.0.0/0            0.0.0.0/0           tcp spt:3838
  ACCEPT  tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:3838
Chain POSTROUTING (policy ACCEPT)
  target  prot opt source               destination
  ROUTE   0    --  0.0.0.0/0            192.168.1.6         ROUTE oif:sld
  ROUTE   0    --  0.0.0.0/0            192.168.1.254       ROUTE oif:sld
  ...
  ...

Chain POSTROUTING (policy ACCEPT)
  target  prot opt source               destination
  Wed Oct 17 11:09:51 2007:  21 /usr/bin/killall sld
  Chain PREROUTING (policy ACCEPT)
target prot opt source destination

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain POSTROUTING (policy ACCEPT)
target prot opt source destination
...
...
Wed Oct 17 11:10:03 2007: 40 /usr/bin/killall sld
Appendix C. The Appearance of the GUI in Microsoft Windows Environments

The ARL SecureLink middleware is designed and implemented by B. Lax of the U.S. Army Research Laboratory to provide an assurance of confidentiality between a pair of communicating entities. However, before the service can be rendered, the two entities must mutually verify their claimed identities. Doing so necessitates the use of peer-to-peer cryptographic certificates. ARL created and installs the certificates in every networked computer that uses the ARL SecureLink middleware.

B. Lax of ARL is the author of an in-house certification authority (CA) that issues and signs the needed certificates using the OpenSSL command. He also creates the graphical user interface for the ARL SecureLink middleware and provides a convenient method for controlling and managing the middleware and its associated firewall.

Note that using the ARL SecureLink middleware outside ARL will require authorization from the ARL Technology Transfer Office.

POC:
The ARL SecureLink Middleware: blax@arl.army.mil
The GUI and mutual authentication: b.lax@arl.army.mil
The ARL Technology Transfer Office: rtto@arl.army.mil

Usage: M:\Python\Proj\arltw\SecLink\SecLink.py [conf=\arltw\conf\sl.conf]
Before running any command, view the configuration parameters and change them if necessary. Select File->SaveConfig, or click Close.
- To start/stop the ARL SecureLink middleware, click the Start/Stop button.
- To enable/disable the firewall, click the Enable/Disable button.
- To protect one or more hosts, enter their IP addresses and press the Protect button.
- To unprotect one or more hosts, enter their IP addresses and press the Unprotect button.
- To save the current configuration parameters, select File->Save
- To exit, select File->Exit or click the X button located on the upper right corner of the screen.
INTENTIONALLY LEFT BLANK.
### Acronyms

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Full Form</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARL</td>
<td>U.S. Army Research Laboratory</td>
</tr>
<tr>
<td>ERA</td>
<td>electronic records archives</td>
</tr>
<tr>
<td>GUIs</td>
<td>graphical user interfaces</td>
</tr>
<tr>
<td>IP</td>
<td>internet protocol</td>
</tr>
<tr>
<td>NARA</td>
<td>National Archives and Records Administration</td>
</tr>
<tr>
<td>pid</td>
<td>process identification</td>
</tr>
<tr>
<td>No. of Copies</td>
<td>Organization</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>1 elec</td>
<td>ADMNSTR</td>
</tr>
<tr>
<td></td>
<td>DEFNS TECHL INFO CTR</td>
</tr>
<tr>
<td></td>
<td>ATTN DTIC OCP (ELECTRONIC COPY)</td>
</tr>
<tr>
<td></td>
<td>8725 JOHN J KINGMAN RD STE 0944</td>
</tr>
<tr>
<td></td>
<td>FT BELVOIR VA 22060-6218</td>
</tr>
<tr>
<td>1 HC</td>
<td>DARPA</td>
</tr>
<tr>
<td></td>
<td>ATTN I XO S WELBY</td>
</tr>
<tr>
<td></td>
<td>3701 N FAIRFAX DR</td>
</tr>
<tr>
<td></td>
<td>ARLINGTON VA 22203-1714</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>1 HC</td>
<td>OFC OF THE SEC OF DEFNS</td>
</tr>
<tr>
<td></td>
<td>ATTN ODDRE (R&amp;AT)</td>
</tr>
<tr>
<td></td>
<td>THE PENTAGON</td>
</tr>
<tr>
<td></td>
<td>WASHINGTON DC 20301-3080</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>1 HC</td>
<td>US ARMY RSRCH DEV AND ENGRG CMND</td>
</tr>
<tr>
<td></td>
<td>ARMAMENT RSRCH DEV AND ENGRG CTR</td>
</tr>
<tr>
<td></td>
<td>ARMAMENT ENGRG AND TECHNGLY CTR</td>
</tr>
<tr>
<td></td>
<td>ATTN AMSRD AAR AEF T J MATTS</td>
</tr>
<tr>
<td></td>
<td>BLDG 305</td>
</tr>
<tr>
<td></td>
<td>APG MD 21005-5001</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>1 HC</td>
<td>PM TIMS, PROFILER (MMS-P)</td>
</tr>
<tr>
<td></td>
<td>AN/TMQ 52</td>
</tr>
<tr>
<td></td>
<td>ATTN B GRIFFIES</td>
</tr>
<tr>
<td></td>
<td>BUILDING 563</td>
</tr>
<tr>
<td></td>
<td>FT MONMOUTH NJ 07703</td>
</tr>
<tr>
<td>1 HC</td>
<td>SMC/GPA</td>
</tr>
<tr>
<td></td>
<td>2420 VELA WAY STE 1866</td>
</tr>
<tr>
<td></td>
<td>EL SEGUNDO CA 90245-4659</td>
</tr>
<tr>
<td>1 HC</td>
<td>US ARMY INFO SYS ENGRG CMND</td>
</tr>
<tr>
<td></td>
<td>ATTN AMSSEL IE TD F JENIA</td>
</tr>
<tr>
<td></td>
<td>FT HUACHUCA AZ 85613-5300</td>
</tr>
<tr>
<td>No. of Copies</td>
<td>Organization</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------</td>
</tr>
<tr>
<td>5 HCs</td>
<td>ROBERT CHADDOCK</td>
</tr>
<tr>
<td>1 Elec</td>
<td>US NATIONAL ARCHIVES &amp; RECORDS ADMIN</td>
</tr>
<tr>
<td></td>
<td>8601 ADELPHI RD</td>
</tr>
<tr>
<td></td>
<td>COLLEGE PAR MARYLAND 20740-6001</td>
</tr>
</tbody>
</table>

Total: 30 (2 Electronic, 28 HCs)