The software consists of DownscaleConcept.exe, an executable file developed from Matlab, and a GIS tool for running DownscaleConcept, DoConGIS, which is used from within ArcGIS. DownscaleConcept was developed to estimate soil moisture at a fine resolution based on coarser, spatial soil moisture estimates by considering terrain characteristics such as slope, aspect, and contributing area.

13. SUPPLEMENTARY NOTES
The views, opinions and/or findings contained in this report are those of the author(s) and should not contrived as an official Department of the Army position, policy or decision, unless so designated by other documentation.

14. ABSTRACT
This technical report is the user manual for a soil moisture downscaling tool that is implemented in ArcGIS. The software consists of DownscaleConcept.exe, an executable file developed from Matlab, and a GIS tool for running DownscaleConcept, DoConGIS, which is used from within ArcGIS. DownscaleConcept was developed to estimate soil moisture at a fine resolution based on coarser, spatial soil moisture estimates by considering terrain characteristics such as slope, aspect, and contributing area.

15. SUBJECT TERMS
soil moisture, downscaling, disaggregation, wetness, GIS
ABSTRACT

This technical report is the user manual for a soil moisture downscaling tool that is implemented in ArcGIS. The software consists of DownscaleConcept.exe, an executable file developed from Matlab, and a GIS tool for running DownscaleConcept, DoConGIS, which is used from within ArcGIS. DownscaleConcept was developed to estimate soil moisture at a fine resolution based on coarser, spatial soil moisture estimates by considering terrain characteristics such as slope, aspect, and contributing area.
This technical report is the user manual for a soil moisture downscaling tool that is implemented in ArcGIS. The software consists of DownscaleConcept.exe, an executable file developed from Matlab, and a GIS tool for running DownscaleConcept, DoConGIS, which is used from within ArcGIS. DownscaleConcept was developed to estimate soil moisture at a fine resolution based on coarser, spatial soil moisture estimates by considering terrain characteristics such as slope, aspect, and contributing area.
DownscaleConcept 2.3 User Manual

Downscaled, Spatially Distributed Soil Moisture Calculator

Coleman, M.L., Dozier, A.Q., Fields, C.M., and Niemann, J.D.
Civil and Environmental Engineering
A226 Engineering
Colorado State University
April 2011
# Table of Contents

1  Software Description .............................................................................................................. 4

2  Software Installation ............................................................................................................... 5

   2.1  Software Requirements .................................................................................................... 5

   2.2  DoConGIS Installation ..................................................................................................... 5

   2.3  Optional Software ............................................................................................................ 6

3  Software Use ........................................................................................................................... 7

   3.1  Inputs ................................................................................................................................ 7

       3.1.1  Coarse-scale moisture grid ........................................................................................ 7

       3.1.2  Fine-scale topographic grids ..................................................................................... 7

       3.1.3  Potential evapotranspiration ...................................................................................... 8

   3.2  Running DownscaleConcept ............................................................................................ 8

       3.2.1  DoConGIS tool ......................................................................................................... 8

       3.2.2  Command line version ............................................................................................ 18

   3.3  Outputs ........................................................................................................................... 20

       3.3.1  Viewing Outputs in ArcGIS .................................................................................... 20

4  Acknowledgments .................................................................................................................... 26

Appendix A   Acquiring ASTER elevation data ........................................................................ 27

Appendix B   Acquiring TauDEM 5 software ........................................................................... 31

Appendix C   Terrain Characteristics - Calculations ................................................................. 33
1 Software Description

The software consists of DownscaleConcept.exe, an executable file developed from Matlab, and a GIS tool for running DownscaleConcept, DoConGIS, which is used from within ArcGIS. DownscaleConcept was developed to estimate soil moisture at a fine resolution based on coarser, spatial soil moisture estimates by considering terrain characteristics such as slope, aspect, and contributing area.
2 Software Installation

2.1 Software Requirements

The software was developed using a Windows-based computer and should be run on a computer using either Windows XP or Windows 7 but may be either a 32-bit or 64-bit architecture. Additionally, the Matlab Compiler Runtime (MCR) is required. This software is included in the self-extracting installation package. DownscaleConcept may be run from the Windows command prompt but ESRI ArcGIS 9.3 or higher is required in order to use the DoConGIS tool. Two versions of DownscaleConcept.exe are provided: DownscaleConcept32.exe is for computers with a 32-bit processor, and DownscaleConcept64.exe is for computers with a 64-bit processor.

2.2 DoConGIS Installation

A self-extracting *.msi file is provided for automatic installation of both DownscaleConcept.exe and the DoConGIS tool. Double-clicking on the *.msi file will lead the user through the installation process. If MATLAB R2010b or MCR (version 7.14) is already installed on the host machine, then press Cancel when the following box appears. Otherwise, this will guide the installation of MCR version 7.14.

When finished with the installation process, the following dialog should let you know that the installation was successful. Section 3.2 below describes how to open the tool within ArcMap.
Optional Software

While not required for use of the downscaling software, the topographic analysis freeware TauDEM is useful for calculating topographic attributes and generating the files needed as input to the downscaling software. TauDEM is available at the following URL:

http://hydrology.usu.edu/taudem/taudem5.0/index.html

Appendix B describes how to acquire TauDEM software. Appendix C details how to use TauDEM to provide inputs for DownscaleConcept.exe.
3 Software Use

3.1 Inputs

Use of the DownscaleConcept software requires the user to provide a coarse-scale raster for soil moisture as well as fine-scale rasters for elevation, slope, specific contributing area (SCA), and aspect (direction of steepest descent). Such terrain characteristics can be estimated from digital elevation models (DEMs). Appendix A details the process to obtain fine-scale DEMs from the National Aeronautics and Space Administration (NASA), although many other agencies provide DEM data. Additionally, the user must provide an estimate of the annual average daily potential evapotranspiration rate.

3.1.1 Coarse-scale moisture grid

The first input required by DownscaleConcept is a coarse-resolution soil moisture grid. This grid provides the base moisture values that act as spatial average moisture values for the downscaled moisture pattern. The moisture values in the coarse grid should have units of \([L^3/L^3]\) and the grid should be based in a projected coordinate system so that the grid has horizontal units of \([L]\). DownscaleConcept also requires that the grid be in a GeoTIFF format (NoData values must be a negative number).

3.1.2 Fine-scale topographic grids

DownscaleConcept requires fine-scale grids for the elevation, slope, aspect, and specific contributing area (SCA). The resolution of these grids determines the resolution of the downscaled moisture estimates provided by DownscaleConcept. The extent of the fine-scale estimates is the same as that of the coarse-scale moisture grid. All of these grids should be provided in a projected coordinate system so that the grids have horizontal units of meters. The DEM should have units of \([m]\), the slope grid should have units of \([m/m]\), the aspect should have units of \([\text{degrees clockwise from North}]\), and the SCA should have units of \([m^2/m]\). The attributes will have the appropriate units when a DEM with appropriate projected coordinates is analyzed for slope and SCA by the TauDEM software and aspect is calculated by the ArcGIS Aspect function (Spatial Analyst toolbox, Surface tools). DownscaleConcept requires the grids to be in the GeoTIFF format (NoData values must be a negative number), which is also the file format used as input and provided as output by the TauDEM software. Instructions for calculation of terrain characteristics are found below in Appendix C.

In order to minimize the impacts of cross-boundary features (e.g. watersheds) on the topographic attributes calculated for the area of interest, the initial DEM used to calculate the attributes should extend some distance beyond the area of interest on all sides during the DEM topographic analysis. The DEM can then be clipped to the area of interest after the analysis. The user may need to connect (“mosaic”) multiple smaller DEMs together to obtain a single DEM extending
beyond the area of interest. Note, however, that DEM extents that are too large and/or resolutions that are too fine may lead to computer memory problems.

3.1.3 Potential evapotranspiration

The final input required for DownscaleConcept is an estimate of the annual average daily potential evapotranspiration (PET) rate in [mm/day] for the estimate area. Only one PET estimate is required for the entire estimate area.

3.2 Running DownscaleConcept

Instructions for using DownscaleConcept both through the DoConGIS tool and from the command prompt are provided below. The screen capture figures in the instructions are the same as those the user should see when using the example files provided in the “C:\Program Files\CSU\DownscaleConceptGIS\Example” folder created during software installation.

3.2.1 DoConGIS tool

1. Open ArcMap after installing DownscaleConceptGIS (refer to the installation procedure as described in Section 2.2 above).

2. On the menu bar at the top, click Tools->Customize… On the Toolbars tab, check “DownscaleConcept Tools” as shown in the figure below. Click Close.
3. The following toolbar should now be visible.

4. Click on the DoCon icon and the following dialog should appear.

5. Specify the estimated annual average daily potential evapotranspiration
6. Provide the TIFF file names for the coarse-scale moisture grid and the fine-scale topographic attributes (which can be calculated from TauDEM according to instructions found in Appendix C) to the dialog box either by dragging and dropping raster layers into the drop-down boxes, expanding the drop-down menu and selecting a file path, pressing the icon and browsing for the files, or placing the file path directly into the drop-down box.
7. The completed dialog box should look similar to the one below when using the input files from the Example subdirectory of the installation directory.
8. Click the Save ( ) button on the dialog to save your soil moisture model file (using *.sme extension). This saves a text file containing file paths to all input files for Downscale Concept as well as model parameters and running options.

9. Opening a SME file in a text editor will return something like the following figure, where the lines contain the version number, file paths to input files, and model parameters or options respectively.
10. Under the Tools menu at the top of the dialog, other model parameters can be viewed and adjusted.

a. Tools->Units Description... describes the units used for analysis.

![Units Description](image1)

b. Tools->Model Parameters... allows the user to view or specify the model parameters that are conceptually linked to physical processes affecting soil moisture levels.

![Model Parameters](image2)
c. Tools->Attribute Bounds... allows the user to specify minimum values for the Potential Solar Radiation Index (PSRI), which is calculated within DownscaleConcept, and the slope. These attribute values are found in the denominators of calculations within DownscaleConcept so their minimum values must be greater than zero. A nominal minimum slope value is 0.5 / cellsize. In this case the cell size is 30 m.

![Attribute Bounds](image)

![Set Program File Paths](image)

d. Tools->Set File Paths... allows the user to specify the paths to the DownscaleConcept executable file and the parameter file path. DownscaleConceptGIS writes the parameter file prior to running DownscaleConcept.exe.
e. Another option within DownscaleConcept is to truncate downscaled soil moisture estimations at soil porosity. This can be done by checking Tools -> Truncate SM at Porosity.

f. Hovering over any of the model parameters in the above dialogs will prompt a balloon to pop up, describing the parameter.
g. Clicking About brings up a description of the tool.

11. Save the *.sme file again. Then, click “Run DownscaleConcept” at the bottom of the dialog box to calculate the downscaled soil moisture estimates.
12. A console window will display while DownscaleConcept is running:

![Console Window](image)

13. When the tool finishes calculating, the output should look like similar to the following figure, although the console window will close immediately after finishing:

![Command Prompt](image)

14. If the output TIFF files are not automatically loaded into ArcGIS, then either an error occurred in DownscaleConcept or in pulling output into ArcGIS. One solution is to make sure all input TIFF files are in GeoTIFF format, exported from TauDEM or ArcMap. All fine-scale topographic rasters must be exactly the same size, containing the same amount of rows and columns with the same cell size and spatial reference. Also, ensure that none of the input files found temporary directory are loaded within ArcGIS (Temp files are copied to the location shown in Tools->Set File Paths..., and then DownscaleConcept.exe executes calculations on the temporary files, and then temporary files are deleted. This process cannot be done when these temporary files are loaded within ArcGIS because ArcGIS places a lock on any file open within its framework).
3.2.2 Command line version

Two executable files, “DownscaleConcept32.exe” and “DownscaleConcept64.exe”, are distributed with DownscaleConceptGIS and can be found in the “Program Files\CSU\DownscaleConceptGIS” folder on the host machine. The appropriate executable file for the central processing unit of the host machine may be run from the Windows Command Line Prompt or by double-clicking on a batch file. To run DownscaleConcept from the command line, the user must provide seven file names, representing the model parameter file, four input GeoTIFF files and two output GeoTIFF files. The file names must be provided in the following order: model parameters, coarse soil moisture, elevation, slope, specific contributing area, aspect, fine-scale PSRI, and fine-scale moisture estimate.

3.2.2.1 Input file format

When running DownscaleConcept from the command line the user must first specify the name of the file containing the model parameters. This file is a standard text file and the default parameter values are provided in the file named “Params.txt” in the installation directory. The format of the file is shown in the below screen capture (A “%” sign at the beginning of a line indicates a comment, and values are delimited by white space, either spaces or tabs):

![Parameter file format screenshot](image)

The remaining file names provide locations for the coarse-scale soil moisture grid, the fine-scale topographic grids and the output files. The requirements for the coarse-scale moisture and topographic attribute input files are discussed in Section 3.1 above.

3.2.2.2 Command line usage

DownscaleConcept can also be run from a batch file and an example batch file (“RunDownscaleConcept.bat”) is included in the installation directory. Batch files are simply text files with a list of command line actions to perform. Command line prompts must follow the
pattern below (brackets ‘[’ and ‘]’ indicate optional parameters, if running on a 32-bit processor, replace DownscaleConcept64.exe with DownscaleConcept32.exe):

```bash
[<path>]DownscaleConcept64.exe  "[<path>]<Params text filename>"
  "[<path>]<Elevation GeoTIFF filename>"
  "[<path>]<CoarseSoilMoisture GeoTIFF filename>"
  "[<path>]<Slope GeoTIFF filename>"
  "[<path>]<ContributingArea GeoTIFF filename>"
  "[<path>]<Aspect GeoTIFF filename>"
  "[<path>]<OutputPSRI GeoTIFF filename>"
  "[<path>]<OutputSoilMoisture GeoTIFF filename>"
```

Different input file paths must be separated with a space at the command line. If a file path contains a space within its name then the file path must be enclosed in double quotation marks (e.g., “File Path Containing Spaces.txt”). For an example of a command line prompt that runs DownscaleConcept, open “RunDownscaleConcept.bat” with any text editor. The following screen capture shows the command prompt window when running the command line version using the files in the Example subdirectory. The command prompt below shows a general form when the current directory contains “DownscaleConcept[64 or 32].exe.” Quotations are only required around file paths containing spaces.
3.3 Outputs

Outputs of DownscaleConcept, whether run through DoConGIS or from the command line, are GeoTIFF files for the fine-scale soil moisture and the potential solar radiation index (PSRI) pattern. The fine-scale soil moisture estimate provides soil moisture estimates for the specified date at the spatial resolution of the provided topographic attributes. The estimate has the same units as that of the coarse moisture pattern, \[\text{L}^3/\text{L}^3\]. The extent of the estimate is that of the intersection of the coarse-scale moisture and the topographic attributes provided. A second output from DownscaleConcept is the PSRI pattern with the same extent and resolution as the other topographic attributes. PSRI is calculated and used by DownscaleConcept to generate the fine-scale moisture pattern and is provided as output for reference. The PSRI represents the potential insolation available on a sloped surface relative to that of a horizontal surface at the same location on the winter solstice date.

3.3.1 Viewing Outputs in ArcGIS

DoConGIS automatically loads output files into ArcGIS after running DownscaleConcept when Tools->Auto Load Output is checked. If for some reason output files do not load, viewing the outputs will require some post-processing. Since GeoTIFF files do not store a tag for a NoData value (a GeoTIFF file may look as if it contains a NoData value within ArcGIS, but NoData values are actually stored within *.aux files), a filtering process is required for ArcGIS to read the output rasters. Instructions below discuss how to view the data in ArcGIS.

1. In ArcMap, right-click on the data frame in the table of contents and select Add Data...
2. Browse to the folder containing your outputs and add the outputs to the map. Select Yes when asked to build pyramids.
3. ArcGIS will automatically assign large lower and upper bounds to the outputs. To fix this, right-click on the layer in the table of contents to open its Properties window and select the Symbology tab. Select Classified in the field on the left. Click Yes when asked to compute a histogram.
4. Press OK, and the output may look bad initially… like the below figure. This is because of the unrecognized NoData value.
5. DownscaleConcept nominally exports NoData in the GeoTIFF file as a negative number. In order for ArcGIS to recognize this number, a new grid will be calculated using a condition. There are many ways to do this in ArcGIS, but a simple way is to open ArcToolbox -> Spatial Analyst Tools -> Conditional -> Con. Place the output fine-scale soil moisture grid into the first and third fields and place “Value >= 0” in the second field like so:
6. The following raster will automatically be added to your map session, which looks much better.
4 Acknowledgments

The authors would like to thank the United States Army Corps of Engineers’ Engineer Research and Development Center and the Army Research Office for funding of the research and development of the downscaling model and associated software. Also, we would like to thank George Mason for supplying the coarse resolution data used for the development and trial applications of the model and software.
Appendix A  Acquiring ASTER elevation data

A digital elevation model (DEM) is used to calculate the topographic attributes required by DownscaleConcept. ASTER global DEM data is available for most parts of the world and can be downloaded from the internet at the URL:


For convenience, directions for downloading ASTER data have also been transcribed here:

1. Go to https://wist.echo.nasa.gov/api/ and login to your account (you must be a registered user).

2. Select the following options in the search Page:
   a. From Land Discipline: Select [ASTER] (This will populate the Category box definitions)
   b. From Category box: Select [ASTER Global Digital Elevation Model V001]

3. Choose search area parameters: location or region

4. Scroll to the bottom of the page and select “START SEARCH”
   a. Note that you can only search for 1000 granules at a time. If there are more granules that match your query, you will be first presented with the dataset
results to your query. From this page, check the box next to the ASTER GDEM dataset and press the "List data granules" button to view your result granule listing.

b. To find more than the 1000 granules returned, it is recommended that you refine your search parameters.

5. Proceed to "Step 1" and select your desired granules. Select an area greater than your area of interest because edge effects can be significant while calculating contributing area. The following figure displays the area of interest compared to the downloaded DEM coverage. Notice that four DEMs were downloaded to cover the area of interest.
6. Press the “Add selections to cart” button to create your order contents.

7. Accept the Data Quality Summary Disclaimer.

8. Choose ordering option for data retrieval. WIST will report that the granules are not orderable if you have not logged in as a registered user.

9. Check appropriate policy acknowledgements (required fields)
10. If desired, select a different option to applying the order options to all granules or saving as order preference.

11. Proceed and select “Next Step”. The data granules will now be accessible in your shopping cart.

12. Select “Go to step 2: Order Form”

13. You may be asked to fill out address location and billing information for verification. No charge will be associated with GDEM data archives.

14. Select “Submit Order Now!” to process your order.

15. Wait for email confirmation to retrieve data via FTP.

16. Follow email directions to retrieve data.
Appendix B  Acquiring TauDEM 5 software

The TauDEM software is free software produced by Utah State University that is useful for calculating the topographic attributes required by DownscaleConcept. TauDEM can be downloaded from the following URL:

http://hydrology.usu.edu/taudem/taudem5.0/index.html.

That website also provides instructions for installing and using the TauDEM software. Note that TauDEM also requires installation of a message passing interface software, MPICH2, and the above-referenced website also provides instructions for obtaining and installing that software as well. The TauDEM instructions about adding the MPICH software to the user’s search path were unclear. Therefore, additional instructions for this part of the installation are found below:

1. Click Start->Right-click Computer->Properties->Advanced System settings->Advanced tab->Environment Variables… Navigate within the “System variables” to find “Path” in the “Variable” field as shown in the screenshot below.

![Environment Variables Screenshot](image)

2. Click Edit… below the System variables. Add “;C:\Program Files\MPICH2\bin” to the end of the values in the “Variable value:” field.
If ArcGIS was running during the installation of TauDEM, close and reopen it before using TauDEM.
Appendix C  Terrain Characteristics - Calculations

DownscaleConcept requires terrain information such as contributing area, slope and aspect to downscale a coarse soil moisture estimate. In order to determine topographical characteristics, a DEM must be downloaded, manipulated, and utilized in terrain characteristic calculations. A sample tutorial for processing data through TauDEM is found in the sections below.
C.1 Manipulate DEM data for placement into TauDEM

Prior to calculating terrain characteristics, a few pre-processing steps should be considered. In order to minimize the impacts of underestimating contributing area calculated for the area of interest (e.g., having a watershed much larger than the downloaded DEMs), it is suggested that the initial DEM extend beyond the area of interest during the DEM topographic analysis. The DEM can then be clipped to the area of interest after the analysis. The user may need to connect (“mosaic”) multiple smaller DEMs together to obtain a single DEM extending beyond the area of interest. This may be accomplished in ArcGIS as well. Note that DEM extents that are too large and/or resolutions that are too fine may lead to computer memory issues.

1. Open the ArcMap file that was started in Section Error! Reference source not found., if not already open.

2. Right-click the data frame (“Downscaled Soil Moisture Estimation”) in the table of contents->Add Data... Browse for the downloaded DEM data and click Add. Do this for all the DEM grids that you downloaded. On the Tools toolbar (shown below – if it not displayed, right-click on the grey space where other toolbars are located and select “Tools” on the drop down list), click the world symbol to zoom to the full extent of all the data.
3. For convenience, define a group layer by right-click on the data frame->New Group Layer. Double-click the New Group Layer and change its name to Small DEMs. Highlight all the DEMs again and drag them into Small DEMs. Now, drag Small DEMs below the coarse soil moisture grid so that the coarse soil moisture grid displays above the DEMs.

![Table of Contents](image)

4. A histogram of the data in the DEMs needs to be evaluated. Therefore, double-click on each of the DEMs within the table of contents (on the “Display” tab) to open their associated Layer Properties. Open the Symbology tab, and select Classified in the “Show:” field to the left. It will ask you if you want to compute a histogram. Click Yes.

![Histogram](image)

5. Now that the histogram has been computed, go back to Stretched in the Show field by clicking on it.
6. Right-click on the Color Ramp list box and uncheck Graphic View. Then, select Elevation #1 in the drop-down list. Click OK.

7. Repeat this process for every DEM that you downloaded.

8. Once you completed the process, you should have a view that looks like this:
9. Now, mosaic the adjacent DEM pieces together. Open ArcToolbox (shown in the lower left in the figure above). Open Data Management Tools->Raster->Raster Dataset->Mosaic To New Raster. Fill the form out similar to the following figure. Ensure that the Raster dataset name has the extension *.tif, because TauDEM only processes this file format (TIFF).

10. Close the output message box.
11. In the table of contents, right-click the new layer name and click Properties… Go to the Symbology tab. Right-click on the Color Ramp and uncheck Graphic View. Then, select the Elevation #1 color ramp from the drop-down list. Click OK.

12. Up until now, the DEM data has been in an un-projected, Geographical Coordinate System. Also, the coordinate system may very well be undefined. Therefore, right-click the data frame “Downscaled Soil Moisture Estimation” in the table of contents, click Properties… On the Coordinate System tab, see if the Current coordinate system is defined. If so, click Cancel. If not, go to “Select a coordinate system”. Predefined-> Geographic Coordinate Systems-> World ->WGS 1984 or a different, more applicable geographical coordinate system to area of interest.

13. For use in DownscaleConcept, a projected coordinate system is required. Therefore, project the new DEM to a coordinate system associated with the specific area of interest. For Afghanistan, the WGS 1984 UTM Zone 41N is applicable. Open the ArcToolbox, and click on Data Management Tools->Projections and Transformations->Raster->Project Raster.

14. Place the DEM into the Input Raster field.
15. Select an output file path for the projected raster, and ensure that the file has extension *.tif because DownscaleConcept requires TIFF files as input. Note that TauDEM requires TIFF files as well if using it for topographic analysis of the DEM characteristics.

16. Click the symbol next to Output Coordinate System.
17. Press Select... Navigate to Projected Coordinate System->UTM->WGS 1984-> WGS 1984 UTM Zone 41N.prj (Remember this projection is applicable to Afghanistan, not necessarily your application.

![Coordinate System Browser]

18. Choose either the CUBIC or BILINEAR option as the Resampling Technique because these are the most suitable for DEM data.

19. Choose the desired cell-size. It is suggested not to make the cellsize larger. Making it smaller, though, may increase processing time significantly. The figure below displays the difference between an unprojected coarse grid and a projected finer grid (remember that this finer grid is no more accurate than the original coarse grid’s accuracy and can also increase both the processing time and run into memory issues during runtime that may result in crashing your computer)...
20. Ensure that the final Project Raster form looks similar to the figure below and press OK.

![Project Raster Form](image)

21. Add a new group layer, name it Big DEMs, and place it under the coarse soil moisture grid. Drag the two DEMs (unprojected and projected) into the group layer.
22. Applying the same color ramp to this raster image as the un-projected one, the display should look like the below figure.
C.2 Geo-Processing with TauDEM

TauDEM is used to calculate slope and contributing area for each cell within the DEM. To run TauDEM follow the instructions below...

1. Open ArcToolbox.

2. If you haven’t added TauDEM Tools, right-click in the white space in ArcToolbox, select Add Toolbox… and browse to TauDEM in the Program Files directory (if you installed it already). Highlight TauDEM Tools and click Open.

3. Within ArcToolbox, open TauDEM Tools->Basic Grid Analysis->Pit Remove. Place the projected DEM as the Input Elevation Grid.
   a. Enter input number of processes consistent with how many processors your computer has. If you don’t know how many processors your computer has, open your task manager and go to the Processes tab. The number of windows within the CPU Usage History field is the number of processors your computer has. The figure below shows 4 processors.
b. Click OK. Running Pit Remove should take a couple minutes. If it is taking longer, there might be a memory issue and a DEM with coarser resolution may need to be processed instead.

4. Then, in TauDEM Tools, click on Basic Grid Analysis->D-Infinity Flow Directions, which tends to have better results than D-8 Flow Directions and produces slope and angle of flow direction as an output. Place the DEM with filled pits as the input raster.

5. Click OK. This process may take an hour or two depending on the extent and resolution of the DEM. With a DEM the size used in this example (9 smaller grids
connected), a 64-bit quad-core computer processing using 3 processes at 2.67 GHz took 2.5 hours to finish the task. The following console should pop up when running TauDEM.

6. Now, contributing area can be calculated. Go to TauDEM Tools, click on Basic Grid Analysis->D-Infinity Contributing Area. Deselect “Check for edge contamination” to ensure that missing values do not appear in the area of interest. Click OK.
7. If desired, run D-Infinity Contributing Area with “Check for edge contamination” selected in order to see how many missing values due to edge effects run through the area of interest.

   a. After running the Contributing Area calculation, zoom into the area of interest with the Contributing Area displayed on top.

   b. Double-click on the contributing area layer to open its Layer Properties. On the Symbology tab, select Classified or Stretched in the Show field to the left. In the bottom right of the window is “Display NoData as”. Click on the drop down box next to this and select a bright color (red or pink). Click OK. Observe the contributing area grid on the map.

   c. If there are no missing values through the area of interest, every upstream point has been included in analysis. If not, it’s ok, DownscaleConcept uses more of a relative contributing area anyways, but you may consider retrieving more of the basin extent in the original DEM.
C.3 Produce Aspect Grid
In order to determine solar effects on soil moisture estimation, the aspect (direction in which a slope is facing) is used as input to DownscaleConcept. Calculate aspect in ArcMap by following the instructions below:

1. In ArcMap, click Tools->Extensions... Ensure that the Spatial Analyst extension is selected.

   ![Extensions window](image)


3. Place the projected DEM (not the one with filled pits) into the Input Raster field.
4. Ensure that the suffix is “.tif” because DownscaleConcept accepts only TIFF file formats as inputs. Click OK.

5. Drag the aspect layer below the coarse soil moisture grid. Output will look something like this:
C.4 Clipping Terrain Characteristics to Area of Interest

After terrain characteristics have been calculated, all associated rasters will be clipped to the area of interest for modeling purposes. Follow these instructions:

1. In ArcToolbox, open Data Management Tools->Raster->Raster Processing->Clip.

2. There are three grids that will be clipped: Aspect, ContribArea, and Slope. Place one of these three into the “Input Raster” field on the Clip dialog. Place the Coarse Soil Moisture grid into the “Output Extent” field. Change the extension on the Output Raster Dataset to “.tif” to ensure the output raster is in the TIFF format. Ensure that the dialog looks like the one in the figure below and then click OK.

![Clip Dialog](image)

3. If the clip does not reduce the size of the Aspect / Slope / Contributing Area grid, then make sure that Coarse SM has a defined coordinate system (ArcToolbox->Data Management Tools->Projections and Transformations->Define Projection) and repeat Step 2.
4. Repeat Steps 1 through 3 for each of the three terrain characteristics (Aspect, Slope, Contributing Area) to reduce the size of each of the grids.