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FOREWORD 
 
This report documents the effort to couple computational fluid dynamics (CFD) and 
experimental ground testing more closely. The effort is comprised of rapid prototyping 
manufacturing techniques, CFD, experimental ground testing, a multitude of diagnostic 
measurement techniques, and computer software designed as interface tools. 
 
Experiments were conducted in both the Air Force Research Laboratory (AFRL) Subsonic 
Aerodynamic Research Laboratory (SARL) and the Air Force Institute of Technology’s (AFIT) 
3 by 3 wind tunnel; both tunnels are located at Wright-Patterson Air Force Base, Ohio.   
 
This report contains descriptions of the rapid prototyping techniques, experimental operations, 
and computational analyses. The purpose of the report is to document pertinent information 
about this effort. The information provides planners with guidelines for similar efforts that may 
be required in the future. For more details, the reader is directed to review the papers and 
journals listed in the bibliography section. 
 
After the performance of the two experimental ground tests, methods to properly integrate 
experimental testing methodologies and computational simulations seamlessly were developed in 
the forms of the Virtual Diagnostics Interface (ViDI) and OMS software. These systems are the 
culmination of the unified approach to testing and data visualization/analysis. 
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1.  INTRODUCTION 
 
To characterize and improve upon aircraft designs in an expedient and efficient manner, it is 
imperative to generate approaches for rapidly assessing new aircraft designs.  Recent 
technological advancements have enabled faster and more accurate assessment in three specific 
areas: CFD modeling, Rapid Prototyping (RP), and experimental global measurements. The Air 
Force Research Laboratory Air Vehicles Directorate (AFRL/RB) initiated a joint 
computational/experimental ground testing program to investigate and analyze the flow field of 
the Unmanned Combat Air Vehicle (UCAV) X45-A as well as a Strike Tanker configuration. 
The test program used various rapid prototyping manufacturing technologies to fabricate models 
for ground testing; implemented innovative, non-intrusive measurement techniques; and 
compared CFD results with experimental data acquired from ground tests. 
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2. Rapid Prototyping 
 
Rapid Prototyping (RP) is a robust, accurate, and affordable method to support aerospace 
research and development.  RP serves as the link between CFD simulations and experimental 
ground testing correlations.  Current manufacturing techniques used for manufacturing metal 
wind tunnel models are slow and costly. Reliance on these traditional methods creates a delay in 
validating the analytical model's predicted results with results from testing the physical model. 
RP may prove to be the fastest means to create a bridge between these CFD and experimental 
ground testing databases. 
 
In the past, it took months to manufacture models for ground testing.  With the seamless merging 
of computational models and recent innovations in RP technologies, inexpensive models can be 
fabricated literally overnight and tests performed immediately thereafter. Rapid fabrication 
results in a faster and better response to the designer's needs by permitting concurrent study of 
new concepts in the wind tunnel and via computer simulation. Testing of RP models early in the 
design cycle serves as a vital verification of system performance. Should the testing indicate a 
need for design changes, the changes can be made early in the design cycle where the cost and 
schedule impacts are less severe. 
 
While current RP manufacturing processes include stereo lithography, selective laser sintering, 
laser engineered net-shaping, and fused deposition modeling, among many others, two 
techniques were implemented under the direction of the Air Force Research Laboratory Air 
Vehicles Directorate: stereo lithography (SLA) and selective laser sintering (SLS). 
 
SLA is a layered manufacturing method that utilizes a photo-curable liquid resin in combination 
with an ultraviolet laser. A vat of the resin sits underneath the laser, and the laser "draws" on the 
top layer of liquid. When the ultraviolet laser beam hits the liquid it hardens a small amount of 
the resin under the beam point. By drawing and then filling the outline of a layer, a solid layer of 
material is created. This layer is then lowered a small amount into the vat, a new layer of liquid 
is placed on top, and the process repeats itself. By creating one flat layer at a time, a very precise 
geometry can be created, resulting in a complete part. Due to its accuracy and surface finish, it 
has become the most popular of the rapid prototyping methods. 
 
SLS is a layered manufacturing method that creates solid, three-dimensional (3-D) objects by 
fusing powdered materials with a CO2 laser. A thin layer of powder material is laid down and the 
laser draws on the layer, sintering together the particles hit by the laser. The layer is then lowered 
a small amount and a new layer of powder is place on top. This process is repeated one layer at a 
time until the part is complete. Subsequent to this process, the part is sintered, which fuses the 
powder particles together, and finally the part is infiltrated with another metal to fill the voids 
between the particles and form a fully dense high strength part. 
SLA is generally used to make inexpensive, plastic parts having relatively modest mechanical 
properties. In contrast, SLS is a more expensive process but can generate metallic parts with 
mechanical properties comparable to steel.  Also, SLS parts can be machined, drilled, and 
polished just like traditional metals. 
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The basic philosophy is to use RP technologies to quickly and inexpensively build parts that 
define the outer mold line of the model. Models built entirely with these materials are generally 
not stiff enough or strong enough to withstand the loads in a wind tunnel test. For the UCAV X-
45A model, a quarter-inch-thick steel plate was used to support the model. The plastic parts were 
then fabricated using a process called SLA. The entire computer model can be seen in Figure 1. 

 
 

 
 

Figure 1:  Exploded View of UCAV X45-A Built with SLA Method 
 

The model is roughly 3 feet long with a span of 4 feet and has three pairs of deflecting control 
surfaces on the trailing edge. Models built entirely with these materials are generally not stiff 
enough or strong enough to withstand the loads in a wind tunnel test. The SLA parts were 
manufactured using Accugen 100 resin. This material has a tensile strength of 9.7 ksi and a 
modulus of elasticity of 440 ksi. The maximum deflection at the wing tip is about 0.35 inch, as 
can be seen in the deflection contours shown in Figure 2. The completed model, as mounted in 
the Subsonic Aerodynamic Research Laboratory (SARL) is shown in Figure 3. Various testing 
has been performed on this model at Mach numbers of 0.2 and 0.4 through the angle of attack 
range of -4 to 24 degrees. 

 

 7
3



 
 
Figure 2:  Finite Element Analysis for UCAV X45-A Wing Deflection 
 

 
 

Figure 3:  Finished SLA-built UCAV X45-A Mounted in SARL 
 

With some understanding of rapid prototyping manufacturing technologies the further 
investigations were performed to demonstrate the advantages of rapid prototyping in the early 
development of AFRL technology demonstrators. 
 
An airframer provided the University of Dayton Research Institute with detailed electronic 
model information to fully define the external Strike Tanker geometry. Efforts began for the 
design of the model to address the factors of mounting, instrumentation, and rapid prototype 
fabrication material and technique. 
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Having addressed the mounting and instrumentation issues, the final aspect of the wind tunnel 
model design effort was the selection of a particular rapid prototyping technique. Given the 
extremely thin wing cross sections in the current design there was concern that the wings might 
fail or deflect excessively during testing, so an analysis was performed to estimate the wind 
deflection at Mach 0.2 with a 20 degree angle of attack for both SLA and SLS model 
configurations. Deflection results from the SLS model are indicated in Figure 4. Maximum wing 
tip deflections for the SLA and SLS model configurations were 0.25 and 0.004 inch, 
respectively. With this information, a decision was made to use SLS for the application to 
demonstrate the technology and generate experience for future applications.  
 

 
 
Figure 4:  Finite Element Analysis for Strike Tanker Wing Deflection 

 
Current generation SLS equipment limits the maximum part size to approximately a 10 by 10 by 
10 inch volume, so the wind tunnel model had to be fabricated in several pieces and then 
assembled. Ultimately, the model was broken into six pieces: forward and aft fuselage, left and 
right wings, and left and right tail fins as depicted in Figure 5. 

 

 
 

Figure 5:  Exploded View of Strike Tanker Built by SLS Method 
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As depicted in Figure 6, the assembled wind tunnel model was delivered and successfully 
mounted in the AFIT low speed wind tunnel where testing of the aircraft configuration has 
occurred. 

 

 
 

Figure 6:  Finished SLS-built Strike Tanker Mounted in AFIT Wind Tunnel 
 

This project has demonstrated that non-metallic prototypes can be used successfully as wind 
tunnel models with some careful design. Each wind tunnel environment imposes a set of 
performance requirements that must be defined before choosing the RP process. Selection of the 
appropriate material for the design constraints is crucial and the aircraft CAD model may have to 
be adjusted to accommodate the RP process. 

 10
6



 
3. UCAV X45-A 
 
 The John Hopkins University Applied Physics Laboratory (JHU/APL), under contract to 
AFRL designed, analyzed, and fabricated a low cost wind tunnel model of the UCAV X45-A. 
Multiple configurations of the model were tested with varying inboard, mid-board, and outboard 
elevator angles (-20, 0, and +20 degrees) at Mach numbers of 0.2 and 0.4. Although angle of 
attack sweeps from -4 to 24 degrees were performed, the majority of the data acquisition 
occurred at the angles of 12 and 20 degrees as a result of aerodynamic interest. 
 
 
 
3.1 Experimental Ground Test Facility 
 
The UCAV X45-A model was installed in the SARL. The SARL, as schematically shown in 
Figure 7, was built to provide research for complex flow configuration vehicles in the subsonic 
regime to researchers within the Air Force and DoD organizations. The SARL is an open-circuit, 
atmospheric subsonic wind tunnel with a test section dimension of 10 by 7 and 15 feet. The 
facility is capable of operating at the Mach number range of 0.15 to 0.6. 
 

 
 

Figure 7:  Schematic Drawings (Top, Right, and Front) of SARL 
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3.2 Global Measurement Techniques 
 
Three major global diagnostic techniques: Pressure Sensitive Paint (PSP), Projection Moire 
Interferometry (PMI), and Planar Doppler Velocimetry (PDV), were implemented during a 
seven-week test. In addition, a software system called Virtual Diagnostics Interface (ViDI), 
consisting of an interactive, 3D environment of the SARL facility, has been developed to enable 
both the pre-test optimization and planning of the instrumentation deployment, and the 
comparative evaluation of global surface pressure distributions (PSP) and model deformation 
(PMI). The last portion of the test included state-of-the-art skin friction measurement technique 
(SFS3). 
 
3.2.1 Pressure Sensitive Paint (PSP) 
 
PSP is an optical diagnostic capable of recovering global surface pressure distributions on test 
models. PSP is a surface coating that utilizes luminescence to measure static pressure on the 
surface. The technique exploits oxygen-sensitive luminescent molecules that are dispersed in 
polymer binders or paints. In wind tunnel applications, the PSP is applied to the model by 
conventional paint spraying techniques. The cured paint is illuminated with a short wavelength 
(< 530 nm) source, and the surface image is observed through a long-pass (> 550 nm) optical 
filter. Light sources such as blue LED arrays are mounted external to the test section to 
illuminate the painted model and effect luminescence emission from the entrapped oxygen-
sensitive molecules. PSP emission occurs in the orange region of the visible spectrum (~650 
nm), the intensity of which is inversely proportional to pressure such that brighter regions in the 
paint emission indicate lower pressure relative to the darker areas. Typically, the image is 
acquired with a digital camera to enhance the measurement sensitivity and accuracy and is 
processed with false color for clarity. Scientific-grade CCD cameras with spectral band-pass 
filters to discriminate between the excitation (blue) and emission (orange) signals, capture the 
intensity image of the PSP-coated model surface, providing a means to recover global surface 
pressure distributions on test articles of interest. A very high resolution, two-dimensional map of 
the air pressure can be achieved with this technology. The application of the Pressure Sensitive 
Paint technology is divided into two separate methods; Intensity-based and Lifetime-based, each 
depicted in Figure 8, respectively. Figure 9 shows a side-by-side comparison of the two PSP 
concepts as performed on the same UCAV X45-A configuration. 
 
3.2.1.1 Intensity-based method 
 
PSP images acquired either prior or immediately following tunnel operation (wind off) are 
ratioed with images acquired during tunnel operation (wind on). This “intensity method” requires 
the acquisition of associated wind off images at each model position, attitude and configuration 
to allow ratioing with the corresponding wind-on image.  
 
3.2.1.2 Lifetime-based method 
 
In the time-resolved, lifetime-based method, excitation of the PSP is accomplished using the 
same light sources as the intensity-based method. Following excitation of the PSP, the excited 
state luminescence decay is collected using a fast-framing camera. Typically, the decay is 
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approximated using two images at different decay times following the pulsed excitation and 
integrating photons for fixed periods of time that have been predetermined to maximize pressure 
sensitivity. The first image usually consists of a short gate width and is collected either during or 
shortly after it ends. This can be thought of as the reference image because the excited-state 
decay has the least pressure sensitivity. The second image is taken at a later time after the 
excitation pulse and usually has a longer gate width, ensuring maximum pressure and 
temperature sensitivity. 
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Figure 8:  Cartoon Depictions of the Concepts of PSP 

 
 

 
 

Figure 9:  Side-by-side Comparison of Intensity-based and Lifetime-based PSP 
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3.2.2 Projection Moire Interferometry (PMI) 
 
PMI is a video-based, noncontacting measurement technique capable of obtaining spatially 
continuous measurements of out-of-plane structural deformations, as depicted in Figure 10. The 
technique is well suited to measuring the deformation of aeroelastic vehicle components or 
aerodynamic control surfaces. PMI provides a full-field measurement of the actual wind-on 
model geometry, facilitating the refinement of baseline CFD grids to match the wind-on model 
shape. Figure 11 shows a side-by-side comparison of the earlier performed Finite Element 
analysis and the Projection PMI visualization for the UCAV X45-A. 
 

 

Raw PMI data image 
showing projected 
grid lines 

Moiré fringes generated by 
interfering raw PMI data 
with a computationally 
generated reference grid 

PMI-measured airfoil 
shape data obtained by 
processing moiré fringe 
images 

 
Figure 10:  Depiction of the PMI concept 

 
 

 
 

Figure 11:  Side-by-side Comparison of Finite Element Analysis and PMI 
 
3.2.3 Planar Doppler Velocimetry (PDV) 
 
PDV is a velocity measurement technique capable of recovering planar three-component velocity 
data, as observed in Figure 12. The method relies on a direct measurement of the frequency-
shifted light scattered by moving particles suspended in the flow under investigation (i.e., 
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Doppler effect). Since the frequency shift is many orders of magnitude smaller than the 
frequency of the illuminating light itself, a molecular filter serves as a frequency-to-intensity 
converter. Negative velocity causes negative Doppler shift and increased transmission through 
the molecular filter, whereas positive velocity causes positive Doppler shift and decreased 
transmission through the molecular filter. 
 

 
 

Figure 12:  PDV measurement technology concept 
 
 
3.2.4 Skin-Friction Shear Stress Sensor (SFS3) 
 
Skin friction balances (direct sensors) are based on a floating element. Direct sensors measure 
the integrated force produced by the wall shear-stress on a flush-mounted, moveable, floating 
element. The size of the floating element dictates the sensitivity required of the measuring 
system, which may be passive (displacement) or active (force-feedback). The principle of the 
measurement is based on the transformation of tangential tension into the deformation of a thin 
film. A magneto-resistive transducer, as seen in Figure 13, for point measurements, was tested in 
both the Innovative Scientific Solutions, Inc.’s low speed wind tunnel at 10 to 40 meters per 
second flow velocity, and the Air Force Research Laboratory’s Subsonic Aerodynamic Research 
Laboratory at 30 to 140 meters per second flow velocity.  
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Figure 13:  Magneto-resistive transducer and its placement in the UCAV X45-A. 
 
3.3 Computational Fluid Dynamics (CFD) 
 
Initially, a grid and subsequent solutions were generated to provide needed information for the 
fabrication and stress analysis of the UCAV X45-A model. Three-dimensional Euler solutions 
were obtained using AVUS, an Euler/Navier-Stokes code developed in the Computational 
Sciences Branch Air Vehicles Directorate. AVUS is an unstructured, cell-centered, finite-
volume, Godunov-type solver that uses least-squares gradient reconstruction and limiting for 
second-order spatial accuracy and second-order point-implicit time integration. It handles two 
and three dimensions, arbitrary cell types, and has been efficiently parallelized using Message 
Passing Interface (MPI). 
 
In an effort to compare similar scenarios and resulting conditions the initial grid was modified to 
encompass not only the aircraft configuration but also the wind tunnel walls and sting/mount 
device at the various pitching angles chosen for the experimental test. The intent of the revised 
grid is to better emulate the wind tunnel experiment. The domain boundaries relating to the wind 
tunnel walls were modeled as no-slip, inviscid surfaces while the inflow/outflow boundaries 
were modeled using the Riemann invariant freestream condition. 
 
Euler simulations for quasi-steady-state conditions were acquired for Mach 0.2 and 20 degrees 
angle of attack to compare with the PDV measurements, Figure 14. However, realizing that 
viscous effects would be an issue, especially in the region of the nose-generated vortex and the 
vortex at the wing/body juncture, grids were reconstructed to develop a viscous grid layer. The 
revised grid consisted of 14,546,389 cells and was used by the AVUS solver under full Navier-
Stokes viscous capability. Figure 15 shows a few example visualizations of the simulations for 
various elevator angle settings for Mach 0.2 and 20 degrees angle of attack conditions. 
 
Each computational case was performed using the two-equation Wilcox (1998) k-w turbulence 
model. Computational damping factors of advection and diffusion were 0.15 and 0.1, 
respectively. AVUS was operated in double precision with spatial discretization set for second-
order accuracy and temporal discretization set for first-order accuracy. 
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Figure 14:  Visualization of Flowfield about UCAV X45-A (Euler Simulation) 
 
 

 
 

12 degrees AoA 
Mach 0.2 

Flaps -20, -20 
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Mach 0.2 
Flaps 0, 0 

12 degrees AoA 
Mach 0.2 

Flaps 20, 20 

Figure 15:  CFD Flowfield Visualizations for UCAV X45-A, Three Elevator Settings 
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3.4 Joining of Experiments and CFD 

he seven week test of the rapid prototyped UCAV X-45A wind tunnel model within the 
/RB) 

ment 

FD results provide a database of global surface and off-body measurements. It is imperative 
t 

; 

 
 

t 
n 

he following images, shown in Figure 16, are comparisons between the computational 
lver for 

 
Figure 16: Side-by-side Comparison of CFD and PSP 

 
T
Subsonic Aerodynamic Research Laboratory allowed the Air Vehicles Directorate (AFRL
to establish its process for the integration of CFD and experimental ground testing. AFRL/RB 
demonstrated the ability to assess the aerodynamics of an advanced configuration through the 
use of technology assessment tools such as CFD, experimental ground testing, and global 
diagnostic measurement techniques. Future efforts will focus on the automation and refine
of the global diagnostic measurement techniques as well as the development of software for the 
ease of geometry and grid manipulation.  
 
C
that the data supplied by experimental ground testing also provide such global measurements. I
is one thing to perform experimental ground testing and compare it to computational simulations
it is another thing to integrate the two elements. Within one-half hour after the acquisition of the 
experimental data, the data was processed and recorded side-by-side with the computational 
results. The goal of the integration was for each separate program to provide their strengths to
better each other. The CFD analyses could be used to develop the test matrix and direct the test
whereas the experimental ground test may be used to validate the CFD results. Eventually, once 
confidence in the CFD code is established, the CFD could be used to extend the knowledge 
database for a given aircraft configuration beyond the ground test envelope and into the fligh
regime. Working in tandem, in an integrated fashion, these two technology assessment tools ca
be quite powerful. 
 
T
simulations and the Pressure Sensitive Paint measurements. Even though only a Euler so
CFD was used, the comparison is within 10 percent. 
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During testing the physics as 
ence, 

positions of the cameras and the verification of the flowfield 
analyzed by PDV were validated through the use of CFD analysis. Figure 17 shows, in sequ
the raw image obtained during PDV testing; the CFD analysis for the same viewing angle of the 
flowfield; and the finished PDV image relating velocity vectors. 
 

 
 

Figure 17: Using CFD to Validate PDV Camera Position for Testing 
 

itial testing within the SARL at the 30 to 140 meters per second conditions proved destructive 

Figure 18: Visualization of the Coefficient of Skin Friction as Predicted by CFD 

In
to the polymer suspending the floating element used to make the skin friction measurements. 
After readjusting the polymer the experiments were performed again. Visualizations of skin 
friction as predicted by CFD are shown in Figure 18. 
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4.  STRIKE TANKER 

 
4.1 Experimental Ground Test Facility 
 
The tunnel is of Eiffel-type, with a closed test section. The intake plenum has dimensions of 122 
by 111 by 70 inch, and is fitted with a one-quarter-inch aluminum honeycomb flow-straightener 
and four 20 by 20 inch steel mesh anti-turbulence screens. The converging section has a 
contraction ratio of 9.5:1. The length from the end of the last anti-turbulence screen to the 
beginning of the test section is 95.5 inch. The test section is 31 by 44 by 72 inch and is composed 
of Plexiglas side walls and a Plexiglas upper wall. The model support sting enters the tunnel 
through a slot at the bottom of the test section. It can traverse angles of attack from -25 to +25 
degree, and is supported by a turntable, enabling sideslip angles from -20 to +20 degree. The 
tunnel is shown in schematic in Figure 19. 
 

 
 

Figure 19: AFIT’s Low Speed Wind Tunnel 
 
The force and moment data were collected with an Able Corporation Series D, MKII nominal 
100 pound-force, six-component internal strain gauge balance, accurate to 0.25 percent of full 
capacity.  
 
The model is shown mounted on the balance, supported by the sting in the wind tunnel in Figure 
20. The model wing span, b, was 20 inches, which led to a ratio of the span to wind tunnel width 
of 0.49.  
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int (PSP) – intensity based 
 
PSP was utilized in the current study. Pressure maps of the upper surface of the strike tanker 
were collected using PSP. The PSP setup in this experimental study utilized a Bi-Luminophore 
PSP from Innovative Scientific Solutions Inc. (ISSI).  Notably, no base coat was applied to the 
model for the series of tests described here, though future testing may incorporate a base coat in 
order to reduce noise in the PSP signal. This paint was chosen due to its low temperature 
sensitivity and its ability to provide compensation for the model displacement relative to the 
excitation light source, as well as the instability of the light source itself.  The Bi-Luminophore 
PSP is very similar to Uni-FIB, a single layer paint composed of PtTFPP that uses a FIB binder; 
however, it uses a reference probe in addition to the signal probe.  The bi-luminophore paint 
exhibits a pressure sensitivity of 6% psig and a response time of 0.3 s and its emission spectrum 
ranges from 500 nm to 800 nm with a peak at 650 nm with 460 nm illumination at 20 o C.  The 
light sources used to illuminate the model for the strike tanker test condition were in the form of 
an array of four 2-inch blue LED light sources emitting at a wavelength of 405 nm. A matrix of 
more than 30 marker points was utilized to account for the spatial deformation of the model 
during the data processing.  

The intensity images of t  two lenses mounted to 
 14-bit Cooke PCO Series 1600 CCD camera linked up with ISSI’s image acquisition software, 

r 
lumination conditions separated in time. The filter wheel used contained a 645-nm 

ng pass filter for the signal probe and a 550 ± 40-nm band-pass filter for the reference probe. In 

ap system was used. The pressure at each tap was collected using Endevco 5 psig 
ressure transducers. 

 
or each measurement, the analysis began with the reference image that was acquired at ambient 

pressures, also known as a wind-off image.  In addition, a dark, or background, image was 

 
Figure: 20: Model Configuration Mounted in AFIT Low Speed Wind Tunnel. 

 
4.2 Diagnostic Measurement Techniques 
 
4.2.1 Pressure Sensitive Pa

 
he PSP during testing were captured using one of

a
OMS Acquire.  The Bi-Luminophore paint requires that two images be taken at each test 
condition.  The use of a filter wheel is therefore necessary to capture two separate images unde
the same il
lo
addition to all of the PSP equipment used for the last set of experimental tests, all of the 
previously discussed wind tunnel equipment including the force and moment balance and 
pressure t
p

F
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acquired with the lighting system turned off to account for any variations in background room 
light. The two categories of “wind on” images (one for each filter) collected during for test were 
processed with reference to the dark image and the wind-off image using ISSI’s OMS Lite 
Version 1.0 software in order to obtain surface pressure plots. The images were aligned using the 
marker points within the images, and the resulting pressure maps were filtered and smoothed 
using a Gaussian filter with the maximum half width of the filter set to 10 pixels in each of the 
two axes.  
 
4.2.2 Temperature Sensitive Paint (TSP) 
 

valuation of several binary paint systems developed specifically for two-gate lifetime 
approa
andidates for temperature compensated pressure measurements. Both binary paints reduce the 

ns, Inc’s UniFIB pressure paint from 
e RuBpy/UniFIB 

 demonstration tests on the Strike 

eriments and CFD 

 

f 

E
ches (mentioned previously) indicate that Py2/UniFIB and RuBpy/UniFIB are good 

c
temperature sensitivity of Innovative Scientific Solutio
.5% per degree Celcius to less than 0.1% per degree Celcius. Because th0

binary is a one-layer system, it was chosen for low-speed PSP
anker model.  Initial results from the Strike Tanker indicated that even though the T

RuBpy/UniFIB is a single-layer paint the reference and pressure probes are distributed non-
uniformly necessitating the need for a wind-off measurement. Close agreement was obtained in 
the low-speed tests between PSP and pressure tap data.  
 
4.3 CFD 
 
CFD analyses were performed to determine the pressure distribution over the wing surface. The 
three-dimensional solutions were obtained with a full Navier-Stokes code implementing the 
Spalart-Allmaras turbulence model. The CFD code is an   unstructured, cell-centered, finite 
volume, Godunov-type solver that has least-squares gradient reconstruction and limiting for 
second-order spatial accuracy and first-order, point implicit time interpretation. The grid 
consisted of 501,300 cells: 372,472 tetrahedral and 128,828 prisms to acquire viscous boundary 
layer effects.  
 
4.4 Comparison of Exp
 

CFD results are compared to the PSP measurements in Figure 21. The plots of surface 
pressure based on the CFD simulation employing the Spalart-Allmaras turbulence model showed 
a similar trend as the angle of attack was increased from 8 degrees to 14 degrees. The low
pressure region near the leading edge of the wing diminished as a broader low pressure region 
near the wing body junction grows. It should be noted that the mesh spacing near the surface o
the CFD model was on the order of 10 microns. 
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Figure 21: Comparison of CFD and PSP Results for Varied Angle of Attack
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APPENDIX A 
 

tely with no facility impact, 2) 

mics, structures, controls, and integration 

rmed to 
data. The 

Virtual Diagnostic Interface (ViDI) 
 
The virtual diagnostics interface (ViDI) is a software ensemble that provides unified data 
handling and interactive 3D displays for pretest planning, real time data visualization and post 

st analysis to enable: 1) test planning and optimization remote
comparative evaluation of experimental and computational data sets of disparate file formats for 
code optimization and validation, and 3) the establishment of a central hub to source, store and 
retrieve experimental results and display them in near-real time to enable characterization of the 

pact of technologies on the vehicle aerodynaim
components to achieve a true rapid technology assessment capability. 
 
Appendix A is the tutorial generated to introduce a new user to tasks needing to be perfo
prepare geometry for visualization, to plan out optical instrumentation, and to visualize 
uthors of this tutorial are Richard Schwartz and Gary Fleming of the Advanced Sensing and a

Optical Measurement Branch, NASA/Langley Research Center. 
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ed and a brief instruction 
anual to OMS 3.xx. In addition, “How to” application package tutorials for ProImage, 

 
APPENDIX B 

 
OMS 3.xx (ProImage, Profield, Prograph) 

 
 
The original OMS 3.xx software code was modified to increase its capability to compare results 
from experimental ground testing and Computational Fluid Dynamics solutions, and to facilitate
CFD validation using experimental data. 
 
Appendix B consists of a description of the modification tasks perform
m
ProField, and ProGraph are included. The information in Appendix B was generated and 
provided by Sergey Fonov, Innovative Scientific Solutions, Inc., Dayton OH.  
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Preliminary Operations 
 

Step 0.  Preparing a Model for Data Processing  
Using the OMS “ProImage” Program 
 
1. Apply contrast marker points on the model surface. The 

number and position of these markers should describe  
the peculiarities of the Model Geometry. The total 
number of markers should be about 15..25, and applying 
them on the periphery and extreme points of the model 
is most effective.  

Figure 1 

 
 
2. Measure the 3D coordinates of these markers, and write 

them into a file (in our case, MARK_UP.APM).  

Note. The file is a list of marker coordinates in ASCII 
format.  

 
3. Prepare a bitmap with the model image.  
 
4. After starting ProImage open an existing bitmap 

SENS_OFF.B16 that is located in subfolder 
SAMPLES\STEP_0 of the current folder: 

Choose the Open... command from the File menu, 

or 

Click the following icon from the upper toolbar: 

Figure 2 

 
The standard Open Dialog will appear on your screen. 
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Figure 3 

 
 
5. Choose the file STEP_0.B16, and click the Open control 

button. The Open Dialog will be closed, and the bitmap 
will appear on your screen. 

Figure 4 

 
 
6. Select 2D markers on the bitmap in the order of 

sequence of the 3D marker numbers using the model photo 
(Figure 1). 

Choose the Mark... command from the Markers menu, 

or 

Click the following icon from the upper toolbar: 

Figure 5 

 
The Mark Options Dialog will appear on your screen. 
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Figure 6 

 
 
7. Choose all of the needed parameters in the Mark Options 

Dialog as shown above.  
 
8. Click the OK control button. The cursor shape is 

changed to . Click on the points on the bitmap, and 
the markers will be placed at these points. 

Note. The selection of markers is to be performed with 
the highest accuracy. If a marker has been selected 
inaccurately, it is recommended that this be corrected 
through the use of Move radio button. Use of the Delete 
radio button does not change the numbers of the rest of 
the markers. If a marker is to be added (using Add 
radio button), it will acquire a number that is equal 
to the last marker number plus one. Therefore, the 
order of the marker numeration may be violated.  

Figure 7 

 
 
9. To turn off the regime of marker selection, choose the 

Mark... command from the Markers menu again.  
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10. The quality of the marker choice can be controlled 
using the resection procedure. Choose the Resection... 
command from the OMS Project menu. The Resection Methods Dialog 
will appear on your screen. 

Figure 8 

 
 

11. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
12. Click the Project control button. The Mesh Files tab of the 

OMS Property Sheet Dialog will appear on your screen. 

Figure 9 

 
 
13. Choose all of the needed parameters in the Mesh Files tab 

as shown above. The appropriate files are to be chosen 
from the same folder (subfolder SAMPLES\STEP_0 of the 
current folder). You may type the names or click the … 
control button. In this case the standard Open Dialog will 
appear on your screen to permit you to choose the files 
and their storage. 

 
14. Click the OK control button. The Resection Methods Dialog 

will appear on your screen again. 
 
15. Click the OK control button. The warning message 

concerning the absence of the file with the standard 
markers will appear on the screen.  
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16. Click the OK control button. The warning messages 
concerning the transformation error will appear on the 
screen. 

 
17. Click the OK control button or press Enter. The 

standard Save As Dialog will appear on your screen. 

Figure 10 

 
 

18. Click the OK control button. The 3D Flowfield will be 
saved on the disk with the default name UP.XYZ in the 
same folder. To visualize it is necessary to open this 
file using the ProField application. 

Note. If the result of the procedure is unsatisfactory 
(the Flowfield is displaced relative to the Geometry), 
it is necessary to repeat Steps 6-18. 

Figure 11 

 
19. To save the chosen markers on the disk, choose the Save 

Markers As... command from the Markers menu. The standard 
Save As Dialog will appear on your screen.  

68



ProImage User's GUIDE 8 

Figure 12 

 
 

20. Choose all of the needed parameters in the Save As Dialog 
as shown above.  

 
21. Click the OK control button. The markers will be saved 

on the disk as the file HST_315DD.MPT. In subsequent 
processing this file will be used as a file with 
standard markers.  
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Chapter 1. Working with a Project File  
 

Step 1. Creating a Project File 
 
1. To create a new project file, choose the New OMS Project... 

command from the OMS Project menu. The OMS Property Sheet Dialog 
will appear on your screen. 

Figure 1.1 

 
 
2. Choose all of the needed parameters in the Test Features 

tab as shown above.  
 
3. Click the Write... control button. The standard Save As Dialog 

will appear on your screen. 
 
4. Enter subfolder SAMPLES\STEP_1 of the current folder. 
 
5. Type “STEP_1” in the File name text box, and click the 

Save control button. The Save As Dialog will be closed, and 
the project file with the name STEP_1.IMS will be 
created. Its name will appear in the This File information 
pane.  
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6. Click the Refe Files tab in the OMS Property Sheet Dialog. It 
will appear on your screen. 

Figure 1.2 

 
 
7. Choose all of the needed parameters in the Refe Files tab 

as shown above.  
 
8. Click the Sens Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 1.3 

 
 
9. Choose all of the needed parameters in the Sens Files tab 

as shown above.  
 

10. Click the Mesh Files tab in the OMS Property Sheet Dialog. It 
will appear on your screen. 
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Figure 1.4 

 
 

11. Choose all of the needed parameters in the Mesh Files tab 
as shown above.  

 
12. Click the Test Features tab in the OMS Property Sheet Dialog. It 

will appear on your screen again. 
 

13. Click the Check control button. The presence of all 
chosen files in the project folder SAMPLES\STEP_1 will 
be verified.  

 
14. Click the OK control button. The project file will be 

created, and all chosen parameters will be saved into 
it.  
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Chapter 2.  Processing a Project 
 

Files Necessary for Working with a Project 
 
Subfolder SAMPLES\STEP_2 of the current folder contains 
the following bitmaps: 

1) REFE_DARK.B16 – a dark reference bitmap;  

2) SENS_DARK.B16 – a dark sensitive bitmap; 

3) REFE_OFF.B16 – a wind-off reference bitmap;  

4) SENS_OFF.B16 – a wind-off sensitive bitmap; 

5) REFE_ON.B16 – a wind-on reference bitmap;  

6) SENS_ON.B16 – a wind-on sensitive bitmap. 
 
The following files with information concerning markers 
should be in the same subfolder: 

1) HST_315DD.MPT – markers on the image. This file is 
created manually by the user. It will be used for 3D 
transformations; 

2) MARK_UP.APM – real 3D coordinates of markers on the 
model. 

 
The following files with additional information should be 
in the same subfolder: 

1) STEP_2.IMS – project file that contains the information 
that is necessary for processing the PSP test data;  

2) UP.APT – Geometry of the model; 

3) COEFFNEW.CLB – file that contains the coefficients of 
the calibration; 

4) PCO_CAMERA.CAM – file that contains the camera 
parameters. 

 
Step 2. Processing a Project Using Default Parameters 

 
1. After running ProImage open an existing file STEP_2.IMS 

that is located in subfolder SAMPLES\STEP_2 of the 
current folder. Choose the Open Project... command from the 
B Convert menu. The standard Open Dialog will appear on your 
screen. 
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Figure 2.1 

 
 
2. Choose the file STEP_2.IMS, and click the Open control 

button. The Open Dialog will be closed, and the wind-on 
sensitive bitmap will appear on your screen. 

Figure 2.2 

 
 
3. Choose the Dark Frame Subtraction command from the B Convert 

menu to subtract dark bitmaps from the processed 
bitmaps. The corrected wind-on sensitive bitmap will 
appear on your screen. (Four bitmaps--wind-off 
reference, wind-on reference, wind-off sensitive, and 
wind-on sensitive--will be corrected. Use the Image 
command from the View menu to switch between these 
bitmaps.) 
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Figure 2.3 

 
 
4. Choose the Flat Field Correction command from the B Convert menu 

to compensate for vignette-effect of the videocamera 
objective lens and the spread of the sensitivity of the 
photodetector array. The corrected wind-on sensitive 
bitmap will appear on your screen. (Four bitmaps-–wind-
off reference, wind-on reference, wind-off sensitive, 
and wind-on sensitive--will be corrected. Use the Image 
command from the View menu to switch between these 
bitmaps.) 

Figure 2.4 
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5. Choose the Automatic Marking... command from the B Convert 
menu. The Quick Marker Search Dialog will appear on your 
screen. 

Figure 2.5 

 
 
6. Choose all of the needed parameters in the Quick Marker 

Search Dialog as shown above.  
 
7. Click the OK control button. Four bitmaps with markers 

will be created (wind-off reference, wind-on reference, 
wind-off sensitive, and wind-on sensitive). Use the 
Image command from the View menu to switch between these 
bitmaps. 
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Figure 2.6 

 
 
8. Choose the Markers Precise Position... command from the B Convert 

menu. The Revise Markers Dialog will appear on your screen. 

Figure 2.7 

 
 
9. Choose all of the needed parameters in the Revise Markers 

Dialog as shown above.  
 

10. Click the OK control button. The position of the 
markers will be corrected. 
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Figure 2.8 

 
 

11. Choose the Hide Markers command from the Markers menu. The 
special symbols of the markers and their numbers will 
become invisible. 

Figure 2.9 

 
 

12. Choose the Fill Up All Markers... command from the B Convert menu 
to remove the marker images from the bitmaps. The Fill Up 
Markers Dialog will appear on your screen. 
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Figure 2.10 

 
 

13. Choose all of the needed parameters in the Fill Up Markers 
Dialog as shown above.  

 
14. Click the OK control button. The position of the 

markers will be corrected. 

Figure 2.11 

 
 

15. Choose the Filtering... command from the B Convert menu to 
apply the 2D Gauss filter on the bitmaps. The Gaussian 
Filter Parameters Dialog will appear on your screen. 

Figure 2.12 

 
 

16. Choose all of the needed parameters in the Gaussian Filter 
Parameters Dialog as shown above.  

 
17. Click the OK control button.  
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Figure 2.13 

 
 
18.Choose the BackGround Work... command from the B Convert menu 

to remove the background on the bitmaps. The BackGround 
Select/Compensate Dialog will appear on your screen. 

Figure 2.14 
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19. Choose all of the needed parameters in the BackGround 
Select/Compensate Dialog as shown above.  

 
20. Click the OK control button. The bitmaps will be 

corrected. 

Figure 2.15 

 
 

21. Choose the Distortion Correction command from the B Convert menu 
to compensate for objective-lens distortions of the 
bitmaps. This command may be used only once. Then it 
becomes inactive. 

Figure 2.16 
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22. Choose the Alignment Images... command from the B Convert menu 
to align the bitmaps. The Image Alignment Dialog will appear 
on your screen. 

Figure 2.17 

 
 

23. Choose all of the needed parameters in the Image Alignment 
Dialog as shown above.  

 
24. Click the OK control button. Warning messages about the 

transformation error will appear on the screen.  
 

25. Click the OK control button, or press Enter. Four 
aligned bitmaps will be created (wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu to 
switch between these bitmaps. 

Figure 2.18 

 
 

26. Choose the Image Convert command from the B Convert menu to 
transform the intensity on the aligned bitmaps to the 
physical parameters. Four bitmaps will be created 
(ratio of the intensity on the reference bitmap to the 
intensity on the sensitive bitmap, pressure, ratio of 
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the pressure to the static pressure, and Cp). Use the 
Image command from the View menu to switch between these 
bitmaps. The Cp flowfield is shown below. 

Figure 2.19 

 
 

27. Choose the Final Filtering... command from the B Convert menu to 
apply the 2D Gauss filter on the bitmaps with physical 
parameters. The Gaussian Filter Parameters Dialog will appear on 
your screen. 

Figure 2.20 

 
 

28. Choose all of the needed parameters in the Gaussian Filter 
Parameters Dialog as shown above.  

 
29. Click the OK control button. The corrected bitmap with 

the Cp flowfield will appear on your screen. 
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Figure 2.21 

 
 

30. Choose the Resection... command from the B Convert menu to 
map the 2D bitmaps (with physical parameters) on the 3D 
mesh that describes the model surface. The Resection 
Methods Dialog will appear on your screen. 

Figure 2.22 

 
 

31. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
32. Click the OK control button. The Image Alignment Dialog will 

appear on your screen. 

Figure 2.23 

 
 

33. Choose all of the needed parameters in the Image Alignment 
Dialog as shown above.  
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34. Click the OK control button. The warning messages 

concerning the transformation error will appear on the 
screen.  

 
35. Click the OK control button, or press Enter. The 3D 

flowfields will be created. For visualization it is 
necessary to open the file STEP_2.XYZ (it is created at 
Step 36) using the ProField application. 

Figure 2.24 

 
 

36. Choose the Save Results command from the B Convert menu to 
save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_2_P_TO_PST.IMP, STEP_2_IREFE_ISENS.IMP, 
STEP_2_PRESSURE.IMP, and STEP_2_CP.IMP). These files 
contain the bitmaps of the physical parameters and the 
markers on them. Also the file with 3D flowfields will 
be written on the disk (STEP_2.XYZ).  

 
37. Choose the Close Project command from the B Convert menu to 

close the project file.  
 

86



ProImage User's GUIDE 26 

Step 3. Processing a Project Automatically 
 
Subfolder SAMPLES\STEP_3 of the current folder contains 
all of the files necessary to process the project (for 
additional information see Step 2). 
 
1. Open an existing file STEP_3.IMS that is located in 

subfolder SAMPLES\STEP_3 of the current folder (for 
additional information see Steps 1-2 of Step 2.) The 
wind-on sensitive bitmap will appear on your screen. 

Figure 3.1 

 
 
2. Choose the Automatic Convert... command from the B Convert 

menu. The Automatic Convert Scenario Dialog will appear on your 
screen. 
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Figure 3.2 

 
 
3. Choose all of the needed parameters in the Automatic 

Convert Scenario Dialog as shown above.  
 
4. Click the OK control button. Steps 3-35 of Step 2 will 

be performed. Default parameters will be used in the 
Dialogs. To change them you may click the necessary 
control buttons, and the appropriate Dialog will appear 
on your screen. 

Four bitmaps will be created (ratio of the intensity on 
the reference bitmap to the intensity on the sensitive 
bitmap, pressure, ratio of the pressure to the static 
pressure, and Cp). Use the Image command from the View 
menu to switch between these bitmaps. Also 3D 
flowfields will be created. 

The Cp flowfield is shown below. 
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Figure 3.3 

 
 
5. Choose the Save Results command from the B Convert menu to 

save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_3_P_TO_PST.IMP, STEP_3_IREFE_ISENS.IMP, 
STEP_3_PRESSURE.IMP, and STEP_3_CP.IMP). These files 
contain the bitmaps of the physical parameters and the 
markers on them. Also the file with 3D flowfields will 
be written on the disk (STEP_3.XYZ). For visualization 
it is necessary to open the file STEP_3.XYZ using the 
ProField application. 

Figure 3.4 

 
 
6. Choose the Close Project command from the B Convert menu to 

close the project file.  
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Step 4. Processing a List of Projects Automatically 
 
Subfolder SAMPLES\STEP_3 of the current folder contains 
all of the files necessary to process the project (for 
additional information see Step 2). The project files 
from subfolders SAMPLES\STEP_1, SAMPLES\STEP_2, and 
SAMPLES\STEP_3 will be processed. 
 
1. Choose the Automatic Convert List... command from the B Convert 

menu. The Automatic Convert Scenario Dialog will appear on your 
screen. 

Figure 4.1 

 
 
2. Select the STEP_1.IMS file in the Files/Directory list using 

the mouse. 
 
3. Click the > control button. This file will be placed in 

the Files list pane. 
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Figure 4.2 

 
 
4. Double click the [..] in the Files/Directory list. The list of 

folders in the SAMPLES folder will appear on your 
screen. 

Figure 4.3 

 
 
5. Repeat Steps 2-4 to select the STEP_2.IMS file from the 

SAMPLES\STEP_2 folder and the STEP_3.IMS file from the 
SAMPLES\STEP_3 folder.  

Figure 4.4 

 
 
6. Click the OK control button. Three project files will 

be processed automatically. Steps 3-35 of Step 2 will 
be performed. Default parameters will be used in the 
Dialogs. To change these you may click the necessary 
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control buttons, and the appropriate Dialog will appear 
on your screen. 

Four bitmaps for each project file will be created 
(ratio of the intensity on the reference bitmap to the 
intensity on the sensitive bitmap, pressure, ratio of 
the pressure to the static pressure, and Cp). They will 
be written on the disk into the appropriate folder. 
These files contain the bitmaps of the physical 
parameters and the markers on them. 

Also 3D flowfields for each project file will be 
created. These files with 3D flowfields will be written 
on the disk into the appropriate folder. 
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Step 5. Influence of Dialog Parameters  
on the Results of Project Processing  
 
Subfolder SAMPLES\STEP_5 of the current folder contains 
the same files as SAMPLES\STEP_2, except that it contains 
a file for the Flat Field Correction and the following 
files with markers on the bitmaps:  

1) REFE_OFF.MPT – markers on the wind-off reference 
bitmap;  

2) SENS_OFF.MPT – markers on the wind-off sensitive 
bitmap; 

3) REFE_ON.MPT – markers on the wind-on reference bitmap;  

4) SENS_ON.MPT – markers on the wind-on sensitive bitmap. 
 
 
1. Open an existing file STEP_5.IMS that is located in 

subfolder SAMPLES\STEP_5 of the current folder (for 
additional information see Steps 1-2 of Step 2). The 
wind-on sensitive bitmap will appear on your screen. 

Figure 5.1 

 
 
2. Choose the Dark Frame Subtraction command from the B Convert 

menu to subtract the dark bitmaps from the processed 
bitmaps. The corrected wind-on sensitive bitmap will 
appear on your screen. (Four bitmaps-–wind-off 
reference, wind-on reference, wind-off sensitive, and 
wind-on sensitive--will be corrected. Use the Image 
command from the View menu to switch between these 
bitmaps.) 
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Figure 5.2 

 
 
3. Choose the Flat Field Correction command from the B Convert menu 

to compensate for distortions of the videocamera 
objective lens and the spread of the sensitivity of the 
photodetector array. The corrected wind-on sensitive 
bitmap will appear on your screen. (Four bitmaps-–wind-
off reference, wind-on reference, wind-off sensitive, 
and wind-on sensitive--will be corrected. Use the Image 
command from the View menu to switch between these 
bitmaps.) 

Figure 5.3 
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4. Choose the Automatic Marking... command from the B Convert 
menu. The Quick Marker Search Dialog will appear on your 
screen. 

Figure 5.4 

 
 
5. Choose all of the needed parameters in the Quick Marker 

Search Dialog as shown above. In the case of chosen 
parameters (the Select only fixed markers check box is turned 
on), only fixed markers will be copied. 

 
6. Click the OK control button. Four bitmaps with markers 

will be created (wind-off reference, wind-on reference, 
wind-off sensitive, and wind-on sensitive). Use the 
Image command from the View menu to switch between these 
bitmaps. 
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Figure 5.5 

 
 
7. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen again. 

 
8. Turn off the Select only fixed markers check box; type “7” in 

the Markers Radius text box; and click the OK control 
button. The number of markers will more than Markers 
Radius is equal to “2”. 

Figure 5.6 

 
 
9. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen again. 
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10. Turn on the Output As Is radio button in the Output pane and 
the Entropy Based radio button in the Threshold pane. Click 
the OK control button. The number of markers will 
increase. 

Figure 5.7 

 
 

11. Choose the BackGround Work... command from the B Convert menu 
to remove the background on the bitmaps. The BackGround 
Select/Compensate Dialog will appear on your screen. 
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Figure 5.8 

 
 

12. Choose all of the needed parameters in the BackGround 
Select/Compensate Dialog as shown above.  

 
13. Click the OK control button. All of the intensities on 

the bitmaps that are less than 500 will become 
background. 

Figure 5.8 

 

98



ProImage User's GUIDE 38 

 
14. Choose the BackGround Work... command from the B Convert menu. 

The BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
15. Turn on the by Scaled Image Average radio button, and type 

“0.5” in the Scale text box in the BackGround Select pane. 
Click the OK control button. All of the intensities on 
the bitmaps that are less than one-half of the average 
intensity will become background. 

Figure 5.9 

 
 

16. Choose the BackGround Work... command from the B Convert menu. 
The BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
17. Turn off the BackGround Select check box, and turn on the 

BackGround Compensate check box in the Mode of Operation pane. 
Type “60” in the Value text box. Click the OK control 
button. All of the intensities on the bitmaps will be 
diminished by 60. 

99



ProImage User's GUIDE 39 

Figure 5.10 

 
 

18. Choose the BackGround Work... command from the B Convert menu. 
The BackGround Select/Compensate Dialog will appear on your 
screen again. 

 
19. Turn on the by 2 Sides Strap Interpolation radio button, and type 

“50” in the Side Straps Width text box in the BackGround 
Compensate pane. Click the OK control button.  

Figure 5.11 

 
 

20. Choose the Alignment Images... command from the B Convert menu 
to align the bitmaps. The Image Alignment Dialog will appear 
on your screen. 
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Figure 5.12 

 
 

21. Choose all of the needed parameters in the Image Alignment 
Dialog as shown above.  

 
22. Click the OK control button. Warning messages about the 

transformation error will appear on the screen.  
 

23. Click the OK control button, or press Enter. Four 
aligned bitmaps will be created (wind-off reference, 
wind-on reference, wind-off sensitive, and wind-on 
sensitive). Use the Image command from the View menu to 
switch between these bitmaps. 

Figure 5.13 

 
 

24. Choose the Image Convert command from the B Convert menu to 
transform the intensity on the aligned bitmaps to the 
physical parameters. Four bitmaps will be created 
(ratio of the intensity on reference bitmap to the 
intensity on the sensitive bitmap, pressure, ratio of 
the pressure to the static pressure, and Cp). Use the 
Image command from the View menu to switch between these 
bitmaps. The Cp flowfield is shown below. 
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Figure 5.14 

 
 

25. Choose the Resection... command from the B Convert menu to 
map 2D bitmaps (with physical parameters) on the 3D 
mesh that describes the model surface. Then the Resection 
Methods Dialog will appear on your screen. 

Figure 5.15 

 
 

26. Choose all of the needed parameters in the Resection 
Methods Dialog as shown above.  

 
27. Click the OK control button. The Image Alignment Dialog will 

appear on your screen. 

Figure 5.16 

 
 

28. Choose all of the needed parameters in the Image Alignment 
Dialog as shown above.  
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29. Click the OK control button. Wwarning messages about 

the transformation error will appear on the screen.  
 

30. Click the OK control button, or press Enter. The 3D 
flowfields will be created. For visualization it is 
necessary to open the file STEP_5.XYZ (it is created at 
Step 31) using the ProField application. An inaccurate 
Flowfield is caused by poor Alignment and poor 
Resection. The violet parts of the Flowfield are 
attributed to background due to discrepancy.  

Figure 5.17 

 
 

31. Choose the Save Results command from the B Convert menu to 
save the active project and the results of the data 
processing. Four bitmaps will be written on the disk 
(STEP_5_P_TO_PST.IMP, STEP_5_IREFE_ISENS.IMP, 
STEP_5_PRESSURE.IMP, and STEP_5_CP.IMP). These files 
contain the bitmaps of the physical parameters and the 
markers on them. Also the file with 3D flowfields will 
be written on the disk (STEP_5.XYZ).  

 
32. Choose the Close Project command from the B Convert menu to 

close the project file.  
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Chapter 3. Editing a Single Bitmap 
 

Step 6. Editing the Intensity Values on a Bitmap 
 
1. After running ProImage open an existing bitmap STEP_6.P 

that is located in subfolder SAMPLES\STEP_6 of the 
current folder: 

• Choose the Open... command from the File menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 6.1 

 
The standard Open Dialog will appear on your screen. 

Figure 6.2 

 
 
2. Choose the file STEP_6.P, and click the Open control 

button. The Open Dialog will be closed, and the bitmap 
will appear on your screen. 
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Figure 6.3 

 
 
3. Choose the Arithmetic... command from the Edit menu. The 

Arithmetic Operations with Constant Dialog will appear on your 
screen. 

Figure 6.4 

 
 
4. Choose all of the needed parameters in the Arithmetic 

Operations with Constant Dialog as shown above.  
 
5. Click the OK control button. The palette in the right-

hand portion of the application window will be changed, 
and the level of intensity on the bitmap will be 
increased by 10. 
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Figure 6.5 

 
 
6. To create a mask region on the bitmap: 

Choose the Mask by Boxes command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.6 

 

The cursor shape will be changed to . 
 
7. Press the left mouse button, and move the mouse. Choose 

the desired box size, and release the mouse. The 
selected part of bitmap will be represented with bright 
colors and the out-mask region with muted colors. 
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Figure 6.7 

 
 
8. Repeat Step 6-7, and create an additional mask region 

on the bitmap. 

Figure 6.8 

 
 
9. Choose the Flood in Masked Regions... command from the Edit 

menu. The Flood In Masked Region With User Defined Value Dialog will 
appear on your screen. 
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Figure 6.9 

 
 

10. Choose all of the needed parameters in the Flood In Masked 
Region With User Defined Value Dialog as shown above.  

 
11. Click the OK control button. The intensity in the 

masked regions will be equal to 15. 

Figure 6.10 

 
 

12. Choose the Close command from the File menu to close the 
bitmap.  

 
13. Open an existing file STEP_6.P again (or more 

information see Steps 1-2). Figure 6.3 will appear on your 
screen. 

 
14. Choose the Cut Off Intensities... command from the Edit menu. The 

Cut Off Intensities Dialog will appear on your screen. 

Figure 6.11 
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15. Choose all of the needed parameters in the Cut Off Intensities 
Dialog as shown above.  

 
16. Click the OK control button. The palette in the right-

hand portion of the application window will be changed, 
and the limits of intensity on the bitmap will be equal 
to 0.2 and 0.9. 

Figure 6.12 

 
 

17. To rotate the bitmap choose the Flip/Rotate... command from 
the Edit menu. The Flip/Rotate Dialog will appear on your 
screen. 

Figure 6.13 

 
 

18. Choose all of the needed parameters in the Flip/Rotate Dialog 
as shown above.  

 
19. Click the OK control button. The bitmap will be 

rotated. 
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Figure 6.14 

 
 

20. To create a mask region on the bitmap: 
Choose the Mask by Polygon command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.15 

 
The cursor shape will be changed to . 

 
21. Click the mouse to fix the polyline nodes at some 

points. Click the mouse at the first node to close the 

polyline. The cursor shape will be changed to . Click 
inside (outside) the polygon. The inner (outer) region 
of the bitmap will be represented with bright colors 
and the out-mask region with muted colors. 
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Figure 6.16 

 
 

22. Choose the Fill Up... command from the Edit menu. The Eight 
Connected Float Fill Up Dialog will appear on your screen. 

Figure 6.17 

 
 

23. Choose all of the needed parameters in the Eight Connected 
Float Fill Up Dialog as shown above.  

 
24. Click the OK control button. The intensity in the 

masked region will be changed using bilinear 
interpolation. 
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Figure 6.18 

 
 

25. Choose the Close command from the File menu to close the 
bitmap.  

 
26. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on your 
screen. 

 
27. Open an existing file with coordinates of the markers 

STEP_6.MRK that is located in the same folder. Choose 
the Open Markers... command from the Markers menu. The 
standard Open Dialog will appear on your screen. 

Figure 6.19 

 
 

28. Choose the file STEP_6.MRK, and click the Open control 
button. The Open Dialog will be closed, and the markers on 
the bitmap will appear on your screen. 
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Figure 6.20 

 
 

29. To add new markers: 

• Choose the Mark... command from the Markers menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 6.21 

 
The Mark Options Dialog will appear on your screen. 

Figure 6.22 

 
 

30. Choose all of the needed parameters in the Mark Options 
Dialog as shown above.  

 
31. Click the OK control button. The cursor shape is 

changed to . Click at the points on the bitmap, and 
the markers will be placed at these points. 
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Figure 6.23 

 
 

32. To turn off the regime of markers selected, choose the 
Mark... command from the Markers menu again.  

 
33. To hide the images of the markers on the bitmap, choose 

the Hide Markers command from the Markers menu.  

Figure 6.24 

 
 

34. To remove the dark spots of the marker images from the 
bitmap, choose the Fill Up Markers... command from the Edit 
menu. The Fill Up Markers Dialog will appear on your screen. 
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Figure 6.25 

 
 

35. Choose all of the needed parameters in the Fill Up Markers 
Dialog as shown above.  

 
36. Click the OK control button. The regions of the markers 

will be bi-interpolated using region boundary points on 
the bitmap. (The region of the marker is the circle 
with the center at the point where the marker has been 
placed.) 

Figure 6.26 

 
 

37. Create mask regions on the bitmap (for additional 
information see Steps 6-7). 
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Figure 6.27 

 
 

38. Choose the Flat Filter... command from the Edit menu. The Flat 
Round Filter Dialog will appear on your screen. 

Figure 6.28 

 
 

39. Choose all of the needed parameters in the Flat Round Filter 
Dialog as shown above.  

 
40. Click the OK control button. The intensity in the 

masked regions will be changed using the flat filter. 
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Figure 6.29 

 
 

41. Choose the Close command from the File menu to close the 
bitmap.  

 
42. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on your 
screen. 

 
43. Choose the Gauss Filter... command from the Edit menu. The 

Gaussian Filter Dialog will appear on your screen. 

Figure 6.31 

 
 

44. Choose all of the needed parameters in the Gaussian Filter 
Dialog as shown above.  

 
45. Click the OK control button. The intensity on the 

bitmap will be changed using the Gauss filter. 
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Figure 6.32 

 
 

46. Choose the Close command from the File menu to close the 
bitmap.  

 
47. Open an existing file STEP_6.P again (for additional 

information see Steps 1-2). Figure 6.3 will appear on your 
screen. 

 
48. Create mask regions on the bitmap (for additional 

information see Steps 6-7.) 

Figure 6.33 
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49. Choose the Median Filter... command from the Edit menu. The 
Median Filter Dialog will appear on your screen. 

Figure 6.34 

 
 

50. Choose all of the needed parameters in the Median Filter 
Dialog as shown above.  

 
51. Click the OK control button. The intensity in the 

masked regions will be changed using the median filter. 

Figure 6.35 

 
 

52. Choose the Ranged Filter... command from the Edit menu. The 
Ranged Filter Dialog will appear on your screen. 
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Figure 6.36 

 
 

53. Choose all of the needed parameters in the Ranged Filter 
Dialog as shown above.  

 
54. Click the OK control button. The intensity in the 

masked regions will be filtrated. 

Figure 6.37 

 
 
55.To undo the mask selection: 

Choose the Mask All command from the Mask menu, 

or 

Click the following icon from the upper toolbar: 

Figure 6.38 

 
The entire bitmap will be represented with bright 
colors. 
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Figure 6.39 

 
 

56. Choose the 3D Filter... command from the Edit menu. The 3D 
Round Gaussian Filter Dialog will appear on your screen. 

Figure 6.40 

 
 

57. Choose all of the needed parameters in the 3D Round 
Gaussian Filter Dialog as shown above.  

 
58. Click the OK control button. The intensity in the 

masked regions will be filtrated. 
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Figure 6.41 

 
 

59. Choose the Thinning... command from the Edit menu. The 
Thinning Dialog will appear on your screen. 

Figure 6.42 

 
 

60. Choose all of the needed parameters in the Thinning Dialog 
as shown above.  

 
61. Click the OK control button.  
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Figure 6.43 

 
 

62. Choose the Expansion... command from the Edit menu. The 
Spread Dialog will appear on your screen. 

Figure 6.44 

 
 

63. Choose all of the needed parameters in the Spread Dialog 
as shown above.  

 
64. Click the OK control button.  
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Figure 6.45 

 
 
65. Choose the Weighted Hybrid Map... command from the Edit menu. 

The Image Histogram Dialog will appear on your screen. 

Figure 6.46 

 
 

66. Choose all of the needed parameters in the Image Histogram 
Dialog as shown above.  

 
67. Click the OK control button.  
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Figure 6.47 
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Step 7. Removing Background from a Bitmap 
 
1. After running ProImage, open an existing bitmap 

STEP_7.B16 that is located in the subfolder 
SAMPLES\STEP_7 of the current folder (for additional 
information see Steps 1-2 of Step 6). 

Figure 7.1 

 
 
2. Choose the BackGround... command from the Tools menu to 

remove the background on the bitmap. The BackGround 
Select/Compensate Dialog will appear on your screen. 
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Figure 7.2 

 
 
3. Choose all of the needed parameters in the BackGround 

Select/Compensate Dialog as shown above.  
 
4. Click the OK control button. All of the intensities on 

the bitmaps that are less than the average intensity 
will be background. 

Figure 7.3 
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5. Choose the BackGround... command from the Tools menu. The 

BackGround Select/Compensate Dialog will appear on your screen 
again. 

 
6. Turn on the by Threshold Value radio button, and type “1000” 

in the Threshold Value text box in the BackGround Select pane. 
Click the OK control button. All of the  intensities on 
the bitmap that are less than 1000 will become 
background. 

Figure 7.4 

 
 
7. Choose the BackGround... command from the Tools menu. The 

BackGround Select/Compensate Dialog will appear on your screen 
again. 

 
8. Turn on the by Scaled Image Average radio button, and type 

“0.5” in the Scale text box in the BackGround Select pane. 
Click the OK control button. All of the intensities on 
the bitmap that are less than one-half of the average 
intensity will be background. 
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Figure 7.5 

 
 
9. Choose the BackGround... command from the Tools menu. The 

BackGround Select/Compensate Dialog will appear on your screen 
again. 

 
10. Turn off the BackGround Select check box, and turn on the 

BackGround Compensate check box in the Mode of Operation pane. 
Turn on the by Value radio button, and type “300” in the 
Value text box. Click the OK control button. The palette 
in the right-hand portion of the application window 
will be changed, and all of the intensities on the 
bitmap will be diminished by 300.  

Figure 7.4 
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11. Choose the BackGround... command from the Tools menu. The 
BackGround Select/Compensate Dialog will appear on your screen 
again. 

 
12. Turn on the by 2 Sides Strap Interpolation radio button, and type 

“100” in the Side Straps Width text box in the BackGround 
Compensate pane. Click the OK control button. The bitmap 
will be corrected. 

Figure 7.5 
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Chapter 4. Preparing Project File for ProField Application 
 

Step 8. Preparing a File for ProField Application 
 
The subfolder SAMPLES\STEP_8 of the current folder 
contains all of the files necessary to process the 
project (for additional information see Step 2). 
 
1. Open an existing file STEP_8.IMS that is located in the 

subfolder SAMPLES\STEP_8 of the current folder (for 
additional information see Steps 1-2 of Step 2). The 
wind-on sensitive bitmap will appear on your screen. 

Figure 8.1 

 
 
2. Repeat Steps 3-4 of Step 2 with the same parameters.  

131



ProImage User's GUIDE 71 

Figure 8.2 

 
 
3. Choose the Automatic Marking... command from the B Convert 

menu. The Quick Marker Search Dialog will appear on your 
screen. 

Figure 8.3 
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4. Choose all of the needed parameters in the Quick Marker 
Search Dialog as shown above.  

 
5. Click the OK control button. Four bitmaps with markers 

will be created (wind-off reference, wind-on reference, 
wind-off sensitive, and wind-on sensitive). Use the 
Image command from the View menu to switch between these 
bitmaps. 

 
6. Repeat Steps 8-21 of Step 2 with the same parameters.  

Figure 8.4 

 
 
7. To restore the 3D Flowfields from all of the project 

bitmaps, choose the Resection... command from the OMS Field 
menu. The Resection Methods Dialog will appear on your 
screen. 

Figure 8.5 

 
 
8. Choose all of the needed parameters in the Resection 

Methods Dialog as shown above.  

Note. It is recommended that the Resect 1 be used when 3D 
markers are measured with mean accuracy. In this case 
the Resect 1 yields a reliable solution. It is 
recommended that the Resect 2 be used when the 3D markers 
are measured with extremely high accuracy. Although the 
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Resect 2 yields a more exact solution than Resect 1, the 
solution is not so reliable.  

 
9. Click the OK control button. Warning messages about the 

transformation error will appear on the screen.  
 

10. Click the OK control button, or press Enter.  
STEP_8.XYZ will be created. It contains 3D flowfields 
that are mapped from the wind-off reference, wind-off 
sensitive, wind-on reference, and wind-on sensitive 
bitmaps. The bitmaps with markers are also mapped on 
the 3D mesh to create appropriate 3D Flowfields. 

 
11. Choose the Close Project command from the B Convert menu to 

close the project file.  
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Chapter 1.  Processing a Project 
 

Files Necessary for Working with a Project 
 

Subfolder SAMPLES\STEP_1 of the current folder contains 
the STEP_1.XYZ file. This file was created in the 
ProImage application. For additional information 
concerning its creation, see Step 8 of ProImage How to... 
 
This subfolder also contains the following bitmaps: 
 

1) REFE_DARK.B16 – a dark reference bitmap;  

2) SENS_DARK.B16 – a dark sensitive bitmap; 

3) REFE_OFF.B16 – a wind-off reference bitmap;  

4) SENS_OFF.B16 – a wind-off sensitive bitmap; 

5) REFE_ON.B16 – a wind-on reference bitmap;  

6) SENS_ON.B16 – a wind-on sensitive bitmap. 
 
The subfolder contains the following files with 
information concerning markers: 
 

1) REFE_OFF.MPT – markers on the wind-off reference 
bitmap;  

2) SENS_OFF.MPT – markers on the wind-off sensitive 
bitmap; 

3) REFE_ON.MPT – markers on the wind-on reference bitmap;  

4) SENS_ON.MPT – markers on the wind-on sensitive bitmap; 

5) HST_315DD.MPT – markers on the image. This file is 
created manually by the user and used for 3D 
transformations; 

6) MARK_UP.APM – real 3D coordinates of markers on the 
model. 

 
This subfolder contains the following files with 
additional information: 
 

1) STEP_1.IMS – project file containing the information 
necessary for processing the PSP test data;  

2) UP.APT – file containing the geometry of the model; 

3) COEFFNEW.CLB – file containing the coefficients of the 
calibration; 

4) PCO_CAMERA.CAM – file containing the camera parameters. 
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Step 1.     Calculating the Cp Flowfield 
 
1. After running ProField, open an existing file 

STEP_1.IMS that is located in the subfolder 
SAMPLES\STEP_1 of the current folder. Choose the Open 
Project... command from the OMS Field menu. The standard Open 
Dialog will appear on your screen. 

Figure 1.1 

 
 
2. Choose the file STEP_1.IMS, and click the Open control 

button. The Open Dialog will be closed, and the OMS Property 
Sheet Dialog will appear on your screen. 

 
This project works with two fields transferred on the 3D 
geometry: “sens” – ratio of the wind-on to wind-off 
sensitive images and “refe” – ratio of the wind-on to 
wind-off reference images. These fields were created using 
the “step_2pr.ims” and step_2re.ims projects included in 
the step_2 subdirectory of the Sample_ProImage directory. 
 
Significant angular parallax between the CCD cameras 
acquiring reference and sensitive images for bi-
luminophore paint application can create a problem in 
alignment between the sensitive and reference channels. 
In this case it is more desirable to align independently 
the images in the sensitive and reference channels. The 
2D-3D command in the ProImage Program allows the 
possibility of transferring all four source images on the 
mesh (after background subtraction, flat field and 
distortion correction).    
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Figure 1.2 

 
 
3. Click the OK control button. The OMS Property Sheet Dialog 

will be closed, and the Geometry will appear on your 
screen. 
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Figure 1.3 

 
 
4. To rotate the Geometry on your screen: 

• Choose the Rotate command from the View menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 1.4 

 

The cursor shape will be changed to . 
 
5. Press the left mouse button, and drag the mouse. The 

Geometry will be rotated around the axis that is 
directed from the point of view to the center of the 
model while moving the mouse. Release the mouse button 
at the final position of the Geometry. 

Figure 1.5 
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6. Choose the Cp Calculation... command from the OMS Field menu. 
The Cp calculation Options Dialog will appear on your screen. 

Figure 1.6 

 
 
7. Choose all of the needed parameters in the Cp calculation 

Options Dialog as shown above.  
 
 
8. Click the OK control button. The 3D Cp flowfield will 

appear on your screen. 
 
9. To represent the Cp flowfield in a more desirable view, 

choose the Appearance... command from the Options menu. The 
Appearance Dialog will appear on your screen. 
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Figure 1.7 

 
 
10. Choose all of the needed parameters in the Appearance 

Dialog  
 
11. Click the OK control button. The palette will appear 

in the right-hand portion of your screen. 

Figure 1.8 
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12. Click the Options control button at the bottom of the 
palette. The Spectrum Appearance Dialog will appear on your 
screen. 

 
13. Choose all of the needed parameters in the Spectrum 

Appearance Dialog.  
 
14. Click the OK control button. The 3D Cp flowfield will 

appear on your screen. It may be compared with the 3D 
Cp flowfield that was obtained in Step 2 of ProImage 
How To. 

 
15. Choose the Save Results command from the OMS Field menu to 

save the result of the Cp calculation.  
 
16. Choose the Close Project command from the OMS Field menu to 

close the project file.  
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Chapter 2.  Simple Operations with Files 
 

Step 2.       Editing the Geometry and Flowfield 
 
1. Open an existing file STEP_2.FLD that is located in 

subfolder SAMPLES\STEP_2 of the current folder: 

• Choose the Open... command from the File menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.1 

 
The standard Open Dialog will appear on your screen. 

Figure 2.2 

 
 
2. Choose the file STEP_2.P, and click the Open control 

button. The Open Dialog will be closed, and the Geometry 
will appear on your screen. 

Figure 2.3 
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3. To view separate blocks of Geometry, choose the 
Appearance... command from the Options menu. The Appearance 
Dialog will appear on your screen. 

Figure 2.4 

 
 
4. Choose all of the needed parameters in the Appearance Dialog 

as shown above.  
 
5. Click the OK control button. The blocks will be 

represented with different colors, and the front blocks 
will be displayed as a grid. 

Figure 2.5 

 
 
6. To select a part of the Geometry: 

• Choose the Select... command from the Edit menu, 

or 

• Click the following icon from the upper toolbar: 
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Figure 2.6 

 
The Select Dialog will appear on your screen. 

Figure 2.7 

 
 
7. Choose all of the needed parameters in the Select Dialog as 

shown above.  
 
8. Click the OK control button.  
 
9. Click the necessary block. The nodes of this block will 

be represented as red markers. 

Figure 2.8 

 
 

10. To magnify a portion of the screen on your screen: 

• Choose the Zoom Rectangle command from the View menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.9 
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The cursor shape will be changed to . 
 
11. Press the left mouse button, and drag the mouse. The 

new picture fragment will be limited by the rectangle 
appearing on the screen. Releasing the mouse button 
rescales the picture. 

Figure 2.10 

 
 

12. Choose the Destruct Mesh... command from the Edit menu. The 
Destruct Mesh Dialog will appear on your screen. 

Figure 2.11 

 
 

13. Choose all of the needed parameters in the Destruct Mesh 
Dialog as shown above.  

 
14. Click the OK control button. The grid of the selected 

block will become unstructured.  
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Figure 2.12 

 
 

15. Choose the Undo command from the Edit menu. The grid of 
the selected block will return to the structured form. 
Figure 2.10 will appear on your screen. 

 
16. Choose the Redirect Normal command from the Edit menu. The 

normal of the selected block will become opposite.  

Figure 2.13 

 
 

17. Choose the Undo command from the Edit menu. The normal of 
the selected block will return to the initial one. 
Figure 2.10 will appear on your screen. 

 
18. To show the Cp flowfield:  

• Choose the Field Variables... command from the Options menu, 

or 

• Click the following icon from the upper toolbar: 

Figure 2.14 
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The Field Variables Dialog will appear on your screen. 

Figure 2.15 

 
 

19. Choose all of the needed parameters in the Field Variables 
Dialog as shown above.  

 
20. Click the OK control button. The Cp flowfield will 

appear on your screen. (Figure 2.10 will appear on your 
screen.) 

 
21. To view the Flowfield, choose the Appearance... command 

from the Options menu. The Appearance Dialog will appear on 
your screen again. 

Figure 2.16 

 
 

22. Choose all of the needed parameters in the Appearance Dialog 
as shown above.  

 
23. Click the OK control button.  
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Figure 2.17 

 
 

24. Choose the Filter... command from the Edit menu. The Field 
Filtering Dialog will appear on your screen. 

Figure 2.18 

 
 

25. Choose all of the needed parameters in the Field Filtering 
Dialog as shown above.  

 
26. Click the OK control button. The flowfield of the 

selected block will be filtered.  
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Figure 2.19 

 
 

27. Choose the Close command from the File menu to close the 
opened file.  
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Step 3. Representing the Flowfield Value as a 3D Object 
 
1. Open an existing file STEP_3.XYZ that is located in 

subfolder SAMPLES\STEP_3 of the current folder. (For 
additional information, see Steps 1-2 of Step 2.)  

 
2. To visualize the Geometry rotate it on your screen. 

(For more information, see Steps 4-5 of Step 1.) 

Figure 3.1 

 
 
3. Show the Cp flowfield. (For more information see Steps 

18-20 of Step 2.) 

Figure 3.2 

 
 
4. Choose the Import 3D Field... command from the Import/Export 

menu. The standard Open Dialog will appear on your screen. 
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Figure 3.3 

 
 
5. Choose the file STEP_3.XYZ, and click the Open control 

button. The Open Dialog will be closed, and the Import Dialog 
will appear on your screen. 

Figure 3.4 

 
 
6. Choose all of the needed parameters in the Import Dialog as 

shown above.  
 
7. Click the OK control button.  
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Figure 3.5 
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Chapter 3.  Working with a Project File 
 

Step 4. Creating a Project File 
 
1. To create a new project file, choose the New OMS Project... 

command from the OMS Project menu. The OMS Property Sheet Dialog 
will appear on your screen. 

Figure 4.1 

 
 
2. Choose all of the needed parameters in the Test Features 

tab as shown above.  
 
3. Click the Write... control button. The standard Save As Dialog 

will appear on your screen. 
 
4. Create a subfolder SAMPLES\STEP_4 of the current 

folder, and enter it. 
 
5. Type “STEP_4” in the File name text box, and click the 

Save control button. The Save As Dialog will be closed, and 
the project file with the name STEP_4.IMS will be 
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created. Its name will appear in the This File information 
pane.  

 
6. Click the Refe Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 

Figure 4.2 

 
 
7. Choose all of the needed parameters in the Refe Files tab 

as shown above.  
 
8. Click the Sens Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 4.3 

 
 
9. Choose all of the needed parameters in the Sens Files tab 

as shown above.  
 

10. Click the T Files tab in the OMS Property Sheet Dialog. It will 
appear on your screen. 
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Figure 4.4 

 
 
11. This tab remains empty at this Step. It is used for 

processing TSP images. 
 
12. Click the Mesh Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 4.5 

 
 
13. Choose all of the needed parameters in the Mesh Files tab 

as shown above. The Field on Mesh text box is empty. In 
this version of the ProField application, a default 
filename is used. It is created by ProImage. For 
example, if ProImage runs project STEP_4.IMS, it 
creates the default name STEP_4.XYZ.  

 
14. Click the Resultant Files tab in the OMS Property Sheet Dialog. It 

will appear on your screen. 
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Figure 4.6 

 
 
15. The tab remains empty at this Step. In this case the 

appropriate filenames will be created as a default. In 
our case the image files will be named 
STEP_4_IREFE_ISENS.IMP, STEP_4_PRESSURE.IMP, 
STEP_4_P_PSTAT.IMP, and STEP_4_CP.IMP; the marker files 
will be named STEP_4_IREFE_ISENS.MPT, 
STEP_4_PRESSURE.MPT, STEP_4_P_PSTAT.MPT, and 
STEP_4_CP.MPT.  

Files for temperature are created for TSP only. 
 

16. Click the Test Features tab in the OMS Property Sheet Dialog. It 
will appear on your screen again. 

 
17. Click the Check control button. The presence of all of 

the chosen files in the project folder SAMPLES\STEP_4 
will be verified.  

 
18. Click the OK control button. The project file will be 

created, and all of the chosen parameters will be saved 
in it.  
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Chapter 4.  Additional Features 
 

Step 5. Drawing the Chart 
 
1. Open an existing file STEP_2.FLD that is located in 

subfolder SAMPLES\STEP_2 of the current folder. (For 
more information see Steps 1-2 of Step 2.) 

Figure 5.1 

 
 
2. View the Cp flowfield. (For more information see Steps 

18-20 of Step 2.) The Cp flowfield will appear on your 
screen. 

Figure 5.2 

 
 
3. To draw the chart:  

• Choose the Chart command from the Tools menu, 

or 

• Click the following icon from the upper toolbar: 
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Figure 5.3 

 
The step_2 (Cp) window will appear in the right lower corner 
of your screen. 

 
4. Press the left mouse button at the first point (cursor 

shape is changed to ), and move the mouse. Release 
the mouse button at the second point, and the function 
chart will appear in this window. 

Figure 5.4 
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Step 6. Creating a New Function 
 
1. Open an existing file STEP_2.FLD that is presented in 

subfolder SAMPLES\STEP_2 of the current folder. (For 
more information see steps 1-2 of Step 2.) 

Figure 6.1 

 
 
2. View the Cp flowfield. (For more information see Steps 

18-20 of Step 2.) The Cp flowfield will appear on your 
screen. 

Figure 6.2 

 
3. Choose the Field Calculator... command from the Tools menu. The 

Field Calculator Dialog will appear on your screen. 
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Figure 6.3 

 
 
4. To create a new function, click the Create A control 

button. The New field name Dialog will appear on your screen. 

Figure 6.4 

 
 
5. Choose all of the needed parameters in the New field name 

Dialog as shown above.  
 
6. Click the OK control button. The warning message will 

appear on the screen.  
 
7. Click the OK control button, or press Enter. The 

function “new_Cp” will be created, and the Field Calculator 
Dialog will appear on your screen again. 
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Figure 6.5 

 
 
8. Choose all of the needed parameters in the Field Calculator 

Dialog as shown above.  
 
9. Click the A = B + C control button. The warning message 

will appear on the screen.  
 

10. Click the OK control button, or press Enter. The 
“new_Cp” will be equal to the sum of “Cp” and 10. 

 
11. Click the Close control button.  

 
12. Turn on the palette. (For more information see Steps 9-

11 of Step 1.) 
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Figure 6.6 

 
 

13. View the “new_Cp” flowfield. (For more information see 
Steps 18-20 of Step 2.) The “new_Cp” flowfield will 
appear on your screen. The palette in the right portion 
of the application window will be changed, and the 
level of intensity on the bitmap will be increased on 
10. 

Figure 6.7 

 
 

14. Click the Options control button at the bottom of the 
palette. The Spectrum Appearance Dialog will appear on your 
screen. 
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Figure 6.8 

 
 

15. Choose all of the needed parameters in the Spectrum 
Appearance Dialog as shown above.  

 
16. Click the OK control button. The 3D Cp flowfield will 

appear on your screen. It may be compared with the 3D 
Cp flowfield. 

Figure 6.9 
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Chapter 1. Creation of simple Geometries (using File menu) 
 

Step 1. How to input data at the beginning of work using 
keyboard 
 
1. After running ProGraph: 

• Choose the New... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 1.1 

 
Then the Regular Input Dialog Box will appear on your screen. 

Figure 1.2 

 
 
2. Input the coordinates of the point. Type “0”, “-1” and 

“1” in text boxes as shown below. 
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Figure 1.3 

 
 
3. Save the coordinates in the keyboard buffer. 

• Click the Input after control button.  

or 

• Press Enter. 

Note. Coordinate values appear in the list above. X, Y 
and Z are the coordinates of this point; K is the 
number or patch; N is the number of the section and M 
is the current number of points in this section.  

Figure 1.4 

 
 
4. Repeat steps 2-3 to input the coordinates of the 

following points: 

X Y Z 
0 1 1
0 1 -1
0 -1 -1
0 -1 1

Note. The input points will appear in the list below.  
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Figure 1.5 

 
 
5. Click the Cut button the in Points pane. This permits one 

to turn on the regime of working with the Clipboard.  
 
6. Select the second point in the list above with the use 

of the mouse.  

Note. You also may click the list and use the following 
keys to move in the list:  

→, ↓ - upward 

↑, ← - downward 

PgUp, Home – to the beginning of the list 

PgDn, End – to the end of the list. 
 
7. Cut the second point into the Clipboard. 

• Click the Cut button.  

or 

• Press Enter. 

Note. The second point is removed from the list and 
placed into the Clipboard. The remaining points are 
renumbered. 

Figure 1.6 

 
 
8. Turn on the Paste check box in the Points pane.  
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9. Select the last point in the list.  
 
10.Put the content of Clipboard to the end of list. 

• Click the Input after control button.  

or 

• Press Enter. 

Note. The fifth point appears in the list.  

Figure 1.7 

 
 
11.Input a new content to Clipboard. Type “0”, “2” and 

“2” in text boxes in the Buffer pane. 
 
12.Select the fourth point in the list.  
 
13.Click the Replace button in the Points pane to replace the 

selected point with a Clipboard contents.  
 
14.Save the inputted coordinates in keyboard buffer. 

• Click the Replace control button.  

or 

• Press Enter. 
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Figure 1.8 

 
 
15.Turn off the Paste check box in the Points pane (click on 

it with the mouse).  
 
16.Click the New line button in the “Componentry” pane to 

input a new section.  

Figure 1.9 

 
 
17.Click the New line button. 

or 

Press Enter. 

Note. The first point of a new line is the point that 
has been selected in the first line.  
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Figure 1.10 

 
 
18.Click the Find button in the Component Entry pane to find 

some inputted point with the use of its integer-valued 
address (K, N and M indices).  

 
19.Then: 

• Click the Find button. 

or 

• Press Enter. 

The Find Dialog Box will appear on your screen.  

Figure 1.11 

 
 
20.Type “1”, “1” and “3” in the text boxes and click the 

Find control button. This point will be selected in the 
list of inputted points. 
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Figure 1.12 

 
 
21.Click the OK button in Componentry pane to finish the 

input.  
 
22.Then: 

• Click the OK control button. 

or 

• Press Enter. 

The Regular Input Dialog Box will be closed and the Geometry 
will appear on your screen. 
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Figure 1.13 

 
 

177



ProGraph User's GUIDE 11 

Step 2. How to open a file containing the Geometry 
 
ProGraph uses Geometries in the form of regular or non-
regular meshes which can be  created by different 
geometrical systems such as AutoCAD© 14, Tecplot©, 
UniGraphics©. 
 
Geometry should be converted to one of the following 
formats: APT, SKL, DAT or WRL. 
 
1) When an APT file is opened, its format remains the same 

and the file is not converted. Its patches are painted 
with the following colors: the first –  blue, the 
second –  green, the third – red, the fourth – white 
and the fifth – pink. If the number of patches is 
greater than five, the color scheme is repeated 
periodically.  

 
2) When a SKL file is opened, two cases may take place.  

• Sections of the Geometry have different number of 
points. In this case the file isn’t converted and it 
appears on your screen as a series of sections. The 
colors of these sections correspond to the numbers 
of patches (see the first point).  

or 

• All sections of the Geometry have the same number of 
points. In this case the file is converted to an APT 
one automatically. The colors of the patches 
correspond description in 1). 

 
3) When a DAT file is opened, three events may take place.  

• The DAT file contains a structured grid only. In 
this case the file is converted to an APT one 
automatically.  

or 

• DAT file contains an unstructured grid only. In this 
case the file appears on your screen as a number of 
triangles. ProGraph uses only triangles as an 
element of unstructured grid. Another polyhedrons 
are converted to triangles automatically. 

or 

• DAT file contains both structured and unstructured 
grid. In this case the file is converted to an 
unstructured grid and it appears on your screen as a 
number of triangles (see the previous point).  
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4) When WRL file is opened, it is converted to 
unstructured grid automatically (see the previous 
point).  

 
 
1. To open an existing file STEP_2.APT that is presented 

in the subfolder SAMPLES of the current folder: 

• Choose the Open... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 2.1 

 
Then the standard Open Dialog Box will appear on your 
screen. 

Figure 2.2 

 
 
2. Choose the file STEP_2.APT and click the Open control 

button. Then the Open Dialog Box will be closed, and the 
Geometry will appear on your screen. 
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Figure 2.3 
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Step 3. How to append one Geometry file with another 
 
The procedure for appending depends on the format of 
opened file. 
 
1) When APT file is opened, only APT, SKL or DAT file may 

be appended. A new file is converted in accordance with 
the procedure described in Step 2.  

 
2) When SKL file is opened, only APT or SKL file may be 

appended. A new file is converted in accordance with 
the procedure described in Step 2.  

 
3) When DAT file is opened, only DAT or WRL file may be 

appended. A new file is converted in accordance with 
the procedure described in Step 2.  

 
4) When WRL file is opened, only DAT or WRL file may be 

appended. A new file is converted in accordance with 
the procedure described in Step 2. 

 
 
0. To append an existing file STEP_3.APT that is presented 

in subfolder the SAMPLES of the current folder to the 
existing file STEP_2.APT opened in Step 2: 

• Choose the Append... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 3.1 

 
Then the standard Open Dialog Box will appear on your 
screen. 

Figure 3.2 
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1. Choose an existing file STEP_3.APT. The Geometry will 
appear on your screen. 

Figure 3.3 
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Step 4. How to save a Geometry file on the disk 
 
The procedure of saving depends on the format of created 
file. 
 
1) When a file of APT format has been created, it may be 

saved as a file of APT, SKL, DAT, or WRL format.  
 
2) When a file of SKL format has been created, it may be 

saved as a file of SKL format only.  
 
3) When a file of DAT format has been created, it may be 

saved as a file of DAT, or WRL format only.  
 
4) When a file of WRL format has been created, it may be 

saved as a file of DAT, or WRL format only.  
 
 
0. To save a file created in Step 3 with a new name 

STEP_4.APT to the subfolder SAMPLES of the current 
folder: 

• Choose the Save... command from the File menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 4.1 

 
Then the standard Save As Dialog Box will appear on your 
screen. 

Figure 4.2 

 
 
1. Type “STEP_4” in the File name text box and click the Save 

control button. Then the Save As Dialog Box will be closed 
and the file will be saved under the new name. 

183



ProGraph User's GUIDE 17 

Figure 4.3 
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Chapter 2. Geometry editing (using theEdit menu) 
 
Step 5. How to select a patch and create a block 

 
0. Open an existing file STEP_2.APT that is presented in 

the subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the patch: 

• Choose the Patches ~ Capture command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 5.1 

 

The cursor shape will be changed to . 
 
2. Then: 

• Press the left mouse button and drag the mouse. The 
patch under the cursor will be painted with a yellow 
color and patch number will appear in the Status 
Bar. Releasing the mouse button captures the patch 
and inputs it to the block.  

or 

• Click the patch. 

The selected patch will be highlighted with a yellow 
color and its points will be painted in blue. The 
selected patch will be transferred  into the block and 
its number will appear in the Status Bar. 

The patch that is included in block as the second one 
will be highlighted by green nodes, the third  by red, 
the fourth by white and the fifth by pink. If the 
number of selected patches is more than five, the color 
scheme will be repeated periodically. 
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Figure 5.2 
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Step 6. How to select a patch and to add it to the block with 
the use of the Input & Add to block command 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see Steps 1-2 of Step 2.) 

 
1. To select the patch: 

• Choose the Patches ~ Input & Add to block... command from the 
Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 6.1 

 
Then the Input Patch Dialog Box will appear on your screen. 

Figure 6.2 

 
 
2. Choose necessary parameters in the Input Patch Dialog Box as 

shown above. 
 
3. Click the OK button. Then the selected patch will be 

highlighted by a yellow color and its points will be 
represented as blue markers. (For more information 
about colors see Step 5.) The caught patch will be 
inputted to the block and its number will be in Status 
Bar. 

187



ProGraph User's GUIDE 21 

Figure 6.3 
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Step 7. How to select a patch and to add it to non-empty block 
 
0. To add a new patch to the block created at Step 6:  

• Choose the Patches ~ Add to block command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 7.1 

 

Then cursor shape will be changed to . 
 
1. Then: 

• Press left mouse button and drag the mouse. The 
patch under cursor will be painted with a yellow 
color and patch number will appear in Status Bar. 
Releasing the mouse button selectes the patch and 
inputs it to the block.  

or 

• Click the patch. 

Then the caught patch will be painted with a yellow 
color and its points will be represented as green 
markers. The caught patch will be inputted to the block 
and its number will appear in Status Bar. (For more 
information about colors see Step 5.) 

Figure 7.2 
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Step 8. How to remove a patch from the block  
 
0. To remove a patch from the block created at Step 7: 

• Choose the Patches ~ Remove from block command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 8.1 

 

Then cursor shape will be changed to . 
 
1. Then: 

• Press left mouse button and drag the mouse. The 
patch under cursor will be painted with a brown 
color and patch number will appear in Status Bar. 
Releasing the mouse button removes the patch from 
the block.  

or 

• Click the patch. 

Then the initial color of removed patch will be 
restored. (For more information about colors see Step 2 
and Step 5.) The patch isn’t deleted from the Geometry 
and remains on its place. 

Figure 8.2 
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Step 9. A set of one-action operations with block 
 
0. To delete all needed patches included in the block 

created at Step 8: 

• Choose the Patches ~ Delete block command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 9.1 

 
Only the patches that aren’t included in the block 
remain on your screen. Their colors are changed. (For 
more information about colors see Step 2.) 

Figure 9.2 

 
 
1. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 9.3 

 
Then old Geometry will appear on your screen again. 
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Figure 9.4 

 
 
2. Select the patch with the number 1. (For more 

information see steps 2-3 of Step 5.)  

Figure 9.5 

 
 
3. To keep all the patches included in the block: 

• Choose the Patches ~ Extract block command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 
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Figure 9.6 

 
Only the patches included in the block remain on your 
screen. Their colors may be changed. (For more 
information about colors see Step 2.)  

Figure 9.7 

 
 
4. To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 9.8 
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Step 10. How to convert files to another format 
 
0. Open an existing file STEP_10.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 10.1 

 
 
1. To convert this file to DAT format: 

• Choose the Patches ~Convert to ~ VRML or DAT command from the 
Edit menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.2 

 
Then the file of DAT format will appear on your screen. 
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Figure 10.3 

 
 
2. To convert this file to SKL format: 

• Choose the Patches ~ Convert to ~ SKL... command from the Edit 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.4 

 
Then the Convert to SKL Dialog Box will appear on your screen. 

 
3. Choose all needed parameters in the Convert to SKL Dialog Box 

as shown below. 

195



ProGraph User's GUIDE 29 

Figure 10.5 

 
 
4. Click the OK control button. Then the file of SKL 

format will appear on your screen. 

Figure 10.6 

 
 
5. To undo all changes: 

• Choose the Patches ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 10.7 

 
Then old Geometry will appear on your screen again. 
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Figure 10.8 

 
 
6. Choose the Patches ~ Convert to ~ SKL... command from the Edit 

menu again. Then the Convert to SKL Dialog Box will appear on 
your screen. 

 
7. Choose all needed parameters in the Convert to SKL Dialog Box 

as shown below. 

Figure 10.9 

 
 
8. Click the OK control button. Then the file of SKL 

format will appear on your screen. 
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Figure 10.10 

 
 
9. To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 10.11 

 
 
10.Choose the Patches ~ Convert to ~ SKL... command from the Edit 

menu again. Then the Convert to SKL Dialog Box will appear on 
your screen. 

 
11.Choose all needed parameters in the Convert to SKL Dialog Box 

as shown below. 

198



ProGraph User's GUIDE 32 

Figure 10.12 

 
 
12.Click the OK control button. Then the file of SKL 

format will appear on your screen. 

Figure 10.13 

 
 
13.To convert this file to APT format: 

• Choose the Patches ~ Convert to ~ APT... command from the Edit 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 10.14 
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Then the Convert to APT Dialog Box will appear on your screen. 

Figure 10.15 

 
 
14.Choose all needed parameters in the Convert to APT Dialog Box 

as shown above. 
 
15.Click the OK control button. Then the file of APT 

format will appear on your screen. 

Figure 10.16 

 
 

200



ProGraph User's GUIDE 34 

Step 11. How to select a section 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the section: 

• Choose the Lines ~ Capture ~ Section command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 11.1 

 

Then cursor shape will be changed to . 
 
2. Then: 

• Press left mouse button and drag the mouse. The 
points of section under cursor will be painted with 
a white color and section and patch numbers will 
appear in Status Bar. Releasing the mouse button 
selectes the section.  

or 

• Click the section. 

Then the points of caught section will be painted with 
a white color. 

When a block has been created, only a section belonging 
to this block may be caught. When no patches are 
included in the block, any section may be caught. 
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Figure 11.2 
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Step 12. How to select a section with the use of Input ~ Section 
command 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the section: 

• Choose the Lines ~ Input ~ Section... command from the Edit 
menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 12.1 

 
Then the Input section Dialog Box will appear on your screen. 

 
2. Choose all needed parameters in the Input section Dialog Box 

as shown below. 

Figure 12.2 

 
 
3. Click the OK control button. The points of caught 

section are painted with a white color and section and 
patch numbers appear in Status Bar. 

When a block has been created, only a section belonging 
to this block may be caught. When no patches are 
included in the block, any section may be caught. 
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Figure 12.3 
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Step 13. How to select a line 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the line: 

• Choose the Lines ~ Capture ~ Line command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 13.1 

 

Then cursor shape will be changed to . 
 
2. Then: 

• Press left mouse button and drag the mouse. The 
points of line under cursor will be painted with a 
white color and line and patch numbers will appear 
in Status Bar. Releasing the mouse button selectes 
the line.  

or 

• Click the line. 

Then the points of caught line will be painted with a 
white color. 

When a block has been created, only a line belonging to 
this block may be caught. When no patches are included 
in the block, any line may be caught. 
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Figure 13.2 
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Step 14. How to select a line with the use of Input ~ Line 
command 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the line: 

• Choose the Lines ~ Input ~ Line... command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 14.1 

 
Then the Input line Dialog Box will appear on your screen. 

 
2. Choose all needed parameters in the Input line Dialog Box as 

shown below. 

Figure 14.2 

 
 
3. Click the OK control button. The points of caught line 

are painted with a white color and line and patch 
numbers appear in Status Bar. 

When a block has been created, only a line belonging to 
this block may be caught. When no patches are included 
in the block, any line may be caught. 
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Figure 14.3 
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Step 15. How to split a patch on two patches 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. Select a section. (For more information see steps 2-3 

of Step 11.) 

Figure 15.1 

 
 
2. To split a patch on two patches:  

• Choose the Patches ~ Split patch in block command from the Edit 
menu. 

or 

• Click the following icon from the left toolbar: 

Figure 15.2 

 
Then the patch that contains the caught section will be 
split. This section is used as a border of two new 
patches. The caught section belongs to both patches. 
The colors of patches will be changed. (For more 
information about colors see Step 2.) 
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Figure 15.3 

 
 

210



ProGraph User's GUIDE 44 

Step 16. A set of one-action operations with sections  
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. Select a section. (For more information see steps 2-3 

of Step 11.) 

Figure 16.1 

 
 
2. To delete the caught section: 

• Choose the Lines ~ Delete command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.2 

 
Then the caught section will be deleted. The next 
section becomes the caught one. 
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Figure 16.3 

 
 
3. To undo all changes: 

• Choose the Lines ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 16.4 

 
Then old Geometry will appear on your screen again. 

Figure 16.5 
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4. To copy the caught section: 

• Choose the Lines ~ Duplicate... command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.6 

 
Then the Duplicate Dialog Box will appear on your screen. 

 
5. Choose all needed parameters in the Duplicate Dialog Box as 

shown below. 

Figure 16.7 

 
 
6. Click the OK control button. Then the caught section 

will be duplicated and its points will be distinguished 
as a white markers with green border. 

Figure 16.8 

 
 
7. To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 16.9 

 
 
8. To copy the caught section to Clipboard: 

• Choose the Lines ~ Copy command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.10 

 
Then the caught section will be copied to Clipboard. It 
may be placed at any position. 

 
9. To select another section press right mouse button, 

choose the Next Section (Line) command from the context menu 
and select necessary section. (For more information see 
steps 2-3 of Step 11.) 

214



ProGraph User's GUIDE 48 

Figure 16.11 

 
 
10.To place the Clipboard content instead of the caught 

section: 

• Choose the Lines ~ Paste command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 16.12 

 
Then the Clipboard content will replace the caught 
section. 
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Figure 16.13 
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Step 17. How to rebreak a section 
 
0. Open an existing file STEP_17a.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) Then the Geometry 
will appear on your screen. 

Figure 17.1 

 
 
1. Select the second section of a green patch. (For more 

information see steps 2-3 of Step 11.) 

Figure 17.2 

 
 
2. To rebreak the caught section: 
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• Choose the Lines ~ Rebreak... command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 17.3 

 
Then the Rebreak Dialog Box will appear on your screen. 

 
3. Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 

Figure 17.4 

 
 
4. Click the OK control button. Then the caught section 

will be rebroken. 
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Figure 17.5 

 
 
5. To undo all changes: 

• Choose the Lines ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 17.7 

 
Then old Geometry will appear on your screen again. 

 
6. To rebreak another section choose the Lines ~ Rebreak... 

command from the Edit menu again. Then the Rebreak Dialog Box 
will appear on your screen. 

 
7. Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.8 

 
 
8. Click the OK control button. Then the fourth section 

will be rebroken. It will become the caught one. 

Figure 17.9 

 
 
9. To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 17.10 

 
 
10.To rebreak all sections of the patch choose the 

Lines ~ Rebreak... command from the Edit menu again. Then the 
Rebreak Dialog Box will appear on your screen. 

 
11.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 

Figure 17.11 

 
 
12.Click the OK control button. Then all the sections of 

green patch will be rebroken.  
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Figure 17.12 

 
 
13.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 17.13 

 
 
14.To rebreak the green patch in some range choose the 

Lines ~ Rebreak... command from the Edit menu again. Then the 
Rebreak Dialog Box will appear on your screen. 

 
15.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.14 

 
 
16.Click the OK control button. Then the green patch in 

the range from the fifth line to the tenth line will be 
rebroken.  

Figure 17.15 

 
 
17.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 17.16 

 
 
18.To rebreak the second and the third sections of green 

patch choose the Lines ~ Rebreak... command from the Edit menu 
again. Then the Rebreak Dialog Box will appear on your 
screen. 

 
19.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 

Figure 17.17 

 
 
20.Click the OK control button. Then the second and the 

third sections of green patch will be rebroken.  
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Figure 17.18 

 
 
21.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 17.19 

 
 
22.To rebreak the second and the third sections of green 

patch choose the Lines ~ Rebreak... command from the Edit menu 
again. Then the Rebreak Dialog Box will appear on your 
screen. 

 
23.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.20 

 
 
24.Click the OK control button. Then the second and the 

third sections of green patch will be rebroken with new 
number of points.  

Note. APT format of opened file is violated. 

Figure 17.21 

 
 
25.Open an existing file STEP_17b.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) Then the Geometry 
will appear on your screen. 
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Figure 17.22 

 
 
26.Select the second section of a green patch. (For more 

information see steps 2-3 of Step 11.) 

Figure 17.23 

 
 
27.To rebreak all sections of green patch in accordance 

with the caught section choose the Lines ~ Rebreak... command 
from the Edit menu. Then the Rebreak Dialog Box will appear 
on your screen. 

 
28.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.24 

 
 
29.Click the OK control button. Then all sections of 

green patch will be rebroken in accordance with the 
caught section.  

Figure 17.25 

 
 
30.Open an existing file STEP_17c.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) Then the Geometry 
will appear on your screen. 
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Figure 17.26 

 
 
31.Select the last section. (For more information see 

steps 2-3 of Step 11.) 

Figure 17.27 

 
 
32.Choose the Lines ~ Rebreak... command from the Edit menu. Then 

the Rebreak Dialog Box will appear on your screen. 
 
33.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.28 

 
 
34.Click the OK control button. Then new Geometry will 

appear on your screen. 

Figure 17.29 

 
 
35.Open an existing file STEP_17d.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) Then the Geometry 
will appear on your screen. 
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Figure 17.30 

 
 
36.Select the ninth line of green patch. (For more 

information see steps 2-3 of Step 13.) 

Figure 17.31 

 
 
37.To change the number of sections in green patch choose 

the Lines ~ Rebreak... command from the Edit menu. Then the 
Rebreak Dialog Box will appear on your screen. 

 
38.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 
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Figure 17.32 

 
 
39.Click the OK control button. Then new Geometry will 

appear on your screen. 

Figure 17.33 

 
 
40.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 17.34 

 
 
41.Choose the Lines ~ Rebreak... command from the Edit menu. Then 

the Rebreak Dialog Box will appear on your screen. 
 
42.Choose all needed parameters in the Rebreak Dialog Box as 

shown below. 

Figure 17.35 

 
 
43.Click the OK control button. Then new Geometry will 

appear on your screen. 
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Figure 17.36 
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Step 18. How to select a point 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the point: 

• Choose the Point ~ Capture command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 18.1 

 

Then cursor shape will be changed to . 
 
2. Then: 

• Press left mouse button and drag the mouse. The 
point under cursor will be distinguished as a white 
marker with red border and its number will appear in 
Status Bar. Releasing the mouse button selectes the 
point.  

or 

• Click the point. 

Then the caught point will be distinguished as a white 
marker with red border. 

When a block has been created, only a point belonging 
to this block may be caught. When a section or a line 
has been caught, only a point belonging to this section 
or line may be caught. When no patches, sections or 
lines have been caught, any point may be caught. 
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Figure 18.2 
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Step 19. How to select a point with the use of Input command 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. To select the section choose the Point ~ Input... command 

from the Edit menu. Then the Find Dialog Box will appear on 
your screen. 

 
2. Choose all needed parameters in the Find Dialog Box as 

shown below. 

Figure 19.1 

 
 
3. Click the OK control button. Then the caught point will 

be distinguished as a white marker with red border. 

When a block has been created, only a point belonging 
to this block may be caught. When a section or a line 
has been caught, only a point belonging to this section 
or line may be caught. When no patches, sections or 
lines have been caught, any point may be caught. 
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Figure 19.2 
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Step 20. A set of one-action operations with points 
 
0. Open an existing file STEP_2.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

 
1. Select a point. (For more information see steps 2-3 of 

Step 18.) 

Figure 20.1 

 
 
2. To delete the caught point: 

• Choose the Point ~ Delete command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.2 

 
Then the caught point will be deleted. The next point 
will become the caught one.  

Note. APT format of opened file is violated. 
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Figure 20.3 

 
 
3. To undo all changes:  

• Choose the Point ~ Undo command from the Edit menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 20.4 

 
Then old Geometry will appear on your screen again. 

Figure 20.5 
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4. To copy the caught point: 

• Choose the Point ~ Duplicate... command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.6 

 
Then the Duplicate Dialog Box will appear on your screen. 

 
5. Choose all needed parameters in the Duplicate Dialog Box as 

shown below. 

Figure 20.7 

 
 
6. Click the OK control button. Then the caught point will 

be duplicated and distinguished as a green markers with 
red border.  

Note. APT format of opened file is violated. 

Figure 20.8 

 
 
7. To undo all changes choose the Point ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 20.9 

 
 
8. To copy the caught point to Clipboard: 

• Choose the Point ~ Copy command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.10 

 
Then the caught point will be copied to Clipboard. It 
may be placed at any position. 

 
9. To select another point press right mouse button, 

choose the Next point command from the context menu and 
select necessary section. (For more information see 
steps 2-3 of Step 18.) 
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Figure 20.11 

 
 
10.To place the Clipboard content instead of the caught 

point: 

• Choose the Point ~ Paste command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.12 

 
Then the Clipboard content will replace the caught 
point. 
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Figure 20.13 

 
 
11.To undo all changes choose the Point ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 20.14 

 
 
12.To edit the coordinates of the caught point: 

• Choose the Point ~ Edit... command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 
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Figure 20.15 

 
Then the Edit point Dialog Box will appear on your screen. 

 
13.Choose all needed parameters in the Edit point Dialog Box as 

shown below. 

Figure 20.16 

 
 
14.Click the OK control button. Then the caught point 

will be moved.  

Figure 20.17 

 
 
15.To undo all changes choose the Point ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 20.18 

 
 
16.To drag the caught point: 

• Choose the Point ~ Drag command from the Edit menu. 

or 

• Click the following icon from the left toolbar: 

Figure 20.19 

 
 
17.Then: 

• Press left mouse button and drag the mouse. The 
caught point will be moved and its new coordinates 
will appear in Status Bar. Releasing the mouse 
button drops the caught point at the last position. 

or 

• Click a new position of the caught point. 

Then the caught point is moved in the plane of 
curvilinear quadrangle that is formed by neighboring 
sections and lines. This curvilinear quadrangle is 
covered by a grid that has 100x100 cells. The point can 
be placed in the points of this grid only. The point 
can’t be dragged outside the quadrangle. 
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Figure 20.20 
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Chapter 3. Block transforming (using Transformations menu) 
 
Step 21. How to create a block projection on other patches 

 
0. Open an existing file STEP_21a.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 21.1 

 
 
1. Append an existing file STEP_21b.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 3.) 
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Figure 21.2 

 
 
2. Select the green patch. (For more information see steps 

2-3 of Step 5.)  

Figure 21.3 

 
 
3. To create a projection of block on the other patch: 

• Choose the Reflection command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 
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Figure 21.4 

 
Then the Geometry will appear on your screen. 

Figure 21.5 

 
 
4. Keep all the patches included in the block. (For more 

information see step 4 of Step 9.) Only the patches 
included in the block remain on your screen. Their 
colors are changed. (For more information about colors 
see Step 2.) 

Figure 21.6 
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Step 22. How to create an intersection of two patches 
 
0. Open an existing file STEP_22a.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 22.1 

 
 
1. Append an existing file STEP_22b.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 3.) 

Figure 22.2 
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2. To show first points and sections choose the View features 
command from the Options menu. Then the View features Dialog Box 
will appear on your screen. 

 
3. Choose all needed parameters in the View features Dialog Box 

as shown below. 

Figure 22.3 

 
 
4. Click the OK control button. Then first sections will 

be represented with big yellow markers and first point 
at each section will be represented as big red markers. 

Note. Patches must be crossed.  

Figure 22.4 

 
 
5. To set the plane view constY =  click the following icon 

from the upper toolbar . Then a new projection of 
Geometry will appear on your screen. 
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Figure 22.5 

 
 
6. Select the green patch. (For more information see steps 

2-3 of Step 5.)  

Figure 22.6 

 
 
7. To intersect these patches and to create smooth 

conjugation of intersecting area: 

• Choose the Intersection... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 
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Figure 22.7 

 
Then the Intersection Dialog Box will appear on your screen. 

 
8. Choose all needed parameters in the Intersection Dialog Box as 

shown below. 

Figure 22.8 

 
 
9. Click the OK button. Then the Geometry will appear on 

your screen. 

Figure 22.9 

 
 
10.To set the plane view constX =  click the following icon 

from the upper toolbar . Then a new projection of 
Geometry will appear on your screen. 
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Figure 22.10 
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Step 23. How to merge patches included in the block 
 
0. Open an existing file STEP_23a.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 23.1 

 
 
1. Select the green patch. (For more information see steps 

2-3 of Step 5.) 

Figure 23.2 

 
 
2. Select the red patch. (For more information see steps 

1-2 of Step 7.) 
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Figure 23.3 

 
 
3. To merge this patches: 

• Choose the Merge... command from the Transformations menu. 

or 

• Click the following icon from the upper toolbar: 

Figure 23.5 

 
Then the Merge Dialog Box will appear on your screen. 

 
4. Choose all needed parameters in the Merge Dialog Box as 

shown below. 

Figure 23.5 

 
 
5. Click the OK control button. Then the number of lines 

will remain the same and the number of sections will 

257



ProGraph User's GUIDE 91 

increase. Double points will be represented with big 
green markers. The colors of patches will be changed. 
(For more information about colors see Step 2.) 

Figure 23.6 

 
 
6. Open an existing file STEP_23b.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 23.7 

 
 
7. Select the green patch. (For more information see steps 

2-3 of Step 5.) 
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Figure 23.8 

 
 
8. Select the red patch. (For more information see steps 

1-2 of Step 7.) 

Figure 23.9 

 
 
9. Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 

 
10.Choose all needed parameters in the Merge Dialog Box as 

shown below. 
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Figure 23.10 

 
 
11.Click the OK button. The patches in block have 

different numbers of lines. After merging APT format 
will be violated. Then a warning about APT format 
violation will appear on your screen. 

 
12.Click the Yes control button or press Enter. Then a new 

Geometry of SKL format will appear on your screen. The 
sections of block belong to one patch now. The colors 
of patches will be changed. (For more information about 
colors see Step 2.) 

Figure 23.11 

 
 
13.Open an existing file STEP_23c.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 
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Figure 23.12 

 
 
14.Select the green patch. (For more information see 

steps 2-3 of Step 5.) 

Figure 23.13 

 
 
15.Select the red patch. (For more information see steps 

1-2 of Step 7.) 
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Figure 23.14 

 
 
16.Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 

 
17.Choose all needed parameters in the Merge Dialog Box as 

shown below. 

Figure 23.15 

 
 
18.Click the OK control button. The points of sections in 

the first and the second patches have different 
distributions.  

A new Geometry appears on your screen. The sections of 
block belong to one patch now. The second patch is 
rebroken in accordance with the first one. The colors 
of patches are changed. (For more information about 
colors see Step 2.) 
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Figure 23.16 

 
 
19.Open an existing file STEP_23d.APT that is presented 

in subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 23.17 

 
 
20.Select the red patch. (For more information see steps 

2-3 of Step 5.) 
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Figure 23.18 

 
 
21.Select the green patch. (For more information see 

steps 1-2 of Step 7.) 

Figure 23.19 

 
 
22.Choose the Merge... command from the Transformations menu 

again. Then the Merge Dialog Box will appear on your 
screen. 

 
23.Choose all needed parameters in the Merge Dialog Box as 

shown below. 
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Figure 23.20 

 
 
24.Click the OK control button. Then the number of 

sections will remain the same and the number of lines 
will increase. The colors of patches will be changed. 
(For more information about colors see Step 2.) 

Figure 23.21 
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Step 24. A set of one-action transformations of block 
 
0. Open an existing file STEP_10.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 24.1 

 
 
1. Select the green patch. (For more information see steps 

2-3 of Step 5.)  

Figure 24.2 

 
 
2. To scale the block: 

• Choose the Scaling... command from the Transformations menu. 
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or 

• Click the following icon from the right toolbar: 

Figure 24.3 

 
Then the Scaling Dialog Box will appear on your screen. 

 
3. Choose all needed parameters in the Scaling Dialog Box as 

shown below. 

Figure 24.4 

 
 
4. Click the OK control button. Then the block will be 

scaled and a new Geometry will appear on your screen. 

Figure 24.5 

 
 
5. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 
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or 

• Click the following icon from the upper toolbar: 

Figure 24.6 

 
Then old Geometry will appear on your screen again. 

Figure 24.7 

 
 
6. To move the block: 

• Choose the Move... command from the Transformations menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.8 

 
Then the Move Dialog Box will appear on your screen. 

 
7. Choose all needed parameters in the Move Dialog Box as 

shown below. 
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Figure 24.9 

 
 
8. Click the OK control button. Then the block will be 

moved and a new Geometry will appear on your screen. 

Figure 24.10 

 
 
9. To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again.  
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Figure 24.11 

 
 
10.To rotate the block: 

• Choose the Rotation... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.12 

 
Then the Rotation Dialog Box will appear on your screen. 

 
11.Choose all needed parameters in the Rotation Dialog Box as 

shown below. 

Figure 24.13 
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12.Click the OK control button. Then the block will be 
rotated and a new Geometry will appear on your screen. 

Figure 24.14 

 
 
13.To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again.  

Figure 24.15 

 
 
14.To mirror the block: 

• Choose the Flip... command from the Transformations menu. 

or 
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• Click the following icon from the right toolbar: 

Figure 24.16 

 
Then the Flip Dialog Box will appear on your screen. 

 
15.Choose all needed parameters in the Flip Dialog Box as 

shown below. 

Figure 24.17 

 
 
16.Click the OK control button. Then the block will be 

mirrored and a new Geometry will appear on your screen. 

Figure 24.18 

 
 
17.To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again.  
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Figure 24.19 

 
 
18.To add symmetrical block to the present one: 

• Choose the Symmetric... command from the Transformations 
menu. 

or 

• Click the following icon from the right toolbar: 

Figure 24.20 

 
Then the Symmetry Dialog Box will appear on your screen. 

 
19.Choose all needed parameters in the Symmetry Dialog Box as 

shown below. 

Figure 24.21 
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20.Click the OK control button. Then a new Geometry will 
appear on your screen. 

Figure 24.22 

 
 
21.To undo all changes choose the Patches ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again.  

Figure 24.23 

 
 
22.To halve the number of points in every section of 

block: 

• Choose the Knife command from the Transformations menu. 

or 
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• Click the following icon from the right toolbar: 

Figure 24.24 

 
Then a new Geometry will appear on your screen. 

Figure 24.25 

  
 
23.To enlarge the linear size of the block press right 

mouse button and choose the Extrapolate... command from the 
context menu. Then the Extrapolation Dialog Box will appear on 
your screen. 

 
24.Choose all needed parameters in the Extrapolation Dialog Box 

as shown below. 

Figure 24.26 

 
 
25.Click the OK control button. Then a new Geometry will 

appear on your screen. 
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Figure 24.27 
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Chapter 4. Section transforming (using right mouse menu) 
 
Step 25. A set of one-action transformations of section 

 
0. Open an existing file STEP_10.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 25.1 

 
 
1. Select a section. (For more information see steps 2-3 

of Step 11.)  

Figure 25.2 

 

277



ProGraph User's GUIDE 111 

 
2. To scale the caught section press right mouse button 

and choose the Scaling... command from the context menu. 
Then the Scaling Dialog Box will appear on your screen. 

 
3. Choose all needed parameters in the Scaling Dialog Box as 

shown below. 

Figure 25.3 

 
 
4. Click the OK button. Then the selected section will be 

scaled and a new Geometry will appear on your screen. 

Figure 25.4 

 
 
5. To undo all changes:  

• Choose the Lines ~ Undo command from the Edit menu. 

or 
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• Click the following icon from the upper toolbar: 

Figure 25.5 

 
Then old Geometry will appear on your screen again. 

Figure 25.6 

 
 
6. To move the caught section press right mouse button and 

choose the Move... command from the context menu. Then 
the Move Dialog Box will appear on your screen. 

 
7. Choose all needed parameters in the Move Dialog Box as 

shown below. 

Figure 25.7 

 
 
8. Click the OK control button. Then the caught section 

will be moved and a new Geometry will appear on your 
screen. 

279



ProGraph User's GUIDE 113 

Figure 25.8 

 
 
9. To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 25.9 

 
 
10.To rotate selected section press right mouse button 

and choose the Rotation... command from the context menu. 
Then the Rotation Dialog Box will appear on your screen. 

 
11.Choose all needed parameters in the Rotation Dialog Box as 

shown below. 
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Figure 25.10 

 
 
12.Click the OK control button. Then selected section 

will be rotated and a new Geometry will appear on your 
screen. 

Figure 25.11 

 
 
13.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 25.12 

 
 
14.To mirror selected section press right mouse button 

and choose the Flip... command from the context menu. Then 
the Flip Dialog Box will appear on your screen. 

 
15.Enter all necessary parameters in the Flip Dialog Box as 

shown below. 

Figure 25.13 

 
 
16.Click the OK button. Then selected section will be 

mirrored and a new Geometry will appear on your screen. 
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Figure 25.14 

 
 
17.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 25.15 

 
 
18.To add symmetrical section to the caught one press 

right mouse button and choose the Symmetric... command 
from the context menu. Then the Symmetry Dialog Box will 
appear on your screen. 

 
19.Enter all required parameters in the Symmetry Dialog Box as 

shown below. 
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Figure 25.16 

 
 
20.Click the OK button. Then a new Geometry will appear 

on your screen. 

Note. APT format of opened file is violated. 

Figure 25.17 

 
 
21.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 25.18 

 
 
22.To move selected section using linear interpolation 

press right mouse button and choose the Interpolate... 
command from the context menu. Then the Interpolate Dialog Box 
will appear on your screen. 

 
23.Enter all required parameters in the Interpolate Dialog Box 

as shown below. 

Figure 25.19 

 
 
24.Click the OK button and selected section will be moved 

to the next one and a new Geometry will appear on your 
screen. 
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Figure 25.20 

 
 
25.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 

Figure 25.21 

 
 
26.To prescribe a definite value for coordinate (X, Y or 

Z) of all the points included in the selected section 
press right mouse button and choose the Prescribe... 
command from the context menu. Then the Prescribe Dialog Box 
will appear on your screen. 
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27.Choose all required parameters in the Prescribe Dialog Box 
as shown below. 

Figure 25.22 

 
 
28.Click the OK control button. Then selected section 

will be moved to the next one and a new Geometry will 
appear on your screen. 

Figure 25.23 

 
 
29.To undo all changes choose the Lines ~ Undo command from 

the Edit menu. Then old Geometry will appear on your 
screen again. 
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Figure 25.24 

 
 
30.To halve the number of points in the selected section 

press right mouse button and choose the Knife command 
from the context menu. Then a new Geometry will appear 
on your screen. 

Note. APT format of opened file is violated. 

Figure 25.25 
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Step 26. A set of one-action transformations of section part 
 
0. Open an existing file STEP_10.APT that is presented in 

subfolder SAMPLES of the current folder. (For more 
information see steps 1-2 of Step 2.) 

Figure 26.1 

 
 
1. Select a section. (For more information see steps 2-3 

of Step 11.)  

Figure 26.2 

 
 
2. Choose a point of selected patch. (For more information 

see steps 2-3 of Step 18.) 

289



ProGraph User's GUIDE 123 

Figure 26.3 

 
 
3. To diminish the number of points in the selected 

section press right mouse button and choose the Knife 
command from the context menu. Then the new Geometry 
will contain only the points from the first one up to 
caught one. 

Note. APT format of opened file is violated. 

Figure 26.4 

 
 
4. To undo all changes:  

• Choose the Patches ~ Undo command from the Edit menu. 

or 
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• Click the following icon from the upper toolbar: 

Figure 26.5 

 
Then old Geometry will appear on your screen again. 

Figure 26.6 

 
 
5. To copy a part of selected section to Clipboard press 

right mouse button and choose the Copy part command from 
the context menu. Then the section part from the first 
point up to the chosen  point will be copied to 
Clipboard. It may be placed at any position. 

 
6. To return to the regime of section editing press right 

mouse button and choose the Exit command from context 
menu.  

291



ProGraph User's GUIDE 125 

Figure 26.7 

 
 
7. To select another section press right mouse button, 

choose the Next Section (Line) command from the context menu 
and select necessary section. (For more information see 
steps 2-3 of Step 11.) 

Figure 26.2 

 
 
8. To place a copy of the Clipboard contents to the end of 

the caught section press right mouse button and choose 
the Merge command from the context menu. Then a new 
Geometry will appear on your screen. 

Note. APT format of opened file is violated. 
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Figure 26.8 
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