Re-Mastering Knoppix for the MYSEA Testbed

by

Paul C. Clark, Albert Wong, Jean Khosalim

January 2006

Approved for public release; distribution is unlimited

Prepared for: National Reconnaissance Office
This material is based upon work supported by the National Reconnaissance Office under MIPR No. F448129. Any opinions, findings, and conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect the views of the National Reconnaissance Office.
1. REPORT DATE (DD-MM-YYYY) 01-2006
2. REPORT TYPE Technical
3. DATES COVERED (From - To) Jan 2005 - Dec 2005

4. TITLE AND SUBTITLE
Re-Mastering Knoppix for the MYSEA Testbed

5a. CONTRACT NUMBER

5b. GRANT NUMBER F448129

5c. PROGRAM ELEMENT NUMBER

5d. PROJECT NUMBER

5e. TASK NUMBER

5f. WORK UNIT NUMBER

6. AUTHOR(S)
Paul C. Clark, Albert Wong, Jean Khosalim

7. PERFORMING ORGANIZATION NAME(S) AND ADDRESS(ES)
Naval Postgraduate School, Monterey, California, 93943

8. PERFORMING ORGANIZATION REPORT NUMBER NPS-CS-06-006

9. SPONSORING/MONITORING AGENCY NAME(S) AND ADDRESS(ES)
National Reconnaissance Office
14675 Lee Road
Chantilly, VA 20151

10. SPONSOR/MONITOR’S ACRONYM(S) NRO

11. SPONSOR/MONITOR’S REPORT NUMBER(S)

12. DISTRIBUTION/AVAILABILITY STATEMENT
Approved for public release; Distribution is unlimited

13. SUPPLEMENTARY NOTES

14. ABSTRACT
When a computing environment is operating in a multilevel mode, where users have different clearances, and data exists at multiple levels of classification, supporting commercial-grade operating systems and applications is a major challenge. The Monterey Security Architecture (MYSEA) at the Naval Postgraduate School is a proposed solution. A testbed has been developed to research and prototype the architecture. One part of the architecture requires “thin clients” -- workstations with no ability to save data or state locally. One approach to provide a reasonable thin client in the short term is to boot an operating system from optical media, such as a CD or DVD. Knoppix is an open source effort that provides a pre-packaged bootable Linux operating system on CD. However, the current version of Knoppix does not provide the configuration and applications required for the MYSEA testbed. This document provides a generic process for re-mastering (or re-packaging) the Knoppix CD, as well as the specific steps for producing a Knoppix CD that is usable in the MYSEA architecture.

15. SUBJECT TERMS
Multilevel Security, MYSEA, Knoppix

16. SECURITY CLASSIFICATION OF:
a. REPORT Unclassified
b. ABSTRACT Unclassified
c. THIS PAGE Unclassified

17. LIMITATION OF ABSTRACT None

18. NUMBER OF PAGES 12

19a. NAME OF RESPONSIBLE PERSON
Paul Clark

19b. TELEPHONE NUMBER (Include area code) 831-656-2395
Re-Mastering Knoppix for the
MYSEA Testbed

Paul C. Clark, Albert Wong, Jean Khosalim

January 2006
ACKNOWLEDGEMENTS

This material is based upon work supported in part by the National Reconnaissance Office and other government sponsors. Any opinions, findings, conclusions or recommendations expressed in this material are those of the authors and do not necessarily reflect those of the sponsors.

Author Affiliation:

Center for Information Systems Security Studies and Research
Computer Science Department
Naval Postgraduate School
Monterey, California 93943
# Table of Contents

1. Introduction ................................................................................................................ 1  
2. Procedures for Re-Mastering Knoppix ....................................................................... 1  
   2.1 Requirements ...................................................................................................... 1  
   2.2 Boot Knoppix ..................................................................................................... 2  
   2.3 Generate a Kick List .......................................................................................... 2  
   2.4 Generate MYSEA Configuration Files ............................................................... 2  
   2.5 Create a new CD Image ...................................................................................... 3  
3. Future Work ................................................................................................................ 5  
4. References .................................................................................................................. 5  
A Knx Shell Script .......................................................................................................... 6  
   A.1 Knx Explained .................................................................................................... 6  
   A.2 The Knx Script .................................................................................................. 6  
B The MYSEA Configuration Changes ....................................................................... 10  
   B.1 Kick List (kick.txt) ........................................................................................... 10  
   B.2 Hosts File .......................................................................................................... 10  
   B.3 Autoconfig (knoppix-autoconfig) ...................................................................... 11  
   B.4 Browser Configuration changes ........................................................................ 11  
   B.5 Email Settings ................................................................................................... 12  
   B.6 Application Startup ........................................................................................... 13  
   B.7 Toolbar Configuration ...................................................................................... 13
1. Introduction

The Monterey Security Enhanced Architecture (MYSEA) Project is a research effort that is aimed at providing “a trusted distributed operating environment for enforcing multi-domain security policies, which supports unmodified COTS productivity applications.” [Irvine03] Clients are able to access data at varying levels of classification on a server that enforces a multi-domain security policy. However, when commodity operating systems are employed on the clients, there is no assurance that the data is not leaked to lower classifications. To counter this problem, MYSEA, among other controls, requires the use of diskless clients.

The near-term method of providing diskless clients is to use Windows XP Professional Embedded on some clients and a Linux-based diskless implementation known as Knoppix. This paper describes how a standard Knoppix distribution was modified to support the needs of MYSEA. The steps provided in the sections that follow assume some familiarity with Unix.

2. Procedures for Re-Mastering Knoppix

This section describes how to create a new configuration of a Knoppix CD from an existing Knoppix CD. This is necessary for the MYSEA project because some specific configurations, especially network settings, need to be changed from those that come standard on a Knoppix CD. Due to factors that are probably based on the drive geometry or sector layout of the disk that was used to create the official Knoppix distribution ISO image, it may not be possible to simply re-master an image without deleting some small packages first.

2.1 Requirements

The PC specifications for the re-mastering are given below:

- 5 GB spare hard disk partition
- 1 GB RAM
- Floppy drive or available USB port (for importing files)
- A system with two CD/DVD drives where at least one is a CD burner.

It is possible to have just one CD/DVD drive that can burn CDs, but it requires the use of an additional hard disk partition, and the use of the “tohd” and “fromhd” cheat codes, or the “bootfrom” cheat code [Hacks05]. Cheat codes are additional information that can be given at the Knoppix boot prompt. The Knoppix web site has a list of cheat codes that can be used, as does the Knoppix CD at “KNOPPIX/knoppix-cheatcodes.txt”.

In addition, the following software is required

- Knoppix 3.6 bootable CD
- Knoppxi 3.9 bootable CD

---

1 If the system has less than 1 GB of RAM, then an additional 750 MB Linux swap partition is required.
ISO images for a bootable CD can be found on the Knoppix web site [Knoppix], which can then be burned onto a CD-R using standard CD writing software.

2.2 Boot Knoppix

The re-mastering starts by booting the Knoppix 3.9 CD.

When booting Knoppix on some systems the X-window server may have trouble getting started. To overcome this problem, cheat codes will have to be used. For example, the following can be used to specify a particular resolution and X-Server:

```
knoppix screen=1400x1050 xserver=XF86_SERVER
```

Other information, such as monitor refresh rates, can also be provided by using cheat codes.

Once booted, start a command-line window and “su” to root (which requires no password).

2.3 Generate a Kick List

The “kick list” is a list of packages that need to be deleted from a Knoppix distribution, which will be necessary if other packages need to be added, and may be needed anyway, even if no packages are added.

To help determine the packages that can be deleted, start a root window (K > Knoppix > Root Shell) and execute the following command to list all the installed packages, from the largest to the smallest:

```
dpkg-query -W --showformat='${Installed-Size} ${package}
' | sort -nr
```

In the output of the above command, the number to the left of each package is the amount of space the package is using on the disk. Selecting a package that other packages depend on will automatically include those dependent packages.

Create a file in the home directory named “kick.txt” containing the names of the packages to be deleted, one per line. This list will be used by a script to automate the removal process.

For the MYSEA re-mastered Knoppix CD, Appendix B lists the packages that are put into the kick list.

2.4 Generate MYSEA Configuration Files

If the target Knoppix CD shall be used to boot a thin client in the MYSEA environment, create the other configuration files in the home directory, as specified in Appendix B.
2.5 Create a new CD Image

This section describes how to install Knoppix onto a spare partition on a hard drive, in preparation for re-mastering a Knoppix CD. Perform the following steps:

1. Make sure there is a spare partition.

   See the requirements listed earlier in the document. Partitions can be created and deleted by using the fdisk command from a Knoppix Root Shell. If there is only one IDE disk, the following will start an fdisk session:

   ```
   fdisk /dev/hda
   ```

   The fdisk command should be used with care, since existing partitions can easily be corrupted or lost through incorrect use of this command.

2. Import the knx shell script to the home directory.

   The knx shell script was written in support of the MYSEA project to simplify and quicken a process that may need to be repeated many times before the end result is satisfactory. The script is provided as Appendix A, along with an explanation of the command syntax and semantics. Be warned that a copy and paste of the script from this document to a Knoppix environment may lead to parts of the script being syntactically incorrect. Use of the “dos2unix” command may be required, as well as some manual editing to correct pasting errors.

3. Declare the partition where the Knoppix source shall be installed.

   Use the export command to define the “partition” shell variable with the specific partition defined earlier. **For example**, if /dev/hda1 is the intended target, the following command would be used:

   ```
   export partition=hda1
   ```

   Be careful to define the correct partition because it will be reformatted, causing a loss of existing data on that partition.

4. Perform the re-mastering process by using the knx script.

   The knx script has six options that are intended to be run in the following order:
   doformat
dosource
domaster
domysea (optional)
dokick
doiso
However, at the end of each option, the script will prompt whether the next option in the sequence should be performed, allowing the script to continue. Therefore, the following command will start the script with the first option, which is to prepare the target hard drive by partitioning the chosen partition:

```bash
knx doformat
```

As noted above, the “domysea” option is only necessary if the CD shall be used in the MYSEA environment. If this option is not needed, then the script must be exited at that point and restarted with the “dokick” option.

Pay attention to the output of the “dokick” option, because just before it actually deletes all the packages in the kick list, it displays all the packages that it will delete (including the packages that are dependent on the packages in the kick list). Make sure there are not any unintended package deletions before continuing. In addition, the “dokick” option will display the amount of space that will be freed up if it is performed; make sure this is enough before continuing.

If non-package files or software need to be installed, then they should be added after the “dokick” step and before the “doiso” step. Be aware that the `/home/knoppix` subdirectory is on a RAM disk, so copying files into that area on the target partition will not have the desired result. If a new subdirectory off of the home directory is desired, then it needs to be copied to `/etc/skel` on the target partition, and the `/etc/X11/Xsession.d/45xsession` file needs to be modified on the target partition to do the copying to the RAM disk during bootup. This can be done at an appropriate spot after the “Copy profiles if not already present” comment in the 45xsession file.

At the end of the “doiso” step, the size of the ISO file is displayed. Make sure it is less than size of the CD-R to be used. For 650MB CD-Rs, the maximum capacity is about 735 MB, and for 700MB CD-Rs, the maximum capacity is about 795 MB. If the image is too big, additional packages need to be added to the kick list, and the last two steps (dokick and doiso) need to be repeated.

5. **Burn the ISO image to a CD.**

It was found that even if the system has an available CD burner (other than the one the source Knoppix CD was booted on), the knoppix 3.9 configuration may not have enough free memory to allow the burning to take place. For systems with two CD drives, it is possible to boot Knoppix 3.6 to complete the burning process. If, however, the only CD burner was used to boot the source Knoppix CD, then the system must be rebooted from the target hard drive partition to free the CD drive.

---

2 The 650 and 700 MB designations refer to the capacity of a pressed audio CD. Due to the nature of how data is recorded on CD-Rs, they can hold more than the advertised capacity.
If the target partition needs to be booted, then reboot the source Knoppix CD. Then, at the knoppix boot prompt, enter the following cheat code to boot from the target hard drive partition (assuming /dev/hda1 is the target):

```
knoppix bootfrom=/dev/hda1/knx/knoppix.iso
```

After the system is booted from the hard drive, the boot CD can be removed.

The path to the ISO image is one of the following:
- From the booted CD: `/mnt/hda1/knx/knoppix.iso`
- From the booted target partition: `/knx/knoppix.iso`

The following CD burning software can be used:

```
K > Multimedia > K3b
```

Using the above software, the following menu option can be used to burn a CD from the ISO image:

```
Tools > CD > Burn CD Image
```

3. Future Work

Future work will include a migration to Knoppix version 4, which can boot from a DVD, thus removing storage barriers for desired software. In addition, an effort to improve the boot performance would be beneficial.

4. References

Hacks05  *Knoppix Hacks*, Kyle Rankin, O’Reilly, 2005.


Appendices

A Knx Shell Script

A.1 Knx Explained

The KNX Shell Script was written to simplify the steps to re-master a Knoppix CD. The syntax of the script is:

```
knx  {doformat | dosource | domaster | docustom | doiso | doburn }
```

It expects the “partition” shell variable to be assigned the target partition (e.g., “hda1”). The actions normally taken were divided up into steps that may need to be done as a group. The command options are explained below:

- **doformat** Prepares the target hard disk partition by formatting it, and preparing it for the Knoppix source. When it is done, it prompts the user whether to continue to the next step (dosource).
- **dosource** Copies the Knoppix source from the booted CD, as well as any “kick list” (kick.txt), to the target partition.
- **domaster** Copies the boot files from the CD to the target partition.
- **domysea** Performs configuration changes that are specific to the MYSEA network, and the needs of a thin client in that environment.
- **dokick** Re-masters the target partition by deleting all packages specified in the kick list (if provided).
- **doiso** Goes through the steps necessary to create a bootable ISO image from the target hard disk partition. The final “knoppix.iso” image is stored in TBD.

A.2 The Knx Script

```bash
#!/bin/bash

# functions
#
part=${partition}
ksource=/mnt/${part}/knx/source/KNOPPIX
kmaster=/mnt/${part}/knx/master/KNOPPIX

format_disk() {
  [ ! -b /dev/${part} ] && { echo "No partition"; exit 1; }
}
```

[ -d /mnt/$(part)/knx ] && umount /mnt/$(part)
mke2fs /dev/$(part)
mount -rw /dev/$(part) /mnt/$(part)
mkdir /mnt/$(part)/knx
mkdir -p $(ksource)
mkdir -p $(kmaster)
l -lR /mnt/$(part)
}


copy_source() {
    [ ! -d $(ksource) ] && { echo "No source directory"; exit 1; }
echo "Copying knoppix source..."
    cp -Rp /KNOPPIX/* $(ksource)
du -s $(ksource)
}

copy_master() {
    [ ! -d $(kmaster) ] && { echo "No master directory"; exit 1; }
echo "Copying knoppix master..."
    rsync -a --exclude "/KNOPPIX/KNOPPIX" \
              /cdrom/ /mnt/$(part)/knx/master/
du -s /mnt/$(part)/knx/master
}

mysea_config() {
    [ ! -d /mnt/$(part)/knx ] && mount -rw /dev/$(part) /mnt/$(part)
    [ ! -f $(ksource)/etc/dhcpc/resolv.conf ] && \
        { echo "No source"; exit 1; }
    cd $(HOME)

    # Make sure all the files we need are here before we do anything.
    if [ ! -e hosts ]; then
        echo "No hosts file exists in the home directory.";
        exit 1;
    fi
    if [ ! -d .mozilla/firefox/3d4ef4xp.default ]; then
        echo "No Firefox configuration directory exists.";
        exit 1;
    fi
    if [ ! -d .mozilla-thunderbird ]; then
        echo "No Thunderbird configuration directory exists.";
        exit 1;
    fi
    if [ ! -e 45xsession ]; then
        echo "No 45xsession file exists in the home directory.";
        exit 1;
    fi
    if [ ! -e knoppix-autoconfig ]; then
        echo "No knoppix-autoconfig file exists in the home directory.";
        exit 1;
    fi
    if [ ! -e perftests ]; then
        echo "No performance test software exists.";
        exit 1;
    fi
}
# Now try to copy everything into the right place on the hard drive.
echo "Cleaning up."
rm -rf ${ksource}/etc/skel/.mozilla-thunderbird/
rm -rf ${ksource}/etc/skel/perftests/

echo "Copying files."
cp hosts ${ksource}/etc/
cp 45xsession ${ksource}/etc/X11/Xsession.d/
cp knoppix-autoconfig ${ksource}/etc/init.d/
cp .kde/share/config/kickerrc
${ksource}/etc/skel/.kde/share/config/
cp .mozilla/firefox/3d4ef4xp.default/bookmarks.html \
   ${ksource}/etc/skel/.mozilla/firefox/3d4ef4xp.default/
cp .mozilla/firefox/3d4ef4xp.default/prefs.js \
   ${ksource}/etc/skel/.mozilla/firefox/3d4ef4xp.default/
cp -R .mozilla-thunderbird ${ksource}/etc/skel/
cp -R perftests ${ksource}/etc/skel/

echo "Changing permissions"
find ${ksource}/etc/skel/.mozilla-thunderbird -type d \
   -exec chmod go+rx {} \;
find ${ksource}/etc/skel/.mozilla-thunderbird -type f \
   -exec chmod go+r {} \;

echo "Done."
}

remove_pkgs() {
    [ ! -e kick.txt ] && { echo "No kick.txt file exists"; exit 1; }

echo "Copying kick file"
rm -f ${ksource}/opt/kick.txt
cp kick.txt ${ksource}/opt
cp .bash_history
find ${ksource}/etc/skel/.mozilla-thunderbird -type d \
   -exec chmod go+rx {} \;
find ${ksource}/etc/skel/.mozilla-thunderbird -type f \
   -exec chmod go+r {} \;

echo "Creating slim file"
echo "mount /proc proc proc" > ${ksource}/opt/slim
echo "apt-get --purge remove \`cat /opt/kick.txt\`` >>
$(ksource)/opt/slim
echo "apt-get clean" >> $(ksource)/opt/slim
echo "umount /proc" >> $(ksource)/opt/slim
chmod 700 $(ksource)/opt/slim

echo "Removing packages"
chroot $(ksource) /opt/slim
}

create_iso() {
    [ ! -d ${kmaster} ] && { echo "No master directory"; exit 1; }

echo "Creating ISO cloop filesystem..." 
rm -f .bash_history
cd /mnt/${part}/knx
rm -rf source/KNOPPIX/.rr_moved
mkisofs -R -U -V "KNOPPIX filesystem" -P "KNOPPIX remaster" \
   -hide-rr-moved -cache-inodes -no-bak \
-pad source/KNOPPIX \
| nice -5 /usr/bin/create_compressed_fs - 65536 \
> master/KNOPPIX/KNOPPIX

```
echo "Updating md5 checksum..."
cd /mnt/${part}/knx/master
rm -f KNOPPIX/md5sums
find -type f -not -name md5sums -not -name boot.cat
 -not -name iso;inux.bin -exec md5sum {} \; \
>> KNOPPIX/md5sums
```

echo "Creating final iso image..."
cd ..
```
mkisofs -pad -l -r -J -v "KNOPPIX" -no-emul-boot \
 -boot-load-size 4 -boot-info-table \
 -b boot/isolinux/isolinux.bin \
 -c boot/isolinux/boot.cat \
 -hide-rr-moved -o knoppix.iso master/
ls -l knoppix.iso
```
B The MYSEA Configuration Changes

It would be wise to create the files specified in this appendix once and put them onto removable media so they can be quickly reused, instead of recreating them every time the Knoppix CD is rebooted. Creating a re-mastered disk may take several tries before it behaves as desired.

B.1 Kick List (kick.txt)

A file named “kick.txt” must exist in the home directory with the following contents:

- nessus
- nessusd
- nessus-plugins
- startnessus-knoppix
- ethtool
- ethtool-common
- mysql-server
- mysql-common
- gcc
- gdb
- g++
- g++-3.3
- gcj-3.3
- apache
- apache2-utils
- apache-common
- apache-utils
- cvs
- nmap
- netcat
- netcat6

B.2 Hosts File

A file named “hosts” must exist in the home directory with the following contents:

```
127.0.0.1     knoppix     localhost
192.168.0.130 mlsserver.cisrlabmlstestbed1.com mlsserver
192.168.100.1 ntara.cisrlabmlstestbed2.com ntara
192.168.101.1 stara.cisrlabmlstestbed3.com stara
192.168.102.1 ctara.cisrlabmlstestbed4.com ctara
```
B.3 Autoconfig (knoppix-autoconfig)

Perform the following steps to modify the existing knoppix-autoconfig file:
1. Copy “/etc/init.d/knoppix-autoconfig” to the home directory.
2. Open the file in the home directory for editing.
3. Just below the following line:
   
   \[CMDLINE="$(cat /proc/cmdline)"
   \]

   add the following line:

   \[CMDLINE="$CMDLINE nodhcp"
   \]

4. Below the line that starts with the following:
   
   \[echo " ${BLUE}Skipping DHCP broadcast..."
   \]

   add the following lines:
   
   \[ifconfig eth0 192.168.3.11 netmask 255.255.255.0 \ 
      broadcast 192.168.3.255 up \ 
      route add default gw 192.168.3.1
   \]

5. Save the changes and exit the editor.

B.4 Browser Configuration changes

1. From the toolbar (not a root command-line window), start “firefox”.
2. Edit > Preferences
3. Select “General” from the left-hand pane.
   Select: Use Blank Page
   Select “Connection Settings”
   Select: “Manual Proxy Configuration”
   Check: Use the same proxy for all protocols
   HTTP Proxy: mlsserver.cisrlabmlstestbed1.com
   Port: 80
   No Proxy for: localhost, 127.0.0.1, mlsserver.cisrlabmlstestbed1.com
   OK
4. Select “Privacy” from the left-hand pane.
   Select “History”
   Remember: 0 days
   Select “Cache”
   Use up to: 0 KB
   OK
5. Bookmarks > Manage Bookmarks
   File > New Folder
   Name: Demo Links
   OK
   Select “Demo Links” folder
   File > New Bookmark
   Name: “MLS Server”
   Location: http://mlsserver.cisrlabmlstestbed1.com
   OK
   File > New Bookmark
   Name: ntara
   Location: https://ntara.cisrlabmlstestbed2.com/tarantella/
OK
File > New Bookmark
   Name: stara
   Location: https://stara.cisrlabmltestbed3.com/tarantella/
   OK
File > New Bookmark
   Name: ctara
   Location: https://ctara.cisrlabmltestbed4.com/tarantella/
   OK
File > New Bookmark
   Name: Coalition
   Location: http://mlsserver.cisrlabmltestbed1.com/coalition/
   OK

Make sure all added bookmarks are in the Demo Links folder in the following order:
   MLS Server
   ntara
   stara
   ctara
   Coalition

File > Close
6. Exit the browser

B.5 Email Settings

1. Select **K > Internet > Thunderbird Mail Client**.
2. Don’t import anything.
3. New Account Setup:
   Email account
4. Identity:
   Your Name: Demo 2
   Email Address: mdemo2@mlsserver.cisrlabmltestbed1.com
5. Server Information
   IMAP
   Incoming Server: mlsserver.cisrlabmltestbed1.com
   Outgoing Server: mlsserver.cisrlabmltestbed1.com
6. User Names
   Incoming User Name: mdemo2
7. Account Name
   Demo 2
8. Edit > Account Settings
   Server Settings (left pane)
   **Uncheck**: Check for new messages at startup
   **Uncheck**: Check for new messages every XX minutes
   When I delete a message: Remove it immediately
   **Check**: Clean up (“Expunge”) Inbox on Exit
   **Check**: Empty Trash on Exit
B.6 Application Startup

1. Copy the “/etc/X11/Xsession.d/45xsession” file to the home directory.
2. Open the file in the home directory for editing.
3. Replace the following line:
   ```bash
   Exec=konqueror --geometry 850x600+85+70 file:$INDEXFILE
   With this line:
   Exec=firefox --geometry 850x600+85+70
   ```
4. Below the if/then block that starts with the following:
   ```bash
   if [ ! -e $HOME/.mozilla -a "$FREESPACE" -gt 1500 ]
   ```
   Add the following if/then blocks:
   ```bash
   if [ ! -e $HOME/.mozilla-thunderbird -a "$FREESPACE" -gt 1800 ] && [ -d /etc/skel/.mozilla-thunderbird ]; then
   rsync -Ha --ignore-existing /etc/skel/.mozilla-thunderbird $HOME/ 2>/dev/null
   find $HOME/.mozilla-thunderbird -type f -exec chmod go-r {} 
   \;
   find $HOME/.mozilla-thunderbird -depth -type d -exec chmod go-rx {} \;
   else
   echo "Unable to configure Thunderbird."
   fi
   if [ ! -e $HOME/perftests -a "$FREESPACE" -gt 25000 ] && [ -d /etc/skel/perftests ]; then
   rsync -Ha --ignore-existing /etc/skel/perftests $HOME/ 2>/dev/null
   else
   echo "Unable to install performance tests."
   fi
   5. Save the file.

B.7 Toolbar Configuration

1. Right-click unused part of the toolbar panel.
2. Remove From Panel > Application Button > Home
   Remove From Panel > Application Button > Knoppix
   Remove From Panel > Application Button > Knoqueror
   Remove From Panel > Application Button > Open Office
3. Remove From Panel > Special Button > Desktop Access  
   Remove From Panel > Special Button > Window List  
4. Add to Panel > Application > Internet > Thunderbird Mail Client  
5. If necessary, move the toolbar icons so that the Firefox and Thunderbird icons are next to each other.
INITIAL DISTRIBUTION LIST

1. Dudley Knox Library, Code 013
   Naval Postgraduate School
   Monterey, CA 93943-5100

2. Research Office, Code 09
   Naval Postgraduate School
   Monterey, CA 93943-5138

3. Paul C. Clark
   Computer Science Department
   Naval Postgraduate School
   Monterey, CA 93943

4. Cynthia E. Irvine
   Computer Science Department
   Naval Postgraduate School
   Monterey, CA 93943

5. Jean Khosalim
   Computer Science Department
   Naval Postgraduate School
   Monterey, CA 93943