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Abstract 
 
Numerous features have been added to both the IFSAS and Trident codes. Both codes 
were integrated into a single solver for 3D fluid-structure interaction simulations. A 
multiple material model using a mixed-cell approach was implemented in the IFSAS 
code, and validated against experimental data. Adaptive grid schemes for underwater 
shock and bubble analysis, hydrostatic pressure and airwater/seafloor boundaries, 
underwater explosion profiles, and fluid-backed shapes were also implemented. 
 
The improvements made to the Trident program include upgrading the translators 
between Trident and USA/CFA Version 5, automating the clipping of the fluid 
element meshes at the waterline, creating a link to the IFSAS code in the UNDEX 
shell program, and an extension of capabilities for analysing the response of 
equipment mounts to UNDEX loading. 

 

Résumé 
 
De noumbreuses caractéristiques ont été ajoutées aux codes IFSAS et Trident. Ces 
deux codes ont été intégrés à un résolveur de simulations tridimensionnelles de 
l’interaction fluide-structure. Un modèle à plusieurs matériaux utilisant une approche 
à cellules mixtes a été inséré dans le code IFSAS et validé au moyen de données 
expérimentales. Des schémas de grilles adaptatifs sur l’analyse des chocs sous-marins 
et des bulles sous-marines, la pression hydrostatique et les limites de la surface et du 
fond marin, les profils d’explosions sous-marines et les formes à support liquide ont 
aussi été mis en oeuvre. 

Les améliorations apportées au programme Trident comprennent le perfectionnement 
des traducteurs entre le code Trident et l’USA/CFA Version 5, l’automatisation du 
découpage des maillages d’éléments fluides à la ligne de flottaison, la création d’un 
lien avec le code IFSAS dans l’utilitaire de développement UNDEX et l’amélioration 
des capacités d’analyse de la réaction des supports de matériel aux charges produites 
par les UNDEX. 
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Executive summary 
 

Introduction 

For several years DRDC Atlantic and DRDC Suffield have been supporting the 
development of an in-house underwater explosion (UNDEX) analysis capability. In 
the past this work has been performed in conjunction with the UNDEX experimental 
program at DRDC Suffield. More recently, application of these tools to Naval Force 
Protection studies has become a priority. 

 

Principal Results 

Several improvements have been made to the IFSAS analysis code that better allow it 
to perform three-dimensional UNDEX simulations of naval platforms. This includes 
simulating the response of a platform to a shock wave produced by an underwater 
explosion; as well as simulating the behaviour of the gas bubble produced by an 
underwater explosion and its effect on a platform.  

Significance of Results 

The improvements to the IFSAS code allow better simulation of close-range, shallow-
water underwater explosions and their effects on naval platforms. These types of 
simulations are important for determining the vulnerability of a naval asset in a Force 
Protection scenario.  

 

Future Plans 

Further development of the IFSAS code (now called Chinook) is being performed by 
Martec Limited, with support from the Atlantic Innovation Fund. Force Protection 
studies being performed at DRDC Atlantic in 2004 and 2005 will use of the IFSAS 
and Trident codes extensively. 

 

 

 

Donahue, L. (2004). Extension and Validation of UNDEX Analysis Tools. DRDC 
Atlantic CR 2004-269. Defence R&D Canada – Atlantic. 
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Sommaire 
 

Introduction 

Depuis plusieurs années, RDDC Atlantique et RDDC Suffield contribuent à 
l’élaboration d’outils d’analyse internes des explosions sous-marines (UNDEX). Par 
le passé, les travaux ont été effectués conjointement avec le programme expérimental 
UNDEX à RDDC Suffield. Plus récemment, la priorité a été donnée à la mise en 
application de ces outils dans le cadre d’études sur la protection des Forces navales. 

 

Principaux résultats 

Plusieurs améliorations ont été apportées au code d’analyse IFSAS pour qu’il puisse 
effectuer plus facilement les simulations tridimensionnelles UNDEX des plates-
formes navales, y compris la simulation de la réaction d’une plate-forme à une onde 
de choc produite par une explosion sous-marine ainsi que la simulation du 
comportement de la bulle produite par une explosion sous-marine et de ses effets sur 
une plate-forme. 

Portée des résultats 

Les améliorations apportées au code IFSAS permettent de mieux simuler les 
explosions sous-marines en eaux peu profondes de courte portée et leurs effets sur les 
plates-formes navales. Ces simulations sont importantes pour déterminer la 
vulnérabilité des ressources navales dans les scénarios de protection de la Force. 

 

Recherches futures 

Martec Limited, avec l’appui du Fonds d’innovation de l’Atlantique, travaille à 
l’amélioration du code IFSAS (maintenant appelé Chinook). Les études sur la 
protection de la Force menées à RDDC Atlantique en 2004, et qui se poursuivront en 
2005, font largement appel aux codes IFSAS et Trident. 

 

 

Donahue, L. (2004). Amélioration et validation des outils d’analyse UNDEX. RDDC 
Atlantique CR 2004-269. R & D pour la défense Canada – Atlantique. 
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EXECUTIVE SUMMARY 
 
 
Numerous features have been added to both the IFSAS and Trident codes. Both codes were integrated 
into a single solver for 3D fluid-structure interaction simulations. A multiple material model using a 
mixed-cell approach was implemented in the IFSAS code, and validated against experimental data. 
Adaptive grid schemes for underwater shock and bubble analysis, hydrostatic pressure and air-
water/seafloor boundaries, underwater explosion profiles, and fluid-backed shapes were also 
implemented. 
  
The improvements made to the Trident program include upgrading the translators between Trident and 
USA/CFA Version 5, automating the clipping of the fluid element meshes at the waterline, creating a 
link to the IFSAS code in the UNDEX shell program, and an extension of capabilities for analysing the 
response of equipment mounts to UNDEX loading. 
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1.0 INTRODUCTION 

Through initial contracts with Combustion Dynamics Ltd. (CDL) and Martec Ltd., DRDC initiated the 
development of underwater explosion (UNDEX) modelling capabilities [1-6]. Under follow-on joint 
contracts with Martec Limited and CDL, additional capabilities of the IFSAS/Trident system were 
introduced which involved modelling of general 3D hull shell structures with both air- and water-
backed conditions; accounting for 3D structural buoyancy; implementing 3D hull whipping response 
capability in Trident; and modifying the CFD grid formation to allow an adaptive grid scheme (AGS) 
[1,2,7]. Currently, the 2D CFD code can model both shock decay and the bubble motion. The latter can 
produce strong and damaging jets during bubble collapse. 
 
In recent years the IFSAS code has undergone redevelopment to enable the modelling of more complex 
geometries, new pre- and post-processing environments, and user-defined computational models. 
Additional work is needed to complete the redevelopment for near-field UNDEX problems. For far-
field UNDEX problems, Martec Limited has recently developed an UNDEX shell program which 
contains empirically-based and equivalent-beam methods, as well as a modelling interface to 
USA/CFA.  
 
Under the current contract, numerous features have been added to both the IFSAS and Trident codes. 
Both codes were integrated into a single solver for 3D fluid-structure interaction simulations. A 
multiple material model using a mixed-cell approach was implemented in the IFSAS code, and 
validated against experimental data. Adaptive grid schemes for underwater shock and bubble analysis, 
hydrostatic pressure and air-water/seafloor boundaries, underwater explosion profiles, and fluid-backed 
shapes were also implemented. 
 
The improvements made to the Trident program include upgrading the translators between Trident and 
USA/CFA Version 5, automating the clipping of the fluid element meshes at the waterline, creating a 
link to the IFSAS code in the UNDEX shell program, and an extension of capabilities for analysing the 
response of equipment mounts to UNDEX loading. 
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2.0 INTEGRATION OF TRIDENT AND IFSAS 

Martec's Trident implicit finite element code has been integrated with the IFSAS II CFD code into a 
single solver in order to perform underwater explosion analyses involving fluid-structure interactions. 
The IFSAS solver is used to calculate the blast loads due to an underwater explosion, while the Trident 
solver calculates the structural response due to the blast. 
 
These two previously independent programs were compiled and linked together as a single executable. 
This involved some code alterations as the Trident solver is written in the FORTRAN programming 
language while IFSAS is written in C. To link the two programs, a single function was created to 
communicate between the modules. 
 
One difficulty which was encountered during development regarded units. The CPF model had length 
units of millimetres, while IFSAS required input in metres. This problem was solved by creating a file 
(units.tab) which contains the length and pressure conversion factors required to convert the structural 
model into IFSAS units. This file gets called once, during initialization, as illustrated in Figure 1. A  
neutral geometry file (NGF) of the structure geometry is created by Trident. The IFSAS module is 
called and the units.tab file containing the length and pressure conversions is read. The NGF file is 
converted into IFSAS units, and any spaces in nodal numbering are replaced by dummy nodes which 
are not included in the connectivity matrix. These nodes are necessary because IFSAS requires nodes to 
be numbered consecutively. 
 

 

Figure 1: Communication Between Trident and IFSAS Modules During Simulation Initialization 

 
With the new integrated solver, Trident is responsible for invoking and transferring the nodal velocities 
to the IFSAS module. IFSAS incorporates these velocities into its analysis, and calculates the resulting 
fluid field. IFSAS then transfers the pressures acting on the structural elements to the Trident module. 
This cycle is repeated every time interval, as specified by the user. The complete cycle is illustrated in 
Figure 2. 
 
The fluid-structure coupling capability was tested for 3D problems, however no significant amount of 
work or testing was performed with 2D analyses. 
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Figure 2: Communication Between Trident and IFSAS Modules During Simulation 
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3.0 UNDEX ANALYSIS CAPABILITIES FOR IFSAS-II 

A number of capabilities have been added to the IFSAS II CFD code to enable underwater shock and 
bubble modelling. A near-field multiple material model was developed for simulating multi-phase 
flows which uses a mixed cell approach. This model is used in combination with adaptive grid schemes 
(AGS), hydrostatic pressure, and air-water and seafloor interfaces. Underwater profiles were created to 
speed up computation times. 

3.1 NEAR-FIELD MULTIPLE MATERIAL MODEL 

In order to provide an accurate numerical simulation of the bubble jet problem, the following must be 
considered: 
 

1) CFD solver 
2) Equations of state 
3) Detonation products – water interface 

 
These topics are discussed in the following sections, which were taken from the 2002 SAVIAC paper 
written on the subject (Appendix A). 

3.1.1 Solver 

An inviscid CFD solver is adopted, using the flux corrected transport (FCT) algorithm adopted by 
Boris [8]. The 2D axisymmetric equations of mass and momentum (Equations 1 and 2) are solved to 
obtain material densities, ρ, pressures, p, and radial and horizontal velocities, u and v , respectively: 
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∂

+
∂

∂
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In this formulation, internal energy is not considered, because the material pressure is assumed to be a 
function of density only. 
 

3.1.2 Equations of State 

The gas bubble is assumed to consist of air, and expand isentopically according to Equation 3: 
γ

ρ
ρ

⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
=

0
0pp         (3) 

 
where  

0p  = 1 atm 

0ρ  = 1.18 kg/m3
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γ = specific heat ratio = 1.4 
 
A modified Tait equation of state is adopted to model the water: 
 

 0
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ρ
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≤
ρ
ρ

     (5) 

 
where 

B = 3000 atm 
0ρ  = 1000 kg/ m3

n = 7.15 
m = 21494.0 

 
The exponent, m, is selected so that the slopes of the pressure vs. density curves are equal at 
atmospheric pressure. 
 

3.1.3 Detonation Products - Water Interface 

Since the bubble jet problem is modeled using discrete computational cells, each cell can have more 
than one material residing inside of it. Numerous approaches have been proposed to simulate multi-
material problems, including level set methods [9], and mixed cell methods [10]. A mixed cell method 
assuming equal pressure in all cell constituent materials is adopted here. A mixed density, ρmix, is used 
that is a weighted average of the material volume fractions, φi: 
 

        (6) wwggmix φρφρρ +=

 
The subscripts g, w are gas and water constituents, respectively. Conservation of volume dictates that: 
 
          (7) 1=+ wg φφ

 
To obtain the volume fractions, and to maintain a conservative form of the equations, mass fraction 
tracers, T, are used, defined such that: 
 
          (8) gggmixT φρρ =

 
  wwwmixT φρρ =         (9) 
 
and conservation of mass (Equations 6, 8, and 9) dictates that: 
 
          (10) 1=+ wg TT
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Two extra equations are added to Equations 1 and 2 in order to determine the volume fractions: 
 

( ) ( )
0=

∂
∂

+
∂

∂
x
T

u
t
T ii ρρ

       (11) 

 
One equation is written each for gas and water. 
 
It remains to determine the pressure in the mixed cell. The equilibrium pressure is determined by using 
n iterative process; the strategy employed here is as follows: a

 
1
 

) Solve Equations 1, 2, and 11 using FCT to obtain ρmix, Tg, and Tw. 

2) Obtain lower and upper brackets for pressure, pl and pu, respectively, shown in Figure 3. These 
are obtained by assuming a pressure on either side, computing the constituent densities from 
the equations of state (Equations 3, 4, and 5), computing volume fractions from Equations 8 
and 9, and computing the assumed mixed density from Equation 6. In this study, a bracket 
spacing of a factor of 10 was used between lower and upper pressures. 

 
3) Once bracketed, use false position iteration to solve for the desired level of accuracy on ρmix  

shown in Figure 3. This is done by linearly interpolating left and right pressures to obtain a 
pressure estimate, pr. From the pressure estimate, a similar procedure to Step 2 is employed to 
compute an estimate of ρmix. The bracket, whether left or right, is adjusted, and the iteration 
proceeds until the desired tolerance level is attained. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3: Iterative Method for Pressure Determination 
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3.2 ADAPTIVE GRID SCHEMES (AGS) FOR UNDERWATER SHOCK AND BUBBLE ANALYSIS 

Adaptive isotropic, Cartesian grid refinement capabilities implemented in the IFSAS II code facilitated 
the modelling of underwater shocks and bubbles. Specifically, dynamic cell refinement was used. 
Using dynamic cell refinement, the refined area adapts to a specific local gradient, and therefore shifts 
during the simulation. AGS allows for coarser grids to be used, as regions of interest, such as shocks, 
can still be captured with a higher level of accuracy. This being said, the use of AGS still results in an 
increase in the overall computation time as the calculation time step is dictated by the smallest cell size. 
 
Section 3.2.1 details how cells are refined, and Section 3.2.2 outlines the various available dynamic 
AGS criteria. Finally, a ship example using AGS is discussed in Section 3.2.3. 
 

3.2.1 Refinement Levels 

In IFSAS, the degree to which cells are refined is defined by the level of refinement entered by the user 
when specifying the AGS criteria. Figure 4 illustrates how cells are refined, using a 2D example. The 
largest cells are the root cells whose size is determined by the domain resolution. If an AGS with a 
maximum of level 0 refinement is specified, the root cells are not refined and there is no AGS 
refinement performed, even if an AGS criteria has been defined.  

 

 

Figure 4: AGS Refinement Levels 

 
With AGS Level 1, the root cells (or parent cells), are refined once. Accordingly, the smallest cells in a 
Level 1 refinement have twice the resolution of the domain. In Level 2 refinement the smallest cells 
have four times the resolution of the domain, and so forth. The number of refined cells (or children 
cells), nc, produced from the refinement of a single parent cell is dependent on the problem 

imensionality:   d
 
           (12) d

cn 2=
 
where d is 1, 2, or 3 for one-dimensional, two-dimensional, and three-dimensional problems, 
respectively. Cells are refined and coarsened based on criteria to limit the total number of cells. 
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3.2.2 Dynamic AGS Criteria 

The two primary criteria by which a grid can be dynamically refined are pressure gradient and density 
gradient. Following are descriptions of each.  
 
Pressure Gradient 
In pressure gradient-based refinement, cells are refined where there is a sufficiently large pressure 
gradient. The range of gradients for which cells are refined is specified by the user. This method is 
useful for capturing the pressure discontinuity across the normal shock of an expanding gas, shown in 
Figure 5 (left) for a basic shock tube [11]. Also, cells around solid surfaces are refined when this 
criteria is defined. 
Density Gradient 
Density gradient refinement is very similar to pressure gradient refinement, however more shockwave 
information is captured. While there is a density discontinuity across the normal shock as in the 
pressure case, there is also a discontinuity at the contact surface [11], shown in Figure 5 (right). Also, 
cells around solid surfaces are refined when this criteria is defined. 
 

                  

Figure 5: (left) Pressure Profile and (right) Density Profile for Shock Tube 

 

3.2.3 3D Ship Example 

A 3D AGS simulation was performed to test the capability. A TNT charge was detonated beneath a 
ship hull with the wetted surface illustrated in Figure 6. This geometry was imported into a 3D IFSAS 
simulation, and pressure gradient-based AGS was activated. Note that in this case a 3D FSI simulation 
was not performed; this simulation was executed using IFSAS II alone. 
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Figure 6: TNT Explosion Beneath Ship Hull with 3D AGS (X-Z Scales are not Proportional) 

 
Figure 7 shows the results of the simulation for a cross-section along the width of the ship. The mesh at 
time = 0 ms is shown in Figure 7(a); here the refinement around the ship and the charge is clearly 
visible. As the explosion products expand (Figure 7 (b) to (d)), so too does the region of refinement. 
 

 

Figure 7: TNT Explosion Beneath Ship Hull with 3D AGS 
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3.3 HYDROSTATIC PRESSURE 

Hydrostatic pressure was implemented in IFSAS for 2D and 3D calculations in order to simulate the 
effects of gravity on underwater explosions. Hydrostatic pressure allows the bubble surroundings at 
various depths of water to be simulated in greater detail. The hydrostatic effect was implemented as a 
source term on the vertical momentum equation equivalent to ρg, where g is the acceleration due to 
gravity. In addition, the initial hydrostatic pressure field is specified at the cell centres containing water, 
according to: 
 

ghP ρ=         (13) 
 
Figure 8 shows a representative calculation domain which has been initialized with hydrostatic 
pressure, which appears as horizontal lines of constant pressure.  

 

Figure 8: Initial Hydrostatic Pressure Field 

3.4 AIR-WATER INTERFACE EFFECTS 

An air-water interface was developed to model the interaction between a shockwave and the surface. 
This boundary condition predicts how a shock transmits through and reflects off of a free surface, 
without actually simulating the region of air above the surface of the water. The air-water interface is 
treated as a contact surface, which is solved using a Reimann solver.  
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A 1D test case was performed to verify the correct boundary behaviour. In this test case, a 10,000 atm 
Hugoniot shock in the water travels towards the air-water interface (located on the right-hand side of 
the domain). The left-hand boundary is an inflow with the Hugoniot condition (433 m/s). Figure 9 (left) 
shows the incident normal shock before collision with the free surface boundary. The wave 
transmission solution results in a reflected rarefaction wave in the water, as shown in Figure 9 (right). 
The transmitted normal shock into the air has been neglected. The reflected state behind the rarefaction 
is p = 1.244 MPa, ρ = 1000.524 kg/m3, and U = 853.8 m/s. 
 
 
 
 

 

Incident 
Shock 

Figure 9: 1D Solution for Reflection from a Free Surface (left) Inci
Expansion Wave 

3.5 SEAFLOOR INTERFACE EFFECTS 

A seafloor interface was developed to model the interaction between a s
seafloor interface is treated as a contact surface, which is solved usin
state is modelled as an elastic material with the properties of sand. 
 
In this test case, a 10,000 atm Hugoniot shock in the water travels 
(located on the right-hand side of the domain). The left-hand boundary 
condition (433 m/s). Figure 10 (left) shows the incident normal sh
seafloor. The Hugoniot shock reflects from the interface as a norm
ρ = 1321 kg/m3, and U = 203.5 m/s. 
 
 
 

 
 
  
Reflected 
Expansion 
Wave
 

dent Shock (right) Reflected 

hockwave and the seabed. The 
g a Reimann solver. The solid 

towards the seafloor interface 
is an inflow with the Hugoniot 
ock before collision with the  
al shock with p = 1.925 GPa, 
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Figure 10: 1D Solution for Reflection from Seafloor (left) Incident Shock (right) Reflected 
Normal Shock 

3.6 UNDERWATER EXPLOSION PROFILES 

TNT profiles were implemented into the IFSAS code to improve the ease with which explosives can be 
modelled in multiple dimensions. They allow a wide range of explosives to be simulated without 
performing the calculations required for a balloon model each time the charge size or material is 
changed. Profiles are also useful in 3D problems when small increases in resolution come at the 
expense of long calculation times. Profiles give a high-resolution starting point for blast calculations 
which dramatically cuts down on the calculation time. 
 
There are over 150 profile files available to IFSAS. These profile files were created from high 
resolution, one-dimensional calculations which used the balloon analogue model to simulate a 1 kg 
TNT charge. The density, pressure, and velocity profiles at varying shock wave positions along the 
domain were saved into individual files. This 1D profile data can then be mapped onto 2D circles and 
3D spheres for multiple-dimensional calculations. 
 
Scaling factors allow the 1 kg TNT profiles to be used for other explosives and charge sizes. The 
profiles are scaled for other explosives using the appropriate TNT equivalency factor. Table 1 gives 

NT equivalency values for some other common explosives.  T
 

Table 1: TNT Equivalencies for Various Explosives [12] 

Explosive Pressure 
Equivalence 

Impulse 
Equivalence 

Composition C4 1.37 1.19 
Composition B 1.11 0.98 
HBX-1 1.17 1.16 
RDX 1.14 1.09 
Pentolite 1.42 1.00 
Tritonal 1.07 0.96 

Reflected 
Normal 
Shock

Incident 
Shock 
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When load duration, ∆t, is low in comparison with the structure's natural period, T, the pressure 
impulse controls the structural response more than the shape of the pressure-time curve. Conversely, 
when ∆t/T is relatively large, the curve shape maters, and it is important to know the pressure 
magnitudes. In this case the pressure equivalence values should be used. 
 
The published TNT equivalency values should be used with caution. While it may be appropriate to use 
these values for low-level calculations, or in the case that no experimental data is available, the 
equivalency values may need to be modified slightly to account for a particular set of initial conditions. 
If possible, preliminary calculations should be performed and compared with experiment to determine 
an appropriate equivalency value. 
 
For different explosive radii, R, and charge masses, mcharge, IFSAS selects the profile corresponding to : 
 

  
3/1

charge
1kg

m
RR =        (14) 

 
where R1kg is the equivalent profile for 1kg TNT. Scaling in this manner has the effect of stretching or 
compressing the 1 kg TNT profile, depending on whether the charge size is larger or smaller. By 
investigating the pressure-time trace for a point in the domain, the scaling in Equation (14) is evident. 
The pressure-time traces are effectively scaled by: 
 
         (15) 3/1

charge1kg mtt  =
 
where tlkg is the timescale of the 1kg TNT profile, and t is the equivalent timescale for charge mass 
mcharge. With this change in the timescale, the impulse applied to a point is altered to account for the 
new charge size.  

3.7 FLUID–BACKED SHAPES 

Two simulations were created to test the ability of IFSAS II and Trident to model fluid-backed shapes. 
Figure 11 shows a schematic of the test cases. Two plates are moved at a constant velocity through the 
fluid domain. In the first case there is air between the plates, representing an empty hull compartment; 
in the second case there is water between the plates, representing a hull component filled with fuel or 
other liquid.  
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Figure 11: Fluid-Backed Shape Test Cases (top) Air-Backed (bottom) Water-Backed 

 
Figure 12 shows the results of the air-backed case. As the plates travel through the fluid, the water 
pressure increases in front of the right plate. There is also a low pressure region trailing the left plate 
which is not evident in the figure. There is a negligible pressure increase between the plates due to the 
highly compressible nature of air. 
 
 
 
 

 

Figure 12: Simulation Results for Air-Backed Shapes 
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Figure 13 illustrates the results of the water-backed test case. In this case, the same pressure 
distribution is evident on the leading sides of both plates. As in the air-backed case, the low pressure 
region on the trailing edge is not apparent in the plots. 
 
 
 

 

Figure 13: Simulation Results for Water-Backed Shapes 
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4.0 VERIFICATION AND VALIDATION 

Some comparisons were made against experimental data in order to determine the effectiveness of the 
various implemented features. Bubble collapse and jetting phenomenon were simulated and compared 
with data from DRDC Suffield. Also, a verification exercise was performed to ensure that the IFSAS-
Trident units conversion was correct. 

4.1 BUBBLE COMPARISON WITH THEORETICAL 

To demonstrate the UNDEX analysis methods, two problems are analyzed here; a free field bubble 
pulse, and a bubble jet on a non-responding target. For both problems, the layout is similar; 1 kg of 
TNT at 1000 m depth is employed. For the free field bubble, one-quarter of the explosive was 
considered, due to symmetry conditions. An axisymmetric computational grid was used, with an 
expansion grid used at the uppermost and right sides of the grid.  The bubble energy was simulated by 
using a starting pressure in the gas bubble consistent with the ideal gas equation of state: 
 

1−
=

γ
VP

E       (16) 

 
where E is the total charge energy, P is the initial pressure, γ is the specific heat ratio of the bubble gas, 
and V is the gas bubble volume. 
 
Figure 14 is a plot of the water mass fraction tracer and velocity vectors for four times, blue being gas, 
and red is water; one bubble pulse is shown.  It can be seen that the pulse is consistent with observed 
experimental behaviour [13]. The bubble maximum radius and pulse time were calculated as 0.35 m 
and 7.0 ms, respectively. These compared well with similitude equations obtained from Keil [14] of 
0.34 m and 6.6 ms. 
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Figure 14: Mass Fraction and Vector Plot - Free-Field Bubble 

 
An axisymmetric grid with expansion grids similar to those used in the bubble pulse problem were used 
for the bubble jet. Figure 15 shows the results of the jetting bubble for four times. The bubble initially 
undergoes a rapid expansion to a maximum radius, and flattens near the target. Eventually, the low 
pressure region re-pressurizes, and causes the formation of a high velocity water jet. The jet impinges 
on the bubble, and forms a toroidal shape which dissipates with increasing time. This is consistent with 
observed experimental results [13]. 
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Figure 15: Mass Fraction and Vector Plot - Bubble Jet 

 
Figure 16 shows a plot of pressure vs. time at the center of the non-responding target. The results show 
that there is a large initial pressure from the shockwave that has a relatively small duration. This is 
followed by a long low-pressure phase and a high pressure-high impulse phase from the jetting bubble. 
The jetting pressure is significantly longer than that developed by the initial shockwave. 
 
The current simulations were performed without applying hydrostatic pressure. In these simulations, 
the hydrostatic pressure is huge compared with the gradient across the bubble as the simulated depth is 
on the order of 1000 m.  It is anticipated that in this case, the effect of hydrostatic pressure is 
negligible. The effect of hydrostatic pressure on the bubble shape will be investigated in future studies 
of bubbles in closer proximity with the free surface. 
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Bubble Jet Impulse

Figure 16: Pressure as a Function of Time for Bubble Jet Simulation 

4.2 METRES AND MILLIMETRES VERIFICATION 

One difficulty encountered during the current work was associated with model units. The CPF models 
in use have length units of millimetres, however IFSAS requires information in metres. Therefore, units 
must be converted during initialization and coupling. This is discussed in Section 2.0. 
 
The units conversion method was verified by performing a simple test. Figure 17 illustrates the 
simulation configuration. A 1 kg TNT charge is placed below a steel plate submerged in water. The 
plate edges are fixed. The simulation was run twice. In the first case, the dimensions were specified in 
metres, and the conversion factors required by IFSAS for length and pressure were both 1.0. In the 
second case, the dimensions were specified in millimetres, and the conversion factors for length and 
pressure were 10-3 and 10-6, respectively. 
 
The absolute, resultant translation and rotation of selected nodes on the plate were monitored. The 
values extracted at 3 ms and 10 ms are shown in Table 1, with the plate deformation at these times, as 
well as the locations of the nodes being monitored, shown in Figure 18. As shown in the table, the 
translations are equivalent considering the length units in each case, and the rotations are equal as these 
are independent of model units.  
 
The translations and rotations at points 17 and 18 are not equal, although these points may appear at 
first to be symmetrical. Both the finite element and the CFD meshes were relatively coarse in this test. 
Figure 17 shows the plate mesh; note that the relatively coarse triangular mesh results in symmetry 
plane perpendicular to the page. This plane of symmetry is different from the plane along the other 
diagonal based on the element orientations. If the results at node 17, for example, were compared with 
the results for the node diagonally opposite, there would be much better agreement. Also, the charge 
shape, as detected on the CFD mesh, may not have been symmetrical with respect to the centre of the 
plate, again due to the coarse resolution. With higher CFD and finite element mesh resolutions, the 
solution at node 17 should approach that at node 18. 
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Figure 17: Simulation Configuration for Units Verification 

 

Table 2: Comparison of Translations and Rotations at Select Nodes for Units Verification 

node 31 Tres Rres  node 12 Tres Rres

m 1.4211e-02 1.9974e-01  m 1.7697e-01 1.8922e+00 t = .3e-2 
mm 1.4211e+01 1.9974e-01  

t = .3e-2
mm 1.7697e+02 1.8922e+00 

m 1.4047e-01 1.4448e+00  m 3.7001e-01 4.8557e+00 
t = .1e-1 

mm 1.4047e+02 1.4448e+00  
t = .1e-1

mm 3.7001e+02 4.8557e+00 
         
node 17 Tres Rres  node 18 Tres Rres

m 6.8150e-01 8.3573e+00  m 8.1518e-01 6.4707e+00 t = .3e-2 
mm 6.8150e+02 8.3573e+00  

t = .3e-2
mm 8.1518e+02 6.4707e+00 

m 9.5396e-01 6.6886e+00  m 1.0842e+00 4.8493e+00 
t = .1e-1 

mm 9.5396e+02 6.6886e+00  
t = .1e-1

mm 1.0842e+03 4.8493e+00 
 
 

      

Figure 18: Deformed Plate at (left) t = 3 ms and (right) t = 10 ms 
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5.0 TRIDENT IMPROVEMENTS 

5.1 UPGRADE TO TRIDENT-USA/CFA TRANSLATORS  

During the period, two versions of the USA/CFA code were installed at the DRDC Atlantic site. The 
first version to be installed was USA5. After some minor modifications to the translators, the new 
version worked fine. However, due to some small changes in the USA/CFA input data, it was found 
that old models would not run. With fairly little effort, the necessary changes were identified, and the 
old models were then modified and successfully executed. The second version to be installed was 
USA6. Whereas USA5 uses integer*4 addressing, USA6 uses integer*8 addressing. The advantage in 
the latter is that much larger fluid models can be handled.  

5.2 COUPLING NON-LINEAR TRIDENT-USA/CFA 

The coupling of non-linear Trident to USA/CFA was investigated. It was established that the simplest 
approach to linking the two systems would be either using a predetermined time step that would be the 
same for both Trident and USA/CFA or allowing the codes to run at different time steps. Trident does 
permit a predetermined time step, with the possibility of updating it during a restart. Template source 
codes for developing such a link were obtained from the USA/CFA vender. Furthermore, the Trident to 
IFSAS II link, developed during this project and described in Section 2.0, is very similar to the one 
needed for the Trident to USA/CFA link. Particularly important and significant is the ability of the 
Trident and IFSAS II codes have to run using different time steps. 

5.3 AUTOMATIC CLIPPING OF FLUID ELEMENTS 

A capability to automatically (or transparently) clip fluid element models for added mass calculations 
has been added to the Trident system. When the fluid element model is used in the Trident solver for 
added mass calculations, only the portion of the model below the user-defined waterline is taken into 
account. A feature has been added for visually checking the waterline prior to a Trident added mass 
calculation. Also included in this task was the ability to use any of the three global coordinate planes 
for the waterline plane. This now being the case with the waterline plane, the ability to use any one of 
the three global coordinate planes for plane of symmetry had to be incorporated. Furthermore, a feature 
was added to Trident for visually checking the user-defined plane of symmetry. 

5.4 LINK TO IFSAS CODE FROM UNDEX SHELL 

Earlier, the old UNDEX Shell was incorporated directly into the Trident system as an Application 
Interface (API). At the same time the IFSAS component of the old UNDEX Shell was separated from 
the new UNDEX Shell and offered as a separate API called IFSAS. In addition to the previous feature 
for generating Neutral Geometry Files, the new IFSAS has a feature for modifying an existing IFSAS 
II input data file to include parameters unique to UNDEX. The FE Solver wizard in Trident has been 
updated to include the option create input files for a coupled Trident/IFSAS analysis. Both linear and 
non-linear analyses can be performed. The IFSAS II API is demonstrated in Appendices A, B and C. 
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5.5 EQUIPMENT MOUNTS EXTENSION TO TRIDENT 

No work was completed regarding the equipment mounts extension to Trident. Instead, the resources 
planned for this task were re-allocated to the integration of Trident and IFSAS. This came about as the 
result of developing an unplanned single executable and the additional effort needed to accommodate 
the Fortran and C programming languages. 
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6.0 CONCLUSIONS AND RECOMMENDATIONS 

Under the current contract, numerous features have been added to both the IFSAS and Trident codes. 
Both codes were integrated into a single solver for 3D fluid-structure interaction simulations. A 
multiple material model using a mixed-cell approach was implemented in the IFSAS code, and 
validated against experimental data. Adaptive grid schemes for underwater shock and bubble analysis, 
hydrostatic pressure and air-water/seafloor boundaries, underwater explosion profiles, and fluid-backed 
shapes were also implemented. 
 
The improvements made to the Trident program include upgrading the translators between Trident and 
USA/CFA Version 5, automating the clipping of the fluid element meshes at the waterline, creating a 
link to the IFSAS code in the UNDEX shell program, and an extension of capabilities for analysing the 
response of equipment mounts to UNDEX loading. 
 
There are some areas which may be addressed by future bubble model developments. The bubble 
model described produces results that are qualitatively consistent with observed experimental 
behaviour, however there were some observed problems with the computational scheme.  
 

1) FCT Scheme: The FCT algorithm exhibited density oscillations in some problems that 
resulted in non-physical negative densities. This phenomena has been well documented in the 
CFD community [16]. A Godunov scheme should minimize or eliminate spurious negative 
densities if an appropriate multi-phase approach can be defined. 

 
2) Diffusion: Since the interface was not explicitly tracked to within one cell resolution, several 
mixed cells resulted. Since air is significantly more compressible than water, the mixed 
material may be less stiff than what actually exists, and may result in lower pressures and 
impulses. This could be resolved by including a SLIC or variant interface tracker [17] to 
maintain a sharp interface. 

 
3) Cavitation: Bubbles at shallower depths were attempted, however, it was found that the 
cavitation part of the Tait equation of state may have been too severe; at shallow depths, the 
bubbles never contracted once the maximum expansion was reached. A floor cavitation 
pressure similar to that used in Luton and Wardlaw [18] will be used to try and resolve this 
problem. 
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A CFD model has been developed for analysis of close proximity underwater 
explosions to non-responding targets i.e. the bubble jetting problem.  An explicit 
FCT algorithm is adopted for solution of the Euler equations, and a multiple 
material model assuming mixed properties and pressure equilibrium is used to 
simulate the interaction between detonation products and water.  Calculations 
performed on deep water models show that the new model is capable of 
capturing all of the relevant physical phenomena, particularly the large impulse 
and velocity of the water jet. 

 
 
 

INTRODUCTION 
 
The detonation of underwater weapons such as mines and torpedoes is a key factor in the design of naval surface 
vessels and submarines.  Threat assessments have been broadened to include terrorist attacks using devices placed 
in close proximity to vessels in port.  A close proximity underwater explosion subjects the hull structure to an 
extremely high intensity transient loading.  This high transient load is due to the initial shockwave contact, the 
response induced cavitation formation and closure, and finally the detonation-bubble expansion, collapse, and 
possible water jet impact.  The ability to accurately model such an event requires the ability to simulate all of 
these phenomena for a range of charge sizes, standoff distances, and target geometries. 
 
Figure 1 shows a schematic of a bubble jet formation on a non-responding target.  The detonation products 
undergo a rapid expansion, and the gas bubble flattens out near the target.  The over-expansion of the bubble 
causes a large low-pressure region in the vicinity of the detonation products-water interface.  This low pressure 
region is eventually repressurized everywhere except for near the target, and the bubble starts to collapse towards 
the target.  Finally, a high-velocity water jet is formed, and the gas bubble forms a toroidal shape.  The impulsive 
load generated from the water jet is significantly larger than that of the initial shock wave, and can cause severe 
damage. 
 
Traditionally, two phase approaches consisting of a Lagrangian time step and an Eulerian remap step are utilized 
to solve jetting problems [1].  An alternative approach is described here; a CFD Eulerian solver is utilized, 
thereby eliminating the need for a Lagrangian step.  
 
 

METHODOLOGY 
 
In order to provide an accurate numerical simulation of the bubble jet problem, the following must be considered: 
 

1) CFD solver 
2) Equations of state 
3) Detonation products – water interface 

 



 

An inviscid CFD solver is adopted here, using the flux corrected transport (FCT) algorithm adopted by Boris [2].  
The 2-D axisymmetric equations of mass and momentum (Equations 1 and 2) are solved to obtain material 
densities, ρ , pressures, p, and radial and horizontal velocities, and  , respectively: u v
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In this formulation, internal energy is not considered, because the material pressure is assumed to be a function of 
density only. 
 
The gas bubble is assumed to consist of air, and expand isentopically according to Equation 3: 
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where  
 

0p  = 1 atm 

0ρ  = 1.18 kg/m3

γ = specific heat ratio = 1.4 

 
A modified Tait equation of state is adopted to model the water: 
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where 
 
B = 3000 atm 

0ρ  = 1000 kg/ m3

n = 7.15 
m = 21494.0 
 
The exponent, m, is selected so that the slopes of the pressure vs. density curves are equal at atmospheric 
pressure. 
 
 
 
 
 

 



 

DETONATION PRODUCTS-WATER INTERFACE 
 
Since the bubble jet problem is modeled using discrete computational cells, each cell can have more than one 
material residing inside of it.  Numerous approaches have been used to simulate multi-material problems, 
including level set methods [3], and mixed cell methods [4].  A mixed cell method assuming equal pressure in all 
cell constituent materials is adopted here.  A mixed density, mixρ , is used that is a weighted average of the 

material volume fractions, iφ : 

 
          [6] wwggmix φρφρρ +=

 
The subscripts g, w are gas and water constituents, respectively.  Conservation of volume dictates that: 
 
           [7] 1=+ wg φφ

 
To obtain the volume fractions, and to maintain a conservative form of the equations, mass fraction tracers, T, are 
used, defined such that: 
 
           [8] gggmixT φρρ =

 
     wwwmixT φρρ =       [9] 

 
 
and conservation of mass (Equations 6, 8, and 9) dictates that: 
 
           [10] 1=+ wg TT
 
Two extra equations are added to Equations 1 and 2 in order to determine the volume fractions: 
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One equation is written each for gas and water. 
 
It remains to determine the pressure in the mixed cell.  The equilibrium pressure is determined by using an 
iterative process; the strategy employed here is as follows: 
 

1) Solve Equations 1, 2, and 11 using FCT to obtain mixρ , , and . gT wT

2) Obtain lower and upper brackets for pressure,  and , respectively, shown in Figure 2.  These are 

obtained by assuming a pressure on either side, computing the constituent densities from the equations of 
state (Equations 3, 4, and 5), computing volume fractions from Equations 8 and 9, and computing the 
assumed mixed density from Equation 6.  In this study, a bracket spacing of a factor of 10 was used 
between lower and upper pressures. 

lp up

3) Once bracketed, use false position iteration to solve for the desired level of accuracy on mixρ  shown in 

Figure 2.  This is done by linearly interpolating left and right pressures to obtain a pressure estimate, .  

From the pressure estimate, a similar procedure to Step 2 is employed to compute an estimate of 
rp

mixρ .  

The bracket, whether left or right, is adjusted, and the iteration proceeds until the desired tolerance level 
is attained. 

 
 
 
 

 



 

RESULTS 
 
To demonstrate the formulation, two problems are analyzed here; a free field bubble pulse, and a bubble jet on a 
non-responding target.  For both problems, the layout is similar; 1 kg of TNT at 1000 m depth is employed.  For 
the free field bubble, one-quarter of the explosive was considered, due to symmetry conditions.  An axisymmetric 
computational grid was used, with an expansion grid used at the uppermost and right sides of the grid.  The 
bubble energy was simulated by using a starting pressure in the gas bubble consistent with the ideal gas equation 
of state: 
 

1−
=

γ
VP

E      [12] 

where V = gas bubble volume. 
 
Figure 3 is a plot of the water mass fraction tracer and velocity vectors for four times, blue being gas, and red is 
water; one bubble pulse is shown.   It can be seen that the pulse is consistent with observed experimental behavior 
[5].  The bubble maximum radius and pulse time were calculated as 0.35 m and 7.0 ms, respectively.  These 
compared well with similitude equations obtained from Keil [6] of 0.34 m and 6.6 ms. 
 
An axisymmetric grid with expansion grids similar to those used in the bubble pulse problem were used for the 
bubble jet.  Figure 4 shows the results of the jetting bubble for four times.  The bubble initially undergoes a rapid 
expansion to a maximum radius, and flattens near the target.  Eventually, the low pressure region re-pressurizes, 
and causes the formation of a high velocity water jet.  The jet impinges on the bubble, and forms a toroidal shape 
which dissipates with increasing time.  This is consistent with observed experimental results [5]. 
 
Figure 5 shows a plot of pressure vs. time at the center of the non-responding target.  The results show that there 
is a large initial pressure from the shockwave that has a relatively small duration.  This is followed by a long low-
pressure phase and a high pressure-high impulse phase from the jetting bubble.  The jetting pressure is 
significantly longer than that developed by the initial shockwave. 
 
 

MODEL LIMITATIONS AND FUTURE DIRECTIONS 
 
The bubble model described above produces results that are qualitatively consistent with observed experimental 
behaviour.  However, there were some observed problems with the computational scheme: 
 

1) FCT scheme – the FCT algorithm exhibited density oscillations in some problems that resulted in non-
physical negative densities.  This phenomena has been well documented in the CFD community [7].  A 
Godunov scheme will now be implemented; this should minimize or eliminate spurious negative 
densities. 

2) Diffusion – since the interface was not explicitly tracked to within one cell resolution, several mixed 
cells resulted.  Since air is significantly more compressible than water, the mixed material may be less 
stiff than what actually exists, and may result in lower pressures and impulses.  This will be resolved by 
including a SLIC or variant interface tracker [8] to maintain a sharp interface. 

3) Cavitation – bubbles at shallower depths were attempted.  However, it was found that the cavitation part 
of the Tait equation of state may have been too severe; at shallow depths, the bubbles never contracted 
once the maximum expansion was reached.  A floor cavitation pressure similar to that used in Luton and 
Wardlaw [1] will be used to try and resolve this problem. 

 
Other future directions include deformable (responding) targets, hydrostatic pressure, real explosives, and free 
surface effects. 
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Figure 2:  Iterative Method for Pressure Determination 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3:  Mass Fraction and Vector Plot - Free-Field Bubble 

 



 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4:  Mass Fraction and Vector Plot - Bubble Jet 
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Figure 5:  Pressure vs. Time - Bubble Jet 
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APPENDIX B 
 

TRIDENT-IFSAS CONNECTION EXAMPLE 1: 
SHIP HULL SUBJECTED TO UNDEX 
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This tutorial details how to create a hull mesh in Trident and apply an IFSAS load. 
 
 
SET UP THE PROBLEM 
 
To start a new simulation, begin by creating a new directory (Hull_Example) for the problem inside the 
Trident directory, at the same level as the exes directory (using Windows Explorer). Copy the cfd.inp 
file from the Example_Files directory into this new directory. 
 
 
LAUNCH TRIDENT 
 
Now set up the working directory for the problem. Select Files → Working Directory from the menu 
bar. The window shown in Figure B.1 will appear. 
 

1) Click the Browse button to locate the directory for this problem or type the path to the directory 
in the edit box field ("Hull_Example") 

2) Click the OK button when finished 
 

 

Figure B.1: Working Directory Window 

 
SET UP A NEW PROBLEM DATABASE 
 
To set up a new problem database, begin by selecting Files  →  Database  from the menu bar. This 

pens the Database window, pictured in Figure B.2.  o
 

1) From the Options field select Open New. 
2) In the Database Prefix field click Browse.  
3) Ensure that you are in the working directory for this problem (Hull_Example) and enter the 

database name ("hull_ex"). Click Open to close this window and this will place the problem 
name in the Database Prefix edit field. 

4) Click OK to create the new database. 
5) A message will confirm this operation. Click OK to close this window. 
 

 

Figure B.2: Database Window 
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INITIALIZE MODEL UNITS AND ELEMENT PROPERTIES 
 
To initialize the model units and element properties, select Generate/Modify  →  Properties from the 

enu bar. m
 

1) Click Initialize from the Properties window. 
2) Click Yes to proceed with the initialization from the popup window. 
3) From the Properties window click Model Units to open the Model Units window, shown in 

Figure B.3. 
4) From the Length Unit field select meters. 
5) Leave the Force Unit field as Newtons. 
6) Click OK to accept these values and return to the previous window. 

 

 

Figure B.3: Model Units Window 

 
C
 

reate the element material properties: 

1) From the Properties window click Create to open the Create Property window. 
2) Click the Material button to create a new material. 
3) In the material window that appears, enter "1" as the material number and click OK. 
4) In the Material Number 1 window (shown in Figure B.4), modify the material name; in the 

Name field type "Steel" and set the other fields to the correct steel properties. Click OK to 
proceed to the next window. 

5) Leave the values as their defaults in this window and click OK. 
6) Click OK to the message that indicates the material has been successfully created. 
7) Click Cancel to the next material window, since a second material is not required 

 

 

Figure B.4: Material Number 1 Window 
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N
 

ow create the plate properties: 

1) From the Create Property window click Plate. 
2) In the next window enter "1" as the plate number and click OK to proceed to the next window. 
3) In the Name field enter steel_plt. 
4) In the Material ID field enter "1". 
5) In the Thickness field enter "0.00635". 
6) Click OK. 
7) Click OK to the message that indicates that the plate has been successfully created. 
8) Click Cancel to the next material window, since a second plate is not required. 
9) Click Cancel to close the Create Property window. 
10) Click Cancel to close the Properties window. 
 

 

Figure B.5: Plate Number 1 Window 

 
 
INITIALIZE AND CREATE THE NODES FOR THE HULL 
 
From the Generate/Modify menu click Nodes. 
 

1) From the Nodes window click Initialize. 
2) Click Yes to proceed with the initialization. 
3
 

) Click OK to the message that indicates the nodes have been initialized. 

1) From the Nodes window click Create. A window similar to the one shown in Figure B.6 will 
appear. 

2) Using the Tables B.1 and B.2, enter the X, Y and Z coordinates for each of the nodes. 
3) Click OK when the three coordinates have been entered. 
4) When you have entered all the coordinates click the Cancel button to return to the previous 

window. 
5) Click the Cancel button again to close the Nodes window. 
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Figure B.6: Create Node Window 

 

Table B.1: Hull Nodes (Part I) 

Node X Y Z 
1 7.00 7.50 0.00 
2 7.00 7.00 0.00 
3 7.10 6.50 0.00 
4 7.20 6.00 0.00 
5 7.40 5.50 0.00 
6 7.75 5.00 0.00 
7 8.25 4.50 0.00 
8 8.75 4.00 0.00 
9 9.50 3.70 0.00 

10 10.00 3.50 0.00 
11 10.50 3.30 0.00 
12 11.00 3.00 0.00 
13 11.50 3.30 0.00 
14 12.00 3.50 0.00 
15 12.50 3.70 0.00 
16 13.25 4.00 0.00 
17 13.75 4.50 0.00 
18 14.25 5.00 0.00 
19 14.60 5.50 0.00 
20 14.80 6.00 0.00 
21 14.90 6.50 0.00 
22 15.00 7.00 0.00 
23 15.00 7.50 0.00 
24 7.00 7.50 10.00 
25 7.00 7.00 10.00 
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Table B.2: Hull Nodes (Part II) 

Node X Y Z 
26 7.10 6.50 10.00 
27 7.20 6.00 10.00 
28 7.40 5.50 10.00 
29 7.75 5.00 10.00 
30 8.25 4.50 10.00 
31 8.75 4.00 10.00 
32 9.50 3.70 10.00 
33 10.00 3.50 10.00 
34 10.50 3.30 10.00 
35 11.00 3.00 10.00 
36 11.50 3.30 10.00 
37 12.00 3.50 10.00 
38 12.50 3.70 10.00 
39 13.25 4.00 10.00 
40 13.75 4.50 10.00 
41 14.25 5.00 10.00 
42 14.60 5.50 10.00 
43 14.80 6.00 10.00 
44 14.90 6.50 10.00 
45 15.00 7.00 10.00 
46 15.00 7.50 10.00 

 
 
When all the nodes are entered your workspace should resemble the following: 

 

 

Figure B.7: Workspace with Nodes 
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CREATE  ELEMENTS FORMING THE HULL 
 
To create the hull mesh using the defined nodes, select Generate/Modify → Mesh from the menu bar. 
 

1) Click Plate from the Mesh window to open the Plate Mesh window, shown in Figure B.8. 
2) From the Element Type field select Quadrilateral Shell. 
3) From the Number of Edges field select Four. 
4) In the NeIe fields enter "1-10-1-10".  
5) Ensure that the Plate Property Number field is set to 1. 
6) Ensure that the Material Property Number field is set to 1. 
7) Click OK when these materials are entered and use the mouse to select the four nodes which 

will make up the plate. Select the nodes in order as indicated in the table below (Table B.3). 
8) Click OK at the Biasing Factors window to accept the default values of 0.  The mesh will then 

be drawn to the display. 
9) If the mesh looks as expected click Yes to retain the mesh 
10) When finished meshing the hull click Cancel to return to the previous window. 
11) Click Cancel again to close the Mesh window. The finished mesh is shown in Figure B.9. 
 

 

Figure B.8: Plate Mesh Window 
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Table B.3: Mesh Node Order 

Mesh Node Order 
n1 n2 n3 n4 
46 45 22 23 
45 44 21 22 
44 43 20 21 
43 42 19 20 
42 41 18 19 
41 40 17 18 
40 39 16 17 
39 38 15 16 
38 37 14 15 
37 36 13 14 
36 35 12 13 
1 2 25 24 
2 3 26 25 
3 4 27 26 
4 5 28 27 
5 6 29 28 
6 7 30 29 
7 8 31 30 
8 9 32 31 
9 10 33 32 

10 11 34 33 
11 12 35 34 

 

 

Figure B.9: Workspace with Completed Mesh 
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VERIFY THE ELEMENT NORMALS 
 
To verify that the element normals are oriented properly, select Verify → Element Normals from the 

enu bar. m
 

1) Select Vectors from the Element Normals window. 
2) Ensure that all normals are point outwards, as shown in Figure B.10.  If not you will need to 

reverse the direction of the element’s normal. 
 

 

Figure B.10: Element Normals 

 
 
REMOVE DUPLICATE NODES 
 
To remove duplicate nodes, select Generate/Modify → Nodes from the menu bar. 
 

1) Click Equivalence to open the Equivalence window. 
2) Select Radius and click OK to accept the 0.1 meter default radius. 
3) Click the Yes button to start the equivalence procedure. 
4) Click OK to close the confirmation window 
5) Click Cancel to return to the Nodes menu 
6) Click Compress to start the node compressing procedure. 
7) Click OK to the warning message. 
8) Click Yes to include the unattached nodes in the compression. 
9) Click OK to the message which indicates that the nodes have been compressed. 
10) Click Cancel to close the Nodes window 

 
 
SAVING YOUR WORK 
 

o save the model, select File → Model from the menu bar. T
 

1) From the Open/Save field select Save. 
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2) From the Model Filename prefix field enter "hull_ex" or use the Browse button to enter the file 
name prefix. 

3) Click  to advance to the next window 
4) From the Save Model Files window click All Files. 
5) Click OK to save the file at the Prefix.GOM File window and leave the subtitle as the default 

 
 
CREATE THE BOUNDARY CONDITIONS FOR THE HULL  
 
To create the boundary conditions for the hull, begin by selecting Generate/Modify → Boundary 
Conditions from the menu bar. To create the boundary conditions for the top edges of the hull: 
 

1) Ensure that Create is selected in the Options field. 
2) Select Box in the other field and click OK to advance to the Box window. 
3) Select Inside and click OK. 
4) In Boundary Conditions set all fields to Fixed. 
5) Click the Z button on the toolbar at the right to obtain an XY display. This view will aid in 

selecting the boundaries. 
6) Click OK from the Boundary Conditions window to begin the boundary selection. 
7) Using the mouse draw a box around the top portion of the hull, and click the right mouse 

button when finished (Figure B.11). 
8) Click Yes to the message to confirm the boundary condition box is correct. 
9) Click the Done button to return to the menu. 

 

 
 

Figure B.11: Top Edge Boundary 

 
To create the boundary conditions for left and right edges of the hull: 
 

1) Click the Y button on the toolbar at the right to obtain an XZ display. This view will aid in 
selecting the other boundaries. 

2) Ensure that Create is selected in the Options field. 
3) Select Box in the other field and click OK to advance to the Box window. 
4) Select Inside and click OK. 
5) In the Boundary Conditions set all fields to Fixed. 
6) Click OK to select the boundaries. 
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7) Using the mouse draw a box around the left edge portion of the hull, enclosing the top-most 
nodes (see Figure B.12). Click the right mouse button when finished. 

8) Click Yes to the message to confirm the boundary condition box is correct 
9) Using the mouse draw a box around the right edge portion of the hull, enclosing the bottom-

most nodes (see Figure B.12). Click the right mouse button when finished.  
10) Click Yes to the message to confirm the boundary condition box is correct. 
11) Click Done when finished with these two boundaries 
12) Click the Cancel button to close the boundary condition window. 

 

 

Figure B.12: Left and Right Edge Boundaries 

 
 
VERIFY BOUNDARY CONDITIONS 
 
To verify that the boundary conditions were created successfully, begin by selecting Verify → 

oundary Conditions from the menu bar.  B
 

1) Click OK to accept the default values, which are all components and fixed type. 
2) The figure below (Figure B.13) indicates the fixed boundaries. 
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Figure B.13: Boundary Verification 

 
 
CREATE THE FLUID ELEMENTS 
 

o create the fluid elements, select Generate/Modify → Fluid Structure from the menu bar. T
 

1) Select Structural Element Conversion. 
2) Select Active Elements to create fluid elements from all displayed elements. 
3) Click the Yes button to accept the mesh and close the window. 
4) Click OK to the message that indicates the number of elements created. 

 
 
SET THE FLUID ELEMENT PROPERTIES  
 
To set the properties for the fluid elements, select Generate/Modify → Fluid Elements  from the menu 

ar. b
 

1) Select Modify to open the Element Types window. 
2) Select Fluid Elements from this window to modify the fluid elements only. 
3) Select 4 Node Fluid Panel. 
4) From the Modify menu select Box from the Single/Box field and click . 
5) Select Inside from the Box window and click . 
6) Click the All button to modify all of the fluid elements. 
7) Click the External Air Backed button to apply this property to the fluid elements. The 

configuration code should now be set to 1. 
8) Click OK to accept these changes. 
9) Click  to move to the previous window. 
10) Click Cancel to close the Elements window. 
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CREATE THE IFSAS NGF FILE 
 
The IFSAS NGF (Neutral Geometry File) is created by Trident by first selecting Interface → IFSAS 
rom the menu bar. f

 
1) Select Neutral Geometry File to create the NGF shape file for IFSAS. This will open the 

window shown in Figure B.14. 
2) In the File Prefix field enter the same prefix as before (hull_ex) 
3) Click the OK button to create the file. 
4) Click the OK button to close the window that indicates the number of elements created. 
5) Click the OK button to close the window that indicates the file has been created. 

 

 

Figure B.14: Neutral Geometry File Window 

 
 
CREATE THE IFSAS INPUT DATA FILE 
 

he IFSAS input file is created by first selecting Interface → IFSAS from the menu bar. T
 

1) Select IFSAS Input Data File to create the input file for IFSAS. The window shown in Figure 
B.15 will appear. 

2) In the File Prefix enter “cfd” as the filenames.  Ensure the NGF File Prefix is set to hull_ex.  
Click the  button. 

3) In the Grid Geometry Specification window (Figure B.16) the CFD computational grid is set.  
Enter the number of cells in X, Y and Z along with the dimension in each direction. These 
values are shown in the Figure B.16 below. Click the  button. 

4) At the Shape Specification window (Figure B.17), the centroid of the explosive charge is 
entered, along with the spherical radius of the charge.  Enter the centroid position of the 
charge, along with the radius and pressure as indicated in Figure B.17 below.  Click the OK 
button to accept the changes and create the CFD input file. 

5) Click OK to the message which indicates the file has been successfully created. 
6) Click the  button at the IFSAS Input Data File to close the window. 
7) Click the Cancel button at the IFSAS window to close this window. The explosive shape 

should now appear  in the workspace, as shown in Figure B.18. 
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Figure B.15: IFSAS Input File Data Window 

 

 

Figure B.16: IFSAS Input File Data Window 

 

 

Figure B.17: Shape Specification Window 
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Figure B.18: Domain with Explosive Shape 

 
SAVE ALL FILES  
 
A
 

gain, save all files by selecting Files → Model from the menu bar. 

1) From the Open/Save field select Save. 
2) From the Model Filename Prefix field enter "hull_ex" or use the Browse button to enter this. 
3) Click  to advance to the next window. 
4) From the Save Model Files window click All Files. 
5) Click OK at the Prefix.GOM File window and leave the subtitle as the default. 
6) Click Yes to overwrite the prefix.gom file. 
7) Click OK at the Prefix.amd window and accept the default values. 

 
 
PREPARE FILES FOR ANALYSIS 
 
S
 

elect Resources → FE Solver from the menu bar to begin preparing the files for the analysis. 

1) From the FE Solver window (Figure B.19), in the CFD Analysis section set the field to Yes. 
Click the OK button. 

2) In the FE Solver/CFD  window (Figure B.20), click Job Information. 
3) In the Job Information in the Job Prefix field enter "hull_ex" or use the Browse button. Click 

the OK button. 
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4) Click OK from the Prefix Use file window. 
5) Click OK at the Element Results window. 
6) In the Direct Integration window leave the defaults, except change the Lumped Mass File field 

to No (Figure B.21). Click OK to accept the changes 
7) In the next Direct Integration window (Figure B.22) set the Number of final time step to "200".  

Set the time interval to "0.500E-04". Click the OK button. 
8) Click the OK button to confirm the .use file has been created. 
 

 

Figure B.19: FE Solver Window 

 

 

Figure B.20: FE Solver/CFD Window 
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Figure B.21: Direct Integration Window (Part I) 

 

 

Figure B.22: Direct Integration Window (Part II) 

 
 
EXECUTE THE ANALYSIS 
 
T
 

o execute the analysis: 

1) From the FE Solver/CFD window select Run Solver. 
2) Ensure that the Job Prefix window (Figure B.23) contains the correct information. If not use 

the browse button to choose the correct file and directory 
3) Click the OK button. 
4) Click the Yes button to start the analysis 

 

 

Figure B.23: Run Solver Window 
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SOLVER COMPLETION 
 
To complete the analysis: 
 

1) Click OK to the window that indicates the solver has completed 
2) Click CANCEL to close the FE solver/CFD window 

 
 
VIEWING THE RESULTS 
 
To view the results, select Results → Deformation from the menu bar. 
 

1) Select Displacements from the Deformation window. 
2) In the Dynamic Displacements window (Figure B.24) enter "–1" in the Time Step field and 

"0.0" in the Length field. Click OK.  
3) The deformation will be displayed. Modify the Length field to change the deformation scale if 

desired.   
4) Click Cancel to close this window.. 
5) Click Cancel to close the Deformation window. 

 

 
Figure B.24: Dynamic Displacements Window 

 
 

CREATING AN ANIMATION 
 
To create an animation of the results, begin by selecting Options → Plotting from the menu bar. 
 

1) Select Animations from the Plotting window. 
2) Select Create from the Display/Create/Delete field. 
3) Click the  button to advance to the next window. 
4) Leave the defaults in the Animation window and click . 
5) Ensure Deformations Only is selected in the Options field and click OK to start assembling the 

animation. 
 

T
 

o play back the animation: 

1) From the Animation window select Display from the Display/Create/Delete field 
2) Click the  button to advance to the next window 
3) Leave the defaults in this window and click OK to start the animation with five cycles. 
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APPENDIX C 
 

TRIDENT-IFSAS CONNECTION EXAMPLE 2: 
SHIP SUBJECTED TO UNDEX 
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In this tutorial, a ship hull mesh will be imported and coupled with an IFSAS II blast. 
 
 
SET UP THE PROBLEM 
 
To begin the simulation, using Windows Explorer: 
 

1) Create a new directory ("Ship_Example") for the problem inside the Trident directory, at the 
same level as the exes directory.  

2) Copy the cfd.inp file from the Example_Files directory into this new directory. 
3) Copy the ship_ex.gom file from the Example_Files directory into this new directory. 

 
 
LAUNCH TRIDENT AND SET UP THE WORKING DIRECTORY 
 
Launch Trident and set up the working directory by first selecting File → Working Directory from the 

enu bar. m
 

1) The window shown in Figure C.1 will appear. Click the Browse button to locate the directory 
for this problem, or type the path to the directory in the edit box field ("Ship_Example"). 

2) Click the OK button when finished. 
 

 

Figure C.1: Working Directory Window 

 
 
SET UP A NEW PROBLEM DATABASE 
 

o set up a new problem database, select Files → Database from the menu bar. T
 

1) This opens the Database window, shown in Figure C.2.  From the Options field select Open 
New. 

2) In the Database Prefix field click Browse.  
3) Ensure that you are in the working directory for this problem (Ship_Example) and enter the 

database name ("ship_ex"). Click Open to close this window and this will place the problem 
name in the Database PrefixEedit field. 

4) Click OK to create the new database 
5) A message will confirm this operation. Click OK to close this window. 
 
 

 
 
  TR-04-23 



Extension and Validation of  
UNDEX Analysis Methods  54 
 
 

 

Figure C.2: Database Window 

 
 
LOAD GEOMETRY FILE 
 
To load the geometry file which includes the structure geometry, material properties and plate 
properties, select Files → Model from the menu bar. In this model, the material is steel, with a plate 
hickness of 0.00635m.  The material and plate parameters can be modified if desired. t

 
1) From the Model window (Figure C.3) select Open from the Open/Save field. 
2) Click the Browse button and locate the ship_ex.gom file in the working directory. 
3) Click Open in the file dialog box. 
4) Click the  button. 
5) Click Geometry and Element File from the Open Model Files window. 
6) Click OK to load the model. The model should now appear in the workspace, as shown in 

Figure C.5. 
 

 

Figure C.3: Model Window 

 

 

Figure C.4: Open Model Files Window 
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Figure C.5: Loaded Ship Mesh 

 
 
VERIFY THE ELEMENT NORMALS 
 
The direction of the element normals should now be checked. Select Verify → Element Normals from 
he menu bar. t

 
1) Select Vectors from the Element Normals window. 
2) Ensure that all normals point outwards (see Figures C.6 and C.7).  If not you will need to 

reverse the direction of the element’s normal. 
 

 

Figure C.6: Ship Mesh with Normals Displayed (Side View) 
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Figure C.7: Ship Mesh with Normals Displayed (End View) 

 
 
CREATE THE SHIP BOUNDARY CONDITIONS  
 
To create the ship boundary conditions, begin by selecting Generate/Modify → Boundary Conditions 
from the menu bar. To create the boundary conditions for the top edges of the ship: 
 

1) Ensure that Create is selected in the Options field. 
2) Select Box in the other field and click OK to advance to the Box window. 
3) Select Inside and click OK. 
4) In the Boundary Conditions window set all fields to Fixed. 
5) Click the X button on the toolbar at the right to obtain an YZ display. This view will aid in 

selecting the boundaries. 
6) Click OK from the Boundary Conditions window to begin the boundary selection. 
7) Using the mouse draw a box around the top portion of the ship, and click the right mouse 

button when finished, as shown in Figure C.8. 
8) Click Yes to the message to confirm the boundary condition box is correct 
9) Click the Done button to return to the menu 
10) Click the Cancel button to close the Boundary Condition window. 

 

 

Figure C.8: Ship Model Boundaries 
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VERIFY THE BOUNDARY CONDITIONS 
 
To verify that the boundary conditions were loaded appropriately, select Verify → Boundary 
Conditions. Click OK to accept the default values, which are all components and fixed type. The figure 
below indicates the fixed boundaries. 
 

 

Figure C.9: Ship Model Boundary Verification 

 
 
CREATE THE FLUID ELEMENTS 
 
To create the surrounding fluid elements, select Generate/Modify → Fluid Structure from the menu 

ar. b
 

1) Select Structural Element Conversion. 
2) Select Active Elements to create fluid elements from all displayed elements. 
3) Click the Yes button to accept the mesh and close the window. 
4) Click OK to the message that indicates the number of elements created. 

 
 
SET FLUID ELEMENT PROPERTIES 
 
To set the fluid properties, begin by selecting Generate/Modify → Elements from the menu bar. 
 

• Select Modify to open the Element Types window. 
• Select Fluid Elements from this window to modify the fluid elements only. 
• Select 4 Node Fluid Panel. 
• From the Modify menu select Box from the Single/Box field and click . 
• Select Inside from the Box window and click . 
• Click the All button to modify all of the fluid elements 
• Click the External Air Backed button to apply this property to the fluid elements.  The 

configuration code should now be set to 1. 
• Click OK to accept these changes. 
• Click  to move to the previous window. 
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• Click Cancel to close the Elements window. 
 
 
CREATE THE IFSAS NGF FILE 
 
To create the NGF (Neutral Geometry File) of the ship hull for use by IFSAS, select Interface → 
FSAS from the menu bar. I

 
1) Select Neutral Geometry File to create the NGF shape file for IFSAS. This will pen the 

window shown in Figure C.10. 
2) In the File Prefix field enter the same prefix as before (ship_ex). 
3) Click the OK button to create the file. 
4) Click the OK button to close the window that indicates the number of elements created. 
5) Click the OK button to close the window that indicates the file has been created. 

 

 

Figure C.10: NGF Window 

 
 

CREATE THE IFSAS INPUT DATA FILE 
 

he IFSAS input file is created by first selecting Interface → IFSAS from the menu bar. T
 

1) Select IFSAS Input Data File to create the input file for IFSAS. This will open the window 
shown in Figure C.11.  

2) In the File Prefix enter “cfd” as the filenames.  Ensure the NGF File Prefix is set to “ship_ex”.  
Click the  button. 

3) In the Grid Geometry Specification window (Figure C.12) the CFD computational grid is set.  
Enter the number of cells in X, Y and Z along with the dimension in each direction.  These 
values are shown in the figure below.  Click the  button. 

4) At the Shape Specification window (Figure C.13), the centroid of the explosive charge is 
entered, along with the spherical radius of the charge.  Enter the centroid position of the 
charge, along with the radius and pressure as indicated in Figure C.13 below.  Click the OK 
button to accept the changes and create the CFD input file. 

5) Click OK to the message which indicates the file has been successfully created. 
6) Click the  button at the IFSAS Input Data File to close the window. 
7) Click the Cancel button at the IFSAS window to close this window. Figure C.14 shows the 

workspace with the explosive charge shown. 
 
 
  TR-04-23 



Extension and Validation of  
UNDEX Analysis Methods  59 
 
 

 

Figure C.11: IFSAS Input File Data Window 

 

 

Figure C.12: Grid Geometry Specification Window 

 

 

Figure C.13: Shape Specification Window 
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Figure C.14: Domain with Explosive Shape 

 
 
SAVE ALL FILES 
 
To save the model files, select Files → Model from the menu bar. 

 
1) From the Open/Save field select Save. 
2) From the Model Filename Prefix field enter "ship_ex" or use the Browse button to enter this 

field. 
3) Click  to advance to the next window. 
4) From the Save Model Files window click All Files. 
5) Click OK at the Prefix.GOM File window and leave the subtitle as the default. 
6) Click Yes to overwrite the prefix.gom file. 
7) Click OK at the Prefix.amd window and accept the default values. 

 
 
PREPARE FILES FOR ANALYSIS 
 
S
 

elect Resources → FE Solver from the menu bar to begin preparing the files for the analysis. 

1) From the FE Solver window (Figure C.15), in the CFD Analysis section set the field to Yes. 
Click the OK button. 

2) In the FE Solver/CFD  window (Figure C.16), click Job Information. 
3) In the Job Information in the Job Prefix field enter "ship_ex" or use the Browse button. Click 

the OK button. 
4) Click OK from the Prefix Use file window. 
5) Click OK at the Element Results window. 
6) In the Direct Integration window leave the defaults, except change the Lumped Mass File field 

to No (Figure C.17). Click OK to accept the changes. 
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7) In the next Direct Integration window (Figure C.18) set the Number of final time step to "200".  
Set the time interval to "0.500E-04". Click the OK button. 

8) Click the OK button to confirm the .use file has been created. 
 

 

Figure C.15: FE Solver Window 

 

 

Figure C.16: FE Solver/CFD Window 

 

 

Figure C.17: Direct Integration Window (Part I) 
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Figure C.18: Direct Integration Window (Part II) 

 
EXECUTE THE ANALYSIS 
 
T
 

o execute the analysis: 

1) From the FE Solver/CFD window select Run Solver. 
2) Ensure that the Job Prefix window (Figure C.19) contains the correct information. If not use 

the browse button to choose the correct file and directory. 
3) Click the OK button. 
4) Click the Yes button to start the analysis. 
 

 

Figure C.19: Run Solver Window 

 
 
SOLVER COMPLETION 
 
To complete the analysis: 
 

1) Click OK to the window that indicates the solver has completed. 
2) Click CANCEL to close the FE solver/CFD window 

 
 
VIEWING THE RESULTS 
 
To view the results, select Results → Deformation from the menu bar. 
 

1) Select Displacements from the Deformation window. 
2) In the Dynamic Displacements window (Figure C.20) enter "–1" in the Time Step field and 

"0.0" in the Length field. Click OK.  
3) The deformation will be displayed. Modify the Length field to change the deformation scale if 

desired.   
4) Click Cancel to close this window. 
5) Click Cancel to close the Deformation window. 

 

 
 
  TR-04-23 



Extension and Validation of  
UNDEX Analysis Methods  63 
 
 

 
Figure C.20: Dynamic Displacements Window 

 
 

CREATING AN ANIMATION 
 

o create an animation of the results, begin by selecting Options → Plotting from the menu bar. T
 

1) Select Animations from the Plotting window. 
2) Select Create from the Display/Create/Delete field. 
3) Click the  button to advance to the next window. 
4) Leave the defaults in the Animation window and click . 
5) Ensure Deformations Only is selected in the Options field and click OK to start assembling the 

animation. 
 

To play back the animation: 
 

1) From the Animation window select Display from the Display/Create/Delete field. 
2) Click the  button to advance to the next window. 
3) Leave the defaults in this window and click OK to start the animation with five cycles. 
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APPENDIX D 
 

TRIDENT-IFSAS CONNECTION EXAMPLE 3:  
RESPONSE OF STEEL SHELL STRUCTURE TO AIR BLAST 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
  TR-04-23 



Extension and Validation of  
UNDEX Analysis Methods  65 
 
 
In this tutorial, a the response of a steel shell structure to an internal air blast will be calculated.. 
 
 
SET UP THE PROBLEM 
 
To begin the simulation, using Windows Explorer: 
 

1) Create a new directory ("House_Example") for the problem inside the Trident directory, at the 
same level as the exes directory.  

2) Copy the cfd_house.inp file from the Example_Files directory into this new directory and 
rename it "cfd.inp". 

 
 
LAUNCH TRIDENT AND SET UP WORKING DIRECTORY 
 
Launch Trident and set up the working directory for the problem by selecting Files → Working 

irectory. This will open the window shown in Figure D.1. D
 

1) Click the Browse button to locate the directory for this problem. 
2) Or type the path to the directory in the edit box field (House_Example). 
3) Click the OK button when finished. 

 

 

Figure D.1: Working Directory Window 

 
 
SET UP PROBLEM DATABASE 
 

o set up a new problem database, first select Files → Database from the menu bar. T
 

1) This opens the Database window, pictured in Figure D.2. From the Options field select Open 
New. 

2) In the Database Prefix field click Browse.  
3) Ensure that you are in the working directory for this problem (House_Example) and enter the 

database name (house_ex). Click Open to close this window and this will place the problem 
name in the Database Prefix edit field. 

4) Click OK to create the new database 
5) A message will confirm this operation. Click OK to close this window. 
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Figure D.2: Database Window 

 
 
INITIALIZE MODEL UNITS AND ELEMENT PROPERTIES 
 
To initialize the model units and define the element properties, select  Generate/Modify → Properties 
from the menu bar. 
 

1) Click Initialize from the Properties window. 
2) Click Yes to proceed with the initialization from the popup window. 
3) From the Properties window click Model Units to open the Model Units window, shown in 

Figure D.3. 
4) From the Length Unit field select meters. 
5) Leave the Force Unit field as Newtons. 
6) Click OK to accept these values and return to the previous window 
 

 

Figure D.3: Model Units Window 

 
Create the element material properties: 
 

1) From the Properties window click Create to open the Create Property window. 
2) Click the Material button to create a new material. 
3) In the Material window that appears enter "1" as the material number and click OK. 
4) In the Material Number 1 window (Figure D.4), modify the material name; in the Name field 

type Steel and set the other fields to the correct steel properties. Click OK to proceed to the 
next window. 

5) Leave the values as their defaults in this window and click OK. 
6) Click OK to the message that indicates the material has been successfully created. 
7) Click CANCEL to the next material window, since a second material is not required. 
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Figure D.4: Model Units Window 

 
 

Create the plate properties: 
 

1) From the Create Property window click Plate. 
2) In the next window enter "1" as the plate number and click OK to proceed to the next window 

(Figure D.5). 
3) In the Name field enter "steel_plt". 
4) In the Material ID field enter "1". 
5) In the Thickness field enter "0.00635". 
6) Click OK. 
7) Click OK to the message that indicates that the plate has been successfully created. 
8) Click Cancel to the next material window, since a second plate is not required. 
9) Click Cancel to close the Create Property window. 
10) Click Cancel to close the Properties window. 
 

 

Figure D.5: Model Units Window 

 
 

INITIALIZE AND CREATE STRUCTURE NODES 
 
To initialize and create nodes for the steel shell structure, first select Generate/Modify → Nodes from 
he menu bar. t

 
1) From the Nodes window click Initialize. 
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2) Click Yes to proceed with the initialization. 
3) Click OK to the message that indicates the nodes have been initialized. 
4) From the Nodes window click Create. This will open the window shown in Figure D.6. 
5) Using the table below (Table C.1), enter the X, Y and Z coordinates for each of the nodes 
6) Click OK when the three coordinates have been entered. 
7) When you have entered all the coordinates click the Cancel button to return to the previous 

window. 
8) Click the Cancel button again to close the Nodes window. 
 

 

Figure D.6: Create Node Window 

 

Table D.1: Structure Nodes 

Node X Y Z 
1 1.00 1.00 0.00 
2 11.00 1.00 0.00 
3 11.00 1.00 4.00 
4 1.00 1.00 4.00 
5 11.00 11.00 0.00 
6 11.00 11.00 4.00 
7 1.00 11.00 0.00 
8 1.00 11.00 4.00 

 
 
When all the nodes are entered your workspace should resemble the following: 
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Figure D.7: Workspace with Nodes 

 
 

CREATE THE STRUCTURE MESH 
 

o create a mesh using the nodes just created, select Generate/Modify → Mesh from the menu bar. T
 

1) Click Plate from the Mesh window to open the Plate Mesh window shown in Figure D.8. 
2) From the Element Type field select Quadrilateral Shell. 
3) From the Number of Edges field select Four. 
4) In the NeIe fields enter "8-20-8-20" for the first four entries in the table below (Table C.2).  

The first four entries make up the walls of the house. For the last entry, which is the roof, enter 
"20-20-20-20" in this field. 

5) Ensure that the Plate Property Number field is set to 1. 
6) Ensure that the Material Property Number field is set to 1. 
7) Click OK when these materials are entered and use the mouse to select the four nodes which 

will make up the plate. Select the nodes in order as indicated in the table below (Table C.2). 
8) Click OK at the Biasing Factors window to accept the default values of 0. The mesh will then 

be drawn to the display. 
9) If the mesh looks correct click Yes to retain the mesh. 
10) When finished meshing the house, click Cancel to return to the previous window. 
11) Click Cancel again to close the Mesh window 
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Figure D.8: Plate Mesh Window 

 

Table D.2: Plate Connectivities 

Mesh Node Order 
n1 n2 n3 n4 
4 1 2 3 
3 2 5 6 
6 5 7 8 
8 7 1 4 
    

8 4 3 6 
 
 

REMOVE ELEMENTS TO SIMULATE WINDOWS AND DOORS 
 
To remove elements from the mesh, select Generate/Modify → Elements from the menu bar. First, 
emove the side windows: r

 
1) From the Elements menu select Delete. 
2) Click the X button in order to get a side YZ side view. 
3) From the Delete window select Box from the Single/Box field. 
4) Click the  button. 
5) Select Inside from the box window. 
6) Click OK. 
7) Using the mouse create a box around the location of the windows.  This box will have a lower 

corner just above Y=4m, Z=1m and an upper corner just below Y=6m, Z=2.5m.  See the 
diagram below (Figure D.9). 

8) Click the Done button when finished. 
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Figure D.9: Elements Selected for Removal (Side View) 

 
 

N
 

ow remove the front windows and door: 

• From the Elements menu select Delete. 
• Rotate the model in the view port such that the front face of the house is visible. 
• From the Delete window select Box from the Single/Box field. 
• Click the  button. 
• Select Inside from the box window. 
• Click OK. 
• Using the mouse create a box around the location of the two front windows.  One box will have 

a lower corner just above X=1.5m, Z=1m and an upper corner just below X=3m, Z=2.5m.  The 
other box will have a lower corner just above X=7m, Z=1m and an upper corner just below 
X=8.5m, Z=2.5m.  See the Figure D.10. 

• Using the mouse create a box around the location of the front door.  This box will have a lower 
corner just above X=4.5m, Z=0m and an upper corner just below X=5.5m, Z=2m.  See the 
Figure D.11. 

• Click the Done button when finished. 
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Figure D.10: Structure with Windows 

 
 

VERIFY THE ELEMENT NORMALS 
 
Now verify that the element normals are oriented correctly. Select Verify → Element Normals from the 
menu bar. 
 

1) Select Vectors from the Element Normals window. 
2) Ensure that all normals point outwards (Figures D.11, D.12).  If not you will need to reverse 

the direction of the element’s normal. 
 

 

Figure D.11: Correct Normal Directions (Side View) 
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Figure D.12: Correct Normal Directions (Top View) 

 
 
REMOVE DUPLICATE NODES 
 

o remove duplicate nodes, first select Generate/Modify → Nodes from the menu bar. T
 

1) Click Equivalence to open the Equivalence window. 
2) Select Radius and click OK to accept the 0.1 meter default radius. 
3) Click the Yes button to start the equivalence procedure. 
4) Click OK to close the confirmation window. 
5) Click CANCEL to return to the NODES menu. 
6) Click Compress to start the node compressing procedure. 
7) Click OK to the warning message. 
8) Click Yes to include the unattached nodes in the compression. 
9) Click OK to the message which indicates that the nodes have been compressed. 
10) Click Cancel to close the Nodes window 

 
 
SAVING YOUR WORK 
 

o save the model, select Files → Model. T
 

1) From the Open/Save field select Save. 
2) From the Model Filename Prefix field enter "house_ex" or use the Browse button to enter the 

file name prefix. 
3) Click  to advance to the next window. 
4) From the Save Model Files window click All Files. 
5) Click OK to save the file at the Prefix.GOM File window and leave the subtitle as the default. 
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CREATE THE BOUNDARY CONDITIONS 
 
To create the boundary conditions on the bottom surface of the house, begin by selecting 

enerate/Modify → Boundary Conditions from the menu bar. G
 

• Ensure that Create is selected in the Options field. 
• Select Box in the other field and click OK to advance to the Box window. 
• Select Inside and click OK. 
• In the Boundary Conditions set all fields to Fixed. 
• Click the X button on the toolbar at the right to obtain an YZ display.  This view will aid in 

selecting the boundaries. 
• Click OK from the Boundary Conditions window to begin the boundary selection. 
• Using the mouse draw a box around the bottom portion of the house, and click the right mouse 

button when finished. Box should appear as in Figure D.13. 
• Click Yes to the message to confirm the boundary condition box is correct 
• Click the Done button to return to the menu 
• Click the Cancel button to close the boundary condition window. 

 

Figure D.13: Boundaries on Lower Surface 

 
 

VERIFY BOUNDARY CONDITIONS 
 
To verify that the boundary conditions were successfully created, select Verify → Boundary Conditions 
rom the menu bar. f

 
1) Click OK to accept the default values, which are all components and fixed type. 
2) Confirm that the boundaries appear as shown in Figure D.14. 
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Figure D.14: Structure with Boundary Conditions 

 
 
CREATE THE FLUID ELEMENTS 
 
C
 

reate the fluid elements by first selecting Generate/Modify  → Fluid Structure from the menu bar. 

1) Select Structural Element Conversion. 
2) Select Active Elements to create fluid elements from all displayed elements. 
3) Click the Yes button to accept the mesh and close the window. 
4) Click OK to the message that indicates the number of elements created. 

 
 
SET THE FLUID ELEMENT PROPERTIES  
 
Now set the properties for the fluid elements. Select Generate/Modify  → Elements from the menu bar. 
 

1) Select Modify to open the Element Types window 
2) Select Fluid Elements from this window to modify the fluid elements only. 
3) Select 4 Node Fluid Panel. 
4) From the Modify menu select Box from the Single/Box field and click . 
5) Select Inside from the Box window and click . 
6) Click the All button to modify all of the fluid elements. 
7) Click the External Air Backed button to apply this property to the fluid elements. The 

configuration code should now be set to 1. 
8) Click OK to accept these changes. 
9) Click  to move to the previous window. 
10) Click Cancel to close the Elements window. 

 
 
CREATE THE IFSAS NGF FILE 
 
Create the Neutral Geometry File (NGF) which IFSAS will use to detect the structure in the CFD 
calculation. Select Interface → IFSAS from the menu bar. 
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1) Select Neutral Geometry File to create the NGF shape file for IFSAS. 
2) In the File Prefix field enter the same prefix as before (house_ex) (Figure D.15). 
3) Click the OK button to create the file. 
4) Click the OK button to close the window that indicates the number of elements created. 
5) Click the OK button to close the window that indicates the file has been created. 
6) Click Cancel to close the IFSAS window. 
7) Launch a text editor and open the newly created house_ex.ngf file. In this file change every 

occurrence of 32001 to 32002, using the Find/Replace command or its equivalent.  Save the 
file when finished. 

 

 

Figure D.15: Neutral Geometry File Window 

 
THE CFD INPUT FILE 
 
The CFD input file was copied from the Example_Files directory and placed in the working directory 
in the opening portions of this example (rename cfd_house.inp to "cfd.inp"). The CFD input file has 
been setup for this example and involves using a TNT explosive profile to place a 10kg TNT charge 
inside the warehouse structure.  For further information on the CFD input file refer to the CFD Input 
File Manual.  The setup of this problem is shown in Figure D.16.  The mesh of the building is shown 
on the CFD grid (30x30x15 cells, 12x12x6 m), along with the explosive profile inside the warehouse. 
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Figure D.16: Structure with Blast 

 
SAVE ALL FILES 
 

o save the model, select Files → Model. T
 

1) From the Open/Save field select Save. 
2) From the Model Filename Prefix field enter "house_ex" or use the Browse button to enter the 

file name prefix. 
3) Click  to advance to the next window. 
4) From the Save Model Files window click All Files. 
5) Click OK to save the file at the Prefix.GOM File window and leave the subtitle as the default. 
6) Click Yes to overwrite the prefix.gom file 
7) Click OK at the Prefix.amd window and accept the default values 

 
 
PREPARE FILES FOR ANALYSIS 
 
S
 

elect Resources  → FE Solver from the menu bar to begin preparing file for analysis. 

1) From the FE Solver window (Figure D.17), in the CFD Analysis set the field to Yes. Click the 
OK button. 

2) In the FE Solver/CFD window click Job Information. 
3) In the Job Information window (Figure D.18), enter "house_ex" Job Prefix field or use the 

Browse button. Click the OK button. 
4) Click OK from the Prefix.use file window. 
5) Click OK at the Element Results window. 
6) In the Direct Integration window (Figure D.19) leave the defaults, except change the Lumped 

Mass File field to No. Click OK to accept the changes. 
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7) In the next Direct Integration window (Figure D.20) set the Number of final time step to "80".  
Set the time interval to "0.100E-03". Click the OK button. 

8) Click the OK button to confirm the .use file has been created. 
 

 

 

Figure D.17: FE Solver Window 

 

 

Figure D.18: FE Solver / CFD Window 

 

 

Figure D.19: Direct Integration Window (Part I) 
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Figure D.20: Direct Integration Window (Part II) 

 
 
EXECUTE THE ANALYSIS 
 
To execute the analysis: 
 

1) From the FE Solver/CFD window select Run Solver. 
2) Ensure that the Job Prefix window (Figure D.21) contains the correct information. If not use 

the browse button to choose the correct file and directory. 
3) Click the OK button. 
4) Click the Yes button to start the analysis. 
 

 

Figure D. 21: Run Solver Window 

 
 
SOLVER COMPLETION 
 
T
 

o complete the analysis: 

1) Click OK to the window that indicates the solver has completed. 
2) Click CANCEL to close the FE solver/CFD window 

 
 
VIEWING THE RESULTS 
 

o view the results, select Results → Deformation from the menu bar. T
 

1) Select Displacements from the Deformation window. 
2) In the Dynamic Displacements window (Figure D.22) enter "–1" in the Time Step field and 

"0.0" in the Length field. Click OK.  
3) The deformation will be displayed. Modify the Length field to change the deformation scale if 

desired.   
4) Click Cancel to close this window. 
5) Click Cancel to close the Deformation window. 
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Figure D. 22: Dynamic Displacements Window 

 
 

CREATING AN ANIMATION 
 
To create an animation of the results, begin by selecting Options → Plotting from the menu bar. 
 

1) Select Animations from the Plotting window. 
2) Select Create from the Display/Create/Delete field. 
3) Click the  button to advance to the next window. 
4) Leave the defaults in the Animation window and click . 
5) Ensure Deformations Only is selected in the Options field and click OK to start assembling the 

animation. 
 

T
 

o play back the animation: 

1) From the Animation window select Display from the Display/Create/Delete field. 
2) Click the  button to advance to the next window. 
3) Leave the defaults in this window and click OK to start the animation with five cycles. 
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