HSM-PC Users Guide

David J. Pancratz
Linda J. Rogers
John B. Bomar, Jr.

BIODYNAMICS RESEARCH CORPORATION
9901 IH 10 West, Suite 1000
San Antonio TX 78230

September 1998

Interim Report for the Period May 1996 to September 1998

Approved for public release; distribution is unlimited.

Human Effectiveness Directorate
Biodynamics and Protection Division
Biodynamics and Acceleration Branch
2800 Q Street, Bldg 824 Rm 206
Wright-Patterson AFB OH 45433-7947
NOTICES

When US Government drawings, specifications of other data are used for any purpose other than a definitely related Government procurement operation, the Government thereby incurs no responsibility nor any obligation whatsoever, and the fact that the Government may have formulated, furnished, or in any way supplied the said drawings, specifications or other data, is not to be regarded by implication or otherwise, as in any manner licensing the holder or any other person or corporation, or conveying any rights or permission to manufacture, use, or sell any patented invention that may in any way be related thereto.

Please do not request copies of this report from the Air Force Research Laboratory. Additional copies may be purchased from:

National Technical Information Services
5285 Port Royal Road
Springfield, Virginia 22161

Federal Government agencies registered with the Defense Technical Information Center should direct requests for copies of this report to:

Defense Technical Information Center
8725 John J. Kingman Rd STE 0944
Ft. Belvoir, VA 22060-6218

TECHNICAL REVIEW AND APPROVAL

DISCLAIMER

This Technical Report is published as received and has not been edited by the technical editing staff of the Air Force Research Laboratory.

AFRL-HE-WP-TR-1999-0214

This report has been reviewed by the Office of Public Affairs (PA) and is releasable to the National Technical Information Service (NTIS). At NTIS, it will be available to the general public, including foreign nations.

This technical report has been reviewed and is approved for publication.

FOR THE DIRECTOR

Roger L. Stork
ROGER L. STORK, Colonel, USAF, BSC
Chief Biodynamics and Protection Division
Human Effectiveness Directorate
Air Force Research Laboratory
The Head-Spine Model (HSM) originally developed for the Unix environment was recoded for the personal computer. This recode included code improvements and bug fixes, as well as the development of a graphical interface for creating simulations. The HSM can be used to predict the forces and motions of a human spinal column. The vertebrae are modeled with rigid bodies while hydrodynamic elements model the intervertebral discs. A full set of ligamenteous and active muscular models is also incorporated. External accelerations can be applied to the system and the resulting response calculated. A novel method of calculating an initial equilibrium position was incorporated. Several simulations of frontal and vertical accelerations were conducted to demonstrate the utility of the software. Along with the HSM, a database of spinal element properties was created. This database can be separately used from the software to determine mass, material, and geometric properties of the spinal elements as derived from a variety of sources in the literature. This report details the operation of the GUI interface to create, edit, and run simulations.
PREFACE

The investigations described in this report were conducted by the Biodynamics Research Corporation, 9901 I-10 West, Suite 1000, San Antonio TX, 78230. This work was supported with funds from an Air Force SBIR Phase II contract number F41624-96-C-6010 from May 1996 to September 1998. The project manager was Dr. Joseph Pellettiere, AFRL/HEPA.

This research builds upon the original HSM code and initial PC porting described in the Phase I report. For additional information please refer to the companion report, A Personal Computer-Based Head-Spine Model, AFRL-HE-WP-TR-1999-0175.

The members of the research team express their deep appreciation to the many individuals and organizations making contributions to this research program. Without the timely assistance given so generously by everyone, the research program and this report could not possibly have been accomplished.

The research team wishes to express their gratitude for the cooperation, support, and guidance of the Air Force Technical Project Manager Dr. Louise Obergefell and Dr. Ints Kaleps of the Human Effectiveness Directorate, USAF Research Laboratory (AFRL).

Finally, the research team gives a very special thank you to the support staff at BRC. Without the effort of Celina Canales in operations support, this research program could not have been reported effectively. Appreciation is also due to Dr. James Raddin and Dr. McConnell for their technical support, Darrin Smith for engineering support, John Martini and Adolph Mena for illustration support, and Patricia Riley for information services support.
Contents

Overview .......................................................... 1
  History .................................................................... 1
  User Guide Organization ........................................ 2

Installation ............................................................ 3
  What You Need ...................................................... 3
  Installing HSM ....................................................... 3
  Removing HSM ...................................................... 4

User Interface ......................................................... 5
  Screen Layout ........................................................ 5
  Menu Bar .................................................................. 6
  Toolbar ..................................................................... 6
  Tabs ......................................................................... 7

Simulation Wizard ................................................... 8
  Creating a New Simulation ......................................... 8

Editing Parameters ................................................ 11
  Edit Menu ............................................................... 11
  Editing Model Parameters ....................................... 12
  Editing Environment Parameters ......................... 13
  Editing Forcing Function Parameters .................... 16
  Editing Simulation Parameters ............................... 18

Running a Simulation .............................................. 20
  The Run Option ...................................................... 20

Plotting Output Values .......................................... 21
  Plotting Options .................................................... 21

Animation .................................................................. 22
  Simulation Animation ............................................... 22

HSM-PC Database .................................................. 24
  Background ............................................................ 24
  Interface .................................................................. 24

Index ....................................................................... 26
Overview

History

The Head Spine Model (HSM) was originally developed by the USAF Aeromedical Research Laboratory during the late seventies. The HSM was created to aid the solution of problems related to spinal loads resulting from ejection seat acceleration.

Biodynamic Research Corporation contracted with the USAF to create a computer model of the dynamic response of the human head and spine that executes on a PC compatible computer under a Windows environment. The HSM-PC is aimed at creating simulations of the biomechanical responses of the head and spine to potentially traumatic impulsive acceleration and impact events (see HSM-PC Final Report).
# User Guide Organization

<table>
<thead>
<tr>
<th>Chapter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>The history of the Head-Spine Model and a documentation overview.</td>
</tr>
<tr>
<td>Installation</td>
<td>A description of HSM-PC system requirements, installation procedures and the uninstall procedure.</td>
</tr>
<tr>
<td>User Interface</td>
<td>A description of the major features of the user interface including the menu bar, toolbars, and tabs.</td>
</tr>
<tr>
<td>The Simulation Wizard</td>
<td>How to design a simulation by specifying the model elements, the environment, and the simulation parameters.</td>
</tr>
<tr>
<td>Editing Parameters</td>
<td>A description of the mechanism for editing various parameters in a simulation.</td>
</tr>
<tr>
<td>Running a Simulation</td>
<td>How to run a simulation once you have all the specifications assigned.</td>
</tr>
<tr>
<td>Plotting Output Values</td>
<td>An overview of the plotting facilities included in HSM-PC.</td>
</tr>
<tr>
<td>Animation</td>
<td>A description of the animation capabilities of HSM-PC.</td>
</tr>
<tr>
<td>HSM-PC Database</td>
<td>A description of the HSM-PC database and its customization options.</td>
</tr>
</tbody>
</table>
Installation

What You Need

HSM-PC is a native 32-bit Windows applications designed to install with a 32-bit operating system.

Before you begin installing HSM, make sure you have

- An IBM PC or compatible with a 486 or Pentium-class microprocessor and 8 megabytes of RAM (16 recommended) and a mouse.
- The HSM CD-ROM or floppy disks.
- Windows 95/98 or Windows NT 4.0 (or higher) on your system.
- Approximately 15 megabytes of available hard disk space.

Installing HSM

This section describes how to install HSM on a stand-alone system.

To install HSM:

1. Run Windows.
2. Put the HSM CD ROM into your CD ROM drive.
3. Click the Start button and click Run.
   The Run dialog box displays.
4. Type the letter of the drive into which you put the CD ROM followed by SETUP.EXE. Then click OK.
   For example, if D is the letter assigned to your CD ROM drive, you would type, D:\Setup.exe.
The Setup Information screen displays.

5. Read this screen and click OK. The HSM Directory dialog box displays. In this dialog box you can select the directory in which you want to install HSM. The default is C:\Program Files\HSM.

6. To install:

A) To the default directory, click the large square button on the dialog.

-OR-

B) To specify another directory, click the Change Directory button and type the full path in which you want to install HSM.

When you have selected a path, click OK. You will see a status bar indicating the progress of the install. Then you will see a message informing you that the setup is complete.

7. Click OK.

Removing HSM

This section describes how to remove all HSM program files from your system.

1. Run Windows as you normally would.

2. Click the Start button and point to Settings. In the Settings folder, click Control Panel.

3. Double-click the Add/Remove Programs icon. The Add/Remove Programs Properties dialog box displays.

4. Click the Install/Uninstall button.

5. In the Uninstall list box, click HSM and click the Add/Remove button. The Uninstall HSM dialog box asking if you want to remove the HSM program and all of its files displays.

6. Click Remove to remove all HSM files from your system.
User Interface

Screen Layout

- Menu Bar
- Toolbar
- Tabs
Menu Bar

The HSM-PC Menu Bar is always visible within HSM-PC. It contains five drop-down menus:

- The **File** menu contains New, Open, Close, Save, Save As, and Exit options.
- The **Edit** menu allows you access to property screens for the simulation parameters.
- The **Run** menu is used to initiate the computational portion of the simulation.
- The **View** menu is used to evaluate the results of the simulation. It includes options for Animation or Plotting data.
- The **Tools** menu allows the user to access either the Calculator or a Text Editor.
- The **Help** menu gives you quick access to the Help Index and version information.

Status information is displayed on the Menu Bar to the right of the Help option.

---

Toolbar

Many of the essential HSM-PC tools are included on the toolbar, which is located at the top of the main HSM-PC window. While some of these buttons should be very familiar to you from other Windows applications, others will be new to you.

<table>
<thead>
<tr>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create a new the simulation.</td>
</tr>
<tr>
<td>Open</td>
<td>Open an existing simulation.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the current simulation.</td>
</tr>
<tr>
<td>Properties</td>
<td>Shows a drop-down menu of property dialogs.</td>
</tr>
<tr>
<td>Run</td>
<td>Runs the computational portion of the program.</td>
</tr>
<tr>
<td>Animation</td>
<td>Loads animation data and displays the animation toolbar.</td>
</tr>
<tr>
<td>Editor</td>
<td>Opens the text editor.</td>
</tr>
<tr>
<td>Help</td>
<td>Opens the help file.</td>
</tr>
</tbody>
</table>
Tabs

The tabs at the lower left corner of the screen give you access to either viewing the graphical representation of the Head-Spine model or viewing plots of the output data from the simulation.
Creating a New Simulation

Creating a simulation is a 5-step process. The Simulation Wizard walks the user through five screens and indicates the options available. Along with each step in the simulation specification process a separate text file is generated. These files can later be reused in designing future simulations. The initial wizard screen is shown below.

Simulation Parameters

In Step 1 the simulation times, units, and print style are specified. The Starting Time and Ending Time are needed to determine the simulation duration. The Print Interval indicates how often data is recorded in the output file. The Units option is used to specify units for the user interface and the output file. Print Style indicates whether all values are recorded at each time step, or the output values are grouped by element. The Step-by-Step mode is an option to facilitate debugging when the computational portion of the program does not run to completion. The Step-by-Step Print Style enables the user to determine at what point the computation failed and what values were recorded just before the failure.

The file containing simulation parameters is referred to as the Input File. As you leave this dialog you will be asked if you wish to use an existing Initialization File or generate a new one. The Initialization File contains data for the model during the initial settling period. When an Initialization File is reused, time is saved on the computations.
Selecting A Model

In Step 2 the simulation model is selected. There is a choice of three different models. The first model, Selected Vertebrae, allows the user to select a range of vertebrae to include in the simulation. When this option is selected a list box of all rigid bodies is displayed and the range of vertebrae can be selected. The second model, Head-Cervical Spine, includes the head, cervical spine, T1, and representations of the viscera. The third model, Head Spine, includes the head, all vertebrae from C1 to L5, the ribs, the pelvis, and representations of the viscera. The file containing the parameters for the elements of the selected model is referred to as the Elements File.

Specifying the Environment

In Step 3 the environment is specified by adding Rigid Bodies, Springs, Planes and Constraints to the simulation. Rigid Bodies, Springs and Planes can be used to represent restraint systems and occupant seating. Planes are required for the application of forcing functions during the simulation. Constraints are used to constrain the motion of a rigid body in any dimension. The file containing the parameters for Rigid Bodies, Springs, Planes and Constraints is referred to as the Environment file.
Defining Forcing Functions

In Step 4 Forcing Functions can be defined. There are two types of Forcing Functions that can be applied to the planes of a simulation. The user can select from a set of Standard Functions (rectangle, triangle, sinusoid, and haversine) or design their own. The functions can be defined as a Position, Velocity or Acceleration. The user must also define a Direction Vector for the plane of the forcing function. User defined functions can be supplied from a text file or by utilizing a Spreadsheet that is provided with the program. The file containing forcing function information is referred to as the Forcing Function file.

Specifying Output

In Step 5 the data for the Output file is specified. The elements and appropriate data values that will be recorded in the Output file are selected using the dialog shown below. Use the check boxes to select the parameters to be recorded and the list box to select the elements. The Output file will contain data for each recorded value of each selected element at each time step.
## Editing Parameters

### Edit Menu

To edit the parameters of a simulation, either click the toolbar button or select Edit from the Main Menu.

The pull-down menu on the right will be displayed. This menu gives access to the dialog boxes for editing various parameters of the simulation run. It also displays the names of the text files used to store the parameter values. If the file name is selected, a Save As dialog will be displayed and the name of the text file can be changed.

<table>
<thead>
<tr>
<th>Model</th>
<th>Environment</th>
<th>Forcing Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>SELECT.TXT</td>
<td>ENVIRON8.TXT</td>
<td>NODE8.SIM</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Output Parameters</th>
<th>Timing Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>OUT88.TXT</td>
<td></td>
</tr>
</tbody>
</table>
Editing Model Parameters

When Model is selected from the Edit pull-down menu the Model Properties dialog is displayed. The Model Properties dialog has a tab for each type of element in the model. The specific element for that type can be selected from a combo box at the top of the tab and then the properties for that element will be displayed below. These properties are read from the HSM-PC database. The properties are displayed in the units which were selected for that simulation.
Editing Environment Parameters

When Environment is selected from the Edit pull-down menu, the External Element Properties dialog is displayed. This dialog has a tab for each type of element in the environment (Rigid Bodies, Springs, and Planes) and a tab for specifying Constraints on Rigid Bodies in the model. To add new elements to the environment, use the Add button at the bottom of the dialog. To remove an element, first select it in the list box above and then use the Delete button at the bottom of the dialog. To save the changes, select the OK button. To exit without saving, use the Cancel button.

Rigid Bodies

To define a Rigid Body, select the Rigid Bodies tab and press the Add button at the bottom of the dialog. You will be prompted for a name for the rigid body. Next, enter the x, y, and z coordinate values of the primary node for that rigid body using global coordinates. Once a primary node has been defined, secondary nodes for that rigid body can be added using the Add button under the Secondary Nodes list box. Again you will be prompted for a name for each secondary node. After the node has been named, enter the x, y, and z coordinate values (in local coordinates) in the fields provided on the right.
Springs

To define a Spring in the environment, select the Springs tab and press the Add button at the bottom of the dialog. You will be prompted for a name for the Spring and the name will be added to the list box. Now the type of Spring can be selected along with its K1 and K2 values. The end points are selected from a list of primary and secondary nodes.

Planes

To define a Plane in the environment, select the Planes tab and press the Add button at the bottom of the dialog. You will be prompted for Plane number and the number will be added to the list box. Now the coordinates for the three points defining the plane can be entered. The Tab key will position the cursor for entering x, y, and z for point 1 and similarly for point 2 and point 3. Then stiffness to deflection and stiffness to deflection rate can be entered. If any of the values need to be adjusted, simply position the cursor on the appropriate field and enter the new value. Any Planes that are defined for the environment can later be used in defining forcing functions.
Constraints

To define a Constraint for a rigid body, select the Constraints tab and press the Add button at the bottom of the dialog. You will be prompted for Constraint number and the number will be added to the list box. Next select the Rigid Body that you wish to constrain. Use the check boxes at the lower part of the dialog to indicate the motion requiring Constraint.
Editing Forcing Function Parameters

When Forcing Function is selected from the Edit pull-down menu, the Forcing Function Definition dialog is displayed. To add a new Forcing Function, select a Plane using the arrows at the upper left of the dialog. Once you have selected a Plane you can specify the style, type and direction vector for the function.

Standard Functions

If you select a Standard Function as the style, use the second tab to specify the type of function and the function parameters. For Standard Functions you can select from rectangular, triangular, haversine and sinusoidal. Further you need to specify the begin time, end time, peak time (for triangular functions only), offset, and amplitude.
User Defined Functions

When a User Defined Function is selected, the options are to use a file to define the function or use the Spreadsheet provided by the program. If you opt to use a file you will be prompted for the file name. The file should be a text file with two columns of values. The first column specifies the time and the second column specifies the function value for each time.

When the Spreadsheet option is selected, select the Spreadsheet tab and enter the data describing the function in the value column of the Spreadsheet. The Spreadsheet includes graphing capability so that you view the function as you enter values into the Spreadsheet. When the Forcing Function Definition is complete the Forcing Function file will be saved for later use.
Editing Simulation Parameters

When Simulation is selected from the Edit pull-down menu, a submenu is displayed. The submenu contains options for Timing Parameters and Output Parameters.

Editing Timing Parameters

The dialog for editing the simulation Timing Parameters is the same as the dialog described in the Simulation Wizard for setting up Simulation Parameters. Change any of the values that require updating and then press OK.
Editing Output Parameters

The dialog for editing the Output Parameters is shown below. Different element types are displayed on different tabs. Elements from the environment are grouped on the External Elements tab. Use the check boxes to select the parameters to be recorded and the list box to select the elements of interest. Change any of the values that require updating and then press OK.
Running a Simulation

The Run Option

To initiate the computational portion of HSM-PC, either click the toolbar button or select Run Simulation from the Run menu.

During the execution of the simulation the screen will display the time steps as the simulation progresses.

When the simulation computations are complete a dialog will indicate that the program has terminated and will ask “Exit Window?” Select Yes.

After the simulation has been run the Text Editor will display the Error File to display any messages from the computational run. If the simulation is successful, the user will now be able to review the results. Plotting and animation capabilities are provided, or the output file can be viewed with the Text Editor to observe the raw data values. Although the HSM-PC program does not include features for exporting data, result data can be imported using Microsoft Excel.
Plotting Output Values

Plotting Options

When the Plotting tab is selected the screen will display the Plotting Screen. On the right-hand portion of the screen are two panels for specifying the Plotting Options. The upper panel has a list of any model elements which have plot values available in the output file. The lower panel has the element values to plot.

The Plot Items Panel displays a hierarchical list of all the model elements which were selected for the output file. A heading will appear for each group of an element type such as Rigid Bodies or Muscles. When the “plus” sign to the left of the heading is clicked, the hierarchy is expanded to show all the specific elements of that type. After expansion, the “plus” sign becomes a “minus” sign. To collapse an expanded portion of the hierarchy, click the “minus” sign and the specific elements will no longer be listed. To select model element for plotting, click on the specific element in the expanded hierarchical list.

Once a model element is selected from the Plot Items list, the lower panel will display the values which are available for that model element. Select the value you wish to plot from the Plot Values and the plot of that value will be displayed.
After the computational portion of the HSM program has been run, the output data can be viewed as an animation. To initiate an Animation either select the Animation option on the View menu or click the Animation button on the toolbar.

The screen will display the animation toolbar on the right-hand side. The model will only display rigid bodies and planes during the Animation sequence. The HSM program uses the SAE coordinate system (Z-axis pointing down and the X-axis pointing forward) when displaying the model.

**Animation Toolbar**

**Animation**
The Animation portion of the toolbar allows you to play, stop, and rewind the animation sequence. The Loop Mode button will play the animation sequence continuously until the stop option is selected.

**Step Mode**
The Step Mode portion of the toolbar has tools for stepping through the animation sequence in a forward or backward direction. The Step Frames options allows you to set the number of frames to be advanced with each step.

**Speed**
The Speed portion of the toolbar allows the user to set the rate of the animation sequence. The Time Step of the current frame is also displayed here.

**Print Image**
The Print Image option brings up a dialog which allows the user to select a page layout for printing snap shots from the Animation sequence. The dialog has options for a single image page and two sizes of images on a four image per page layout.
The dialog will also prompt the user for the bitmap images to use for the page layouts.

**Save Image**

The Save Image option enables the user to download the current screen image to a bitmap file. The user can use the step mode controls to select the desired image and then capture that image using the Save Image option. A Save File dialog will prompt the user for a file name to assign to the bitmap. These saved images are used with the Print Image option described above.
HSM-PC Database

Background

The best available anatomic, geometric, and materials data that was available to the development team is included in the database. The data can be altered or added to using Microsoft Access. The HSM-PC Database can be accessed by the HSM-PC program on-line or employed as a stand-alone database on the structure and materials properties of the spine.

The HSM-PC Database was developed using Microsoft Access 97. The data in the database include the coordinates and parameter values used in HSM as well as additional data from the more current literature.

Interface
The database application has a main menu that allows access to data from different areas of the spine. Once a selection has been made from the main menu, individual records from the database can be viewed.

The buttons at the lower left corner on the screen allow navigation through the database. From this screen a multiple record view can be selected by pressing the button labeled Multiple Record View.
Index

B
Background 24

H
History 1–2, 1–2

I
Interface 2, 6, 9, 24

T
Tabs 2, 8, 19
Toolbar 7, 12, 20, 22