July 1, 1993 - September 30, 1993
DARPA DICE Manufacturing Optimization

Linda J. Lapointe
Robert V.E. Bryant

Raytheon Company

1993

DARPA
Defense Advanced Research Projects Agency
July 1, 1993 - September 30, 1993
DARPA DICE Manufacturing Optimization

Prepared by
Linda J. Lapointe
Robert V.E. Bryant

Raytheon Company
Missile Systems Laboratories
Tewksbury, MA 01876

October 1993
ARPA Order No. 8363/02
Contract MDA972-92-C-0020

Prepared for
DARPA
Defense Advanced Research
Projects Agency

Contracts Management Office
Arlington, VA 22203-1714
# Contents

1. Summary .................................................................................................................. 1  
2. Introduction .............................................................................................................. 2  
3. MO Tutorial .............................................................................................................. 3  
   3.1 Taking MO for a Test Drive ............................................................................. 3  
   3.2 Starting the MO system ................................................................................... 4  
   3.3 Selecting the Product Data ................................................................................ 4  
   3.4 Selecting the Process Data ............................................................................... 5  
   3.5 Accessing the Translators .............................................................................. 6  
   3.6 Analyzing Manufacturability ............................................................................ 7  
   3.7 Viewing and Printing the Analyzer Results .................................................... 7  
   3.8 Using the Process Modeler .............................................................................. 11  
   3.9 How MO Supports the Two-Tier Team Concept ........................................... 16  
   3.10 Terminating the MO System ........................................................................... 17  
4. Conclusions .............................................................................................................. 18  
5. References .............................................................................................................. 19  
6. Notes ..................................................................................................................... 20  
   6.1 Acronyms ......................................................................................................... 20
Figures

Figure 3.2 MO Main Window ............................................................... 4
Figure 3.3 Select Step Data File Form .................................................. 5
Figure 3.4 Process Model Selection Form ............................................. 6
Figure 3.5-1 RAPIDS to STEP Form .................................................... 6
Figure 3.5-2 STEP to RAPIDS Form ................................................... 7
Figure 3.7-1 MO-Advisor Window ....................................................... 8
Figure 3.7-2 Select Analysis Runs Form ............................................... 9
Figure 3.7-3 Prod QTY versus Process Graph ....................................... 10
Figure 3.7-4 Select Report Type(s) Form ............................................. 11
Figure 3.8-1 Process Modeler Window ............................................... 13
Figure 3.8-2 Process Model Selection Form ....................................... 13
Figure 3.8-3 Manufacturing Activity Specification Form ....................... 14
Figure 3.8-4 Selection Rules Form ...................................................... 14
Figure 3.8-5 Rule Specification Form .................................................. 15
Figure 3.8-6 Resource Utilization Specification Form ............................ 16
Figure 3.9 Acknowledgment Window .................................................. 17
1. Summary

This is the Quarterly Technical Report for the DARPA DICE Manufacturing Optimization. The goal of the Manufacturing Optimization (MO) system is to facilitate a two tiered team approach to the product/process development cycle where a product design is analyzed by multiple manufacturing engineers, and product/process changes are traded concurrently in the product and process domains. The system will support Design for Manufacturing and Assembly (DFMA) with a set of tools to model manufacturing processes, and manage tradeoffs across multiple processes. The subject of this report is the technical work accomplished during the seventh quarter of the contract.

The main thrust of the seventh quarter was integration and test of the MO software and the development of the MO user manual. Highlighted in this report is the tutorial section of the user manual.

During the last quarter, Raytheon’s activities will include test and demonstration of the MO System, as well as delivery of the software and final report.
2. Introduction

This is the Quarterly Technical Report for the DARPA DICE Manufacturing Optimization. The concept behind the Manufacturing Optimization (MO) system is to facilitate a two-tiered team approach to the product/process development cycle where a product design is analyzed by multiple manufacturing engineers, and product/process changes are traded concurrently in the product and process domains. The system will support DFMA with a set of tools to model manufacturing processes, and manage tradeoffs across multiple processes. The subject of this report is the technical work accomplished during the seventh quarter of the contract.

Raytheon spent the seventh quarter on the integration and test of MO software, and on the development of the user manual. Highlighted in this report is the tutorial section of the user manual in order to demonstrate the use of available system functionalities.
3. MO Tutorial

3.1 Taking MO for a Test Drive

The objective of this tutorial is to acclimate you to the MO user interface and the basic MO functionality. This tutorial is written so that you can actually perform the step by step actions needed to execute the demonstration. It is assumed that you are familiar with and have access to a SUN workstation. It is assumed that all supporting external subsystems with MO are loaded on your workstation. Please note that the directory path names referenced throughout this tutorial were established for ease of readability. These path names are subject to change and should be verified with your site system administrator before proceeding with this tutorial.

This tutorial will feature the highlights of the MO system as applied to a printed wiring board. The first part of the tutorial will focus on the File, Analyzer, and Advisor functions, with the assumption that the product data and process model data are already available to the MO system. The tutorial will guide you through the steps of loading the product and process data, analyzing the product data against the process model, and viewing the results in a graphical or textual format. The second part of the tutorial will concentrate on the Modeler. You will learn how to add or modify data to an existing process model by exercising some of the Process Modeler features. The third part of the tutorial will explain how the MO system supports the two-tier team concept.

Helpful hints to keep in mind during your test drive through the MO system:

1) When a new window or form pops up, you must position the window with the mouse and click once to set the window location.

2) Use the backspace key to delete a previous character.

3) Most forms contain Cancel and Help buttons. The Cancel button will automatically abort all entries on the current form and the form will disappear. The Help button will provide information on the current form.
3.2 Starting the MO system

Start the program by typing MO& in a command window. After all data is read and the user interface components are created, the main window will appear. Figure 3.2 depicts the MO main window.

![Figure 3.2 MO Main Window](image)

3.3 Selecting the Product Data

To select or edit a product/STEP data file, select File > STEP Data from the MO main window. The Select Step Data File form will pop up displaying a list of filenames corresponding to the current product data available in the MO system. Verify that the directory path is /MO/PRODUCT_DATA/*.rose in the Filter field. If it is not, then you must click in the Filter field and change the path name. Another method is to select the desired path name from the Directories window. If the Filter field has been altered then click the Filter button to update all the windows in the current form. Select the filename smalldemo.rose from the list of files in the Files window. The entire path name of the product data file will appear in the Step Data Selection field. Click the OK button to load the product data. When the Select Step Data File form disappears, the product data has been loaded successfully. Figure 3.3 depicts the Select Step Data File form.
3.4 Selecting the Process Data

To select or edit a process model data file, select File > Process Model from the MO main window. The Process Model Selection form will pop up displaying a list of filenames corresponding to the current process model data available in the MO system. Verify that the directory path is /MO/PROCESS_DATA/*.rose in the Filter field. If it is not, then correct the path name as you would in the Select Step Data File form. The entire path name of the process model data file will appear in the Process Model Selection field. Select the filename test.rose from the list of files in the Models window. Click the OK button to load the process model data. When the Process Model Selection form disappears, the process model data has been loaded successfully. Figure 3.4 depicts the Process Model Selection form.
3.5 Accessing the Translators

To convert a RAPIDS design into STEP data format, select File > RAPIDS to STEP from the MO main window. The RAPIDS to STEP form will appear. Enter the RAPIDS Design Name in the designated field. Click the OK button to start the processing. The RAPIDS design will be stored into a STEP data file as STEP objects in the same directory as the RAPIDS design. Figure 3.5-1 depicts the RAPIDS to STEP form.
To convert a STEP file to the RAPIDS system format, select File > STEP to RAPIDS from the MO main window. The STEP to RAPIDS form will appear. Enter the Design STEP File and the RAPIDS Design Directory into their respective fields. Click the OK button to start the processing. The STEP file will be stored in the RAPIDS system format in the directory specified. Figure 3.5-2 depicts the STEP to RAPIDS form.

![STEP to RAPIDS Form](image)

Figure 3.5-2 STEP to RAPIDS Form

### 3.6 Analyzing Manufacturability

To run the product data against the process model, select Analyzer > Perform Analysis from the MO main window. The analyzer will select the applicable processes, calculate the yield and rework rates, and determine the ideal and actual estimated cost of the part under analysis. Analysis is complete when the message window at the bottom of the MO main window displays "Manufacturability Analysis is complete."

### 3.7 Viewing and Printing the Analyzer Results

Select Advisor > Manufacturing Advisor from the MO main window. The MO-Advisor window will pop up displaying the selections: File, View, Graphs, Reports, and Help. Figure 3.7-1 depicts the MO-Advisor window.
Figure 3.7-1 MO-Advisor Window

To choose an analysis run, select File > Select Analysis Runs from the MO-Advisor window. The Select Analysis Runs form will pop up displaying a list of filenames corresponding to existing analysis data available in the MO system. Look for the filename testPlan.rose in the current working directory. If it is not there, change the directory path name to /MO/RESULTS/*.rose in the Filter field. Select the filename testPlan.rose from the list of analysis data files in the Runs window. Click the Add Selected Run button to update the Selected Runs window. Click the OK button to load the analysis data. The analysis data has been loaded successfully when the Select Analysis Runs form disappears. Figure 3.7-2 depicts the Select Analysis Runs form.
To specify viewing the process activity from an analysis run, select View > Processes from the MO-Advisor window. (All Activities is the default option.) Processes has been selected when the message “Advisor View Status is set.” is displayed in the message window at the bottom of the MO main window.

To view the production quantity data in a graphical format, select Graphs > Quality Graphs > Prod.QTY from the MO-Advisor window. A new window will pop up displaying a graph of the production quantity (y-axis) versus the process (x-axis). Across the top of the graph are the various graphical representations: bar, line, pie, and stack bar. The default display for a production quantity graph is a line chart. If you click on the bar icon, the graphical representation will change from a line chart to a bar chart. Click on a point in the line graph and a small pop up window will appear displaying the exact quantity value for the specified point. Click the Close button to remove the Prod QTY versus Process graph. Figure 3.7-3 depicts the Prod QTY versus Process graph.
To view the yield analysis data in a textual format, select Reports > Advisor Reports. The Select Report Type(s) form will pop up with a list of report types: Process Flow, Yield/Rework, Costing, and Final Report. Figure 3.7-4 depicts the Select Report Type(s) form. The process flow report is the default. Select report type Yield/Rework and click the OK button to generate the report. Below is a sample report based on the process flow and corresponding yield results for a PWB Fabrication process.

**Fabrication Process Selection/Cost Estimation Report**

MLB - layers 1, 14  OVERALL YIELD is 94 percent

<table>
<thead>
<tr>
<th>Opno</th>
<th>Description</th>
<th>Ideal($)</th>
<th>Actual($)</th>
<th>Rework($)</th>
<th>Yield</th>
<th>Rework</th>
<th># Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>mark part no</td>
<td>0.123</td>
<td>0.12</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>137</td>
</tr>
<tr>
<td>30</td>
<td>oxide treat</td>
<td>1.111</td>
<td>1.11</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>137</td>
</tr>
<tr>
<td>40</td>
<td>bake panels</td>
<td>0.444</td>
<td>0.44</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>137</td>
</tr>
<tr>
<td>50</td>
<td>lay up</td>
<td>3.123</td>
<td>3.12</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>137</td>
</tr>
<tr>
<td>60</td>
<td>laminate</td>
<td>0.600</td>
<td>0.80</td>
<td>0.00</td>
<td>94</td>
<td>0.000</td>
<td>137</td>
</tr>
<tr>
<td>80</td>
<td>route excess</td>
<td>0.715</td>
<td>0.92</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>128</td>
</tr>
<tr>
<td>90</td>
<td>oxide strip</td>
<td>0.250</td>
<td>0.32</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>128</td>
</tr>
<tr>
<td>110</td>
<td>drill tooling</td>
<td>0.220</td>
<td>0.28</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>128</td>
</tr>
<tr>
<td>130</td>
<td>drill</td>
<td>12.123</td>
<td>15.12</td>
<td>1.23</td>
<td>92</td>
<td>0.005</td>
<td>128</td>
</tr>
<tr>
<td>160</td>
<td>electroless</td>
<td>0.661</td>
<td>0.66</td>
<td>0.00</td>
<td>100</td>
<td>0.000</td>
<td>117</td>
</tr>
</tbody>
</table>
Fabrication Yield Analysis Report
MLB - layers 1, 14 OVERALL YIELD IS 94 percent

<table>
<thead>
<tr>
<th>Opno</th>
<th>Design Feature Description</th>
<th>Value</th>
<th>Scrap Per Feature</th>
<th>Opno Yield</th>
</tr>
</thead>
<tbody>
<tr>
<td>60</td>
<td>14 layers and 8 substrates</td>
<td>N/A</td>
<td>6.000</td>
<td>94</td>
</tr>
<tr>
<td>130</td>
<td>annular ring</td>
<td>8.00</td>
<td>8.000</td>
<td>92</td>
</tr>
<tr>
<td>180</td>
<td>aspect ratio</td>
<td>4.00</td>
<td>2.000</td>
<td>98</td>
</tr>
</tbody>
</table>

Figure 3.7-4 Select Report Type(s) Form

To leave the Advisor tool, select File > Exit from the MO-Advisor window.

3.8 Using the Process Modeler

To access the Process Modeler, select Modeler > Process Modeler from the MO main window. The MO - Process Modeler window will appear with the following selections: File, Edit, View, Print, and Help. Figure 3.8-1 depicts the MO-Process Modeler window. To choose an existing process model, select File > Models from the MO - Process Modeler window. The Process Model Selection form will pop up with a list of filenames corresponding to the current process models available in the MO system. Verify that the directory path is /MO/PROCESS_DATA/*.rose in the Filter field. If it is not, then correct the path name as you would in the Select Step Data File form. The entire path name of the process model data file will appear in the Process Model Selection field. Select the filename testModel.rose from the list of files in the Models window. Click the OK button to load the process model. The process model has been loaded successfully when
the Process Model Selection form disappears. Figure 3.8-2 depicts the Process Model Selection form.

To add a new activity node to an existing process model, select Edit > Add Sibling from the MO - Process Modeler window. The Manufacturing Activity Specification form will pop up. Enter the name of the new activity node into the Name field. Enter a brief description of the new activity node into the Description field. Select Process in the Activity window to define the new activity as a process. Select Concurrent in the Child Ordering window to impose an order of concurrent flow. Figure 3.8-3 depicts the Manufacturing Activity Specification form.

Click the Rules button in the Manufacturing Activity Specification form to add, remove or change selection rules for an activity node. The Selection Rules form will appear displaying all the selection rules for an activity node. Figure 3.8-4 depicts the Selection Rules form. Click the New button in the Selection Rules form to create a new rule. The Rule Specification form will appear allowing you to specify the attributes, entities, and operations for your new rule. Figure 3.8-5 depicts the Rule Specification form. Click the Add to Rule button to incorporate your selections. When the rule is completely defined, click the OK button and the Rule Specification form will disappear. Click the OK button in the Selection Rules form to complete the rule modifications for an activity node.

Click the Resources button in the Manufacturing Activity Specification form to add/remove resources and edit setup and run times. The Resource Utilization Specification form will appear displaying all the resources currently stored in the process model. When the resource information form is complete, click the OK button and the Resource Utilization Specification form will disappear. Figure 3.8-6 depicts the Resource Utilization Specification form.

Click the OK button in the Manufacturing Activity Specification form to add the new activity node to the existing process model.

To leave the Process Modeler tool, select File > Exit from the MO-Process Modeler window.
Figure 3.8-1 Process Modeler Window

Figure 3.8-2 Process Model Selection Form
Figure 3.8-3 Manufacturing Activity Specification Form

Figure 3.8-4 Selection Rules Form
Figure 3.8-5 Rule Specification Form
3.9 How MO Supports the Two-Tier Team Concept

Up to this point, the tutorial has been explaining the MO functionality from a single user's perspective. This section explains how MO will support the two-tiered team approach by enabling multiple engineers to analyze and share results.

In a two-tiered approach, multiple engineers analyze the same product model utilizing their respective process models. In our example, the PWB would be analyzed by a fabrication engineer and an assembly engineer using the MO functions which were described earlier in the tutorial. When the individual engineers, complete their analysis, they would notify each other of the location of their analysis results so that each could view and compare results utilizing the MO Advisor module. Described below are the steps that the fabrication engineer would follow to view and compare the assembly engineer's results. The assembly engineer would follow similar steps.

The fabrication engineer would first bring up his own results on the terminal screen. See section 3.7. Leaving his own results displayed, the fabrication engineer then follow the same steps to display the assembly results, selecting the assembly engineer's analysis results filename in the Select Analysis Runs form. After selecting the OK button, the assembly
results are loaded in the Advisor. The fabrication engineer can now view similar formatted graphs and/or reports by using the same Advisor functions that he previously used to display his own results. Then with both sets of results displayed on the his terminal screen, he can visually compare and contrast the results. The assembly engineer would be doing the same on his terminal screen. This enables the product to be viewed across multiple tiered processes facilitating the assessment of product design changes across these processes. The result is a collaboratively engineered design.

Once finalized, one of the team members would generate a report to aid in identifying the suggested design changes for the manufacturing team. To view a report, select Reports >Advisor Reports. The Select Report Type(s) form will pop up with a list of report types: Process Flow, Yield/Rework, and Costing. Select the report options of your choice and click the OK button to generate the custom report.

3.10 Terminating the MO System

To leave the MO system, select File > Exit from the MO main window. An acknowledgment window will pop up prompting you to confirm the exit. Click the OK button as shown in Figure 3.9 to exit the MO system completely.

![Exit Manufacturing Optimization?](image)

**Figure 3.9 Acknowledgment Window**
4. Conclusions

During this reporting period, the main thrust was on the integration and test of the MO software system, as well as the development of the user manual. Highlighted in this quarters technical report is the tutorial section from the user manual.

During the last quarter, Raytheon’s activities will include test and demonstration of the MO System, as well as delivery of the software and final report.
5. References

1. BR-20558-1, 14 June 1991, **DARPA Initiative In Concurrent Engineering (DICE) Manufacturing Optimization - Volume I - Technical.**


6. Notes

6.1 Acronyms

<table>
<thead>
<tr>
<th>Acronym</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASEM</td>
<td>Application Specific Electronic Module</td>
</tr>
<tr>
<td>CAEO</td>
<td>Computer Aided Engineering Operations</td>
</tr>
<tr>
<td>CDRL</td>
<td>Contract Data Requirements List</td>
</tr>
<tr>
<td>DARPA</td>
<td>Defense Advanced Research Projects Agency</td>
</tr>
<tr>
<td>DFMA</td>
<td>Design for Manufacturing and Assembly</td>
</tr>
<tr>
<td>DICE</td>
<td>DARPA Initiative In Concurrent Engineering</td>
</tr>
<tr>
<td>MO</td>
<td>Manufacturing Optimization</td>
</tr>
<tr>
<td>MSD</td>
<td>Missile Systems Division</td>
</tr>
<tr>
<td>MSL</td>
<td>Missile Systems Laboratories</td>
</tr>
<tr>
<td>OSF</td>
<td>Open Software Foundation</td>
</tr>
<tr>
<td>PWA</td>
<td>Printed Wiring Assembly</td>
</tr>
<tr>
<td>PWB</td>
<td>Printed Wiring Board</td>
</tr>
<tr>
<td>PWF</td>
<td>Printed Wiring Fabrication</td>
</tr>
<tr>
<td>ROSE</td>
<td>Rensselaer Object System For Engineering</td>
</tr>
<tr>
<td>STEP</td>
<td>Standard for Exchange of Product Model Data</td>
</tr>
</tbody>
</table>
Distribution List

DPRO-Raytheon
C/O Raytheon Company
Spencer Lab., Wayside Ave.
(one copy of each report)

Defense Advanced Research Projects Agency
ATTN: Defense Sciences Office; Dr. H. Lee Buchanan
Virginia Square Plaza
3701 N. Fairfax Drive
Arlington, VA. 22203-1714
(one copy of each report)

Defense Advanced Research Projects Agency
ATTN: Electronic Systems Technology Office; Capt. Nicholas J. Naclerio, USAF
Virginia Square Plaza
3701 N. Fairfax Drive
Arlington, VA. 22203-1714
(one copy of each report)

Defense Advanced Research Projects Agency
ATTN: Contracts Management Office; Mr. Donald C. Sharkus
Virginia Square Plaza
3701 N. Fairfax Drive
Arlington, VA. 22203-1714
(one copy of each report)

Defense Technical Information Center
Building 5, Cameron Station
ATTN: Selections
Alexandria, VA 22304
(two copies of each report)