MITRE Technology in Education Project
Harrington Database User's Guide

Sharon E. Higginson

Approved for public release
Distribute: Unlimited

93 10 7 0 5 8
Public reporting burden for this collection of information is estimated to average 1 hour per response, including the time for reviewing instructions, searching existing data sources, gathering and maintaining the data needed, and completing and reviewing the collection of information. Send comments regarding this burden estimate or any other aspect of this collection of information, including suggestions for reducing this burden, to the Washington Headquarters Services, Directorate for Information Operations and Reports, 1215 Jefferson Davis Highway, Suite 1244, Arlington, VA 22202-4302, and to the Office of Management and Budget, Paperwork Reduction Project (0704-0188), Washington, DC 20503.

1. AGENCY USE ONLY (Leave blank) 2. REPORT DATE September 1993 3. REPORT TYPE AND DATES COVERED

4. TITLE AND SUBTITLE

MITRE Technology in Education Project: Harrington Database User’s Guide

6. AUTHOR(S)

Sharon E. Higginson

7. PERFORMING ORGANIZATION NAME(S) AND ADDRESS(ES)

The MITRE Corporation
202 Burlington Road
Bedford, MA 01730-1420

8. PERFORMING ORGANIZATION REPORT NUMBER

M 93B0000133

9. SPONSORING/MONITORING AGENCY NAME(S) AND ADDRESS(ES) 10. SPONSORING/MONITORING AGENCY REPORT NUMBER

11. SUPPLEMENTARY NOTES

12a. DISTRIBUTION/AVAILABILITY STATEMENT
Approved for public release; distribution unlimited

12b. DISTRIBUTION CODE

13. ABSTRACT (Maximum 200 words)

MITRE has continued its corporate initiative to help improve public education by extending its efforts to the Harrington Elementary school in Lexington, Massachusetts. As a first step in lending support to the Harrington school, MITRE developed a database program which will be used to inventory the school’s hardware, software, and communication network items. The goal of the inventory is to determine what resources the Harrington school has available such that MITRE can better assist Harrington in using their technology more effectively. This paper, the Harrington Database User’s Guide, provides step-by-step instructions for teachers and students describing how to use and implement the database program.

14. SUBJECT TERMS

guide, hardware, software, editing, saving

15. NUMBER OF PAGES 50

16. PRICE CODE

17. SECURITY CLASSIFICATION OF REPORT

Unclassified

18. SECURITY CLASSIFICATION OF THIS PAGE

Unclassified

19. SECURITY CLASSIFICATION OF ABSTRACT

Unclassified

20. LIMITATION OF ABSTRACT

Unlimited

NSN 7540-01-280-5500

Standard Form 298 (Rev. 2-89) 
Prescribed by ANSI Std. Z39-18 
2-94-102
MITRE Technology in Education Project
Harrington Database User's Guide

Sharon E. Higginson

Contract Sponsor: N/A
Contract No.: N/A
Project No.: A10E
Dept.: D105

Approved for public release; distribution unlimited.
ABSTRACT

MITRE has continued its corporate initiative to help improve public education by extending its efforts to the Harrington Elementary school in Lexington, Massachusetts. As a first step in lending support to the Harrington school, MITRE developed a database program which will be used to inventory the school's hardware, software, and communication network items. The goal of the inventory is to determine what resources the Harrington school has available such that MITRE can better assist Harrington in using their technology more effectively. This paper, the Harrington Database User's Guide, provides step-by-step instructions for teachers and students describing how to use and implement the database program.
PREFACE

As part of MITRE’s Technology in Education (TIE) project, we met with Joe Josiassen (assistant principal and 5th Grade teacher), Sally Josiassen (5th Grade teacher) and Laurie Fales (4th Grade teacher) from the Harrington Elementary School in Lexington, Massachusetts in May, 1993 to discuss Harrington’s resources and determine the areas in which MITRE could lend its support. An immediate need was identified to perform an inventory of the school’s hardware, software, and communication network items. Once the inventory is complete, MITRE’s Education Initiative will then be better able to assist Harrington teachers in using their existing technology more effectively. As part of this effort, a database was developed using Microsoft Works which was designed such that the Harrington teachers and students could continue to use the application in the future and modify the database as necessary. The Harrington Database User’s Guide was developed to provide the Harrington teachers and the students with documentation describing how to use and implement the database.
ACKNOWLEDGMENTS

I would like to extend my thanks to the following individuals for their dedication and support on MITRE's Education Initiative for the Harrington Elementary School: Dr. Barry Horowitz, Mr. Nelson Bolen, Ms. Sue Maciorowski, Dr. George Huff, Ms. Dawn Hersey, Ms. Kimberly Cole Taylor, and Ms. Michelle Tourville from The MITRE Corporation, and Mr. Joe Josiassen, Ms. Sally Josiassen, and Ms. Laurie Fales from the Harrington Elementary School. I would also like to express my appreciation to all the MITRE-Harrington School volunteers for contributing their time and valued efforts to the project. I would like to give a special thanks to the Harrington teachers whose commitment and enthusiasm for education made this project incredibly rewarding.
### TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>SECTION</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>1.1</td>
</tr>
<tr>
<td></td>
<td>1.2</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
</tr>
<tr>
<td></td>
<td>2.1</td>
</tr>
<tr>
<td></td>
<td>2.2</td>
</tr>
<tr>
<td></td>
<td>2.2.1</td>
</tr>
<tr>
<td></td>
<td>2.2.2</td>
</tr>
<tr>
<td></td>
<td>2.3</td>
</tr>
<tr>
<td>3</td>
<td>9</td>
</tr>
<tr>
<td></td>
<td>3.1</td>
</tr>
<tr>
<td></td>
<td>3.1.1</td>
</tr>
<tr>
<td></td>
<td>3.1.2</td>
</tr>
<tr>
<td></td>
<td>3.1.3</td>
</tr>
<tr>
<td></td>
<td>3.1.4</td>
</tr>
<tr>
<td></td>
<td>3.2</td>
</tr>
<tr>
<td></td>
<td>3.3</td>
</tr>
<tr>
<td></td>
<td>3.4</td>
</tr>
<tr>
<td></td>
<td>3.5</td>
</tr>
<tr>
<td></td>
<td>3.6</td>
</tr>
<tr>
<td></td>
<td>3.6.1</td>
</tr>
<tr>
<td></td>
<td>3.6.2</td>
</tr>
<tr>
<td></td>
<td>3.7</td>
</tr>
<tr>
<td></td>
<td>3.8</td>
</tr>
<tr>
<td></td>
<td>3.9</td>
</tr>
<tr>
<td></td>
<td>3.10</td>
</tr>
<tr>
<td></td>
<td>3.10.1</td>
</tr>
<tr>
<td></td>
<td>3.10.2</td>
</tr>
<tr>
<td>4</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>4.1</td>
</tr>
<tr>
<td></td>
<td>4.2</td>
</tr>
<tr>
<td>List of References</td>
<td>RE-1</td>
</tr>
<tr>
<td>Appendix A - Detailed Database Item Descriptions</td>
<td>A-1</td>
</tr>
<tr>
<td>Appendix B - Troubleshooting Questions and Answers</td>
<td>B-1</td>
</tr>
<tr>
<td>SECTION</td>
<td>PAGE</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Appendix C - Keyboard Shortcuts</td>
<td>C-1</td>
</tr>
<tr>
<td>Glossary</td>
<td>GL-1</td>
</tr>
<tr>
<td>Index</td>
<td>IN-1</td>
</tr>
</tbody>
</table>
## LIST OF FIGURES

<table>
<thead>
<tr>
<th>FIGURE</th>
<th>PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1  Microsoft Works Menu Bar</td>
<td>3</td>
</tr>
<tr>
<td>2  Help Menu</td>
<td>5</td>
</tr>
<tr>
<td>3  Database Help Menu</td>
<td>6</td>
</tr>
<tr>
<td>4  Bookmark Menu</td>
<td>7</td>
</tr>
<tr>
<td>5  Harrington Inventory Design View</td>
<td>10</td>
</tr>
<tr>
<td>6  Harrington Inventory Data View</td>
<td>11</td>
</tr>
<tr>
<td>7  Harrington Inventory List View</td>
<td>12</td>
</tr>
<tr>
<td>8  Harrington Inventory Report View</td>
<td>13</td>
</tr>
<tr>
<td>9  Design View Tool Palette</td>
<td>14</td>
</tr>
<tr>
<td>10 Data View Tool Palette</td>
<td>14</td>
</tr>
<tr>
<td>11 List View and Report View Tool Palette</td>
<td>15</td>
</tr>
<tr>
<td>12 Database Entry Bar</td>
<td>17</td>
</tr>
<tr>
<td>13 Record Selector Box</td>
<td>19</td>
</tr>
<tr>
<td>14 Inventory Before Sort by Type</td>
<td>21</td>
</tr>
<tr>
<td>15 Inventory After Sort by Type</td>
<td>21</td>
</tr>
<tr>
<td>A-1 Harrington Inventory Form</td>
<td>A-1</td>
</tr>
<tr>
<td>B-1 Changing Field Width</td>
<td>B-3</td>
</tr>
</tbody>
</table>
SECTION 1
INTRODUCTION

The goal of this inventory project is to determine what resources the Harrington school has available such that MITRE's Education Initiative can better assist the Harrington school in using their technology more effectively. Yet, this tool can provide more than a stepping stone for determining Harrington's resources; the database tool as described in this manual can be used by the teachers to teach database skills. Such a tool could be integrated as part of a class/school project if so desired. When the inventory is complete, this inventory tool may also allow the Harrington school to demonstrate how to conduct inventories to the other schools in the Lexington district.

This Harrington Database User’s Guide will provide an easy-to-use, step-by-step guide for teachers and students to maintain and update the inventory of the hardware, software, and communication network components at the Harrington Elementary School. The Harrington Database User's Guide describes the database features and gives procedures on how to use these features to complete the tasks you want. The Harrington Database User’s Guide is intended to be used in conjunction with the Microsoft Works User's Guide, version 3.0, Chapter 2 (Microsoft Corporation, 1992).

1.1 USER’S GUIDE CONTENTS

The Harrington Database User’s Guide is divided into several sections which provide the following:

- Information on “Getting Started,”
- Explanations and Procedures for Using the Harrington Database, and
- Information on How to Save and Print the Database.

A table of contents and an index are provided to assist you in locating particular areas of interest. Furthermore, several appendices are included which provide:

- The Detailed Database Item Descriptions to assist you in determining the type of information which should be entered for each data field,
- A Troubleshooting Guide to assist you in solving common database problems,
- A list of Keyboard Shortcuts for reference, and
Before you start using the database, it's important to understand the terms and notational conventions used in this documentation.

- The word "choose" is used for carrying out a menu command or a command button in a dialog box.
- The word "select" is used for highlighting the part of the database that you want your next action to affect.
- *Italic* type is used to indicate a book or publication, as well as for indicating file names and floppy disk names.
- Bulleted (*) lists, such as this one, provide information but not procedural steps.
- Numbered lists (1, 2, ...) indicate procedures to be followed with two or more sequential steps. A pointing finger symbol (†) will be used to indicate a procedure that requires only one step.
- Key names match the names on most keyboards and appear in small capital letters. For example, the Shift key appears as SHIFT.

1 The conventions used are identical to that used in the *Microsoft Works User's Guide* where applicable.
SECTION 2
GETTING STARTED

This section gives instructions on starting Microsoft Works and opening the existing *Harrington Inventory* file. In addition, basic information such as choosing commands using the mouse and keyboard, and the on-line help options are provided. A more detailed description of all the options in Microsoft Works can be found in the *Microsoft Works User's Guide*.

2.1 STARTING MICROSOFT WORKS AND OPENING THE EXISTING DOCUMENT

To start the Microsoft Works application and open the *Harrington Inventory* file, follow the steps below.

1. Place the *Harrington School Database* floppy disk in the disk drive.
2. Double click on the Microsoft Works icon to start the application.
3. Choose File from the apple menu and drag the cursor to select Open.
4. Choose the type of application (database) and double-click on the *Harrington Inventory* file.

2.2 CHOOSING COMMANDS

The Microsoft Works commands are grouped on menus. The menu names appear in the menu bar displayed across the top of the screen. The following menu bar (figure 1) should appear for the *Harrington Inventory* database for data view, design view and list view:

![Menu bar]

**Figure 1. Microsoft Works Menu Bar**

You may choose commands from the Microsoft Works menus using the mouse the same as you do in other Macintosh programs. You may also use the keyboard to choose commands (see Appendix C for Keyboard Shortcuts).

1. To display the menu that contains the command you want, point to the menu name on the menu bar with the mouse.
2. Drag to the command you want to choose.

If the command name ends in an ellipsis (...), Microsoft Works displays a dialog box prompting you for further information after you choose the command; otherwise, the command is carried out immediately.

3. If the command displays a dialog box, specify the information needed.

4. When you finish with the dialog box, choose the appropriate command button to carry out the command. In most cases, choosing the OK button carries out the command. In a few cases, the command button that carries out the command may be labeled with a term such as Open or Find Next.

2.2.1 Undoing a Command or Action

If you change your mind or make a mistake while working on the database, you can choose the Edit Undo command to reverse certain commands and actions immediately after you complete them.

Choose Undo from the Edit menu.

Remember that you can undo only the last command you chose or the last cell entry you typed.

2.2.2 Canceling a Command or Closing a Menu

If a menu is open, click anywhere outside the menu and menu bar.

-or-

If a dialog box is open, choose Cancel.

2.3 USING THE HELP FEATURE

On-line help provides information on each command, how to choose the commands and provides the procedures for accomplishing common tasks. To display on-line Help, choose the Window Help Command, or press the HELP key on the keyboard.

Choose Help from the Window menu.
The following display appears on the screen:

```
[Microsoft Works Help]

Click an icon to display more information.

Word Processor
Database
Spreadsheet
Communications
Draw
Product Support Services
```

Figure 2. Help Menu
You may choose which type of Microsoft Works application you want help from. Choose Database to obtain the list of subjects for Database help (see figure 3).

**Figure 3. Database Help Menu**

To choose a topic, simply click once on the title of the subject you want help from. An explanation and figures will appear describing and explaining the process. When you choose a topic, another set of menus appears to assist you in moving around the help menu. The Contents button allows you to go back to the main menu. The Search button allows you to put in key words to help you quickly find a particular area. The Back button allows you to move back one screen. The History button shows you where you have been (which areas you have viewed) in the help menu. The arrow buttons (<< and>>) allow you to move forward or backward in the subject areas. The Help feature also allows you to define a bookmark.
which puts a placeholder in the particular area you are in. You may then leave the help option and go back to that subject area by selecting the name of the bookmark you defined under the Bookmark menu. The bookmark defined for this example is "Copying a field entry in list view DB" (see figure 4).

Figure 4. Bookmark Menu
SECTION 3
DATABASE GUIDE

The Harrington Inventory file has been created to assist the teachers and students in collecting and maintaining the inventory of the hardware, software, and communication network components at the Harrington Elementary School. The database contains a list of items (or fields as they will be referred to in this section) which should be collected for each object inventoried. Each object inventoried will have its own "record" which is a collection of data fields containing specific information about the object. Each Harrington record will contain the following database items:

- Item Description
- Type
- Date of Purchase (DOP)
- Features
- Site License
- Average Usage
- Software Installed
- Peripheral Devices
- Curriculum
- Student Grade Level (GL)
- Maintenance
- Point of Contact (POC)
- Location
- Inventory Date (Inv Date)
- Inventory Number (Inv #)

A detailed description of each of these database fields is provided in appendix A.

This section of the Harrington Database User's Guide is intended to provide the necessary details to understand the database application and provide instructions on how to use the existing Harrington Inventory file. This section contains information on:

- How to enter the database information,
- How to edit existing records,
- How to insert and delete records,
- How to add new fields to the master database,
- How to create a report,
- How to sort the database, and
- How to set up filters.

3.1 DATABASE VIEWS

In the Harrington Inventory database, you can look at information in several different views: design view, data view, list view, and report view. A description of each view, how they are used, how to switch between views, and what they look like are provided in the following paragraphs.
3.1.1 Design View

Design view allows you to create the fields for a record, create the form layout, and move and resize fields. Figure 5 shows the *Harrington Inventory* in design view.

![Harrington Inventory Design View](image)

*Figure 5. Harrington Inventory Design View*
3.1.2 Data View

Data view is one of the forms in which you may enter the database information. You enter the data one record at a time and view data one record at a time. A sample record from the Harrington Inventory file in data view is illustrated in figure 6.

![Harrington Inventory Data View](image)

Figure 6. Harrington Inventory Data View

3.1.3 List View

List view shows all the fields and all the information you enter in a table format of rows and columns. List view may be used to enter database information. The advantage of using list view to enter information, as opposed to data view, is that you can easily copy information from one record to another. List view is useful for viewing several records at one time, for searching for specific information, and/or for sorting for information.
alphabetically, or by item type. A sample list view form from the *Harrington Inventory* file is shown in figure 7.

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Type</th>
<th>DOP</th>
<th>Features</th>
<th>Site License</th>
<th>Average Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>PhoneNet</td>
<td>Communications</td>
<td>9/5/85</td>
<td>N/A</td>
<td>No</td>
<td>4 hrs/day</td>
</tr>
<tr>
<td>Apple II</td>
<td>Hardware</td>
<td>9/5/83</td>
<td>64k memory</td>
<td>N/A</td>
<td>6 hrs/day</td>
</tr>
<tr>
<td>Apple IIgs</td>
<td>Hardware</td>
<td>9/5/84</td>
<td>128k memory</td>
<td>N/A</td>
<td>8 hrs/day</td>
</tr>
<tr>
<td>Microsoft Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 2.0</td>
<td>Yes</td>
<td>3 hrs/day</td>
</tr>
<tr>
<td>Apple Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 1.1</td>
<td>Yes</td>
<td>4.5 hrs/day</td>
</tr>
</tbody>
</table>

Figure 7. *Harrington Inventory* List View
3.1.4 Report View

Report view, like list view, displays the database information in columns and rows. But unlike list view, report view allows you to print the database information. Report view is useful for searching for specific information, sorting for information alphabetically or by item type, and for printing some or all of the database information. A sample report view sorted by item type is shown in figure 8.

![Figure 8. Harrington Inventory Report View](image)

### Table 1

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Type</th>
<th>DOP</th>
<th>Features</th>
<th>Site License</th>
<th>Average Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 2.0</td>
<td>Yes</td>
<td>3 hrs/day</td>
</tr>
<tr>
<td>Apple Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 1.1</td>
<td>Yes</td>
<td>4.5 hrs/yr</td>
</tr>
<tr>
<td>Apple II</td>
<td>Hardware</td>
<td>9/5/83</td>
<td>68k memory</td>
<td>N/A</td>
<td>6 hrs/day</td>
</tr>
<tr>
<td>Apple Igs</td>
<td>Hardware</td>
<td>9/5/84</td>
<td>128K memory</td>
<td>N/A</td>
<td>8 hrs/day</td>
</tr>
<tr>
<td>PhoneNet</td>
<td>Communications</td>
<td>9/5/85</td>
<td>N/A</td>
<td>No</td>
<td>4 hrs/day</td>
</tr>
</tbody>
</table>

3.2 SWITCHING VIEWS

You may choose to switch between views in order to display the information differently, print the database, or make a report. There are two ways to switch between views: 1.) select data view, list view, or design view from the Form menu or select report view from the Report menu, or 2.) use the tool palette to switch views (see paragraph 3.3).

3.3 USING THE TOOL PALETTE

The tool palette provides a quick way to switch between design view and data view. In some views, you can also use the tool palette to choose filters and navigate among records.
The design view palette allows you to easily switch to data view, choose a font, choose a font size, and choose a font style (see figure 9).

![Diagram of Design View Tool Palette](image)

**Figure 9. Design View Tool Palette**

The data view palette allows you to easily switch to design view, navigate through the records, and choose a filter (see figure 10).

![Diagram of Data View Tool Palette](image)

**Figure 10. Data View Tool Palette**
The list view and report view palette allows you to navigate through the records, choose a filter, choose a font, choose a font size, and choose a font style (see figure 11).

![Diagram of the tool palette]

**Figure 11. List View and Report View Tool Palette**

To show or hide the tool palette

- From the Window menu, choose Show Tools or Hide Tools.  
  Note: You may also click the tool palette's close box to hide the palette.

To use the tool palette

- Click the tool you want to use.  
  Note: The Filter, Font, Font Size, and Style tools each display pop-up lists. Drag to choose an option from the list.

To move the tool palette

- Drag the title bar of the tool palette to move the palette to a more convenient location.

To use the navigation tool

- Drag the slider to move proportionately within the database.  
  -or-
- Click the forward or backward arrow to see the next or previous record.  
  -or-
- Press and hold down the mouse button on the forward or backward arrow to move quickly forward or backward in the database.
3.4 INSERTING/DELETING RECORDS

You can insert a new record at any location in the database or delete an entire record from the database in either data view and list view.

To insert a record

1. In data view, use the navigation tool to locate the record that will follow the new record.
   -or-
   In list view, highlight the record directly below the row where you want to insert the new record.

2. From the Data menu, choose Insert Record.

To delete a record permanently

1. In data view, use the navigation tool to locate the record you want to delete.
   -or-
   In list view, highlight the record you want to delete by clicking on the record selector box (see figure 13).

2. From the Data menu, choose Delete Record. All the information for the record is removed and the space is closed where the record previously existed. Deleting a record removes the information for all views.

3.5 ENTERING DATA

You may enter the database information either in data view or list view. In data view, it is easier to see all the fields for a particular record; whereas in list view, you can see many records at once, and it is easy to copy information from one record to another.

To select the appropriate view

- From the Form menu, choose either Data View or List View.

To type and enter information

1. Highlight the field entry where you want to enter information by clicking the mouse button in the desired field.

2. Type the information.
   Note: You can type up to 250 characters. If the entry is too long to be displayed in a field, you can still see the entire entry in the entry bar (see figure 12). You may choose to widen the field in design view or list view.

3. Click the enter box (also see figure 12), or press the RETURN key.
Click the cancel box to restore the entry to what it was before you began typing.

Click the enter box to enter what you type.

Insertion Point

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Microsoft Works</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Software</td>
</tr>
<tr>
<td>DOP</td>
<td>9/5/86</td>
</tr>
<tr>
<td>Features</td>
<td>Version 2.0</td>
</tr>
</tbody>
</table>

Figure 12. Database Entry Bar

In data view, you may use several keys to move around within a record. When you type information into a field and press RETURN, the data is entered and the next field in the next row is highlighted. If you press RETURN when the last field in a record is highlighted, you are automatically moved to the first field of the next record. You may obtain the same results by using the TAB or DOWN ARROW keys. To move to the previous fields within a record in data view, press the SHIFT + RETURN keys or the UP ARROW key.

In list view, pressing the TAB key allows you to move to fields to the right of the field you are currently in. If you press SHIFT + TAB, you can move to the left of the field you are currently in. If you press RETURN in list view, the highlight moves to the same field in the next record (the field directly below the field you were currently in). SHIFT + RETURN allows you to move the highlight up to the same field in the previous record (directly above the field you were currently in).

Refer to appendix A, Detailed Database Item Descriptions, for specifics on the type of information you may wish to consider entering for each database field.

3.6 EDITING RECORDS

As you are typing or after you have entered data into a field or record, you may decide you want to edit the information. To edit information you need to use either data view or list view. The changes you make in data view or list view will be reflected in the other views.
To change an entry after you type it

1. Find the record you wish to update by using the navigation tool in the tool palette (see paragraph 3.3 for instructions on how to use the tool).

2. Select the field entry by clicking the mouse anywhere in the field.

3. In the entry bar, position the insertion point (or cursor) to the right of where you want to begin the change, and then press the DELETE key to delete the characters you want to change, or select the text you want to change in the entry bar by dragging the cursor across the text you want to change or double-clicking to select a word.

4. Type the new text.

5. Click the enter box, or press the RETURN key.

3.6.1 Copying Information

You may also use the Cut, Copy, and Paste commands from the Edit menu to delete and insert information in the entry bar. In list view, you can copy database entries, fields and records; in data view, you can copy database entries only. List view is often more convenient for copying because you can copy multiple records at once.

To copy an entry

1. In data view or list view, highlight the entry you wish to copy. (In list view, you can also highlight a block of entries).

2. From the Edit menu, choose Copy.

3. Highlight the entry or entries where you want the copied information to go. If you copied a block of entries, be sure there are enough blank entries available to receive the information.

4. From the Edit menu, choose Paste.

To copy a record

1. In list view, click the record selector box (see figure 13) to the left of the record you want to copy, or copy multiple adjacent records by dragging through the column of record selector boxes.

2. From the Edit menu, choose Copy.

3. Highlight the blank row where you want to copy the information. If you copied multiple records, make sure there are enough blank records to receive the information; otherwise, Microsoft Works will replace the existing information.
4. From the Edit menu, choose Paste.

![Record Selector Box](image)

Figure 13. Record Selector Box

### 3.6.2 Removing Information

You may also wish to remove information entered into the database. There are several options for removing data. You may choose to remove information entered in a field or record (either to paste the information somewhere else in the database or to remove it permanently), or you may choose to remove an entire field from a form or the database.

**To remove information you want to paste elsewhere**

1. Select the information you want to cut.

2. From the Edit menu, choose Cut. Note: When you use the Cut command, a blank field, entry or record is left in its place.

3. Position the insertion point (or cursor) where you want to paste the information.

4. From the Edit menu, choose Paste.

**To remove information permanently**

1. Select the information you want to remove.

2. From the Edit menu, choose Clear.

**To delete a field from a form**

1. From the Form menu, choose Design View.

2. Select the field you want to delete.
3. From the Form menu, choose Delete Field. The field will be removed from the form you are working with, but does not close the space. Arrange the new form by dragging the other fields to the appropriate areas.

To delete a field from the database permanently

1. From the Form menu, choose List View.
2. Select the field you want to delete.
3. From the Form menu, choose Delete Field.
4. When you see a message asking if you really want to delete the field, choose the OK button if that is what you intend. The field is deleted and closes the space in list view. This field is deleted from all other forms as well.

3.7 ADDING FIELDS TO MASTER DATABASE

You can add a new field to the Harrington Inventory file at any location. To add a new field to the form you are working on, use design view. The field will be automatically added to the overall database.

To add a field to the overall database

1. In design view, choose Place Field from the Form menu.
2. Choose the New button.
3. In the New Field dialog box, type a name for the field.
4. Leave the Show Field Name box checked if you want the field name to be shown on the form, and choose the OK button.

You may rearrange the form to place the field in the order you wish for it to appear by dragging field to the desired location.

3.8 SORTING

Sorting allows you to rearrange and organize the records in the database. You can sort the database in any view except design view. You can do multi-level sorting by sorting individual fields at a time. For each level of sorting, Microsoft Works retains the order of all previous sorting. Choose the least significant field to sort first, and sort the most important field last. The most significant field and its record contents will be displayed at the top of the list in report view or list view, and the least significant field and its record contents will be displayed at the end of the list in report view or list view (see figures 14 and 15).
To sort information

1. From the Data menu, choose Sort.

2. Under the Sort On Field, click the cursor on the ▼ symbol and drag the cursor to select the field you wish to sort on.

   If you want the sort to be in reverse alphabetical order or reverse chronological order, select Descending by clicking the cursor in the box to the left of that option.

3. Choose the sort button.

   Follow the above steps for multi-level sorting.

3.9 FILTERING

Filters can be used to find specific information in a database. For example, if you want to see all the records with the hardware items in the database, you can create a filter to find only those records. With filters, you can view database information in a variety of ways without changing the original information entered. Filters are useful in extracting smaller sets of
information from large databases. Filters can be used or created in any view except design view.

Three types of filters are currently available for use in the Harrington Inventory file: Hardware, Software, and Communications filters. If you wish to view only each of these types of items, select the filter in either data view, list view or report view.

**To select a filter**

- From the Data menu, choose the filter you want: Hardware, Software or Communications.

  Note: In list view or report view, you may select the filter from the tool palette by dragging the cursor to the appropriate selection.

The database records that meet the criteria specified, will be displayed in the view you are currently in. From either data view or report view, you may then print the filtered information (see Section 4, Saving and Printing).


### 3.10 DATABASE REPORTS

You can create a new report or open the existing "Sample Inventory" report in the Harrington Inventory File. "Sample Inventory" is the only existing report currently created. Therefore, when you select report view from the Report menu, the Sample Inventory report is displayed. Report view is one of the views (the other is data view) from which you can print the database information. Filters have been set up (see paragraph 3.9) which can be selected from the tool palette. This allows you to view and/or print selected information. For example, if you want to view and/or print all the hardware items at the Harrington school, you would select the Hardware filter. Only the records with the Type field indicating Hardware are shown and printed.

**To choose an existing report**

- From the Report menu, choose the name of the report you want. "Sample Inventory" is currently shown at the bottom of the report menu.

**3.10.1 Creating Reports**

In addition to the "Sample Inventory" report which already exists in the Harrington Inventory file, you may choose to create your own report(s).

**To create a new report**

2. In the Name The Report box, type a name for the report.

3. Choose the Create button.

4. If you want to print or view only part of the database, choose the filter you want from the Data menu, or create a new filter (see Microsoft Works User's Guide for creating filters). If you do not choose a filter, all the records from the database are inserted into the report.

5. Before printing, you can rearrange fields, change the right margin marker to include or remove fields from the report, or change the appearance of the report. See the following paragraphs for more information.

3.10.2 Arranging the Report

As mentioned above, you may wish to rearrange fields, remove fields from the report, change margins, or change fonts, font size or font style.

To rearrange fields within a report

1. Position the pointer (hand symbol) on the field name.

2. Drag until the field name of the field you want to be adjacent to is highlighted. If you drag to the right, Microsoft Works positions the field you are moving to the right of the highlighted field. If you drag to the left, Microsoft Works positions the field you are moving to the left of the highlighted field.

To remove a field(s) from a report

1. Drag the field to the right of the fields you want to include in the report. Repeat for all fields you do not want included in the report.

2. Drag the right margin marker (refer to figure 8) to the left until the unwanted field(s) is (are) completely outside the margin.

To change the appearance of the report

1. Select the field(s) you want to change.

2. On the tool palette, choose an option from the Font, Font Size, or Style tools.
SECTION 4
SAVING AND PRINTING

The following section describes the saving and printing options for the Harrington Inventory database file.

4.1 SAVING OPTIONS

To save your work permanently, save all documents on a diskette. Save frequently to protect yourself from losing work and time. You can save an individual document, or you can save part of the database as a separate document. The database is currently stored on the Harrington School Database under the file name Harrington Inventory.

To save further changes to the Harrington Inventory

From the File menu, choose Save.

To save the database with a different name

1. From the File menu, choose Save As.
2. In the Save Document As box, type a new name for the database.
3. Choose the Save button.

To create smaller documents and save part of the database as a separate document

1. From the Form menu, choose List View.
2. On the tool palette, choose a filter (Hardware, Software or Communications) from the filter tool.
   -or-
   From the Data menu, choose the filter you want from the list.
3. From the File menu, choose Save As.
4. In the Save Document As box, type a new name for the document.
5. Choose the Save Selected Records Only checked box.
6. Choose the Save button.
4.2 PRINTING DATABASE INFORMATION

You can print the Harrington Inventory file in either data view or report view. Data view will print individual records, while report view will print all the records in a tabular format. Before you print, you can preview the Harrington Inventory to make sure it looks the way you want. You may change the margins, reduce or enlarge the file size, and change the orientation of the file by selecting Page Setup from the File menu. The Harrington Inventory file is currently set up with 1.00 inch margins, a horizontal page orientation, and when printed will be reduced to 58%. These options allow all of the information entered for each database item in the Harrington inventory to be printed.

To preview information before you print

1. From the File menu, choose Print Preview.

2. Choose the Previous button or the Next button to see the previous or next page.

   Note: While the pointer is over the page area, it changes to a magnifying glass. Click anywhere on the page to view that part in full size. When the page is full size, the cursor changes to a hand. To view other parts of the page, drag the hand. To reduce the page, double-click the page or click the close box in the title bar.

3. When you finish previewing, you may choose the Print button to print, or choose the Cancel button to return to the document window.

To print one or more records

1. From the Form menu, choose Data View.

2. If you want to print only some of the records, choose one of the filters (Hardware, Software or Communications); otherwise, all the records can be printed.

3. From the File menu, choose Print.

4. Choose the options you want.

5. Choose the Print button, or press RETURN.

To print a report

1. From the Report menu, choose the Sample Inventory Report.

2. If you want to print only some of the records, choose a filter (Hardware, Software, Communications).

3. From the File menu, choose Print.

4. Choose the options you want.
5. Choose the Print button, or press RETURN.

To cancel printing

Press COMMAND + PERIOD.
LIST OF REFERENCES

This appendix contains a detailed description of each database field in order to assist you in determining the type of information you may wish to enter in the Harrington Inventory. Figure A-1 shows a blank record with each of the field names. You will be entering information in the box to the right of each field name. For a further description on using the database tools and commands, refer to section 3 of this document.

<table>
<thead>
<tr>
<th>Item Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
</tr>
<tr>
<td>DOP</td>
</tr>
<tr>
<td>Features</td>
</tr>
<tr>
<td>Site License</td>
</tr>
<tr>
<td>Average Usage</td>
</tr>
<tr>
<td>Software Installed</td>
</tr>
<tr>
<td>Peripheral Devices</td>
</tr>
<tr>
<td>Curriculum</td>
</tr>
<tr>
<td>Student GL</td>
</tr>
<tr>
<td>Maintenance</td>
</tr>
<tr>
<td>POC</td>
</tr>
<tr>
<td>Location</td>
</tr>
<tr>
<td>Inv Date</td>
</tr>
<tr>
<td>Inv #</td>
</tr>
</tbody>
</table>

Figure A-1. Harrington Inventory Form
**Item Description**

Enter the complete name of the item to be inventoried; for example, Apple Ile computer.

**Type**

Enter the item type, i.e., whether it is a **Hardware** item (computer, printer, disk drive), **Software** item (Apple Works, Microsoft Works), or a **Communications** network item (PhoneNet, Elna).

**DOP**

DOP stands for date of purchase. Enter the approximate month and year the item was purchased for the school. If the information is not available, enter **Unknown**.

**Features**

For this item, enter any features that characterize the item. For example, if the item you are inventorying is the Microsoft Works software package, include the version number (version 3.0) in the "Features" field. If the item is an Apple Ile computer, enter the memory size (128K) in this field. The Features entry may also include any other important information associated with the database item.

**Site License**

This field provides information on licensing for the Harrington school. If a software package carries a site license for the school, simply enter **Yes** in the data field. If the communication packages contain licenses on the number of computers to which they may be installed, enter **Yes**, and in parentheses, indicate the number of computers the package is licensed for. If there is no site license associated with the database item, enter **No**.

**Average Usage**

Enter the average amount of use the item receives in hours/day.

**Software Installed**

For hardware items, list all the software programs installed on the computer. For software or communication items, enter **N/A** for not applicable.

**Peripheral Devices**

For hardware items, list all the exterior connections to other devices such as printers, disk drives, probes, etc.. For software or communication items, enter **N/A** for not applicable.
Curriculum

Enter the subject matter(s) which is (are) taught using the item being inventoried.

Student GL

For software items, enter the student grade level applicable to the software program being inventoried. If the student grade level does not apply (or can be used by any age level), enter N/A.

Maintenance

Enter in the last date on which maintenance was performed for the database item, and the approximate maintenance cost/year. Also, describe any particular recurring maintenance problems associated with the database item. If no maintenance is performed on a regular basis, enter None in the data entry field.

POC

POC stands for point of contact. Enter the person responsible for the database item in the data entry field.

Location

Enter the location(s) of the database item (Room #(s)).

Inv Date

Enter the date the item is inventoried.

Inv #

Enter the inventory number (INV ###, where the numbers assigned begin at 001 and continue sequentially through 999) for each database item. Note that inventory stickers will be provided for the initial inventory in order to tag each Harrington item.
APPENDIX B
TROUBLESHOOTING QUESTIONS AND ANSWERS

This section contains answers to specific questions you may have as you work with the Harrington Inventory database.

How can I move fields within a form?

To move a field within a form, follow the steps below.

1. On the tool palette, click the Design view tool.
   -or-
   From the Form menu, choose Design View.

2. Highlight the field you want to move.

3. Position the pointer anywhere within the field except on a handle, and then drag the field to its new location.

How can I change the font, font size, and style of the information in the database?

You can select a different font, font size and style for each field. When you change the font, font size, or style of database fields in design view, the changes apply only to the form you are in; formatting in list view applies to any associated reports.

To change any of the font characteristics of database information

1. In design view or list view, highlight the field(s) you want to change.

2. On the tool palette, choose the options you want from the Font, Font Size and Style tools.
   -or-
   From the Form menu, choose Format Character, choose the options you want, and then choose the OK button.

How do I delete a record in the database so that a blank record does not remain?

To delete a database record and close the space, follow the steps below.

1. In list view, highlight the entire record by clicking the record selector box to the left of that record's first field.

2. From the Data menu, choose Delete Record.
What do I do if I want to undo an action, but it is too late and/or the undo command does not apply?

If you want to undo an action that cannot be undone through the undo command, you can quit the application (Microsoft Works) without saving any changes, and re-open the previously saved document. However, any other changes you made since the last time the document was saved, will be lost.

What is the difference between design view and data view?

Design view is where you create fields and make a form look the way you want. In design view, you can move and resize fields and add graphics, shading, borders, or other elements with the Draw tools. When you work in design view, you can see the names of the fields you created, but not the information you have entered into the fields.

Data view is where you enter information onto a form. In data view, you can enter information into one record at a time. You can also search for specific information in data view.

How can I print all of a database's fields in a report?

When you create a Database report, Microsoft Works prints the fields that are positioned within the print area. By changing the page orientation, the page margin settings, and reducing the size of the information, you can create a larger print area. The larger the print area is, the more fields you can print on a page. You may also adjust the individual field widths in report view in order to allow more fields to be printed per page.

To change the page orientation, follow the steps below.

1. From the File menu, choose Page Setup.
2. Under Orientation, choose the horizontal (sideways) orientation option.
3. Choose the OK button.

To change print size, follow the steps below.

1. From the File menu, choose Page Setup.
2. Under Reduce or Enlarge, type the enlargement or reduction size of the document.
3. Choose the OK button.
To change the page margin settings, follow the steps below.

1. From the File menu, choose Page Setup.
2. Choose the Document button.
3. Under Margins, type new margin settings to increase the size of the print area.
4. Choose the OK button.
5. In the Page Setup dialog box, choose the OK button.

To move a field, follow the steps below.

1. In report view, position the pointer on the field name of the field you want to move.
2. Drag until the field name of the field you want to be adjacent to is highlighted.

If you drag to the right, Microsoft Works positions the field you are moving to the right of the highlighted field. If you drag to the left, Microsoft Works positions the field you are moving to the left of the highlighted field.

To change the width of a field in report view, follow the steps below.

1. In report view, position the pointer on the right border of the field name box (the cursor will change shape (++) sign indicating that you can now drag the border and change the width - see figure B-1).
2. Drag to the right to widen the field, or to the left to narrow it.

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Type</th>
<th>Version</th>
<th>Features</th>
<th>Site License</th>
<th>Average Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 2.0</td>
<td>Yes</td>
<td>3 hrs/day</td>
</tr>
<tr>
<td>Apple Works</td>
<td>Software</td>
<td>9/5/86</td>
<td>Version 1.1</td>
<td>Yes</td>
<td>4.5 hrs/day</td>
</tr>
</tbody>
</table>

When you position the pointer over a border, it changes shape to indicate that you can now drag the border and change the width.

Figure B-1. Changing Field Width
APPENDIX C

KEYBOARD SHORTCUTS

Many of the Microsoft Works commands can be carried out using keys on the keyboard. Most keyboard shortcuts are also displayed in the Microsoft Works menus. To use a shortcut key, hold down the command key [⌘] while pressing the key that corresponds to the particular command.

<table>
<thead>
<tr>
<th>Command or Action</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>⌘ N</td>
</tr>
<tr>
<td>Open</td>
<td>⌘ O</td>
</tr>
<tr>
<td>Close</td>
<td>⌘ W</td>
</tr>
<tr>
<td>Save</td>
<td>⌘ S</td>
</tr>
<tr>
<td>Quit</td>
<td>⌘ Q</td>
</tr>
<tr>
<td>Print</td>
<td>⌘ P</td>
</tr>
<tr>
<td>Select All</td>
<td>⌘ A</td>
</tr>
<tr>
<td>Cut</td>
<td>⌘ X</td>
</tr>
<tr>
<td>Copy</td>
<td>⌘ C</td>
</tr>
<tr>
<td>Paste</td>
<td>⌘ V</td>
</tr>
<tr>
<td>Undo</td>
<td>⌘ Z</td>
</tr>
<tr>
<td>Help</td>
<td>⌘ ?</td>
</tr>
<tr>
<td>Show Tools</td>
<td>⌘ T</td>
</tr>
<tr>
<td>Insert Record</td>
<td>⌘ I</td>
</tr>
<tr>
<td>Next Record</td>
<td>⌘ =</td>
</tr>
<tr>
<td>Previous Record</td>
<td>⌘ -</td>
</tr>
<tr>
<td>Command or Action</td>
<td>Keyboard Shortcut</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>Find</td>
<td>⌘ F</td>
</tr>
<tr>
<td>Match Records</td>
<td>⌘ M</td>
</tr>
<tr>
<td>Define Filter</td>
<td>⌘ K</td>
</tr>
<tr>
<td>Fill Down</td>
<td>⌘ D</td>
</tr>
<tr>
<td>Duplicate Previous</td>
<td>⌘ E</td>
</tr>
<tr>
<td>Draw On</td>
<td>⌘ J</td>
</tr>
<tr>
<td>List View</td>
<td>⌘ L</td>
</tr>
</tbody>
</table>
GLOSSARY

Entry or field entry

The contents of a field for a certain record. An entry can contain nothing (be blank) or it can contain information.

Field

A category of information, such as Item Description, Type, or Features. A field consists of a field name (Item Description) and a field entry (Apple IIe).

Filter

A set of limiting criteria you specify to extract specific information from a database. For example, a filter named Hardware Items might display all the records which have the identifier "Hardware" in the Type field of the database.

Form

A specific layout of information seen in data view or design view. You can have up to 16 different forms associated with a single database document.

Record

All the information about one item. For example, in the Harrington Inventory database, the record includes: the item description, type, DOP, Features, Site License, Average Usage, Software Installed, Peripheral Devices, Curriculum, Student GL, Maintenance, POC, Location, Inv Date and Inv #.

Report

A printed table showing all or part of the information in a Database document. You can arrange fields in any order, add character styles to individual fields, and calculate totals and subtotals. You can have up to 16 different reports associated with a single Database document.

View

One of four ways to look at Database information. The four views are: design view, data view, list view and report view. For entering information into the Database, use data view. For sorting Database information, use list view. For printing a summary of all the records in the Database, use report view.
INDEX

A
alphabetical order 21

B
Border B2-B3

C
Canceling
an action 4
printing 27
Character formatting
font and font size 14-15, B-1
style 14-15, B-1
Clear 19
Close 15, 26
Copying
fields 18, C-1
records 11, 16-19, C1-C2
Criteria, filter 22, GL-1
Cut and Paste Function 18-19, C-1

D
Data View
defined 10-11, B-2, GL-1
entering field entries 16-17
filters 21-22
Navigation tool 14
printing 22, 26
records
deleting 16
designing 17-18
inserting 16
moving within 17
switching views 13-14
tool palette 13-15
Define Filter (Data menu) C-2
Delete Record (Data menu) 16, B-1
Design view
defined 10, B-2, GL-1
fields

E
Editing 17-18

F
Field
adding to database 20
copying 18-19
defined 9, 11
deleting from database 19-20
editing entries 18
entering data 16-17
moving 23
naming 20
File
Harrington Inventory 3, 9-12, 20, 22, 25-26
opening 3
printing 25-26, B2-B3
saving 25
Filter
creating 22
defined 21-22, GL-1
Define Filter C-2
printing 26
saving 25
using tool palette 13-15
viewing filtered records 21-22
Find (Edit menu) C-2
Font and Font Size 14-15, 23, B-1
Form
defined A-1, B-2, GL-1
data view 11, GL-1
design view 10, GL-1
field
adding 20

IN-1
arranging 20, B-1
deleting 9-10
list view 11-12

G

H
Help 4-7, C-1
Hide tools 15
Highlighting 2
Horizontal page orientation 26, B-2

I
Insert Record (Data menu) 16, C-1
Insertion point 18-19

J

K
Keyboard shortcuts C1-C2

L
List view
  copying 18-19
  defined 9, 11-12, GL-1
  deleting elements 19, 20, B-1
  editing entries 17-18
  entering data 16-17
  field width 16
  fields, moving 17
  filters 22
  reports B-1
  Navigation tool 15
  saving 25
  sorting 20-21
  switching views 13, C-2
  tool palette 15

M
Match Records (Data menu) C-2

Moving
  field B-3
  field in report 23
  tool palette 15

N
Navigation tool 14-15
New field 20

O
Online help 3-7
Opening a document 3, C-1
Orientation 26, B-2

P
Page orientation 26, B-2
Page setup 26, B-2, B-3
Paste Function (Edit menu) 17-20, C-1
Previous Record 15, 17, C-1
Print Preview 26
Printing 13, 23-27, B-2, B-3, GL-1

Q
Quitting Microsoft Works B-2, C-1

R
Record
  copying 11-12, 18
  defined 9-11, A-1, B-2
  deleting 19-20, B-1, B-2
  editing 17-18
  filters 21-22
  inserting 16
  matching C-2
  moving within 13-15, 17
  printing 26
  sorting 20-21
  viewing 16
  Record selector box 19
  Report
    arranging 22-23
  IN-2
creating 22
defined 22, GL-1
fields 23
printing 26, B-2
sorting 20-21

Report View
arranging B-3
defined 9, 13, GL-1
filter 22
Navigation tool 15
printing 26, B-2
switching views 13
tool palette 15

S

Saving, a document 25, B-2
Select All (Edit menu) C-1
Show tools (window menu) 15, C-1
Sorting 11, 13, 20-21
Style 14-15, 23, B-1, GL-1
Switching views 9, 13

T

Tool palette
data view 13-14
design view 13-14
filter tool 14-15, 25
Navigation tool 14-16

U

Undo (Edit menu) 4, B-2, C-1

V

Views
data 9-16, 22, 26, B-2, GL-1
described B-2, GL-1
design 9-10, 13-14, 19, B-1, B-2, GL-1
list 9, 11-13, 15-18, 20, 21, 25, B-1, B-2, GL-1
report 9, 13, 15, 22, 26, B-2, B-3

IN-3