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A Model Solution for C31
* Message Translation and Validation

* Abstract:

This document describes an artifact, the Message Translation and Validation
(MTV) model solution. The MTV model solution is a general solution, written in
Ada, that can be used in a system required to convert between different message
representations. These message representations can be character-based, bit-
based, and internal (i.e., Ada values).

This document provides designers with enough information to determine whether
this solution is applicable to their particular problem. It gives detailed designers
the information needed to specify solutions to their particular problem using the
MTV model solution. Finally, it describes the MTV model solution in enough detail
to enable a maintainer or adapter to understand the solution.I
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* 1. Introduction

l

11.1. Purpose

The purpose of this document is to describe an artifact, the Message Translation and
Validation (MTV) model solution. The MTV model solution is a general solution, written in
Ada, that can be used in a system when the system must convert between different
representations of a message. These message representations can be character-based,

bit-based, and internal (i.e., Ada values). This document enables designers to determine
whether this solution is applicable to their particular problem and shows detailed designers
how to specify solutions to their particular problem using the MTV model solution. Finally,
it describes the MTV model solution in enough detail to enable a maintainer or adapter to
understand the solution.

1.2. Intended Audience
i This document was written specifically for developers of software systems in the Command,

Control, Communications, and Intelligence (C3I) domain where there is a need to translate
and validate incoming and outgoing messages. Enough C3I context information is providedLd

so that developers in other domains, where a need to translate and validate messages also
exists, can understand and use the MTV model solution.

The authors assume that the reader has some knowledge of the Ada programming
language [Ada 83] because the MTV model solution is implemented using Ada. The early
chapters of the document support designers and therefore require less Ada knowledge than
the later chapters that are targeted for the detailed designers, implementors, maintainers,
and model adapters.

!
I
I
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I
1.3. Background 3
Work being produced by Software Architectures Engineering (SAE) Project has been
on-going at the Software Engineering Institute (SEI) since 1986 [Leel 88, VanScoy 87, Lee2

89, D'Ippolito2 89, Lee3 88, Plinta 89, D'Ippolitol 893. The primary goal of the project is to

encourage the creation and use of canonical design solutions for typical recurring problems in
an application domain. The MTV model solution is one such canonical design solution to the

message translation and validation problem recurring in the C31 domain.

SAE's involvement in the C31 domain is primarily with the Granite Sentry Program [Goyden
89, GSSDP 89]. The Granite Sentry Program is a phased hardware and software m
replacement of the systems in the Cheyenne Mountain Complex of the North American

Aerospace Defense Command (NORAD). The Air Force Electronic Systems Division (ESD) of
Wright Patterson Air Force Base is the contracting office, and Air Force Space Command of
Peterson Air Force Base is the development office. The MTV model solution is being

incorporated into the current phases of the Granite Sentry Program and several other C31

programs.

This document was initiated by the Domain-Specific Software Architectures (DSSA) Project

at the SEI.

1.4. Reader's Guide I
This document is broken into nine chapters and four appendices. Each chapter is targeted to
a different portion of the software systems development audience (i.e., designers, detailed

designers, implementors, maintainers, model adapters). If the audience is not specified, the
chapter or appendix is of general interest. $
Chapter 1: Introduction

Defines the purpose of the document, the intended audience, and sets the
context for the work documented in this report.

Chapter 2: The Recurring Problem I
Characterizes C31 systems from a message point of view and defines the
MTV problem found in many C31 systems. I

Chapter 3: TV Model Description
Describes the Translation and Validation (TV) model as a black box. It
describes what the TV model does and how to access its capabilities. Th-is
is the model used to solve the message translation and validation
problem.

Chapter 4: MTV Model Description
Analyzes the MTV recurring problem with respect to the TV model.
Instances of the model are generated to solve the problem, and these
instances form the MTV model. This chapter is targeted for a designer
responsible for designing the system. The designer needs a pool of models
from which to choose solutions to populate the design space. These I
solutions need to be documented such that the system designer can make
educated decisions when selecting particular models.

2 CMU/SEI-89-TR-12
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Chapter 5: MTV Model Solution Overview
Provides an overview of the MTV model solution. This overview is needed
by the designer to understand, at a high level, the consequences of
choosing this MTV model solution. The overview is also provided for the
detailed designer, implementor, maintainer, and model adapter as an
introduction to the MTV model solution.

Chapter 6: MTV Model Solution Application Description
Describes how to apply the MTV model solution that is described in
Chapter 7 to the message translation and validation requirements of a
particldar application. This chapter is targeted for the detailed designers
respor sible for specifying (and actually in this case implementing) all
software for translating and validating messages.

Chapter 7: MW Model Solution Description
Describes the internals of the MTV model solution and exactly how the
model solution provides the capabilities described in Chapter 4, MTV
Model Description. This chapter is targeted for the maintainer and the
model adapter, that is, those responsible for understanding the
implementation of the system for either maintenance purposes or for the
purpose of adapting the model for use in a particular application for
which the current state of the model solution does not suffice. Adaptation
may be necessary because of efficiency problems (size and speed) or
because of the need for additional functionality.

Chapter 8: MTV Model Solution Adaptation Description
Describes how to adapt the MTV model solution described in Chapter 7.
This chapter is targeted for the model adapter.

Chapter 9: Open Issues
Describes issues that may need to be addressed by the designer and
model adapter.

Appendix A. Definitions
Contains a glossary of the terms and acronyms used throughout the
document. Terms defined in this appendix are bold and italicized the
first time they appear in the document.

Appendix B: Detailed Description of the Templates
A reference manual for MTV model solution application. It describes how
to apply all templates individually in detail. This appendix is targeted for
the detailed designer.

Appendix C: MTV Model Solution Ada Code
Contains the Ada code that comprises the MTV model solution. Appendix
C is self-contained.

Appendix D: FooBar Message Ada Code
Contains examples instances of the MTV model solution. The same
example is used throughout the document. Appendix D is self-contained.

!I
I
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* 2. The Recurring Problem

N
IThis chapter briefly describes the C3I domain, the role of messages in it, and the recurring

message translation and validation problem found in it. This chapter sets the context for the3 remainder of the document to discuss the MTV model solution.

2.1. Characteristics of the (0I Domain

A C3I system accepts messages (information) that describe a view of the world as seen by
other systems (sensors, electronic, human, etc.). The C3I system transforms these sensor

views into an internal view. The internal view is used to update the system's view of the
world. It allows the users to examine a portion of the world view in a manner that is
understandable to them. The C3I system or user can also react to new information and send

information about a particular view of the world back out to other systems. It allows for
interactive entry of messages and correction of errant messages. It allows for the recovery of
journalled messages for analysis purposes, and for the generation of simulation scripts (i.e.,

messages) for training and system testing purposes.

Figure 2-1 is a high-level block diagram of a typical C31 system. The following paragraphs

describe the entities shown Figure 2-1. These entities are italicized in the text.

The Gateway sends/receives messages to/from all systems external to the C3 I system. The
Gateway is an interface between the C31 system and all other systems. Messages
(information) are communicated between the systems. The messages enter and leave the C31

3 system as external representations of the information whose formats are defined by the other

systems.

The Mission Processor maintains a view of the world based on the views (external

representations) provided by the other systems. This world view is kept in an internal
representation to allow processing of the information based upon the C3I systems mission
requirements. This view is available to other systems via external representations of the

information and to the user via user representations of the information.

3 CMU/SEI-89-TR-12 6
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The User I/F (user interface) provides a window into the Mission Processor's view of the
world. It presents the information about a user-selectable view in a manner that is
understandable to the user. The user can also add information to the Mission Processor's
view of the world. The messages enter and leave the User I/F as user representations of the
information whose format is understandable to the user.

Finally, the Journal is a storage device used for "safe" storage of all representations of
messages for recovery, analysis, and testing purposes.

The different representations of a message are discussed in more detail in the next sections. 3
General system constraints that are normally placed on the described C3I system can be
summarized as follows:

" C3I systems tend to consist of distributed processors upon which the rmquired
functionality must be allocated.

* C3I systems tend to have soft real-time processing requirements for processing a 3
message and getting the information to the user.1

a CI systems also need to keep journal entries of messages off-line for recovery,

Ianalysis, and simulation purposes.

I
I
I

I
I

I

1Timing requirements tend to be on the order of second to process a memage. The peak load of messages to be
procesmsd per second varies.

6 CMU/SEI-89-TR.-12 3
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2.2. Messages in the C31 Domain

A message is defined as pieces of related information. Based on the characteristics of
systems in the C3 I domain, messages need to be expressed in three forms:

1
1. external representation

2. internal representation
3. user representation 3

Conversion between these forms of a message must be provided. These forms are described

in detail in the following sections. 3
2.2.1. External Message Representation
An external representation (EXR) of a message is a string.2This representation is received

fror (or sent toD systems outside the C3 1 system being developed. The string is normally
cryptic for the purpose of facilitating fast communications. The string contains multiple
fiels, each of which contains the related information in the message. The fields can be
separated by punctuation or be in a fixed position in the string. The fields in the string can
be interpreted as ASCII character strings or bit strings.

An external representation description (EXR description) is a textual description of the
external representation of a message. It defines the size and location of the fields and

punctuation. It also describes the information found in the message and how to interpret the I
information. The EXR description is normally defined outside the scope of the C3I system
being developed and becomes part of the requirements levied upon the C31 system. An EXR

description exists for each message that the C3I system is required to process. Figure 2-2 is I
an example of a textual EXR description. Note that all fields in this EXR are
character-based. This example will be used throughout the document. 3
Figure 2-3 is an example of a message described by the EXR description shown in Figure 2-2.

String values a field can contain are called symbolic images. Symbolic images encode 3
information of a given field. For example, the Direction field shown in Figure 2-2 has a set of
valid symbolic images associated with it: the ASCII characters "N", "S", "E", and "W". The

meaning or value of the symbolic images is North, South, East, and West.

Other characteristics of fields include recurrence of fields in a message set and possible

varying length fields. Varying length fields result from the field being null (i.e., not present) I
or a variable length symbolic image. These characteristics of a field are discussed in detail in
the context of the model solution in Chapter 6.

2A string is defined an a contiguous set of byte. that can be interpreted as ASCII characters or bit streams. i

8 CMU/SEI-89-TR- 12 5
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FooBar Message Format
Field Field Size Range of

Number Field Name (chars) Values Amplifying Data

1 Reporting Location 3 KJL Andrews AFBCPP Peterson AFB
MMR Wright Patterson AFB

Field Separator 1 <cr> Carriage Return

2 Direction 1 N North
S South
E East
W West

3 Date/rime Group Julian Date & Time
3 001-366 Julian Day
2 00-23 Hours
2 00-59 fMinutes

Field Separator 1 Slash

4 Status 1 0 Operational
1 Non-Operational

End-of-Message 1 <cr> Carriage ReturnI
Note: If the Status field indicates Non-Operational, then the Date/Time Group field must

have a value indicating January 1 at 12:00 am (i.e., "0010000").

Figure 2-2: Example Char-Based EXR Description: FooBar Message

I "CPP<cr>Z1831407/O<cr>"

I Figure 2-3: Example Char-Based E FooBar Message

I
I

I
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Messages also have associated with them the notion of validity. There are three concepts
involved with message validity:

- intra-field validity The symbolic image in a field is in the range of valid symbolic
images specified in the EXR description for that field. For example,
valid symbolic images for the Direction field show in the EXR
description in Figure 2-2 are the ASCII characters "N", "S", "E",
and "W".

inter-field validity The symbolic images of interdependent fields conform to constraints
that are specified in the EXR description. For example, the note
specified in the EXR description in Figure 2-2 states that if the
Status field is an ASCII character "1", then the Date/Time Group
field must be exactly the following ASCII characters, "0010000". If
not, the message is not valid.

inter-message validity
The message received is not a redundant message or a message
whose time tag is older than a previously received message. 3

Figure 2-4 shows an example of an EXR description whose fields are bit-based. Notice that

there are two parts to the description. The first deals with the field information descriptions:
the number of bits a field occupies and the meaning of various bit patterns. The second part
deals with the organization of the fields in the message string (i.e., bit positions). For

example, bits 0-1 of word 1 are the most significant bits of the Julian Day, bits 0-5 of word 2
are the next set of significant bits of the Julian Day, and bit 5 of word 3 is the least
significant bit of the Julian Day. Figure 2-5 shows an example EXR of the bit-based EXR

description in Figure 2-4. The values are the same as in Figure 2-3.

I
U
I
I
I
I

37Te model solution described in this document does not address the problem of inter-message validity. The C3I
system must provide this functionality.

10 CMU/SEI-89-TR-12 5
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FooBar Bit-Based Message Format
Field Field Size Range of

Number Field Name (bits) Values Amplifying Data

1 Reporting Location 2 1-3 1 - Andrews AFB
2 - Peterson AFB
3 - Wright Patterson AFB

2 Direction 2 0-3 0 - North
1 - South
2 - East

I_ 3 - West

3 Date/Time Group Julian Date & Time
9 001-366 Julian Day
5 00-23 Hours
6 00-59 Minutes

4 Status 1 0-1 0 - Operational3 Status 1 0-1 1 - Non-Operational

Note: If the Status field indicates Non-Operational, then the Date/Time Group field must

have a value indicating January 1 at 12:00 am.

U

3 FooBar Bit-Based Message Data ro-mat

Byte Bits

I MSB LSB
7 6 5 4 3 2 1 0

------------------------------------------------
1 * * { 1 } { 2 ) {3.day}

2 * * { 3.day }

3 .day) { 3.hour

4 * 3.minute } {4)

* = Bits that have no meaningI
Figure 2-4: Example Bit-Based EXR Description: FooBar Message

1I
3 CMU/SEI-89-TR- 12 1
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2.2.2. Internal Message Representation
An internal representation (INR) of a message, for the purpose of this solution, is an Ada I
typed value. This value is used internal to the C3I system being developed for processing

and analysis purposes. The value is based on the information contained in a message and is

a more natural representation of the information than the EXR. The value is of an Ada I
composite type containing elements that group the information in the message. There is at

least one element for each field in the EXR. The types of the elements can be Ada discrete

types or Ada composite types.4

The purpose of the INR is to allow the information to be organized in a manner that is

usable, natural, and efficient to the implementor and not constrained by the format of the m
message as specified by the EXR description. It also allows the information in the message

to be processed and analyzed by the C31 system for presentation to the user or to be sent to 3
other systems.

An internal representation description (1NR description) is the set of Ada type

declarations needed to define an internal representation of a message. The Ada types areI

defined by the detailed designer and are part of of the detailed design specification. Each

Ada type defines the type for one of the elements. An INR description must exist for each
message to be translated and validated.

Figure 2-6 is an example of an INR description corresponding to the EXR descriptions shown
in Figure 2-2 and Figure 2-4. This example is used throughout the document. Figure 2-7 is

an example the INR described by the INR description in Figure 2-6.

An assumption made by the model solution described in this document is that the INR is
always valid as defined by the Ada types. Once an INR of a message exists, the Ada runtime

(or application) will assure its validity at the intra-field level, and the application will assure 3
validity at the inter-field and inter-message level.

The descriptions of external message representations and internal message representations

begin to define the initial part of the problem, i.e., being able to convert between the EXRs

and the INRs of a message.

I
I

'Type. of the elements can also be fixed or floating point The MTV model solution does not address them. See

Chapter 8 for more details on how the solution can be extended.

12 CMU/SEI-89-TR-12 3
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bytel: 00101001
byte2: 00011011
byte3: 00101110
byte4: 00001110

I Figure 2-5: Example Bit-Based EXRL FooBar Message

U
type Reporng_LocatonType is (Andrews_AFB, PetersonAFB, Wright PattersonjAFB);

* -2
type DirectionType is (North, South, East, West);

-3
subtype JulianDayType is Integer range 1.. 366;
subtype Hour-Type in Integer range 0 .. 23;

subtype Minute-Type is Integer range 0 .. 59;

type Julian.DateTimeRecordType is record

JulianDay: JulianDayype;
Hour: HourType;
Minute : MinuteType;f eand record;

-- 4
type Statu-aType is (Operational, NonOperational);

type FoobarMessageType is record
Reporting-Location : ReportingLocationType; -1
Reporting-Direction: Diretion.Type; -2
ReportingTime : JulianDate_Time_Record_Type; -3
ReportingStatua : StatuaType; -4

end reeord;

1 Figure 2-6: Example INR Description: FooBar Message

I
FoobarMerage: FoobarMessage .Type:=(

ReportingLocation => PetersonAFB,
RsportingDirection=> East,
Reporting-Time =>(

Julian-Day => 183,
Hour => 14,
Minute => 7),

Reportng_Status => Operational);!
Figure 2-7: Example INR FooBar Message

15 CMU/SI-89-'TR 12 13
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2.2.3. User Message Representation

Finally, because information must be presented to the user of a C31 system, and information I
must be obtained from the user, we also need a user representation (USR) of the
information. This representation is a user-readable, fixed-length character string
representation of the information.

The purpose of the USR is to support the presentation of the information in a manner that is
natural to the user and is not constrained by the EXR. The USR supports the interactive
portions of the C31 system requirements. Figure 2-8 is an example of a USR of the message
described by the INR description shown in Figure 2-6. 3

Peterson AFB Last 183 14 7 Operational"

Figure 2-8: Example USR FooBar Message 3
The USR is derived from the INR. Because of this the USR is broken up into elements, one

for each element of the INR. We call these elements of the USR natural images because I
they are more natural representations of the information than those found in the EXR. For
example, the DLrection element shown in the INR description in Figure 2-6 has a set of valid

natural images associated with it, the ASCII character strings "North", "South", " East",
and " West". The meaning or value of the natural images is North, South, East, and West.

The natural images in the USR are images of the INRs shown in Figure 2-6. Although this 3
does not look extremely user readable, it is more so than the EXR, which relies on symbolic
images. How the USR in our model solution supports a user interface is described in more

detail in Chapter 7.

The description of the user message representation defines the final part of the problem, i.e.,
being able to convert between the USRs and the INRs of a message.

II
I
I
I
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2.3. The MTV Recurring Problem

U The different representations of a message described in the previous sections are

representations that a C31 system receives or produces. All three representations are3 necessary for the C3I system to function properly.

The recurring problem becomes evident when we realize that aU messages that the

application must translate and validate must be representable in these forms.

We can therefore summarize the MTV recurring problem requirements. These are defined in
two parts. The first part contains the functional requirements levied upon a solution, and

the second part contains software engineering requirements placed upon the solution.

3 To meet the functional requirements imposed by C31 systems in general, a solution must:

1. Support these real-time activities:

a. Translation and validation of external message representations to
internal message representations.

b. Translation of internal message representations to external message
representations. Validation of internal message representations is the
responsibility of the C3I system.

c. Translation and validation of all message representations to support
writing to a journal.

2. Support these non-real-time activities:

a. Generation of external message representations to support simulation
scripts for training purposes.

b. Generation of all message representations to support system testing.

c. Translation and validation of all message representations to support
reading from a journal.

3. Support these interactive activities:

a. Translation and validation of external message representations to
internal message representations (and vice versa) to support manual
entry of information and presentation of invalid information to allow
correction of the invalid information received.

b. Translation and validation of user message representations to internal
message representations (and vice versa) to support manual entry of
information along with presentation of invalid information to allow
correction of the invalid information received.

To meet the imposed software engineering and implementation requirements a solution

must:

1. Reuse design concepts and implementations (i.e., use a modeling approach).

2. Provide Ada code generation capabilities through the use of Ada generics and
Ada coding templates, and incorporate testing as part of the templates.

3. Use good software engineering practices (e.g., information hiding, abstraction,
separation of concerns).

3 CMU/SEI-89-TR-12 15
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1 3. TV Model Description

U
This chapter describes the Translation and Validation (TV) model as a black box. It
describes what the model does (not how it does it) and how to access the capabilities provided
by the model.

This model is described because it is used to solve the message translation and validation
recurring problem described in Chapter 2. It can also be used to extend the solution or as a
building block to other solutions.

1 This information allows a designer to evaluate the model in the context of the functional
requirements for which a solution is being sought.I
3.1. Functional Description

The TV model provides two abstractions of some information: a primary representation and a
secondary representation. The TV model provides the capability to convert between a
primary and a secondary representation. The conversion entails a real-time validation of the
conversion. The validation is real-time in the sense that if a problem is found, the conversion
process is stopped, and the caller is notified.

3 The primary representation is a representation of some information upon which the
conversion is based. Objects of a primary representation are assumed to always be valid
therefore no checking of this representation is needed. The secondary representation is
another representation of the same information provided in the primary representation.

The model also supports a diagnostic, non-real-time analysis of the secondary representation.
A diagnostic indicator is returned that supports error detection for secondary representations
of a message.

3 Figure 3-1 shows a black box diagram of the TV model. The next section describes the
interface shown in the black box in more detail.

1

3 CMU/SEI.89-Tr- 12 17
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Sec.. ....... Invalid Rep I
d el. '!

PrimaryUPePu ague Secondary. Re

Validity Indicatol

-Secondary Rep

Figure 3-1: TV Model Black Box Diagram I

3.2. Interface Description I

Figure 3-2 shows the interface provided by the TV model expressed as incomplete Ada PDL.5

The parts of the PDL that are bold, italicized, and boxed represent those parts of the

model that are adjustable based upon the nature of the primary and secondary

representations. The model exports a primary representation (PrimaryRep) and a
secondary representation (Secondary-Rep). The primary representation is the base
representation from which a mapping to the secondary representation is defined. This
mapping is defined in The.Map. The primary representation description
(PrirnayRepDescr) describes the format of the primary representation and the secondary
representation description (Secondary_Rep_Descr) describes the format of the secondary
representation.

The Image function provides the capability to convert from a primary representation to a
secondary representation. Conversely, the Value function provides the capability to convert
from a secondary representation to a primary representation. If either conversion fails, the
InvalidRepresentation exception is raised. These operations provide real-time validation

Iand conversions.

"Ada PDL (Program Design Language) is provided to show that the TV model is more than a concept. The model
can be specified and implemented in Ada.
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The Check function provides the capability to check the secondary representation for validity,

based on the legal values specified by the primary representation. The Check function
returns a validity indicator that provides diagnostic support to indicate the invalid fields.
This operation supports non-real-time diagnostic analysis of secondary representations.

3.3. Style Characteristics

The Image and Value functions are complementary translation and vplidation operations,

and the Check function is a diagnostic analyzer. All functions are independent, separate,3 autonomous, and designed to be re-entrant.

The designer has Ledom in selecting the primary and secondary representations but must
tailor the model to allow translation and validation to occur. An important part of the

tailoring process is specifying a mapping between the two representations. The Value,
Image, and Check functions depend upon this mapping to provide their functionality.

A small set of simple concepts are provided by the model. Once these concepts are

understood, the functionality that the model provides and the means of accessing the3 functionality are easily understood.

1
I
I
I
I
I
U
I
I
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package Secondary Rep_TV is

-- Primary Representation Description and Primary Representation type

Primary_RepDescr Note 1

type Primary_Rep is Note2

-- Secondary Representation Description and Secondary Representation type

Secondary_Rep_DescrF i I
Secondary_Repidth : constant Integer := [ m

type SecondaryRep is array (1..Secondary_RepWidth) of Bytes;

-- Mappin between Primary Representation and Secondary Representations
TheMap N 4

-- Functions for converting between primary and secondary representations
function Image(ValueIn : Primary_Rep) return SecondaryRep;
function Value(Image_In : SecondaryRep) return Primary_Rep;

-- Function for checking the validity of a secondary representation 5
type ValidiLty_Indicator is

function Check(Image_In : Secondary_Rep) return ValidityIndicator;
-- Indicators of a valid or inconsistent secondary re resentation
ValidSecondary_ p : constant Validity_jndicator := Note5
InValid_SecondaryRep : constant Validity_Indicator = Note5
InconsistentSecondary_Rep : constant Validity_Indicator = t5

-- Real-time constraint raised by Value and Image functions
InvalidRepresentation : exception;

end SecondaryRepTV;

NOTES:
These notes describe the items boxed in the PDL The items should be tailored by the model adapter to meet I
the specific translation and validation requirements imposed by the two different representations.

Note 1: PrimryRepPescr describes the element(s) of the primary representation.
Note 2: PrimaryRep is an Ada type used to declare objects to hold primary representations. The I

format of the objects is based upon the PimaryRep.Descr.

Note 8: SecondaryRepDecr describes the position of the element(s) of the secondary
representation. SecondaryRepWidth defines the length of the secondary representation I
and must be consistent with the Secondwyfep_Dsscr.

Note 4: TheMap defines the one-to-one mapping between primary representations and secondary
representations.

Note 5: Voliditylndicator is a type that describes the validity indicators VaidSecondaryRep,
InValid-SecondaryRep, and JnconsistentSecondaryRep.

Figure 3-2: Interface Provided by TV Model (Incomplete Ada PDL)
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4. MTV Model Description

I
This chapter analyzes the message translation and validation recurring problem (described
in Chapter 2) with the intent of applying the TV model (described in Chapter 3) to solve the
problem. The result is a description of the MTV model.

4.1. MTV Problem Analysis

3 Examination of the functional requirements of the MTV problem indicate that the following
translation and validation relationships must exist in the MTV model:

1. Conversion between external representations (EXR) and internal
representations (INR) of a message.

2. Conversion between internal representations (INR) and user representations3 (LTSR) of a message.

As a goal, we did not want to tie the detailed designer's specification of the INR description
(Ada type) directly to the EXR description that is part of the requirements levied upon the
C3 1 system. Based on further examination of formats of the predefined EXR descriptions and
definitions of INR descriptions proposed by detailed designers, we saw the need to introduce3 another message representation, the universal representation (UNR).

A UNR is an intermediate representation of the information in a message. It is a
fixed-length string containing a symbolic image in a predefined place for each field in the

EXR with the punctuation removed. The symbolic images of character-based fields that are
of varying length, null, or optional are expanded to their maximum length and padded with
blanks. The symbolic images of bit-based fields are expanded to a length of multiples of one

byte (i.e., a bit-based field of four bits is expanded to one byte, and a bit-based field of 12 bits
is expanded to two bytes). Also, the symbolic images are cut (rearranged) to match the INR,
if necessary. Figure 4-1 is an example of a UNR of the FooBar message described in Chapter
2.

3 The introduction of the UNR stems from our desire to eliminate the dependency of the INR
description of a message from the format of the corresponding EXR description. Both
representations should contain the same information, but in their own format. The UNR

3 CMU/SEI-89-TR-2 21
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contains the information as symbolic images as defined by the EXR, but the symbolic images
are in the order defined by the INR.

"CPPE18314070"

Figure 4-1: Example UNR. FooBar Message 3
Finally, the UTNR description is derived from both the EXR description (as shown in Figure
2-2) and the INR description (as shown in Figure 2-6). 3
Therefore, the MTV model contains three instances of the TV model:

1. External Representation TV Model - Conversion between EXRs and UNRs

of a message.

2. Universal Representation TV Model - Conversion between UNRs and INRs
of a message. I

3. User Representation TV Model - Conversion between USRs and INRs of a
message. 3

Each instance of the TV model is described as a black box, similar to the way the TV model
was described. The description first tells what the TV model instances do (but not how they

do it). Next, it describes how to access the capabilities provided by the TV model instances. I
This is done by building upon the incomplete Ada PDL of the TV model.6 The adjustable
parts of the TV model are further refined to handle the primary and secondary

representations of the three instances defined.7 Those parts of the Ada PDL that still need I
to be tailored to instantiate an implementation of the particular model are
bold' itaUcized, and boxed 3

The MTV model is formed by integrating the TV model instances. Figure 4-2 shows how the
primary and secondary representations supported by each TV model instance allow the 3
instances to be integrated to meet the MTV requirements described in Chapter 2.

Finally, conversion between EXRs and INRs; EXRs and USRs; and UNRs and USRs are not 3
directly supported because they are not part of the required functionality as described in
Chapter 2. Although, the conversions are supported indirectly as a multiple step process.

U
6Ara PDL is provided to show that the TV model is more than a concept. The model can be specified and 3

implemented in Ada.
7Because the instances are customized, each begins to use predefined common Ada types whose definitions can be

found m the package Ct_.Comafon_.Typ.. (CCT) in Appendix Section C. 1.
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4.2. External Representation TV Model

4.2.1. Functional Description
The EXR TV model provides the capability to convert between the EXR of a message (as
shown in Figure 2-3) and the UNR of a message (as shown in Figure 4-1). The conversion U
entails a real-time syntactic check of the message based on the EXR description. For
example: if a field or punctuation is missing, or if a field is the wrong length, the conversion
process is stopped and the caller is notified. The model also supports a diagnostic, I
non-real-time syntactic analysis of EXRs. A diagnostic indicator is returned that supports
error detection for EXRs of a message. 3
Figure 4-3 shows a black box diagram of the EXR TV model. The next section describes the
interface shown in the black box in more detail.

Constraint Error~

ModelUniversal Rep

External Rep
: V e l Ex trnal ReD

Universal ReripI
ImageValidit Indicator

External Rep

Figure 4-3: EXR TV Model Black Box Diagram3

4.2.2. Interface Description
Figure 4-4 shows the interface provided by the EXR TV model expressed in incomplete Ada I
PDL. The model is represented as an Ada package, ExternJ..RepresentationTV. The
package exports the following abstractions. I
The EXR?_Descr, a codification of the textual description of the EXR of a message (as shown
in Figure 2-2), is supplied by the detailed designer for each message. Figure 6-3 shows an

example of how the textual EXR description of the Foobar message is codified for the model I
solution described in this document. This is discussed in more detail in Chapter 6, MTV
Model Solution Application Description. EXRs are stored using the EXR type. UNRs are

stored using the UNR type.
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The Image function provides the capability to convert, in real-time, from a UNR of a message

to an EXR of a message. Conversely, the Value function provides the capability to convert, in
real-time, from an EXR of a message to a UNR of a message. If either conversion fails, the3 Constraint_Error exception is raised.

Finally, the Check function provides the capability to check an EXR of a message for
syntactic correctness based on the EXR description defined in EXR_Descr. In the case of an

invalid EXR, the Check function returns a validity indicator that points to the invalid field.

By definition, the EXR of a message contains fields that are an aggregation of the

information in the message. These fields are accessed by obtaining positional information
with respect to a particular field from the EX&_Descr. The array Cuts is also defined by the
detailed designer and describes how repetitive information in the EXR of a message should

be partitioned to provide a more natural view based on an INR description (as shown in
Figure 2-6). Also, by definition, the TJNR of a message contains elements that are an
aggregation of the symbolic images of each of the fields contained in the EXR. These
elements are accessed via a combination of the positional information obtained from the
EAR_Descr and Cuts.

I
I
I
I
I
I
I
I
I
I
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with Casting_C-on_Types; -- renamed as CCT U
package ExternalRepresentationTV is

-- EXTERNAL REPRESENTATION
-- Ma-i--u width of the EXR and st~ type to it.3
XRWidth : constant Integer :=

subtype 1XR is CCT.Byte_Array (1..gXR_Width);

-- Describes each field in the message as per the 1XR textual description

type rield-Names is

1XR_Descr : array (FieldNames) of CCT.rieldDescription_Type : [ote3; I
-- UNIVERSAL REPRESENTATION

-- Width of the UNR and string type to hold it.

UNR Width : constant Integer Note4;

type UNR is CCT.Byte_String (1..UNRWidth); 3
-- Describes any reorganization of repetitive info*ation

Cuts : array (NumberOfCuts,2) of FieldNamaes := I
-- CONVERSION AND VALIDATION FUNCTIONS

-- Functions for converting between EXRs and UNRs
function Image (ValueIn in UNR) return EX;
function Value (ImageIn in 1XR) return UN;

-- Function for checking the validity of a 12CR
procedure Check (Image In : in 1XCR

Validity_Indicator : out Boolean,
Bad Position : out Integer);

-- Real-time constraint raised by Image and Value functions
Co'straint Error : exception;

end ExternalRpresentationTV; 3
NOTES:

Thes notes describe the items boxed in the PDL. The items must be tailored by the detailed designer for each

instance of the EXR TV model. There will be one instance for each mesage.

Note 1: EXRWidth defines the maximum width of the EXR of a particular message. U
Note 2: FisidNe, is an enumerated type whose literals name the fields as described in the

textual EXR description.

Note 3: EXRJDeacr in an array indexed by FieidNames. Each element of the array describes an
individual field as per the textual EXR description. Each element also contains
information regarding the positions of each elemental symbolic image in the UN.

Note 4; UNRWidth defines the width of the LTNR of a particular menage. 3
Note 5: Cuts defines the repetitive fields that are to be reordered. Each cut is defined as a starting

field and stopping field.

Figure 4-4: EXR TV Model Interface (Incomplete Ada PDL)
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3 4.3. Universal Representation TV Model

4.3.1. Functional Description
The UNR TV model provides the capability to convert between the UNR of a message (as
shown in Figure 4-1) and the INR of a message (as shown in Figure 2-7). The conversion
entails a real-time validation of the conversion that includes syntactic analysis of the range3 of values possible for the elements and checking of any inter-element dependencies. If a
problem is found, the conversion process is stopped, and the caller is notified. The model also
supports a diagnostic, non-real-time syntactic analysis of LUNRs. A diagnostic indicator is3 returned that supports error detection for UNRs of a message.

Figure 4-5 shows a black box diagram of the UNR TV model. The next section describes the5 interface shown in the black box in more detail.

I

Io:i Constraint Error,uNR TV-
3--Internal ReD

-Universal Reo3 V aue :Universal Reo

Internal Rep
m ave. p Validity Indicator

Universal ReD

3 Figure 4-5: UNR TV Model Black Box Diagram

4.3.2. Interface Description
Figure 4-6 shows the interface provided by the UNR TV model expressed in incomplete Ada
PDL. The model is represented as an Ada package, Universal.epresentation_TV. The3 package exports the following abstractions.

The 1NR type is specified by the detailed designer and is the LNR description for a message
(see the FooBar_MessageType in Figure 2-6). INRs are stored using the INR type. UNRs
are stored using the UNR type.

I
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The Image function provides the capability to convert, in real-time, from an INR of a

message to a UNR of a message. Conversely, the Value function provides the capability to
convert, in real-time, from a UNR of a message to an INR of a message. If either conversikn

fails, the ConstraintError exception is raised. 3
The Check function provides the capability to check, in non-real-time, the UNR of a message
for syntactic correctness based on the legal values specified by the INR description and any

inter-element consistency checks based on the textual EXR description.

In the case of an invalid indication, the Check function returns indicators that point to the

invalid fields. ValidUNR and Inconsistent.UNR are indicators that specify the validity of
the UNR of a message as analyzed by the Check function. If the Check function returns
something other than the above two indicators, it is assumed to be an InvalidUNR. 3
By definition, the INR of a message contains elements that are an aggregation of the
information in the message. These elements are accessed by using named association on the

INR (an Ada composite type). Also, by definition, the UNR of a message contains elements
that sae an aggregation of the symbolic images of each field contained in the EXR. These

elements are accessed via UNR_Descr. This array defines the positions in the UJNR of each

element's symbolic image. This abstraction also provides access to the results of the Check
function that allows an application to determine the validity of individual elements of a

UTNR.3

I

I
I
I

I
I
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with Casting_Common_Types; -- renamed as CCT
package Universal_Representation TV is

I -- INTERNAL REPRESENTATION

type INR is

I -- UNIVERSAL REPRESENTATION
-- Width of the UNR and string t to hold it.

UNR_Width : constant Integer :=

type UNR is CCT.Byte_Array (I..UNRWidth);

-- Elemental symbolic im epsitional information.5type ZlementNames is 1M ;

UNRDescr is array (ElementNames) of CCT.PositionType

I -- CONVERSION AND VALIDATION FUNCTIONS
-- Functions for converting between UNRs and INRs
function Image (ValueIn : in INR) return UNR;
function Value(Image_In : in UNR) return INR;

-- Function for checking the validity of a UNR
subtype ValidityIndicator is UNR;
function Check(Image_In - in UHR) return Validity_Indicator;
-- Indicators of a valid, or inconsistent UNR

Valid UNR : constant ValidityIndicator :z INote 5

IInconsistent 011K: constant Validity_Indicator :

-- Real-time constraint raised by Image and Value functions

ConstraintError : exception;

end UniversalRepresentationTV;I
NOTES:

These notes describe the items boxed in the PDL The items must be tailored by the detailed designer for each

instance of the TNR TV model.

3 Note 1: LNR is an Ada type that defines the INR description for a particular message. It also is

used to define objects that hold IN% of the information in a particular message.

Note 2: UNR Width defines the width of the TNR for a particular message.

Note 3: Elamentnames is an enumerated type whose literals name the elements described in IVR
and UNRDeacr.

Note 4: UNR_Decr is an array indexed by ElementJames. Each element of the array describes
the position of an elemental symbolic image in the UNI.I Note 5: The validity indicators Valid_UNR and JnconistentUNR are defined as the aggregation
of the validity indicators of the elemental symbolic images. Elemental symbolic image
validity is defined by the constants CCT.Voiid_Symboliclmage,
CCT.InvaidSymboic _mage, and CCT.lnconsistentSymbolicImage.

Figure 4-6: UNR TV Model Interface (Incomplete Ada PDL)5 CMU/SEI-89-TR12 29
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4.4. User Representation TV Model

4.4.1. Functional Description I
The USR TV model provides the capability to convert between the USR of a message (as
shown in Figure 2-8) and the LNR of a message (as shown in Figure 2-7). The conversion 3
entails a real-time validation of the conversion that includes syntactic analysis of the range
of values possible for the elements and checking of any inter-element dependencies. If a
problem is found, the conversion process is stopped, and the caller is notified. The model also I
supports a diagnostic, non-real-time syntactic analysis of USRs. A diagnostic indicator is
returned that supports error detection for USRs of a message. 3
Figure 4-7 shows a black box diagram of the USR TV model. The next section describes the
interface shown in the black box in more detail.

Constraint Error

Model nInternal ReD

User ReD
VatuUser Ren

Internal ReD5
1maValidit lndIcatot6.

User Rep ck

Figure 4-7: USR TV Model Black Box Diagram

4.4.2. Interface Description
Figure 4-8 shows the interface provided by the USR TV model expressed in incomplete Ada 5
PDL. The model is represented as an Ada package, UserRepresentationTV. The package
exports the following abstractions.

The DM type is specified by the detailed designer and is the INR description for a message
(see the FooBar._MessageType in Figure 2-6). INRs are stored using the INR type. USRs
are stored using the USR type. 3

3
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The Image function provides the capability to convert, in real-time, from an INR of a
message to a USR of a message. Conversely, the Value function provides the capability to
convert, in real-time, from a USR of a message to an INR of a message. If either conversion3fails, the ConstraintError exception is raised.

The Check function provides the capability to check, in non-real-time, the USR of a message
for syntactic correctness based on the legal values specified by the INR description and any
inter-element consistency checks based on the textual EXR description.

In the case of an invalid indication, the Check function returns indicators that point to the
invalid fields. Valid_USR and InconsistentUSR are indicators that specify the validity of
the USR of a message as analyzed by the Check function. If the Check function returns
something other than the above two indicators, it is assumed to be an InvalidUSR.

By definition, the INR of a message contains elements that are an aggregation of the
information in the message. These elements are accessed by using named association on the
INR (an Ada composite type). Also, by definition, the USR of a message contains elements
that are an aggregation of the natural images of each element of the INR. These elements
are accessed via USR_Descr. This array defines the positions in the USR of each element's
natural image. This abstraction also provides access to the results of the Check function that
allows an application to determine the validity of individual elements of a USR.

1
I
I
I
I
I
I
I
I
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with Casting_CoronTypes; -- renamed as CCT I
package UserRepresentationTV is

-- INTERNAL REPRESENTATION 3
type INR is [otel;

-- USER REPRESENTATION 3
-- Width of the USR and string type to hold it.

USRWidth : constant Integer :-

type USR is String (1..USRWidth);

-- Elemental natural image positional information.

type ElentNames is dNote3),
USRDescr is array (ElementNames) of CCT.Position_Type :=

-- CONVERSION AND VALIDATION FUNCTIONS I
-- Functions for converting between USRs and INRs
furction Image(ValueIn : in INR) return USR;
function Value (Image In : in USR) return INR;

-- Function for checking the validity of a USR
subtype ValidityIndicator is USR;
function Check (Image_In - in USR) return ValidityIndicator;
-- Indicators of a valid, or inconsistent USR

Valid USR : constant ValidityIndicator := Note 5

InconsistentUSR : constant ValidityIndicator :-

-- Real-time constraint raised by Image and Value functions
ConstraintError : exception;

end UserRepresentationTV;

NOTES:
TemS notes describe the items boxed in the PDL The items must be tailored by the detailed designer for each 5
instance of USR TV model.

Note 1: /NR is an Ada type that defines the INER description for a particular message. It also is I
used to define objects that hold INR of the information in a particular message.

Note 2: USRWidth defines the width of the USR for a particular message.

Note 8: ElementNamea is an enumerated type whose literals name the elements described in NR
and USR.ever.

Note 4: USRJDescr is an array indexed by Elwnent.Nam. s. Each element of the array describes
the position of a elemental natural image in the US.

Note 5: The validity indicators ValidUSR and InconsiutenLUSR are defined as the aggregation of
the validity indicators of the elemental natural images. Elemental natural image validity
is defined by the constants CCT.ValidNaturotl-lmq, CCT lnvalidNaturalInwge, and
CCT.InconsitentuNaturaljmage.

Figure 4-8: USR TV Model Interface (Incomplete Ada PDL)
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4.5. Typecaster Model

Upon examination of the three instances of the TV model described in the previous sections
and the message representations they deal with, one can see how the pieces fit together to
form the MTV model. Figure 4-2 shows the three instances of the TV model, the message
representations each part supports, and the integration of the instances to form the MTV
model.

Based on our knowledge of the Ada language and results from prototyping, we chose to
combine the UNR TV model and the USR TV model. This combination is possible because
both models perform conversions on INRs. The rationale for this decision is summarized in
the following points:

" If the models were implemented separately, one of the following would have to be
done:

1. The existing Ada packages for both the UNR TV model and the USR TV
model would each have to encapsulate the INR (i.e., Ada type). This
duplication of Ada types would not allow us to fully utilize the strong type
checking provided by the Ada runtime when common types are used.
Reliance on common types and the Ada runtime insures consistent
representations of the information. The duplication of Ada types also
causes a configuration/version management problem.

2. Ada packages would have to be created whose sole purpose would be to
hold the INR (i.e., Ada type). The Ada packages for the UNR TV model
and the USR TV model would "with" the packages, each holding an Ada
type declaration. This solves the problem described in the previous point,
but the additional packages for holding an Ada type and the added
package layering are not necessary and not aesthetically pleasing.

" It seemed natural for the INR to be encapsulated and be the basis of a model.
This model would be capable of producing two images of the information
captured in the INR: the UNR to support the EXR of the information and the
USR to support a user interface.

We call the model resulting from combining the UNR TV model and the USR TV model a
Typecaster. Figure 4-9 shows the results of the combination in the form of a black box
diagram. Figure 4-10 shows the Typecaster model interface expressed in incomplete Ada
PDL. Chapter 7 describes the Typecaster model in more detail.

II
I
I
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Figure 4-9: Typecaster Model Black Box DiagramI

4.6. The MTV Model Description I
The MTV model is based on the EXR TV model and the Typecaster model. The EXR TV
model deals with the abstraction of an EXR of a message, while the Typecasting model deals
with the abstraction of an INR of a message. This separation allows for an independent
analysis of the two representations as long as the interface between the two (UTNR) is agreed
upon.

The remaining chapters of this document describe the model solution, how to apply it given a
set of messages, and how to adapt it given that the model solution doesn't meet a given set of
requirements.

II
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U with Casting_qcojion_Types; -- renamed as CCT
package Typecster is

-- INTERNAL REPRESENTATION

type INR is Figure4Notel ;

type lement Nes is Figure 4-6Note 3

-- UNIVERSAL REPRZSENTATION
-- Width of the UNR and string t to hold it.

UNRWidth : constant Integer 46 Note 2;

subtype UNR is CCT.Byte_Array (1..UNRWidth);
-- Elemental symbolic image positional information.

UNRDescr is array (ElementNames) of CCT.PositionType :Figure 46Note 4 ;

-- Functions for converting between UNRs and INRs

function Image(ValueIn : in INR) return UNR;
function Value(ImageIn : in UNR) return INR;

-- Function for checking the validity of a UNR
subtype UNR ValidityIndicator is UNR;
function Check(Image_In : in UNR) return UNR ValidityIndicator;
-- Indicators of a valid, or inconsistent UNR
ValidUNR : constant DNRValidity_Indicator Figure 4-6 Note 5 ;

InconsistentUNR: constant UNRValidity_Indicator := Figure 4-6Note5;

USER REPRESENTATION
-- Width of the USR and string typ to hold it.

USR Width : constant Integer : = Figure 4-8Note2;
subtype USR is String (1..USRWidth);
-- Elemental natural image positional information.

USR Descr is array (ElementNames) of CCT.PositionType :Figure4-8Note4 ;

-- Functions for converting between USRs and INRs
function Image (ValueIn : in INR) return USR;
function Value (ImageIn : in USR) return INR;

-- Function for checking the validity of a USR
subtype USR Validity-Indicator is USR;
function Check (Image_In : in USR) return USR Validity_Indicator;
-- Indicators of a valid, or inconsistent USR
Valid USR : constant USR_Validity_Indcator :- Figur 4-8 Note53 InconsistentUSR : constant USRValidity_Indicator :m Figure 4-8Note5;

-- Real-time constraint raised by Image and Value functions
Constraint_Error : exception;

end Typecaster;

I Figure 4-10: Typecaster Model Interface Description (Incomplete Ada PDL)
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* 5. MWV Model Solution Overview

I
This chapter briefly presents the parts of the MTV model solution and how to apply them by
describing the categories of parts availaile and outlining the steps involved to use the parts
to generate code for translating and validating a message. The chapter also describes what3 software architecture will result from the application of the MTV model solution and

provides some performance characteristics of the MTV model solution.

3 This chapter is a road map to the rest of the document.

3 5.1. Fundamental Concepts

Before proceedirg with an overview of the MTV model solution, a few concepts must be
3 defined.

5.1.1. Templates
The MTV model solution consists of a set of utilities and Ada coding templates. The Ada

coding templates are provided to guarantee identical instantiations of the MTV model
solution and enhance the probability for reuse. Figure 5-1 shows an example of a template.

i A template is a file containing an incomplete (i.e., not fully defined, thus not compilable) Ada

package specification, package body, and test procedure. The package specification captures
the functional interface defined by a model, and the package body implements the

functionality defined by the same model. This is the model solution. The test procedure
tests the functionality provided by a model solution. All templates also contain a header that
identifies the template by name and version number, and lists the engi- eering points to be

supplied by the user of the template. The instructions for instantiating individual templates
are found in Appendix B.

I The incomplete Ada code in the file contains placeho/derv. Placeholders are embedded in
the Ada code where a general, replaceable piece of information is required to make the

template unique. The templates are instantiated by making a copy of the file and

performing editor substitutions on the placeholders. There are two types of placeholders:
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1. The firt is of the for- <Type> or <First>, i.e., a phrase enclosed in brackets.
The entire phrase (including the brackets) must be replaced. For example,
<Type>_Type becomes Hour-Type for all instances of <Type>Type in a file
when <Type> is replaced by "Hour".

2. The second form is the double question mark, ??. This form means that some I
special action must be taken by the detailed designers, such as supplying a
function body, supplying test cases, or removing some lines from the template,
e.g., the instructions at the beginning of each template. 3

Replacement of the placeholders affects the package specification, the package body, and the
test procedure. Once the package specification and package body are compiled and linked, 3
the test procedure allows for canned and/or interactive testing of the instantiated template.
Figure 5-2 shows an instance of the example template shown in Figure 5-1.

-- I Tempirte Used : IntegerTemplate, Text-Based, Version 1.0

-- Documentation : C/SEZI-89-TR-12
... "A Model Solution for C31 Message Translation and Validation"-- m

-- Fq:n ering Points :
-- Package : <Type>_Typecaster
-- Integer type to be cast : <Type>_Type
-- First in integer range : <First>
-- Last in integer range : <Last>
-- Is symbolic image signed : <Is-signed>

Test procedure : <Type>_Typecaster_Test

with Integer_Typecaster;
package <Type>_Typecaster is

subtype <Type>_Type is integer range <First>..<Last>;

package <Type>_Tc is new Integer_Typecaster 3
(TypeToBeCast => <Type> Type,
Issigned => <Is-signed>);

end <Type> Typecaster; i

with <Type> Typecaster;
procedure <Type>_Typecaster-test is

??Enter test cases
TestCases : array (l..??) of TestRecord : (??);

begin

end <Type>_TypecasterTest

Figure 5-1: Template Example i
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-- Template Used : Integer_Template, Tezt-Based, Version 1.0

-- Documentation CMU/SEI-89-TR-12
-- I "A Model Solution for C31 Message Translation and Validation"

-- Engineering Points
-- Package : Hour_Typecaster
-- Integer type to be cast : Hour_Type

First in integer range 0
Last in integer range : 23

-- Is symbolic image signed : False
-- Test procedure : Hour_Typecaster_Test

I-- *****************************************************************

with Integer_Typecaster;
package Hour_Typecaster is

I subtype Hour_Type is integer range 0..23;

package Hour Tc is new Integer_Typecaster
(TypeTo Be Cast => Hour Type,
Issigned -> False);

end HourTypecaster;

with HourTypecaster;
procedure Hour_Typecaster_test is

Test Cases : array (1..2) of TestRecord := ("04", "23");

* begin

end HourTypecasterTest

u_ Figure 5-2: Instantiation of Template Example

5.1.2. Validity Indicators
The Typecasters' notion of validity indicators is that each individual primitive element, in
both UNR and USR form, has associated with it a character string indicating whether the

element is valid or invalid (i.e., "V " or "I "). The length of the validity indicator string is
equal to the length of the primitive UNR or USR. Indication of message validity is then

achieved by concatenating the elemental validity indicators. The validity indicators for

elements can then be accessed the same way the elements of the UNR and USR are accessed,
via the UNR description and USR description that define the positions of the elements.
Inter-element inconsistencies are indicated by the character string "? ".

Figure 5-3 shows valid, invalid, and inconsistent representations for UNRs and USRs of a
FooBar message. It also shows the validity indicator associated with each.
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Valid UNR: "CPPE18314070"
Validity Indicator: "V VV V V V'9

Invalid UNR "LEPE60014075"
Validity Indicator "I VI V V I"

Inconsistent UNR "CPPEI83i4071"
Validity Indicator "V V? "

Valid USR " Peterson_AFE East 183 14 7 Operational" 3
Validity Indicator "V V V V V V

Invalid USR " Elgin_AYB East 600 14 7SemiOperational"
Validity Indicator "I V I V V I "

Inconsistent USR " PetersonAFB East 183 14 7NonOperational"

Validity Indicator "V V ?

Figure 5-3: Valid FooBar Message

5.1.3. Terminology
Because of the transition from describing the design to describing the implementation, it is

important to note other terms used to describe the implementation that are synonymous
with terms used to describe the design.

" ICD Formatted Message is used interchangeably with EXR.

" Symbolic Image is used interchangeably with UTNR.

" Natural Image is used interchangeably with USR.

" Ada Value is used interchangeably with INR.

I
I
I
I
I
I
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3 5.2. List of Parts

Figure 5-4 lists the contents of the MTV model solution. The figure lists the source files by
category, what each source file contains, where to find hardcopy listings of the source files in

this document, and finally, if the source file contains a code template, where to find
directions for using (instantiating) the template.8 All components listed are necessary to
provide the functionality of the MTV model described in Chapter 4. The components are
grouped into six categories. These categories are listed and briefly described below and are
elaborated upon in Chapter 7.

1. Casting Common Types. An Ada package that contains global type
declarations and constants that are used by the components of the MTV model
solution. This package is analogous to the Ada package Standard. This
package must be compiled into the Ada library for use by other portions of the
MTV model solution. This part of the solution is described in Section 7.1.1, and
the code is presented in Appendix Section C.31.

2. Discrete Typecaster Generics. Ada generic packages that are the
foundation of the Typecaster model solution. These must be compiled into the
Ada library for use by other portions of the MTV model solution. This part of
the solution is described in Section 7.2.1, and the code is presented in Appendix
Section C.2.

3. Discrete Typecaster Templates. Ada coding templates that are the building
blocks of the Typecaster model solution. The templates provide the capability
to perform typecasting on Ada discrete types. Instances of these templates are
layered upon the discrete typecaster generics. This part of the solution is
described in Section 7.2.2, and the code template is presented in Appendix
Section C.3.

4. Composite Typecaster Templates. Ada coding templates that are the
building blocks of the Typecaster model solution. The templates provide the
capability to perform typecasting on Ada composite types. Instances of these
are layered upon instances of both discrete and other composite typecasters.
This part of the solution is described in Section 7.2.3, and the code template is
presented in Appendix Section C.4.

5. ICD Utilities.9 Ada packages that are the foundation of the EXR TV model
solution. These must be compiled into the Ada library for use by other portions
of the MTV model solution. This part of the solution is described in Sections
7.3.2 and 7.3.1, and the code is presented in Appendix Sections C.6.1 and C.6.2.

6. External Representation TV Template. An Ada coding template that is
part of the EXR TV model solution. It provides the capability to convert
between EXRs and UNRs. Instances of these are layered upon the ICD
Utilities. This part of the solution is described in Section 7.3.3, and the code
template is presented in Appendix Section C.5.

alf the file does not contain a template (i.e., it contains utilities), the column will be specified as N/A (Not
Applicable).

9 ICD stands for Interface Control Document. For the Granite Sentry Program, this document cor.tained the EXR
descriptions for the Granite Sentry message set. The acronym is used in the solution because the solution was
developed based mainly on information obtained from the Granite Sentry Program.
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Code Temp Use 3
Category & Appendix Appendix

PIL NAHZ Contents Section Section

Casting Common Types

CCr_.DA package spec C.1 N/A

Discrete Typecaster Generics

mzn xEHrnTcASTZDA generic package spec C.2.1 N/A

DncGrzoMz.P.CwATZR. generic package body C.2.1 N/A

MATf.ONJ _R..TYPRCnWT.ADA generic package spec C.2.3 N/A

MATH.ON-NDZME 'kR.YPECATERADA generic package body C.2.3 N/A

INTMGE-rrBr.TYPECASTEPADA generic package spec C.2.2 N/A

iTEGZR.BrrEa-TYPECASTERADA generic package body C.2.2 N/A

NUMWXATIONTYPCAST_ AnA generic package spec C.2.4 N/A

EnMU gATIONTYPECASTE.ADA generic package body C.2.4 N/A

MATH.ON-.ENJUATION-TYPECAST.ADA generic package spec C.2.6 N/A

MATELON..ENUhnRATION.TYPECASTERADA generic package body C.2.6 N/A

MMWZATIONBrr-TYPECA-rn.DA generic package spec C.2.5 N/A

KNUMATION-Brr WYECASrERADA generic package body C.2.5 N/A

STr G,MAP.TY ECASTkr ADA generic package Spec C.2.7 N/A

STMtNGMAPTWPmCASTERAM generic package body C.2.7 N/A

Discrete Typecaster Templates

RTn'GERJA E-4A template package spec & test proc C.3.1 B.3.1

MATHONJNTEGERT.Th3'1A7_..DA template package spec & test proc C.3.3 B.3.3

IrNomT..BrrTEMPLATE_.ADA template package spec & test proc C.3.2 B.3.2

NUMP ATION_T -TAMD template package spec & test proc C.3.4 B.3.4

MATH.O- NXmURAT!ON.TEMPLDATE.ADA template package spec & test proc C.3.6 B.3.6

mVun AATON._rrTmGZLTC.ADA template package spec & test proc C.3.5 B.3.5

STMG-MAP-_EMPATE-ADA template package spec & test proc C.3.7 B.3.7

Composite Typecaster Templates

RECORDTEMATE.ADA template package spec, body, & test proc C.4.1 B.4.3

PIUVATE-RCORDTfMPLATEADA template package spec, body, & test proc C.4.2 B.4.4

ARAYTEMATLEADA template package spec, body, & test proc C.4.3 B.4.1

PRIVATE-A XY ThMPLATEADA template package spec, body, & test proc C.4.4 B.4.2

WRAPPER-_E.T.ATLADA template package spec, body, & test proc C.4.5 B.4.5

ICD Utilities

FD..UTUTMSADA package Spec C.6.2 N/A

MLDtrrUrrsAD package body C.6.2 N/A

icDuTrIznSADA generic package spec C.6.1 N/A

ICDUTU S.ADA generic package body C.6.1 N/A

External Representation TV Template

MSBOICD-TEMPLATADA template package spec, body, & test proc C.5 B.5.1

Figure 5-4: MTV Model Solution Contents
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5.3. Building Plan
The following are the steps involved in applying the MTV model solution to a set of messages

that need to be translated and validated. These steps are elaborated in Chapter 6.

1. Compile Foundation Utilities. The utilities that form the foundation of the
solution need to be compiled. These include the components in the following
categories: Casting Common Types, Discrete Typecaster Generics, and ICD Utilities.
Section 6.1 describes this step in more detail.

2. Analyze Message. The EXR description for a message needs to be analyzed to
determine how to:

a. Codify the EXR description using the Msg.ICD template. The EXR
description needs to be coded in a grammar that describes the characteristics
of each field.

b. Define the INR description based on the information provided by the EXR
description. The Ada types for each field need to be defined.

3Section 6.2 describes this step in more detail.

3. Instantiate MTV Model Solution. The building blocks (templates) of the MTV
model solution are used to create an instance of the model solution for a message.

Ia. Identify and Build the Discrete Typecasters. The discrete typecasters
needed to translate and validate discrete elements of a message are
identified based on Step 2. Check to see if any instances of them already exist;
some may have been created for other messages. Generate the discrete
typecasters that do not exist using &he appropriate discrete typecaster
templates. Run the generated test routines to check the discrete typecasters.
Section 6.3.1 describes how and when to apply the discrete typecaster
templates. Appendix Section B.3 provides the details for applying individual
discrete typecaster templates.

b. Identify and Build Composite Typecasters. The composite typecasters
needed to group discrete and composite elements of the message are identified
based on Step 2. Check to see if any of them already exist; some may have
been created for other messages. Generate the composite typecasters that do
not exist using the appropriate composite typecaster templates. Run the
generated test routines to check the composite typecasters. Section 6.3.2
describes how and when to apply the composite typecaster templates.
Appendix Section B.4 provides the details for applying individual composite
typecaster templates.

c. Build the External Representation TV. The EXR TV for the message is
generated using the MSGJCD template. The information entered, the field
description array, and the cut array are critical for the proper conversion
between the UNR and the EXR. Run the generated test routine to check the
instance of the EXR TV model solution for the message. Section 6.3.3
describes how and when to apply the MSGICD template. Appendix Section
B.5 provides the details for applying the MSG_ICD template.

d. Tie Together the Two Model Solutions. The instances of the Typecaster
model solution and EXR TV model solution for the message must be tied
together. The communication interface between the two model solutions is the
UNR. Section 6.3.4 describes this step in more detail.

Section 6.3 describeb all these steps in more detail.
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5.4. Architectural View

Figure 5-5 shows the general software architecture that results when the MTV model
solution is applied. The software architecture is shown as Ada packages and the

dependencies among them.10 I

When the EXR TV model solution is instantiated for a set of messages, the resulting
architectural components are instances of the MsgICD template, one per message, all of
which depend upon the ICD Utilities packages.

The Typecaster portion of the software architecture is based upon the structure of the INR
description (i.e., Ada type). When the Typecaster model solution is instantiated for a
particular message, the resulting architectural components are instances of the discrete

typecaster templates and composite typecaster templates, one for each type used to describe I
the INR description of the message. The Typecaster architecture is therefore hierarchical in

nature. The discrete typecasters are dependent upon the discrete typecaster generics. The

composite typecasters are dependent upon both discrete typecaster instances and composite
typecaster instances.

The software architecture for an instance of the MTV model (specifically for the FooBar
message described in Chapter 2) is shown in Figure 6-13. Chapter 7 discusses the software

architecture in more detail.

I
I
I
I
I
I

'*Remember that the MTV model solution in comprised of the EXR TV model solution and the Typecaster model
solution.
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i Figure 5-5: MTV Model Solution Architecture
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5.5. Performance Characteristics

Timing performance characteristics of the MTV model solution were measured using the
FooBar message example shown throughout this document. i

Timing measurements were made on a MicroVAX II with 16 megabytes of memory running
Version 5.1 of the VAX/VMS operating system. The code was compiled under VAX Ada
Version 1.5. All of the code was optimized at both compilation and link time. I
5.5.1. Discrete Typecaster Measurement
The discrete typecasters were measured in the following manner. All functions exported by I
the discrete typecaster (value, image, and check, for both natural and symbolic images) were
addressed individually. Each was called and measured 10,000 times for each discrete value
in the range of valid discrete values to take care of the coarseness of the clock. A running
total was kept for each function exported by the discrete typecaster, and averages were
derived from the total times. It is important to note that the times measure the loop as well
as the function call. The amount added to the total should be negligible.

Performance measurements for discrete typecasters are shown in Figure 5-6. The discrete
typecaster templates (and thus the discrete typecaster generics) from which the discrete
typecaster instances were generated are specified in parenthesis.

5.5.2. Composite Typecaster Measurement i
The composite typecasters were measured in the following manner. All functions exported
by the composite typecaster (value, image, and -heck for both natural and symbolic images)
were addressed individually. Each was called and measured 10,000 times for test cases that
addressed the upper and lower bounds of the discretes they grouped. Again, the calls were
performed 10,000 times to take care of the coarseness of the clock. A running total was kept i
for each function exported by the composite typecaster, and averages were derived from the
total times.

Performance measurements for composite typecasters are shown in Figure 5-7. The
composite typecaster templates from which the composite typecaster instances were I
generated are implicit in the names of the typecasters.

5.5.3. EXR Translation and Validation Measurement
The EXR Translation and Validation was measured in a fashion similar to the composite I
typecasters.

Performance measurements for EXR Translation and Validation are shown in Figure 5-8.

I
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Discrete Typecaster Performance Summary
(Time in mill-seconds)

INR <..> UNR INR <-> USR

Discrete Typecaster Image Value Check Image Value Check

HourTypecaster 0.93 0.48 0.63 0.59 0.22 0.31
(Integer TCT)

MinutefTypecaster 0.93 0.47 0.63 0.59 0.23 0.31
(Integer TCT)

JulianDayTypecaster 0.95 0.51 0.66 0.60 0.26 0.33
(Integer TCT)

DirectionTypecaster 0.16 0.31 0.38 0.27 0.35 0.45
(Enumeration TCT)

ReportingLocation.Typecaster 0.19 0.35 0.44 0.31 0.51 0.62
(Enumeration TCT)

StatusTypecaster 0.28 0.16 0.33 0.29 0.47 0.57
(String Map TCT)

ScaledInteger-100_500_Typecaster 1.22 0.74 0.87 0.58 0.25 0.32
(Math_On_Integer TCT)

ScaledIntege100_ 1000_Typecaster 0.32 0.46 0.72 0.60 0.29 0.38
(MathOnEnumeration TCT)

Hour_BitTypecaster 0.30 0.32 0.51 0.56 0.21 0.31
(IntegerBit TCT)

NMinuteBit,_Typecaster 0.30 0.32 0.51 0.57 0.21 0.32
(Integer_-Bit TCT)

JulianDayBitTypecaster 0.31 *0.43 *0.60 0.56 0.26 0.33
(Integer-Bit TCT)

Direction_BitTypecaster 0.35 0.34 0.53 0.29 0.35 0.46
(Enumeration-Bit TCT)

ReportingLocationBit_-Typecaster 0.32 0.34 0.52 0.31 0.51 0.61
(Enumeration-Bit TCT)

StatusBit,_Typecaster 0.33 0.35 0.51 0.31 0.48 0.58
(Enumeration-Bit TCT)

Notes: * = Timing measurements were performed on code that was not optimized because
of compiler problems with optimized code.

TCT = Typecaster Template

Figure 5-6: Discrete Typecaster Performance Summary

I
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Composite Typecaster Performance Summary
(Time in milli-seconds)

INR <-> UNR INR <-> USR

Composite Typecaster Image Value Check Image Value Check

Juian_Date_Time_ 2.98 1.71 1.92 1.88 0.94 1.02
RecordTypecaster _

FooBarMessage_ 4.17 3.18 3.44 3.03 2.91 3.01
PrivateRecord_Typecaster

JulanDateTimeBit_ 1.20 1.25 1.49 1.76 0.93 1.02
RecordTypecaster

FooBarMessageBit_ 2.61 2.91 3.34 2.95 2.93 3.04
PrivateRecordTypecaster II

Probability_ 0.93 1.08 0.74 0.62 0.50 0.56
Wrapper_Typecaster I I I

Probabiity_ 6.77 9.19 6.66 5.58 4.76 4.75 I
Private_ArrayTypecaster

Figure 5-7: Composite Typecaster Performance Summary I
I
I

EXR Translation and Validation Performailce Summary
(Time in milli-seconds)

EXR <-> UNR

ICD Typecaster Extract Construct Check

FooBar.MessageICD 2.13 3.47 2.50

FooBar..Bit..Message_ICD 3.11 4.93 3.49

Figure 5-8: EXR Translation and Validation Performance Summary

I
I
I
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* 6. MTV Model Solution Application Description

I
This chapter describes how to apply the components of the MTV model solution, introduced
in Chapter 5, to generate Ada code that translates and validates messages, as described in

Chapter 4. This chapter is targeted for a detailed designer and/or implementor.

6.1. Foundation Utilities Compilation

IBefore the Ada software for translating and validating a specific message can be compiled,
tested, and used, the following sets of utilities must be compiled and placed in an Ada

library.

The file CCT_.ADA, listed in Figure 5-4 under the category Casting Common Types,

contains the Ada package CastingCommonTypes (CCT). The package contains global type

declarations and constants that are used by the components of the MTV model solution. This
package is synonymous with the Ada package Standard. This is the first package that must

be compiled. Detailed designers will reference this package during the application of the
MTV model solution. They may need type information and will need to find the names of

predefined constants to apply the solution.

The files listed in Figure 5-4 under the category Discrete Typecaster Generics contain

either an Ada generic package specification or an Ada generic package body. These packages

are the foundation of the Typecaster model solution and are used by other portions of the
MTV model solution. Detailed designers do not need to concern themselves with these

packages other than compiling them into the Ada library. The generic package specifications
and bodies must be compiled in the order the files are listed in Figure 5-4. Finally, the files
listed in Figure 5-4 under the category ICD Utilities contain Ada packages. These are the
foundation of the EXR TV model solution and are used by other portions of the MTV model

solution. Detailed designers do not need to concern themselves with these packages other
than compiling them into the Ada library. The package specifications and bodies must be
compiled in the order the files are listed in Figure 5-4.

Figure 6-1 shows the software architecture of the MTV model solution after the foundation

i utilities have been compiled.
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6.2. Message Analysis

The requirements for translating and validating messages are expressed in the form of
textual EXR descriptions 11 (as shown in Figure 2-2 and Figure 2-4). To apply the MTV
model solution, detailed designers must analyze the EXR descriptions with the MTV model

solution in mind.

Because the MTV model solution separates the concept of an EXR and an INR, the
descriptions for these two must be codified separately, but an interface (UNR) between the
two must exist.-2 How to codify the EXR description is described first. Second, a description

of how to specify the transformation of the ordering from that of the EXR to that of the
desired INR is provided (i.e., through the UNR). These first two analysis steps are used to
instantiate the Msg.ICD template discussed in Section 6.3.3. Finally, how to specify the INR
description (i.e., the Ada types) is described. This last analysis step is used to instantiate the
typecaster templates discussed in Sections 6.3.1 and 6.3.2.

6.2.1. Codifying the EXR Description
Detailed designers should first make sure that the EXR description can be codified given the

Fields data structure supplied by the Msg.ICD Template. The definition of the Fields data
structure is the main step in instantiating the Msg_ICD template as described in Section

*6.3.3.

Fields is an array where each element contains the description of a field (both its EXR and
UNR). Two types of fields are possible: character-based and bit-based. The elements of the

array are variant records where the variant part differs based on whether the field is
character-based or bit-based.

The following information is required to describe a character-based field:

Base The discriminant for the variant record that describes a field. It
specifies whether the field is character-based or bit-based. Values
are of the type CCT.BaseType.

13

CanBeLast A boolean that indicates whether the field can be the last field in
the EXR. This must be set True for at least one character-based
field. The end of message punctuation marker and the length of the
message are used to determine wh .m *1e end of message has been
reached.

Position Describes the position of the symbolic image of this field in the
LTNR. This information is derived by the software and does not need
to be specified by the detailed designers. Values are of the type
CCT.Position_Type.

iThe message EX descriptions were contained in the ICD (Interface Control Document) for the Granite Sentry
I Program.

12Note that the form of each representation is different but the message information content captured by both
representations must be the same.

1aCCT refers to the Ada package CastingCommon Types. See Appendix Section C.1.

CMU/SEI-89-TR-12 51



I
I

Kind Specifies whether the field is single, repetitive, or echoed. A single
field appears once in a message. A repetitive field repeats itself
consecutively in a message. An echoed field has the value of the
field repeated with no more information content. Values are of the
type CCT.Fild_Types.

Width An integer that specifies the number of characters in the field. For U
fields that are varying length, repetitive, or echoed, it specifies the
maximum number of characters in the field.

Element_Size An integer that specifies the number of characters contained in U
each element in the field. If the kind of field is single, then
Element-Size is equal to Width. If the kind of field is repetitive,
then Element_Size is equal to the Width divided by the number of I
times the element is repeated. If the kind of field is echoed, then
ElementSize is equal to the Width divided by the number of times
the element is echoed.

NullPossible A boolean that specifies whether the field can have a null value, i.e.,
no character physically present.

Odd Specifies whether the field can have possible widths other than that
specified by Width and Null-Possible. If true, then a list of integers
specifying the alternate widths must be provided. Values are of the
type CCT.OddDescription.

Separator Specifies the punctuation found at the end of a field. Values are of U
the type CCT.LittleStringType. Also, constants are defined that
specify several common punctuation marks, including a constant for
specifying when no punctuation will be present in a EXR of a I
message. These can be found in the package CCT.

Figure 6-3 shows how Fields should be defined based on the EXR description for the FooBar

message in Figure 2-2. Note that this information does not need to be entered yet. The 3
framework of this description has been captured in the MsgICD template (shown in

Appendix Section C.5). Using the MsgICD template is discussed in Section 6.3.3.

Because of the different possibilities related to the specification of Null-Possible and

OddPossible, the truth table in Figure 6-2 enumerates the different possibilities and their

meaning. It is assumed that a fields has a maximum length n, specified by Width in the I
description.

NullPomsibleu> Odd=>(Possible=,) Meaning

True True, Variable length string (0, ( i2, ... im), or n)
OddLengths=> (il,2, - ) I

True False Variable length string (0 or n)

False True, Variable length string ((il 2, ... im), or n)
OddLengths=> (il, i2, ... i

False False Fixed length string (n)

Figure 6-2: Variable Length Field Truth Table
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type FieldNamea in (ReportingLocation, Direction, DateTimeGroup, Status,

Fields: Icd_UiLDescriptionArray:=
(Reporting-Location =>

(Carn..Be_.As => False,
Position => (0,0), - Filled in at elaboration time
Ease => CcLCharField,

Kind => Cct.Singlu,
Width => 3,
ElamentSize => 3,
NuiLPossible => False,
Odd => (Possible => False),
Separator => Cct.Cr

Directio =>
(Can.BeLast => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.CharField,

Kind => Cot.Single,
Width => 1,

I Element_.Size => 1,

NuiLPossible => False,
Odd => (Possible => False),
Separator => Cct.No_Punctuation

DateTims_Group =>

(CanBoLast => False,

Position => (0,0), - Filled in at elaboration time
Base => CcLChar _Field,

Kind => CcL.Single,
Width => 7,
ElementSize => 7,
NuiLPossible => False,
Odd => (Possible => False),
Separator => Cct.Slhuh

Status =f>
i (CanBe _Las. =f> True,

PoFtion => (0,0), - Filled in at elaboration time
Base => CFt.CharoMField,

Kind =f> Cet.Single,
Width => 1,

I Element _Size => 1,
Null_Possible => False,
Odd => (Possible => False),
Separator => Cct.No._Punctuation

EO Text : oonstant Cat.IttleString.Type := Cct.CR;

I Figure 6-3: Example Codification of Char-Based EXR Description:

FooBar Message
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The following information is required to describe a bit-based field:

Base The discriminant for the variant record that describes a field. It
specifies whether the field is character-based or bit-based. Values
are of the type CCT.BaseType.14

Can_BeLast A boolean that indicates whether the field can be the last field in
the EXR. This must be set True for at least one bit-based field. The
end of message punctuation marker and the length of the message
are used to determine when the end of message has been reached. I

Position Describes the position of the symbolic image of this field in the
UNR. This information is derived by the software and does not need
to be specified by the detailed designers. Values are of the type I
CCT.PositionType.

Numberf_OfBytes An integer specifying the number of bytes that the field spans.

Byte-Positions Specifies the byte number, and start and stop bits within that byte,
for each byte that the field spans. Byte numbers are in the range
1..n, and bits are numbered 0..7, zero being the least significant bit.
Values are of the type CCT.BytePosition_Record.

Figure 6-4 shows how Fi-Ids is defined based on the bit-based EXR description for the
FooBar message in Figure 2-4. Note that field three, Date_Time_Group, is described in three
parts and not one part as in the text-based example, to extract each piece of information 3
individually, each piece must be allocated to its own string.

Finally, EQText is of the type CCT.LittleString, and should specify the end-of-message
punctuation marker for both character-based and bit-based messages. Possible 3
end-of-message punctuation markers are defined in CCT, including one for specifying when
no end-of-message marker will be present. 5
Also, the solution does handle messages that contain both character-based and bit-based
fields, but care should be taken when describing the fields using the Fields array. When
describing the fields, note that bit-based fields are expected to be in specific byte and bit
locations and that character-based fields can be defined as varying length. This dynamic
characteristic of character-based field descriptions could potentially conflict with the static
bit-based descriptions.

I
I
I

14CCT refers to the Ada package CasingCommonjTpes. See Appendix Section C.1.
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i type Field_Names in

(R[ tingLocation, Direction, DateTime_.Group-Day,

Date Time.GroupHour, Date TimeGroupMinute, Status),

I Fields: IccUtiLDenriptionArray:=
(Reporting.Location => (

CanBeLant => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
ExternalFormat => (NumberOILBytes => 1, BytePositions =>

1 => (ByteNumber => 1, BitPosition =>
Start => 4,
Stop => 5))))),I Direction => (

CanBeLast => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
ExternalFormat => (Number_.f_.Bytea => 1, BytePositions =>

1 => (ByteNumber => 1, Bit-Position =>Start => 2,
~Stop => 3))))),

DateTime._GroupDay =>

CanBeLapt => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
External-Format => (Number_O!_Bytes => 3, BytePositions => (

1 => (Byte-Number => 1, BitPosition => (
Start => 0,
Stop => 1)),

2 => (ByteNumber => 2, BitPosition => (
' Start => 0,

Stop => 5)
3 => (ByteNumber => 3, BitPosition =>

Start => 5,

DateTme _Group~or Stop => 5))))),DatTieGou_Hour =>(

CanBeLast => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
ExternalFormat => (NumberOfBytes => 1, Byte-Poaitions =>

1 => (ByteNumber => 3, BitPosition =>
Start => 0,
Stop => 4))))),IDateTime..GroupMinute =>

CanBeLast => False,
Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
External-Format => (NumberOf Bytes => 1, BytePositions =>

1 => (ByteNumber => 4, BitPosition =>

Start => 1,
Stop => 6))))),

Status => (
CanBeLast => False,

Position => (0,0), - Filled in at elaboration time
Base => Cct.BitField,
ExternalFormat => (Number_.OfBytes => 1, Byte_Positions =>

1 => (ByteNumber => 4. Bit-Position =>
Start => 0,
Stop => o)))))),

EOText: constant CctLittleStringType := Cct.NoPunctution;

Figure 6-4: Example Codification of Bit-based EXR Description:
FooBar Message
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6.2.2. Interfacing the EXR and INR Descriptions
If the ordering and grouping of the information in the EXR description is a natural and

acceptable one, then proceed to Section 6.2.3 and define the INR description (Ada type). If,
however, the ordering of information is not appropriate, cutting (i.e., reordering) may be

necessary.

For example, suppose the EXR description contained the field descriptions shown in Figure

6-5, that is, there are eight pieces of information grouped in each field. The goal, though, a
was to represent the information with the INR description containing the Ada types, also

shown in Figure 6-5 - that is, as an array where each element of the array contains

information from fields four, five, and six.

Cuts is an array where each element contains the names of the first and last fields to cut. To
cut information is to reorder related repetitive information from the order specified in the I
EXR description to a more natural order, as specified by the INR description.

The initial step is to specify the Fields. Figure 6-6 shows how a repetitive field is specified.

The next step is to specify the Cuts array, also shown in Figure 6-6. The information in the

Cuts array specifies the fields where cutting is to start and stop. The definition of the Cuts

data structure is a step in instantiating the MsgICD template as described in Section 6.3.3.

Finally, Figure 6-7 shows the EXR and the UNR of the information after it has been cut.

Note that the information in the UNR has been reordered to match that of the INR.

6.2.3. Specifying the INR Description
After it is determined that the textual EXR description can be codified, the INR description S
must be specified, i.e., the Ada types necessary to represent the information in the message
must be specified. These Ada types are the basis for instantiating the typecaster templates

described in Sections 6.3.1 and 6.3.2.

Although the two representations are separate, they are still related with respect to the

information they represent. Therefore, to specify the INR description, one must start by
identifying the primitive elements of the fields (fields that can be represented with discrete

values) in the EXR. In the EXR description shown in Figure 2-2, fields one, two, and four are

primitive (i.e., they cannot be broken down further). Field three, Date_TimeGroup,
however, is not primitive but has three elements that are in primitive form.

Once the primitive elements are identified, the Ada discrete types of these elements must be

specified based on the "meaning" (or amplifying data) specified for the element, not based on
the symbolic information expected in the EXR: 3

" Primitive fields whose meaning can be represented by integers should be defined
as a subtype of integer whose range is defined according to the "Range of Values"
specified in the EXR description (see Figure 2-2).

" Primitive fields whose meaning can be represented by enu -. "ations should be
defined as an enumeration whose range is defined according , the "Amplifying
Data" specified in the EXR description (see Figure 2-2).
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Partial Message Format
Field Field Size Range of

Number Field Name (chars) Values Amplifying Data

4 Detection Confidence 8 aaaaaaaa The DC in each 7.5 deg
(DC) radar barrier segment

reported in sequence.
Values are:

H = High
M = Medium
L= Low

Field Separator 1 <cr> Carriage Return

5 Probability of Detect 16 nrnnnnnn The PD in each 7.5 deg
(PD) nnnnnnnn radar barrier segment

Values are 00..99

3 Field Separator 1 <cr> Carriage Return

6 Barrier Segment 16 anananan The BS in each 7.5 deg
(BS) anananan degree radar segment

Letter is start range:
A=100 F=600
B=200 G-f700
C=300 H=800
D=400 I=900
E=500 J=1000

Number is barrier width
1..5 = 100..500

End of Message 1 <cr> Carriage Returna
type DetectionConfidenceType is (High, Medium, Low, None);,
subtype Integer_..99_Type is Integer range 0..99;
subtype ScaledIntegerj_1OJO._Type is Integer range 100..1000;,
subtype ScaledInteger_100_500Type is Integer range 100..500;

type Barrier_.SegmentRecordType is record
DetectionConfidence : DetectionConfidenceType;
Probability-OfDetection : Integer__99_Type;
StartRange ScaledInteger 100_1000_Type;
Width ScaledInteger_100_500_Type;

end BarrierSegmentRecordType;

BarrierSegments ArrayType is array (1..8) of Barrier_-SegmentRecor&iType;

Figure 6-5: Example of EXR and INR Descriptions Where Cutting Is Necessary

I

ICMU/SEI-89-TR-12 57



I
I

type Field.Names is I
(... Detection Confidene, ProbabilityOfDetect, BarriwrSegmsnt);

Fields: IcdUtil.DecriptionArray :=
(DetectonConfidence =>
(CanBeLast => False,
Position => (0,0), - Filled in at elaboration time
Bass => Cct.CharField.

Kind => Cct.Repetitive,
Width => 8, s,Elemnt-Size => 1,
Nun_-Posible => False,
Odd => (Possible => False),/i

Separator => Cct.Cr

ProbabilityOf Detect =>
(Can Be Last -> False,
Position => (0,0), - Filled in at elaboration time I
Base => Cot.Char_Field,

Kind => Cct.Repetitive,
Width -> 16,
Element-Size a> 2,
NullPossible => False,
Odd => (Possible => False),
Separator => Cct.Cr

Barrier_Sgment =>
(Can Be Last -> True,
Position a> (0,0), - Filled in at elaboration time
Barn => Cct.CharField,

Kind f> Cct.Repetitive, a
Width => 16,

Element-Size => 2,
NullPossible => False,
Odd => (Possible => False), a
Separator => Cct.Cr

Cuts: IedUtil.CutArray :=
(1 f> (Start => DetectionConfidence,

Stop f> Barrier-Segment) 3
Figure 6-6: Example Codification of EXR Description with Repetitive Information

and Specification of Cuts I
I
I
I
I

58 CMU/SEI-89-TR- 12



I
!

IExternal Representation

IField4I I Field 5 I I Field 6 I
Iaaaaaaaa rnnnnnnn r ananananananaian"
"HMDLNHMLN<cr>1122334455667788<cr>AIB2C3D4E5F5G5H5<cr>"

Universal Representation

I I BarrierSegments ArrayType l

Barrier SegmentRecord_TypeII I I
"annanannanannanannanannanannanannanannan"
"HIIAIM22B2L33B3N44D4H55E5M66F5L77G5N88H5 "

I Figure 6-7: Example of EXR and UNR Where Cutting Was Specified

While specifying the discrete Ada types, keep in mind that the character string images of the
integer ranges and enumeration literals selected to represent the information (i.e., natural
images) are the basis for the USR. Chapter 8 contains a discussion of this constraint.

After all Ada discrete types are defined for a message, the discrete types should be grouped
using composite types (arrays and records) as follows:

5 . Physically related elements (i.e., represented by the same Ada type) can be
grouped using an array type, for example, a list of 8 Barrier Segments, as shown
in Figure 6-5.3 .Logically related elements can be grouped using a record type, for example, a
grouping of information pertaining to a Julian Day, as shown in Figure 2-6.

" Elements that are of varying length or can possibly be null are grouped using a
variant record type, where the variant specifies whether the field is present or
not.

" Finally, clements related by inter-element dependencies (as defined in the EXR
description) are grouped using the appropriate composite type (record or array)
and will be declared as a private type. The Ada private type is the mechanism
used to preserve the validity of the internal representation based upon
inter-element dependencies.

The ordering of the information in the INR description of the message must be preserved as

per the EXR description and any cutting that is to be performed. See Chapter 8 for a

discussion of this constraint.

After the discrete grouping is complete, group both composite types and discrete types using

composite types. The same rules defined above can be applied here. This discrete/composite
grouping continues until the composite for the message (usually a record) is defined. Figure

2-6 shows the INR description resulting from the analysis of the EXR description for the

FooBar message shown in Figure 2-2.
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6.3. MTV Model Solution Instantiation

The analysis of the message representations as defined in the previous section is the basis
for creating an instance of the MTV model solution. The results of the analysis drives the

detailed designers' choice of available building blocks (templates) and defines how the I
choices are to be instantiated.

As described in Chapter 5, there are two parts to the MTV model solution: n

* Typecaster model solution

" EXR TV model solution 3
The templates that comprise the Typecaster model solution fall into two categories: discrete

typecasters and composite typecasters. These templates are described in Sections 6.3.1 and I
6.3.2. The EXR TV model solution is captured in one template, the MsgICD template. This

is discussed in Section 6.3.3.

6.3.1. Discrete Typecaster Template Application
Once the INR description is defined (as described in Section 6.2.3), the first of two steps must

be taken to create an instance of the Typecaster model solution. The first step in creating an n
instance of the Typecaster model solution involves generating the appropriate discrete
typecasters for the discrete types defined by the INR description for a message. The discrete

typecasters are generated by selecting from one of the seven discrete typecaster templates
provided by the Typecaster model solution. The names and descriptions of when to use them
are listed below. Also shown is an example of the conversions that result when the 5
functionality of the discrete typecaster template is used. It is of the form:

symbolic image <--> value <-> natural image

I
I
I
I
I
I
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1. Integer Typecaster Template. Use when converting between symbolic
images that are character strings representing integers (zero padded and either
signed or unsigned) and INRs that are integer values. Natural images, by
definition, are character strings based upon images of the INR. 15

Example: "01" <--> 1 <-->" 1"

2. MathOnjnteger Typecaster Template. Use when converting between
symbolic images that are character strings representing integers (zero padded
and either signed or unsigned) and INRs that are scaled integer values.
Natural images, by definition, are character strings based upon images of the
INR.5 Example: "1" <--> 100 <--> " 100"

3. Enumeration Typecaster Template. Use when converting between
symbolic images that are character strings that can be represented as
enumeration literals and INRs that are discrete values. Natural images, by
definition, are character strings based upon images of the INR.
Example: "N" <--> North <--> "North"

4. MathOnEnumeration Typecaster Template. Use when converting
between symbolic images that are character strings that can be represented as
enumeration literals and INRs that are scaled integer values. Natural images,
by definition, are character strings based upon images of the INR.1"
Example: "A" <--> 100 <--> " 100"

5. StringMap Typecaster Template. Use when converting between symbolic
images that are character strings and INRs that are discrete values where the
relationship between the two representations is not supported by other
character-based discrete typecaster templates. More specifically, use when:

* The symbolic images are Ada key words.
Example: "do" <-> DO,AirForce_Base <--> "DO_AirForceBase"

" The symbolic images represent integers but the INR desired is an
enumeration type.
Example: "0" <--> Operational <-->" Operational"

* The symbolic images are case sensitive.
Example: "N" <--> North <--> "North"

n" <--> No_Direction <--> "NoDirection"
Also note that the String-Map typecaster can be used in the place of all
character-based discrete typecasters templates. Natural images, by definition,
are character strings based upon images of the INR.16

6. Integer-Bit Typecaster Template. Use when converting between symbolic
images that are bit strings representing integers and INRs that are integer
values. Natural images, by definition, are character strings based upon images
of the INR."
Example: 00001001 <--> 9 <--> " 9"

7. Enumeration-Bit Typecaster Template. Use when converting between
symbolic images that are bit strings representing enumeration literals and
INRs that are enumeration values. Natural images, by definition, are character
strings based upon images of the INR.' a

Example: 00000001 <--> South <--> "South"

I 16 The natural image of disrete Ada types in defined using the 'image attribute defined by the Ad& language.
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The choice of a discrete typecaster template is dependent upon the answers to the following

two questions: I
1. What is the desired INR description (Ada type)?

2. What is the nature of the symbolic image as a string (bit, alphanumeric
character, or numeric character)? i

The table shown in Figure 6-8 describes which typecaster template to choose based on

answers to the two questions. The rows of the table describe the nature of the symbolic $
image as a string. The columns describe the M description (Ada type) selected to represent
this information.

For example, the symbolic images of the Directions field shown in Figure 2-2 are the
characters "N", "S", "E", and "W". The information in the Direction field is represented as

the Direction.Type enumeration type as shown in Figure 2-6, i.e., I
type D rectionType is (North, South, East, West);

Therefore, upon examining the discrete typecaster template selection table shown in Figure

6-8, one should choose either the Enumeration typecaster template or the String-Map
typecaster template. Before making a choice, the detailed designers should examine the

details involved in applying each possible discrete typecaster template. More detailed I
descriptions of when to use each discrete typecaster template are found in Appendix Section
B.3.

Once a selection is made, the detailed designers create an instance of the discrete typecaster
template chosen by making a copy of the template in a new (empty) file and making the

appropriate editor substitutions. The substitutions are based on placeholders located I
throughout the template. The placeholders are listed in the header comments at the
beginning of the template. Some templates also use the "'? placeholder for special

instructions, for example, replacement rather than substitution, and code fragment selection. U
The "n?" placeholder is never listed in the header comments, but one should always search for
it. The "92?" placeholders should be located and replaced with the appropriate information as

described by the instructions found with the "f?". After the instructions are followed, the I
instructions must be removed. If the instruction lines are not removed, the file will not

compile. This insures that all special instructions are examined. More detailed descriptions

of how to instantiate each discrete typecaster template are in Appendix Section B.3.

After the template is instantiated, the file that contains a typecaster package specification

and a test procedure can be compiled, and the test procedure can be linked and run. The test I
procedure performs two types of testing. First, it performs exhaustive testing on the
typecaster operations based on the range of possible discrete values specified by the INR

description (discrete Ada type). Second, it performs interactive testing, allowing the detailed
designers to enter valid and invalid forms of the different representations. (i.e., symbolic
images, natural images, and values). 3

I
62 CMU/SEI-89-TR- 12 3



I
1

_Symbolic

Images Internal Representations

__Numeric Integer Enumeration Scaled Integer

N Numeric
Char String Integer TCT StringMap TCT athOnlnteger TCT

Char String Enumeration TCT Enumeration TCT MathOnEnumeration TCT

Any
Char String String-Map TCT StringMap TCT String-Map TCT

Bit String IntegerBit TCT EnumerationBit TCT Not Available*

Note:
TCT = Typecaster Template

This functionality was not necessary for Granite Sentry Phase II,
although it could be easily implemented.

IFigure 6-8: Discrete Typecaster Template Selection

6
I
I
!
I
I
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Figure 6-9 shows examples of discrete typecaster template selection based on symbolic

images and Ada types. 16  i
Discrete Typecaster

Symbolic Image Internal Representation Template Selection
"00"-"15" Integer range 0..15 Integer TCT

"00"-"15" (North..NorthNorthWest) StringMap TCT
"00"-"15" Integer range 0..1500 MathOnInteger TCT

"NNN"-"NNW" Integer range 0..15 Enumeration TCT 3
"NNN"-"NNW' (North..NorthNorthWest) Enumeration TCT

"NNN"-"NNW" Integer range 0..1500 MathOnEnumeration TCT 3
00000000-00001111 Integer range 0..15 Integer_.Bit TCT

00000000-00001111 (North..NorthNorthWest) EnumerationBit TCT

00000000-00001111 Integer range 0..1500 Not Available

i
Note: TCT = Typecaster Template

Figure 6-9: Discrete Typecaster Template Selection Examples N
Figure 6-10 shows the typecaster software architecture of the FooBar message defined in

Figure 2-2 after the discrete typecasters have been generated. At the bottom of the I
architecture, the foundation of the Typecaster model solution, are the discrete typecaster

generics. Above these are the instances of the discrete typecaster templates, each dependent
upon a discrete typecaster generic. The instances of the discrete typecaster templates also

show (in parenthesis) which discrete typecaster template was used to generate them.

Finally, before proceeding, detailed designers should study the FooBar message example i
using Figure 2-2, Figure 2-6, and Figure 6-10 with the goal of understanding why specific

templates were chosen, and become familiar with the discrete template descriptions found in
Appendix Section B.3.

i
I

16Note that the StringMap typecaster template could be chosen for all character-based symbolic image
possibilities.
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6.3.2. Composite Typecaster Template Application
Once the necessary discrete typecasters for a message have been instantiated, detailed I
designers can proceed to the second step in creating an instance of the Typecaster model
solution. This second step involves generating the appropriate typecasters for the composite

types defined by the INR description for a message and building these from the bottom of the I
composite type hierarchy to the top, the top being the type for the message. The composite
typecasters are generated by selecting from one of the five composite typecaster templates

provided by the Typecaster model solution. The names and descriptions of when to use them
are listed below:

1. Record Typecaster Template. Use when the INR description is a record. 3
2. PrivateRecord Typecaster Template. Use when the INR description is a

record and inter-element dependencies exist (as defined in the textual EXR
description). I

3. Array Typecaster Template. Use when the INR description is an array.

4. Private._Array Typecaster Template. Use when the INR description is an
array and inter-element dependencies exist (as defined in the textual EXR I
description).

5. Wrapper Typecaster Template. Use when the INR description is a variantrecord where the discriminant indicates whether the information exists or not, I
as defined by the EXR description, i.e., a field that can be null.

More detailed descriptions of when to use each composite typecaster template are found in !

Appendix Section B.4.

Once a selection is made, the detailed designers create an instance of the composite
typecaster template chosen by making a copy of the template in a new (empty) file and
making the appropriate editor substitutions. The substitutions are based on placeholders

located throughout the template. The placeholders are listed in the header comments at the $
beginning of the template. All templates also use the "?" placeholder for special
instructions, for example, replacement rather than substitution, and code fragment selection.

The "??" placeholder is never listed in the header comments, but one should always search for I
it. The ".?" placeholders should be located and replaced with the appropriate information as
is described by the instructions found with the "??". After the instructions are followed, the

instructions must be removed. If the instruction lines are not removed, the-file will not I
compile. This insures that all special instructions are examined. More detailed descriptions
of how to instantiate each composite typecaster template are found in Appendix Section B.4. i

After the template is instantiated, the file that contains a typecaster package specification,
body, and a test procedure can be compiled and the test procedure can be linked and run.

The test procedure performs canned testing based upon valid and invalid symbolic images I
entered by the detailed designers during template instantiation.

Figure 6-11 shows the typecaster software architecture of the FooBar message defined in i
Figure 2-2 after the composite typecasters have been generated. Notice that the instances of
the composite typecaster templates needed for the FooBar message are dependent upon both 5
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discrete and composite typecasters. The instances of the composite typecaster templates also
show (in parenthesis) which composite typecaster template was used to generate them.

After all composite typecasters have been generated, the detailed designers have an instance
of the Typecaster model solution. This is one of two parts of the MTV model solution. The
other part, the EXR TV model solution is discussed in Section 6.3.3.

IAs a review, the natural image of the message is the USR. The symbolic image of the
message is the UNR. This representation is the interface between the EXR TV model

solution and the Typecaster model solution. At this point one can proceed with the

generation of an instance of the EXR TV model solution.

Finally, before proceeding, detailed designers should study the FooBar message example
using Figure 2-2, Figure 2-6, and Figure 6-11 with the goal of understanding why specific
templates were chosen, together with the composite template descriptions found in Appendix

3 Section B.4.

6
£
I
U
!
I
I
I
I
I
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6.3.3. External Representation TV Template Application
After producing an instance of the Typecaster model solution for a message, an instance of

the EXR TV model solution for the same message can be created. The EXR TV model
solution is captured in one template, the Msg_ICD template. It provides the capability to
convert between the EXR and UNR of a message. The UNR is the interface between the

Typecaster model and the EXR TV model.

Instantiation of the Msg.ICD template requires the definition of the Fields and the Cuts

data structures. These are the results of message analysis and are described in Sections3 6.2.1 and 6.2.2.

Detailed designers create an instance of the MsgICD template by making a copy of the

template in a new (empty) file and making the appropriate editor substitutions. The
substitutions are based on placeholders located throughout the template. The placeholders
are listed in the header comments at the beginning of the template. This template also uses

the "??" placeholder for special instructions, for example, replacement rather than
substitution, and code fragment selection. The "??" placeholder is never listed in the header
comments, but one should always search for it. The "??" placeholders should be located and

replaced with the appropriate information as is described by the instructions found with the
"??". After the instructions are followed, the instructions must be removed. If the
instruction lines are not removed, the file will not compile. This insures that all special

instructions are examined. More d -tailed descriptions of how to instantiate the MsgICD
template are found in Appendix Section B.5.

I After the template is instantiated, the file that contains a Msg_ICD package specification,
body, and a test procedure can be compiled and the test procedure can be linked and run.
The test procedure performs canned testing based upon the valid and invalid EXR entered by

detailed designers during template instantiation.

Figure 6-12 shows the EXR TV software architecture of the FooBar message defined in

Figure 2-2 after an instance of the Msg._ICD template has been generated.

The detailed designer does not need to create an instance of the Msg_ICD template if the

EXR and the TJNR are the same, i.e., a fixed-length, character-based string with punctuation
removed, or a fixed-length, bit-based string with at most one field present in each byte of
information.

At this point instances of both model solutions that comprise the MTV model solution exists.
The UNR, or symbolic image, is the interface between the EXR TV model solution and the

Typecaster model solution. What remains is to tie the two solutions together.

Finally, before proceeding, it is recommended that the FooBar message example using Figure

2-2, Figure 6-3, and Figure 6-12 be studied with the goal of understanding how to use the

MsgICD template described in Appendix Section B.5 to codify an EXR description.

9
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Figure 6-12: FooBar Message EXR TV Software Architecture

6.3.4. Tying Together the Two Model Solutions 3
Figure 6-13 shows the software architecture resulting from applying the MTV model solution

to the the FooBar message. Notice that the instance of the EXR TV model solution is

separate from the instance of the Typecaster model solution. I
Now that the two model solutions have been generated and tested for a particular mepsage,

the two solutions need to be tied together. This part of the MTV solution must be coded I
manually.

17

The detailed designers must generate an executive that makes the appropriate calls to the 3
two model solutions based on the message type and the direction that the information is

flowing (i.e., INR to EXR or vice versa). The interface between the two model solutions is the

IUN"R. The Ada code fragment in Figure 6-14 shows a portimn of an example executive.

I
I
I

17Although a template for this in feasible, one is not supplied with this solutiotn n
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type Memsgejda is (.... Foobar, ...);I

Id: Messagikjds;
AMassage: Cctiyte_.Array,
Icd: CctIc&_MessageType;I

G.LNextLExtrALMO-mg(AMeaae),

- identify the message (1d) and
- store it for translation and validation (lcd)

Messagejd(A.Meinage, Id, Icd)

came 1d i

when Foobar =>

dE:teralp :FooBar)(emaage Rcd teastR.Uvep:=lp IId

Unaersaep : FooBaz.MesageRorTypectr.iveraRep;

UnieraL~ep FooBar.MesageRcodTxtraEternFar -ep);

InternalRap := FooBar _MessageRecord Typecaster.Value(UniveralRep);

- process the Internal ..Rep3

User-.Rep := FooBarMemage-Rncor&-Typecastr.Image(InternaLLRp);

end;I

end ase;

Figure 6-14: Example Fragment of an MTV Executive3
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3 7. MTV Model Solution Description

1

IThis chapter describes the implementation of the MTV model solution and how the model
solution provides the capabilities described in Chapter 4. This chapter is targeted for the
maintainer and the model adapter, i.e., the people responsible for understanding the

implementation of the model for:

*Integration purposes, i.e., integrating instances of the model solution into an3 application.

" Maintenance purposes, i.e., fixing errors or enhancing an application.

* Adaptation purposes, i.e., modifying the model solution for use in a particular
application for which the current state of the model solution does not suffice due
to efficiency reasons (size and speed) or possibly the need for additional
functionality.

Fundamental Concepts
Ada packages are used for abstraction purposes, i.e., the encapsulation of data type and3operations on the data type.

Ada generic packages are used when multiple instances of an abstraction are needed and the
common information shared by instances of the abstraction (that makes each instance

unique) can be formally generalized using generic formal parameters.

Ada package templates are used when Ada generic packages are not powerful enough, i.e.,
one cannot formally specify, using generic formal parameters, the common information that
is shared by instances of an abstraction. Ada package templates are also used to ease the3use (hide the use) of Ada generics and encapsulate the objects, types, and operations needed
to instantiate the generics. The templates, in general, also facilitate testing by containing
test drivers.

UOne key to the success of the MTV model solution is the consistent instantiation of the
Typecaster model for each category of parts or templates described briefly in Chapter 5.

1
I
3CMU/SEI-89-TR. 12 73



I
I

7.1. Foundation Type and Constant Definitions 3
7.1.1. Common Casting Types
All packages in the MTV model solution are dependent upon the types and constant
declarations defined in the package CastingCommonTypes (CCT). The types and constants
provide a consistent view of common information used throughout the model solution from

the foundation utilities through the templates. They are the foundation upon which the I
MTV model solution is built.1 8 See Appendix Section C.1 for the complete listing of the CCT
package. 3
There are three sections of the package that are divided by comment lines. They are:

1. Definitions used by the Typecaster model solution. 3
2. Definitions used by the EXR TV model solution.

3. Definitions used by both Typecaster and EXR TV model solutions.

Typecaster Type and Constant Definitions

This section of the CCT package specification contains the following definitions that support

the Typecaster model solution: I
The maximum length of the symbolic images and natural images (i.e., UNR and
USR). These parameters can be adjusted based on the message set. 3

* Constant string declarations upon which all validity indicators, defined in the
typecasters, are based (both symbolic image validity indicators and natural
image validity indicators). The use of these constant string declarations insures
validity indicator consistency across all typecasters.

EXR TV Type and Constant Definitions

This section of the CCT package specification contains the following definitions that support I
the EXR TV model solution:

" The maximum length of an ICD message, i.e., EXR. This parameter can be
adjusted to different message set requirements.

" A type for holding ICD messages, i.e., a record that has as its elements a string
and an integer indicating the length of the EXR. I

" Constant string declarations that define common punctuation found in EXRs.
Others can be added to support different message set requirements.

* Type definitions that support field extraction utilities. 1
* Type definitions that support the Fields data structure found in the

ICDMessage template. This data structure is defined by the template
instantiator and contains the codification of the EXR description for a message. I
Fields supports conversion between EXRs and UNRs.

I

lflmu package should be considered synonymous to the package Standard supplied by Ad. I
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Typecaster & EXR TV Type and Constant Definitions
This section of the CCT package specification contains the following definitions that support
both the Typecaster and EXR TV model solutions:3 The notion of a string (Byte_ Array) as an array of unsigned bytes. The symbolic

image (UNR) is defined using this form.

* The concept of a position that has the attributes start and stop. The position of
fields in the EXR and elements in the UNR and USR are expressed using this
concept.

7.2. Typecaster Model Solution

This section discusses the various parts of the Typecaster model solution. The categories of
parts that make up the Typecaster model solution, as discussed in Chapter 5, are:

* discrete typecaster generics

o discrete typecaster templates

* composite typecaster templates

Because the typecasters are all based upon the Typecaster model, and the implementations
of individual parts within a category are similar, each part will not be examined individually.
Instead, general solutions for each category will be examined.

For each category, the Ada PDL for the specification, body, and test procedure, where they
exist, will be presented. Those portions of the PDL that differ from typecaster to typecaster
in a category will be !bold italicized, and boxed I How the abstractions (provided by a

category of typecasters) are implemented is then discussed. Items to be examined include:

o what abstractions are provided

i what the package exports to provide the abstractions1 what is imported and inherited to support the abstractions

* how the abstractions are provided

I Individual typecasters (either generics, templates or instances) can be examined in detail in
the appendices of this document.

I
I
I
I
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7.2.1. Foundation Utilities: Discrete Typecaster Generics
These are utility packages upon which the Typecaster model solution is built. This is shown I
abstractly in Figure 5-5 and via example in Figure 6-1. All discrete typecaster generics are
Ada generic packages basedupon the Typecaster model described in Chapter 4. 1
Their implementations must be understood when modifications or enhancements to the
model solution are necessary. The Ada code for each discrete typecaster generic is shown in

Appendix Section C.2.

Each discrete typecaster generic has a template associated with it that provides an
"interface" for instantiating the generic. The template also includes a test procedure for I
testing particular instances of the discrete typecaster generic. Figure 7-1 shows the
association of discrete typecaster generics to discrete typecaster templates and also lists the

Appendix Section in which each discrete typecaster generic can be found. The discrete I
typecaster templates are discussed in the next section.

The job of the discrete typecaster generics is to provide a mapping between symbolic images I
or natural images, and typed discrete Ada values. The existence of a discrete typecaster
generic (and thus a discrete typecaster template) is driven by the characteristics of the
symbolic image and the desired INR. This is shown in Figure 6-8. If a relationship exists
between symbolic images and values that is not represented in Figure 6-8, other discrete
typecaster generics and corresponding templates need to be generated. This is discussed

further in Chapter 8

Appendix
Discrete Typecaster Generic Section Discrete Typecaster Template

IntegerTypecaster C.2.1 Integer Typecaster Template

Math_Onjnteger..Typecaster C.2.3 MathOn.Integer Typecaster Template

EnumerationTypecaster C.2.4 Enumeration Typecaster Template

Math_On_EnumerationTypecaster C.2.6 MathOnEnumeration Typecaster Template

String.MapTypecaster C.2.7 String-Map Typecaster Template

Integer-BitTypecaster C.2.2 Integer-Bit Typecaster Template

EnumeratnBitTypecaster C.2.5 Enumeration-Bit Typecaster Template i

Figure 7-1: Discrete Typecaster Generics 3
Figure 7-2 shows the package specification PDL for a discrete typecaster generic. Figure 7-3
shows the package body PDL for a discrete typecaster generic. All discrete typecaster

generic specifications and bodies are identical except where the PDL is
bod, italicized, and boxed

7
I
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SThe discrete typecaster generics provide the following abstract capabilities:

e Convert from a symbolic image to typed discrete Ada value.U e Convert from a typed discrete Ada value to a symbolic image.

e Check a symbolic image for validity (i.e., can it be converted to a value?).

* Convert from a natural image to typed discrete Ada value.

* Convert from a typed discrete Ada value to a natural image.

e Check a natural image for validity (i.e., can it be converted to a value?).

* Exception is raised if conversion from a symbolic image or natural image to a
value fails.

* Typee discrete Ada values are always valid (enforced by the Ada runtime) and
can always be converted to a symbolic image or a natural image.

These abstractions make up the Typecaster model described in Chapter 4.

Two pieces of information are needed to instantiate a particular discrete typecaster generic.
The first is the TypeToBe_Cast. This is an Ada type that is the INR of the information.3 The second piece of information is TheMap. This defines the mapping between symbolic
images and values. This mapping information is expressed differently among discrete
generic typecasters. For example, the Integer..Typecaster (see Appendix Section C.2.1) has
no The-Map because the mapping from symbolic images to values is implicit.19  The
Enumeration Typecaster (see Appendix Section C.2.4), on the other hand, defines The_Map

as an Ada enumeration type where the enumeration literals are the symbolic images, and

the mapping between a symbolic image and value is defined via positional correspondence of
the values defined by the two discrete types. For more information on how The-Map is
defined for individual discrete typecaster generics, see the Ada generic code in Appendix

Section C.2. For more information on specifying the mapping, see the directions for
instantiating individual discrete typecaster templates in Appendix Section B.3.

3 Based upon TypeTo_Be_Cast, The_Map, and some information obtained from the package

CastingCommonTypes, all discrete typecaster generics provide the abstract functionality

described above. The remainder of this section discusses how the functionality is provided

(i.e., implemented).

The SymbolicImageWidth is defined as an integer constant. Its value is based upon
information about the symbolic images provided in The.Map, whether it is implicit or
explicitly defined. Symbolic-image, the type used to hold a symbolic image, is defined as an
array of bytes of length SymbolicImage_Width. The type that defines an array of bytes

comes from CCT.ByteArray. This promotes consistency among the discrete typecaster
generics.

I Similarly, the NaturalimageWidth is defined as an integer constant. Its value is based on

U lTh. mapping is implicit because Ada provic- 'Image and 'Value functionot.
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the size of the image of an Ada value as defined by the Ada 'Image and Ada 'Width

attributes. Naturaljmage, the type used to hold a natural image, is defined as a character I
string of length NaturalImageWidth. The type that defines a character string comes from
Standard.String. This promotes consistency among the discrete typecaster generics. 5
Two Value functions exist that provide the capability to convert from a symbolic image or
natural image to a value. The basic underlying algorithms for both Value functions are
shown in Figure 7-3. All symbolic image Value functions are implemented slightly I
differently. The algorithm involves first interpreting the symbolic image bytes as a character
string or integer based on whether the discrete typecaster generic is character-based or

bit-based. This interpreted resu7" is then used in conjunction with TheMap to obtain the
desired value of the symbolic image. Conversely, all natural image Value functions are
exactly the same. The algorithm involves using the Ada 'Value attribute as the mapping

function to obtain the desired value of the natural image. Finally, the Value functions are
implemented so that the exception ConstraintError is raised by the Ada runtime when
either conversion fails. 5
Two Image functions exist that provide the capability to convert from a value to a symbolic
image or natural image. The basic underlying algorithms for both Image functions are

shown in Figure 7-3. All symbolic image Image functions are implemented slightly
differently. The algorithm involves using TheMap to obtain either a character string or
integer symbolic image, based on whether the discrete typecaster generic is character-based
or bit-based. The result of the mapping is converted to an array of bytes. All natural image

Image functions are very similar. The algorithm involves using the Ada 'Image attribute as

the mapping function to ooain the desired character string of the value. Thii character I
string is then left padded with spaces, as necessary, to fill in the fixed-length natural image.
Finally, because of the strong typing provided by Ada, the solution assumes that values are

always valid, therefore, the Image function should never fail.

Two Check functions exist that provide the capability to check the validity of a symbolic

image or a natural image. The basic underlying algorithms for both Check functions are I
shown in Figure 7-3. The Check functions are implemented exactly the same, but return
different results based on whether they are checking symbolic images or natural images.

The algorithm involves calling the appropriate Value function to see if conversion is possible. I
If no ConstraintError is raised, then the conversion was made, implying that the image is
valid. Either the ValidSymbolicimage or ValidNatural_Image indicator is returned,

depending upon the Check function. If a ConstraintError is raised, then the conversion was I
not made, implying that the image is not valid. Either the Invalid_Symbolicimage or

InvalidNaturalImage indicator is returned, depending upon the Check function.

The validity indicators returned by the Check functions are defined as SymboliImage or
NaturalImage constants. Their value is based on the validity indicators defined in

CastingCommon_Types that are named the same. The validity indicators defined in the
discrete typecaster generics slice the validity indicators defined in Casting-CommonTypa

based on the size of the symbolic image and natural image. Basing the validity indicators for
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3the discrete typecaster generics on those found in CastingCommon_7ypes promotes

consistency across all typecasters. The advantages of having the validity indicators the same
size as the images will become evident when the composite templates are discussed in

USection 7.2.3.

The Image and Value functions are inlined for efficiency reasons.

Finally, when the generic is instantiated, the mapping is checked to ensure it is completely
specified (one-to-one). That is, for every element in the domain (values), there is a5corresponding element in the range (symbolic images), and vice versa. The mapping between
values and natural images is assumed to be complete (one-to-one) as specified by the Ada
'Image and 'Value attributes.

7
I
I
I
U
I
I
U
I
I
I
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with Casting_Common_Types; I
generic

-- Incernal Representation

type Type_To_Be_Cast is generic formal parameter for discrete Ada type ;

-- Mapping from symbolic images to values of type to be cast 3
The Map ... ;I

package 1 i Typecaster is

package CCT renames Casting_Common_Types; 3
-- Universal Representation
-- Symbolic image size and string to hold it.

SymbolicImage_Width constant Integer b o

subtype Symbolic Image is CCT.Byte_Array(I..Symbolic_ImageWidth);

-- Functions for converting between a symbolic image and a value.
-- Also a function for checking the validity of a symbolic image.
function Value (Image_In SymbolicImage) return TypeToBeCast;
function Image(ValueIn Type_To_BeCast) return Symbolic Image;
function Check(ImageIn SymbolicImage) return Symbolic_Image;

-- Symbolic image validity indicators returned by Check function
ValidSymbolic_Image : constant Symbolic-Image :=

CCT. ValidSymbolic_Image (1.. Symbolic_Image_Width);
Invalid SymbolicImage : constant SymbolicImage :=

CCT. InvalidSymbolicImage (1.. SymbolicImageWidth);

-- User Representation
-- Natural image size and string to hold it.
Natural_ImageWidth : constant Integer := TypeToBeCast'width;
subtype Natural_Image is String(i..NaturalImageWidth);

-- Functions for converting between a natural image and a value. 3
-- Also a function for checking the validity of a natural image.
function Value(Image_In : Natural Image) return TypeToBeCast;
function Image(ValueIn : Type_ToBe_Cast) return NaturalImage;
function Check(ImageIn : NaturalImage) return NaturalImage;

-- Natural image validity indicators returned by Check function
Valid Natural Image : constant NaturalImage :=

CCT.ValidNaturalImage (I. Natural_Image_Width);
Invalid NaturalImage : constant Natural Image :=

CCT. InvalidNaturalImage (1. Natural_Image_Width); 3
-- Real-Time constraint raised by Image and Value functions
Constraint Error : Exception;pragm inl"ne (Value, Image);

end I Generic ITpecaster;

Figure 7-2: Discrete Typecaster Generic Package Specification PDL
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I with Unchecked Conversion;

package body FGenric Typecaster is

-*replace in the PDL based on the results of the condition below

if the generic typecaster is character-based then *=STREhVG
elif the generic typecaster is bit-based then *=INTEGER

Bytes_To_* is new UncheckedConversion (Symbolic Image, ;}
To_Bytes is new UncheckedConversion (*, Symbolic_Image)

function Value (ImageIn : Symbolic_Image) return Type_To_BeCast is
The SI BytesTo_ *(ImageIn);

begin

return Mapping (The-Map, TheSI);

end Value;

function Image(Value In : Type To Be Cast) return Symbolic-Image is

TheS i :[Mapping (ThejiMap, Value-In);

begin
return *_To_Bytes (TheSI);

end Image;

function Check(Image_In : SymbolicImage) retu:n Symbolic_Image is
Dummy : TypeToBeCast := Value(ImageIn);

begin

return ValidSymbolicImage;
exception when ConstraintError => return InvalidSymbolicImage;
end Check;

function Value(Image_In : NaturalImage) return TypeToBeCast is
begin

return Type ToBeCast'Value(ImageIn);
end Value;

function Image(ValueIn : Type_To_BeCast) return NaturalImage is
begin

return I Slice of CCT. Blank-String Type To Be Cast'Image(ValueIn);

3 end Value;

function Check(ImageIn : NaturalImage) return NaturalImage is
Dumy : Type_To_BeCast := Value(Image_In);

begin
return ValidNaturalImage;

exception when Constraint Error => return InvalidNaturalImage;
end Check;

begin
Ensure definition of mapping is complete3end [eer TYpecaster;

I Figure 7-3: Discrete Typecaster Generic Package Body PDL
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7.2.2. Building Blocks: Discrete Typecaster Templates
Discrete typecaster templates are the initial building blocks of the Typecaster model
solution. They form the first layer of the solution (software architecture) on top of the
discrete typecaster generics. This is shown abstractly in Figure 5-5 and via example in

Figure 6-10. All discrete typecaster templates contain an Ada package template based upon
the Typecaster model described in Chapter 4 and a test procedure for testing instances of the
discrete typecaster template. The Ada code for the discrete typecaster templates is shown in

Appendix Section C.3.

As mentioned in the previous section, each discrete typecaster template has a generic
associated with it, The template exists for a number of reasons:

" The discrete typecaster templates contain an Ada package that has placeholders
for the definition of the discrete type to be cast and any symbolic image mappingi
information needed to instantiate the discrete typecaster generics. 20

" The templates provide an "interface" for instantiating the corresponding discrete
typecacter generics. I

* The template facilitates testing of particular instances of the discrete typecaster
generics. 3

Figure 7-1 shows the association of discrete typecaster generics to discrete typecaster

templates. Figure 7-4 lists the discrete typecaster templates and the appendix sections
where the code templates can be found. Also included in Figure 7-4 are the name of an I
example instance of each discrete typecaster template and the appendix sections where the
example code can be found. 3

Appendix Appendix
Discrete Typecaster Template Section Example Instance Section

Integer Typecaster Template C.3.1 HourTypecaster D.1.3
Math On Integer Typecaster Template C.3,3 Scaledjnteger 100 500._Typecaster D.4.1

Enumeration Typecaster Template C.3.4 Direction.Typecaster D.1.2 3
MathOnEr -xration Typecaster Temp. e C.3.6 ScaledInteger_100_1000_Typecaster D.4.2

StringMap ,ecaster Template C.3.7 StatusTypecaster D.1.6

IntegerBit Typecaster Template C.3.2 JuhanDayBit..Typecaster D.1.11

EnumerationBit Typecaster Template C.3.5 DiretionBitTypecaster D.1.8 I
Figure 7-4: Discrete Typecaster Templates

Figure 7-5 shows the discrete <Type>_Typecaster package specification PDL. This is the first 3
of two separate code modules found in all discrete typecaster templates. Al
<Type>_Typecaster package specifications found in the discrete typecaster templates are

identical except where the PDL is I bold, itaLicizea, and boxed I
2°An alternative to 4'is packaging approach is described in Chapter 8.
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3 The discrete <Type>_ Typecaster packages provide the following abstract capabilities:2 1

* Convert from a symbolic image to typed discrete Ada value.

a Convert from a typed discrete Ada value to a symbolic image.

* Check a symbolic image for validity (i.e., can it be converted to a value?).

* Convert from a natural image to typed discrete Ada value.

* Convert from a typed discrete Ada value to a natural image.

e Check a natural image for validity (i.e., can it be converted to a value?).3 * An exception is raised if conversion from a symbolic image or natural image to a
value fails.

e Typed discrete Ada values are always valid (enforced by the Ada runtime) and
can always be converted to a symbolic image or a natural image.

These abstractions make up the Typecaster model described in Chapter 4.

U Two pieces of information must be provided to instantiate a particular discrete typecaster

template. The first is the type to be cast, <Type>JType. This is a discrete Ada type that is
the INR of the information. The second piece of information is TheMap. This information

defines the mapping between symbolic images and values, and resides in the
<Type>_Typecaster package. This information is expressed differently depending upon the
discrete typecaster template chosen. For example, the HourTypecaster package (see

Appendix Section D.1.3) has no TheMap because the mapping from symbolic images to
values is implicit via the Ada 'Image and "Value attributes. The DirectionTypecaster3 package (see Appendix Section D.1.2), on the other hand, defines TheMap as an Ada
enumeration type where the enumeration literals are the symbolic images, and the mapping

between a symbolic image and value is defined via positional correspondence of the values
defined by the two discrete types. For more information on how The.Map is defined for
individual discrete typecaster templates, see the discrete typecaster templates in Appendix
Section C.3. For more information on specifying the mapping, see the directions for

instantiating individual discrete typecaster templates in Appendix Section B.3.

Based upon the definitions provided for <Type>_Type and TheMap, all <Type>_Typecaster
packages in the templates instantiate their corresponding discrete typecaster generic. These
<Type>_Typecaster packages provide (i.e., implement) the abstract functionality described

above by renaming all types, constants, and functions exported by the instantiation of the
discrete typecaster generic. That is, the <Type>_Typecaster packages inherit the
functionality provided by the instances of the discrete typecaster generics.

3 Figures 7-6 and 7-7 show the PDL for the exhaustive and interactive portions of the
<Type>_TypecasterTest procedure. This is the second of two separate code modules found in

all discrete typecaster templates. The test procedures are very similar. The parts that vary

most deal with the 110 portions of the test procedure. To signify those parts of the test
procedures that deal with communication with the tester, the PDL is bolded.

3 2 1Note that these are the same as those that described the discrete typecaster generics in the orevious section.
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The test procedure, <Type>_Typecaster_Test, tests the instance of the <Type>_jypecaster 3
package generated during template instantiation. Since each <Type> _Typecaster package is
based on a discrete typecaster generic and these can be instantiated with discrete types only,

the first portion of the test tests the functionality provided by the typecaster packages based 3
on the finite range of values the discrete type can assume.

For each possible discrete value, the following steps are performed first for symbolic images 3
and then for natural images, and any test case failures are reported to the tester-

1. Apply Image function, i.e., convert the value to an image.

2. Apply Check function, i.e., check the image for validity.

3. If Check function indicates an invalid image then the typecaster has failed. I
4. Apply Value function, i.e., convert the image back to a value.

5. If Value function raises a constraint error then the typecaster has failed.

6. Also, if the discrete value from Step 1 is not the same value that results in Step 3
4 then the typecaster has failed.

But exhaustive testing only performs testing of typecaster functionality based on valid 3
symbolic images, natural images, and values. There is also a need to test typecaster

functionality based on invalid symbolic images, natural images, and values, and to make
sure the mapping specified when the template was instantiated is correct. This testing is 3
provided through interactive testing.

Because the typecasters perform translation and validation based on the relationship I
between either symbolic images and values, or natural images and values, the interactive

testing is broken up into two parts. The first part tests translation and validation between

tester-supplied values and symbolic images. The second part tests translation and validation I
between tester-supplied values and natural images.

The following steps are performed for each of the two testing parts described above: 3
1. Prompt tester for image.

2. Apply Check function, i.e., check the image for validity. 3
3. Notify tester of image validity.

4. Apply Value function, i.e., convert the image to a value. I
5. Show tester value of image.

6. If Value function raises a constraint error then notify tester of image invalidity.

7. Prompt tester for value. I
8. Apply Image function, i.e., convert the value to an image.

9. Show tester image of value. 3
10. If tester types AZ at any prompt, exit the test.

I
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This form of interactive testing allows the tester to enter invalid symbolic and natural
images to test the functionality of the typecasters based on invalid images. The tester can
ensure that the typecaster truly treats them as invalid based on the information returned by
the test routine in the form of error messages and the presentation of the results of the
Check function. The tester can also use interactive testing to ensure the mapping used to
instantiate the typecaster was specified properly by entering valid values and images and3examining the results.

I
I
1
I

iI
I
I
I
I
U
I
U
i
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with GnrcTypecaster; -- The corresponding generic typecasterI

package <Type>._Typecaster is
-- Internal Representation & Internal Representation Description
-- Type to be cast U
type <Type>_Type is .

-- Symbolic image (universal representation) mapping information

-- Instantiation of tycaster appropriate for this template

ITp>T isT nypecaster (<Type>_Type, <Type>_Mqp )

-- Uivexs.L Rep.esentation
-- Symbolic image size and string to hold it.
SymbolicImage_Width : Integer renames <Type> TC. Symbolic_Image_Width;."ubtype SymbolicImage is <Type>_TC.SymbolicImage;

-- Functions for converting between a symbolic image and a value. 5
-- Also a function for checking the validity of a symbolic image.
function Value(ImageIn : Symbolic Image) return <Type> Type

renames <Type>_TC.Value;
function Image(Value In : <Type>_Type) return SymbolicImage

renames <Type>_TC. Image;
function Check (Image In : Symbolic Image) return SymbolicImage

renames <Type>_TC. Check;

-- Symbolic image validity indicators returned by Check function
ValidSymbolicImage : renames <Type>_TC.ValidSymbolicImaqe;
InvalidSymbolicImage : renames <Type>_TC.InvalidSymbolic Image;

-- User Representation
-- Natural image size and string to hold it. _

NaturalImageWidth : Integer renames <Type>_TC. NaturalImage_Width;
subtype NaturalImage is <Type> TC.Natural Image;

-- Functions for converting between a natural image and a value. n
-- Also a function for checking the validity of a natural image.
function Value (ImageIn : NaturalImage) return <Type> Type

ren s <Type>_TC.Value;
function Image(Value In : <Type> Type) return Natural Image I

renames <Type>_TC. Image-
function Check(ImageIn : NaturalImage) return NaturalImage

renames <Type>_TC. Check; I
-- Natural image validity indicators returned by Check function
Valid NaturalImage : renames <Type>_TC.Valid Natural Image;
InvalidNatural_Image : renames <Type>_TC.Invalid Natural_Image;

-- Real-Time constraint raised by Image and Value functions
Constraint Error : Exception: I

-Ad .'Zya>...>yPecAster ;

I
Figure 7-5: Discrete Typecaster Template Package Specification PDL
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I with <Type>_Typecaster;
with Unchecked-Conversion;

with CastingComon Types;
with TextIO;
procedure <Type>_TypecasterTest is
begin

3 -- Exhaustive Testing Loop: loop through range of discrete values
for Value in <Type>_Typecaster.<Type>_Type'First ..

<Type>_Typecaster.<Type> Type' Last loop

b-- Symbolic Image Testing
TestSI := <Type>_Typecaster.Image(Value);
CheckSI := <Type>_Typecaster.Check(Test_SI);
if Test SI /= <Type> Typecaster.Valid SymbolicImage then

Notify tester symbolic image exhaustive testing FAILED.end if;

TestValue := <Type>_Typecaster.Value(TestSI);
if Test Value /= Value then

Notify tester symbolic image exhaustive testing FAILED.3 end if;

-- Natural Image Testing

Test NI := <Type>_Typecaster. image (Value);
Checi NI := <Type>_Typecaster. Check (Test_NI);
if Test NI /= <Type>_Typecaster.Valid Symbolic_Image then

Notify tester natural image exhaustive testing FAILED.3 end if;

Test Value := <Type>_Typeca-, :.Value(TestNI);
if Test Value /= Value the"

Notfy tester natural image tustive testing FAILED.
end if;

exception
when Constraint Error =>

Errors := True;

if raised during symbolic image testing then
Notify tester symbolic image exhaustive testing FAILED.

elsif raised during natural image testing then
Notify tester natural image exhaustive testing FAILED.

end if;
end;

end loop;
if Errors occurred then

Notify tester exhaustive testing completed unsuccessfully.
else

Notify tester exhaustive testing completed successfully.
3 end if;

I Figure 7-6: Discrete Typecaster Template Test PDL (Exhaustive)
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-- Interactive Testing Loop 1
loop
begin 3

-- Symbolic Image Testing
Prompt tester for character string or integer symbolic image, Test_SI.
Convert Test SI to CCT.Byte Array.
Check SI := <Type> Typecaster.Check(TestSI);
Show'ester validity indicator, Check_SI, returned by Check function.
Test Value := <Type> Typecaster.Value(Test SI);
Showtester value, Test-Value, returned by Value function.

Prompt tester for a value, Test-Value.
Test_SI := <Type>_Typecaster.Image(TestValue);
Interpret TestSI as character string or integer.
Show tester symbolic image, TestSI, returned by Image function.

-- Natural Image Testing 5
Prompt tester for character string natural image, TestNI.
Check NI := <Type> Typecaster.Check(Test NI);
Show'ester validity indicator, Check.._NI, returned by Check function.
Test Value :- <Type>_Typcaster.Value(Test NI);
Show tester value, Test-Value, returned by Value function.

Prompt tester for a value, Test Value. 3
Test NI := <Type>..Typecaster.Image(Test Value);
ShoW tester natural image, Test_NI, returned by Image function.

exception 3
when Constraint Error I DataError =>

Notify tester of invalid input.
when End Error =>

Notify tester testing complete.
exit;

when Others =>
Notify tester unknown failure has occurred.
exit;

end;
end loop; 3

end <Type> TypecasterTest; I
Figure 7-7: Discrete Typecaster Template Test PDL (Interactive)

I
U
I,
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7.2.3. Building Blocks: Composite Typecaster Templates
Composite typecaster templates are the expansion building blocks of the Typecaster model
solution. They form the remaining layers of the solution (software architecture) and can be
built upon instances of discrete typecaster templates or other instances of composite

typecabLer templates. This is shown abstractly in Figure 5-5 and via example in Figure 6-11.
All composite typecaster templates contain an Ada package specification and body template3 based upon the Typecaster model described in Chapter 4, and a test procedure for testing
instances of the composite typecaster template.

3 The Ada code for the composite typecaster templates is shown in Appendix Section C.4.

The composite typecaster provides a mapping between symbolic images or natural images3 and typed composite Ada values. To provide this mapping, composite typecasters use the
functionality provided by typecasters previously created for the elements of the composite.
The composite typecaster template exists for a number of reasons:

3 To allow the designer to group both discrete and composite typecasters (and thus
their symbolic images, natural images, values, and validity indicators) in a
manner consistent with the EXR description. 22 The composite typecasters are3 therefore dependent upon other typecasters.

9 Ada generic formal parameters cannot be of an Ada composite type. Thus, we
created our own "generics" in the form of code templates. These templates both
automate the production of code and perpetuate the consistencies from the
discrete typecasters.

The template facilitates testing of particular instances of the composite
typecaster templates.

Figure 7-8 lists the composite typecaster templates and the appendix sections where the code

templates can be found. Also inctuded in Figure 7-8 are the name of an example instance of

each composite typecaster template and the appendix sections where the example code can
be found. 

Appendix 
Appendix

Composite Typecaster Template Section Example Instance Section3 Record Typecaster Template C.4.1 JulianDate Time..RecordTypecaster D.2.1

Private..Record Typecaster Template C.4.2 FooBar_-Message..Private_-RecordTypecaster D.2.2

Array Typecaster Template C.4.3 BarrierSegmentArrayTypecaster D.4.3

Privte..Array Typecaster Template C.4.4 ProbabilityPrivate_-ArrayTypecaster D.4.4
Wrapper Typecaster Template C.4.5 Probability_WrapperTypecaster D.4.5I

Figure 7-8: Composite Typecaster Templates

22This grouping continues until all symbolic images are grouped and are in an order compatible with the UNR

expected by the EXR TV model solution for a particular message.

3 CMU/SEI-89-TR-12 89



I

Figures 7-9 and 7-10 show the composite <Type>_Composite_Typecaster package
specification PDL. Figures 7-11 and 7-12 show the composite I
<Type>_Compositeypecaster package body PDL. These are the first two of three separate
code modules found in all composite typecaster templates. All
<Type> _CompoeiteTypecaster package specifications and bodies found in the composite
typecaster templates are identical except where the PDL is bold italicized, and boxed

The composite <Type>_CompositeTypecaster packages provide the following abstract i
capabilities:

2 3

" Convert from a symbolic image to typed composite Ada value. I
" Convert from a typed composite Ada value to a symbolic image.

" Check a symbolic image for validity (i.e., can it be converted to a value?). i

" Convert from a natural image to a typed composite Ada value.

" Convert from a typed composite Ada value to a natural image. 3
* Check a natural image for validity (i.e., can it be converted to a value?).

* An exception is raised if conversion from a symbolic image or natural image to a
value fails. I

" Typed composite Ada values are always valid (enforced by the Ada runtime) and
can always be converted to a symbolic image or a natural image.

*Provide the positions of the elemental images within the composite image (for
both symbolic and natural images).

* Provide the positions of the validity indicators for each elemental image within
the validity indicator for the composite image (for both symbolic and natural I
images).

These abstractions make up the Typecaster model described in Chapter 4. I
To instantiate a particular composite typecaster template, some information must be
provided. The first is the name of the Ada composite type to be cast, 3
<Type>_CompositeType. This is a composite Ada type that is the INR of the information.
The next piece of information is the names of the types, <Ti>_Type..<Th>_Type that the
composite type <Type>_CompositeJype groups. These types (that are grouped by the
composite typecaster being defined) must already be defined in the typecasters
<Tl>_Typecaster..<Th>_Typecaster because the <Type>-CompositeType inherits the types

it groups from the corresponding typecasters. Finally, the names of the elements I
<El>..<En> must be provided. These names are used to define:

* The elements of the composite type <Type> _CompositelType. These represent
objects of the types <Ti>_Type..<Tn>_Type that are inherited from the
typecasters <T1 >_Typecaster.. <Tn>_Typecaster.

23Note that these are basically the same as described in the previous two sections that described the discrete
typecaster generics, and templates with the addition of some capabilities to handle elemental image position. i
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• The names of the elements specified in the discrete type
<Type> ElementNames. These names are used to access:

" Elements of the Symbolic-image. These correspond to the
Symbolic jmages inherited from the typecasters
<Ti>_2ypecaster..<Th> Typecaster via the Image function.

* Elements of the NaturalImage. These correspond to the Natural_Images
inherited from the typecasters <Tl>.Typecaster..<Th>_Typecaster via the
Image function.

* Elemental validity indicators corresponding to the Symbolic-image. These
correspond to the validity indicators inherited from the typecasters
<Tl>_Typecaster.. <Tn>_Typecaster via the Check function.

" Elemental validity indicators corresponding to the Natural.jmage. These
correspond to the validity indicators inherited from the typecasters
<Tl>_Typecaster..<Tn>_Typecaster via the Check function.

This information is expressed differently depending upon the composite typecaster template

chosen. For example, creating the Julian Date TimeRecordTypecaster package (see
Appendix Section D.2.1) involves supplying the names of all elements, and also the types of

all elements grouped by the Ada record. On the other hand, the

BarrierSegmentArrayTypecaster package (see Appendix Section D.4.3) involves supplying

first and last elements (i.e., an integer range) and only one type, the type of the elements
grouped by the array. For more information on individual composite typecaster templates,

see the composite typecaster templates in Appendix Section C.4. For more information on
instantiating individual composite typecaster templates see Appendix Section B.4.

I Based upon the composite type <Type>_<Compoaite>_Type, the names of the elements
<EI>..<En>, the elemental typecasters <Tl>_Typecaster..<Tn>_Typecaster that are grouped,

and some information obtained from the package CastingCommon.Types, all composite

typecaster templates provide the abstract functionality described above. The next thing to
discuss is how the functionality is provided (i.e., implemented).

I The SymbolicimageWidth is defined as an integer constant. Its value is based on the sum
of the SymbolicimageWidths inherited from the elemental typecasters,
<Tl>_Typecaster..<Tn>_Typecaster. Symbolic-Image, the type used to hold a symbolic

image, is defined as an array of bytes of length SymbolicImageWidth. The type that
defines an array of bytes comes from CCT.ByteArray. This promotes consistency among the

3 typecasters.

Similarly, the Natural..mageWidth is defined as an integer constant. Its value is based on3 the sum of the NaturalimageWidths inherited from the elemental typecasters
<Tl>_Typecaster..<Th>5ypecaster. NaturalImage, the type used to hold a natural image,

is defined and a character string of length NaturalimageWidth. The type that defines a

character string comes from Standard.String. This promotes consistency among the

typecasters.

TheSymbolic.ImagePositions is defined as a constant array that holds the starting and
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stopping positions of the elemental symbolic images and is accessed using the names of the

elements specified by the discrete type <Type>ElementNames. The starting and stopping
positions of the elemental symbolic images are based on the progressive summing of the

SymbolicImageWidths inherited from the elemental typecasters 3
<Tl>Typecaster..<Tn>jTypecaster. The type that defines an array of positions comes from

CCT.PositionArray. This promotes consistency among the typecasters.

Similarly, The.NaturaljmagePositions is defined as a constant array that holds the

starting and stopping positions of the elemental natural images and is accessed using the
names of the elements specified by the discrete type <Type>_Element_Names. The starting 3
and stopping positions of the elemental natural images are based upon the progressive

summing of the NaturalimageWidths inherited from the elemental typecasters
<Tl>_ ypecaster..<Th>jypecaster. The type that defines an array of positions comes from

CCT.Position_Array. This promotes consistency among the typecasters.

Two Value functions exist that provide the capability to convert from a symbolic image or 3
natural image t_' a composite value. The basic underlying algorithm for the symbolic image
Value function is shown in Figure 7-11, and the algorithm for the natural image Value

function is shown in Figure 7-12. Both algorithms work the same and can be summarized as I
follows: For each element <En>, slice the elemental image out of the composite image using

the known positions of the elemental images. Convert this image slice to a value using the

Value function inherited from the elemental typecaster and assign the value to the element I
of the composite type. Finally, if any call to an elemental typecaster Value function results
in the ConstraintError exception being raised, the exception is propagated out. 3
Two Image functions exist that provide the capability to convert from a composite value to a

symbolic image or natural image. The basic underlying algorithm for the symbolic image

Image function is shown in Figure 7-11, and the algorithm for the natural image Image I
function is shown in Figure 7-12. Both algorithms work the same and can be summarized as

follows: For each element <En> of the composite type, convert the value to an image using

the Image function inherited from the elemental typecaster. Assign the elemental image to a
slice of the composite image using the known positions of the elemental images. Finally,
because of the strong typing provided by Ada, the solution assumes that values are always

valid, therefore the Image function should never fail.

Two Check functions exist that provide the capability to check the validity of a symbolic

image or a natural image. The basic underlying algorithm for the symbolic image Check

function is shown in Figure 7-11, and the algorithm for the natural image Check function is
shown in Figure 7-12. Both algorithms work the same and can be summarized as follows:

Attempt to convert the image to a value using the composite Value function. If no
CostraintError is raised, then the image is valid so return a valid image indicator. If a

ConstraintError is raised, handle it. This implies the image is invalid and th- invalid i
image indicator must be built from the elemental validity indicators. This is done via the

following steps: For each element <En>, slice the elemental image out of the composite

image using the known positions of the elemental images. Obtain a validity indicator for the i
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elemental image by applying the Check function inherited from the elemental typecaster.

Place the elemental validity indicator in the composite validity indicator, again using the
known positions of the elemental images.

I The validity indicators returned by the Check functions are defined as Symbolicjmage or
Natural-image constants. The composite valid image indicators ValidSymbolicimage and
Valid_Natural.Image are defined as the concatenation of the elemental valid image
indicators inherited from the elemental typecasters <Tl>_ypecaster..<Th>_ ypecaster.
Invalid image indicators are not defined, but instead they are built. They are built by
concatenating the validity indicators for each elemental image. See the description of the

Check function above for more details.

3 Finally, Image and Value functions are inlined for efficiency reasons.

The private composite typecasting templates provide additional capabilities to enforce
inter-element dependencies imposed by the textual EXR description. Figure 7-13 shows the

parts of the PDL of the package specification portion of the
<Type>_'riuateCompositeTypecaster template that are needed to provide the additional3 capabilities.

The <Type>_PrivateCompositejypecaster packages provide the following additional5 capabilities:

" Convert composite values from an accessible form whose data are available to
the application to a protected form where inter-element dependencies are3 checked and preserved.

* Convert composite values from a protected form where inter-element
dependencies are checked and preserved to an accessible form whose data are3 available to the application.

To instantiate a particular private composite typecaster template, one must provide the body

of the function IsConsistent. This function must provide the inter-element consistency

checking based upon the textual EXR description.

The following are the additional constants, types, and functions defined in the private

composite typecaster templates.

<Type>_PublicCompositeType is the Ada composite type to be cast.

< Type>_Private_Compositeype is the private version of the
<Type>PublicComposite_7ype. Its purpose is to encapsulate and hide the information3 from the application and maintain data integrity, i.e., ensure inter-element consistency.

InconsistentSymbolicimage is defined as a Symbolic-image constant. It is used to hold the
indicator returned by the Check function when inter-element inconsistencies in the symbolic

image are detected. Its value is defined by CCTInconsistentSymbolicjmage and its width
is Symbolic imageWidth.
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I
InconsistentNatural_Image is defined as a Natural_Image constant. It is used to hold the
indicator returned by the Check function when inter-element inconsistencies in the natural
image are detected. Its value is defined by CCT.InconsistentNatural-mage and its width is
Natural_ImageWidth. 3
The Make-Public function provides the capability to convert from a value of type
Private_Compositeype to a value of type PublicCompoaite_ Type, that is, to convert

from the protected form to the accessible form. The basic underlying algorithm is to do an
explicit type conversion from the private type to the public type.

The MakePrivate function provides the capability to convert from a value of type I
PublicComposite Type to a value of type PrivateCompositeType, that is, to convert
from the accessible form to the pro'ected form. The basic underlying algorithm is to first do

an explicit type conversion to get the PrivateCompositeype value and then check the
inter-element dependencies via the IsConsistent function. If the elements are not consistent
then a Constraint-Error is raised. 3
The basic underlying algorithms involved in these functions are shown in Figure 7-14.

Figures 7-15 and 7-16 show the PDL for the cymbolic image and natural image portions of i
the <Type>_ypecasterTest procedure. This is the third of three separate code modules
found in all composite typecaster templates. The test procedures are very similar. The parts

that vary most deal with the I/O portions of the test procedure. To signify those parts of the
test procedures that deal with communication with the tester, the PDL is bolded.

The test procedure, <Type>_CompositeTypecasterTest, tests the instance of the
<Type>Composite_-ypecaster package generated during template instantiation. It uses
predefined test cases based on symbolic images specified by the detailed designer when the
instance of the template was created. The detailed designer also specifies whether each
symbolic image test case is valid or invalid, so the test routine can determine if the expected
results were obtained. The entire range of functionality of the typecaster is tested based on
the symbolic image test cases. This type of testing is considered canned testing.

Because the typecasters perform translatior and validation based on the relationship 3
between either symbolic images and values, or natural images and values, the canned
testing is broken up into two parts. The first part tests translation and validation between
the predefined test symbolic image and value. The second part tests translation and 3
validation between the resulting value and natural image.

The following steps are performed for canned testing: 3
1. Apply Check function to predefined test symbolic image, i.e., check the image

for validity.

2. Apply Value function to predefined symbolic image, i.e., convert the image to a
value.

3. If Value function raises a constraint error and the test case was specified as
valid, then notify tester of symbolic image test case failure.
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5 4. Apply Image function, i.e., convert the value to a symbolic image.

5. If the resulting symbolic image is not the predefined test symbolic image
started with (i.e., from Step 1), then notify tester of symbolic image test case3 failure.

6. tipply Image function to value from Step 2, i.e., convert the value to a natural

image.3 7. Apply Check function, i.e., check the natural image for validity.

8. Apply Value function, i.e., convert the natural image to a value.

9. If the resulting value is not the value started with (i.e., from Step 6), then notify
tester of natural image test case failure.

10. If Value function raises a constraint error and the test case was spezified as
valid, then notify tester of natural image test case failure.

This form of canned testing allows testing based on valid or invalid symbolic images. It

allows testing of valid natural images but does not allow testing of invalid natural images.

The specification of the validity of each individual test case allows the test procedure to pass,
even though the typecaster may fail because of an invalid test case.

I3
I
I

I
I
I
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with Castin_Commn Typets;
- -Obtain access to the appropriate discrete or composite typecasters
with '<T1>_.Typecaster; ... with '<Tn>..Tyect;3

package <Typo>4 Cmosite ypecaster is

package CCT renames Castingeion x Types;
-- Internal Representation & Internal Representation Description

Based on the elements <EZ>..<En> and
type <Type>C poteTe is their associated types <TZ> .Tye.Tnjy;

-- Names of the elements3
type <Type> EZlement Names is [I Ij .. <n>1;

-Universal Representation and Universal Representation DescriptionI
-- Symbolic image size and string to hold it.
Symblic Image Width :constant Integer

<T1> Typecater.Symbolic Image.Width +

< Tn>...Typecaster.Symbolic Irnge.Width;3

subtype SymbolicImage is CCT .Byte Array (1.. SymbolicImgeWlidth);

-Functions for converting between a symbolic image and a value.
-Also a function for checking the validity of a symbolic image.

function Value (Image In :SymbolicImage) return <Type> _Type;
function Image (Value In :<Type>_Type) return Symbolic-Image;

function Check (Image In :Symbolic-Image) return Symbolic Image;I

-- Symbolic image validity indicators returned by Check function
Valid Symblic Imag: constant Symblic Imgeo

<T.TpecaterValid..Smbolic Image &U
<77>Typecaster. Valid.Symbolic Image &

<Tn> Typecaster. Valid SymbolicImage;3

Inconsistent-Symbolic -Imagoe constant Symbolic-Image
CCT. InconsistentSymbolic-Image, (1. . SymbolicImageWidth);

-- Pointers to the position of each elemental symbolic imageI
The_SymbolicImage_ositions :constant

CCT.Position Arcay(<Type> Element Names) :

(c<Bl>=>(Start =>O0+l1,3
Stop 0 0+ <El>_Typecaster.Symbolimage-Width),

<E2> => (Start =>The-Symbolic Image_-Posiiions(<Eb.) + 1,
Stop => The...Symboicjmage-.Positiona(<El>) +

<E2>.Typecaster.Symbolic~lmage_ Width),

<En> => (Start -> Th&e-..ymbolcimagePosition(En-1>) + 1,
Stop => The...SymbolicImagej'osition(<En-l>) +

<En>..Typecaster.Symbolic Ilmage..Width));

Figure 7-9- Composite Typecaster Template Package Spec PDL - Part 1
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I -- User Representation and User Representation Description
-- Natural image size and string to hold it
Natural Image Width : constant Integer -<Tl>_T- ypecasterWaturaLlmqge _Width +

<T2>_Typecaster.NaturalImageWidth +

3 l<Tn>-Typecaster-VNaural-mage-Width,

subtype NaturalImage is CCT.ByteArray (1..Natural_ImageWidth);

-- Functions for converting between a natural image and a value.
-- Also a function for checking the validity of a natural image.
function Value(ImageIn NaturalImage) return <Type> Type;
function Image (Value_In <Type> Type) return NaturalImage;
function Check(ImageIn NaturalImage) return NaturalImage;

-- Natural image validity indicators returned by Check function
Valid Natural Image : constant Natural Image =

<Tl> _Typecaster.ValidNatualmage &
<T2>_Typecaster. Valid_Natural Image &

3 <Tn>_Typecaster. ValidNaturallmage;

InconsistentNaturalImage : constant Natural-Image
CCT. InconsistentNatural Image (1. NaturalImage_Width);

-- Pointers to the position of each elemental natural image
The NaturalImagePositions : constant

CCT.Position Array(<Type> Element Names)
(<El> => (Start => 0 + 1,

Stop => 0 + <El>_TypecasterJVaturatlmageWidth),
<E2> => (Start => TheNaturalImagePositions(<El>) + 1,

Stop => The_NaturalImage_-Positions(<El>) +
<E2>_Typecaster. _aturalImageWidth),

3 <En> => (Start => The.Natura~lmagePositions(<En.l>) + 1,
Stop => The_Natura lmage_-Position(<En-l>) +

<En>_Typecaster.NaturalImageWidth));

-- Real-Time constraint raised by Value function
ConstraintError : xception;
pragma inline Value, Image);

end <Type> 4 oote Typecaster;

I
Figure 7-10: Composite Typecaster Template Package Spec PDL - Part 2
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package body <Type>4 i >J.ypecaster isI

function Value (Image In :SymbolicImage) return <Type> _Type is

beReturnValue -. <Type> _Type;

<El> of Return_Value :Tl>....Typecaster. Value(
Image jn(he.$ymbolic ImagePositions(<El>).Start

ThefiSymbolic-Image-Poition(<El>).Stop));

<En> of ReiurnValue.- <Tn>_Typecaster. Value(
Image jn(he.Symbolic-Image-Position.r(cEn>).Start.

The.Symbolic-1mage.Poition(<En>).Stop));
return Return Value;

end Value;3

function Image (ValueIn :<Type> _Type) return Symbolic Image is
Return Image :Symbolicimage;

begin
Return mage(The.Symbolic-Iinage..Poitions(<El>).Start..

TheoSymbolicjmawge -Postion(<EZ>).Stop)
<TZ>...ypecasterlvnage(cEl> of Value jn);

Return jmage(The.$ymbolic Imaige.Posions(<En>).Start..
The.Symboiic-Image-Positiona(<En>).Stop)

<Tn>_Typecaster.image<En> of Value in) ;
return ReturnImage;

end Image;3

function Check (Image_,In :SymbolicImage) return Symbolic Image is
ReturnCheck :Symboli Iage

ReturnValue :Tye Composite Type,

begin
ReturnValue :=Value (Image_In);
return Valid SymbolicImage;

exceptionI
when Constraint Error =>

ReturnCheck(The.Symbolwicmage.j'ositions(<El>).Start..
<T>T The_.SymbolicjnaagePogilons(<EI>).Stop) .'= I
<T>ypecaster. Check(Imagejn(Tk&e..SymtbolicjmagePositions(<El>).Start..

Th&e,.Symbolic-Image.Positions(<El>).Stop));

Return_Clsek(TheSymbolwic.magePoaition.(<En>).Start..
The~ymolic~age..Pouition(<En>).Stop)

<Tn>.j'ypecaster.Check(Imge-ln(7Theymbolicjmage.Poitions(<En>).Start..

The-SymboliIagePjositions(<En>) .Stop));__
return Check Image;

end Check;3

Figure 7-11: Composite Typecaster Template Package Body PDL - Part 1
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Ifunction V~u(mg~n:Natural -image) return <Type> _Type is

begin

<El> of Returnalue .= <Ti>_.Typecaster.Value(
Image Jn(The_NaturalIge-P~oto(<Ei>).Str..

The..Naturalmage.osiion(<E>).Stop));

I <Ein> of ReurnValue = <Tn>_Typecaeter. Va1*ue(
Image jn(TheNaturalimage j'ouiion.(cEn$.Start..

retun Rtur-Vaue;TheNatural jmage.YPositi ons(<En>).Stop));

end Value;

3 function Image (Value-In :<Type> _Type) return Natural-Image is
Return-Image :Natural-Image;

begin

ReturnImage(The NaturaImage-Poaitione(cEl>).Start..
TheNaturalImtage j'oition(<El>) .Stop)

<Ti>_Typecaster.Image(<El> of Value jn);

ReturnImage(The NaturalImage..Pouitions(<En>).Start..
The-N aturalImage.-Positions(<En>).Stop) :=

<Tn>_ Typecaster.Image&<En> of Valuejn);
return Return Image;

end Image;

function Check (Image In :Natural -Image) return Natural Image is
ReturnCheck Natural Ima

ReturnValue <Type> Copsite Type;

beginIReturn_-Value Value (Image In);
return Valid NaturalImage;

excepti.on
when Constraint Error =>

ReturnCheck(The-.NaturalImagePosition.(<El>).Start..
TheNatura lnmage.Position(<EZ>). Stop)

<Ti,_Typecaater.Check(ImageJn(The NaturaL~nmage.Position.(<El>).Start..

The...NaturaljInsage Poaition(<El>).Stop));

RieturnCheck(TheNatura lmage'ouioa(<En>).Start..

<Tn> T TheNaturalImage Positions(<En>).Stop) =
<nypecster.Check(ImsagejnThe..Natural-Image.-Poition(<En>).Start..

The .N aturalk-mage .Yositi one (<En>) .Stop));

return Check Image;
end Check;____

end <Type> CopseTp-ecaster;

3 Figure 7-12: Composite Typecaster Template Package Body PDL.- Part 2
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package <Type> _Private CopieTpecaster is3

-- Internal Representation & Internal Representation Description

type <Type>_Private Composite Tyeis private;

Based on the elements <EZ>..cEn>
and their associated

type <Type> -Public CoposteType is types <T1>..Type..<Tn>_Typen

-Symbolic image validity indicators returned by Check function
InconsistentSymbolic_mage : Constant SymbolicImage :=I

CCT. Inconsistent-Symbolic Image (1. .SymbolicImage_Width);
Inconsistent Natural-Image :Constant NaturalImage :=

CCT. Inconsistent NaturalImage (1..NaturalImage_Width);

-Functions for converting between the <Type> _Private CmpsteTpe
-and the <Type> PublicCopoiteType types.3

function MakePublic (Private Value In: <Type> Private Composite Type);

function Make-Private (Public Value In: <Type> Public CmoieTpe);S

private
type Composte Typ is new3

<Type>_PublicCopitTpe

end <Type> Privatej Composite Typecaster;

Figure 7-13: Private Composite Specification PDL
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3 package <Type> _Private Coosite Typecauter body is

function IS-Consistent (ValueIn: <Type>_Private.. Co ot i Type)

3 return Boolean is
begin

The inter-element dependencies of the composite type are checked
here. If an inconsistency is found false is returned, otherwise true is

returned.
end IsConsistent;

function Make-Public (PrivateValueIn : <Type>_Private- Composite Type)3 return <Type>-Public Composite Type is

begin
return <Type>_Public Coposit Type (PrivateValuen);

I end MakePublic;

function MakePrivate (Public ValueIn in <Type>_Public Composite Type)

return <Type>_Private Copst>ype is

Private-Value : <Type> _Private Copoit Type;

begin

Private_-Value :-<Type>_rivate CmoiteType, (Public Value In);
if Is_Consistent (Private Value) then

return PrivateValue;
else

I sraise Constraint_Error;
end if;

end MakePrivate;

end <Type> Private Composite Typecaster;

I Figure 7-14: Private Composite Body PDL

I
I
I
I
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with <Type> C oIteTypecaster;

vith UncheckedConversion;
with CastingCosmmon_Typos;
with Text_10; _____I

procedure <Type> Cm sItTypecasterTest is

N integer :- ??; -- number of test cases
type TestCaseType is
record

TestImage <Type> Copsie pecaster. Symbolic Image;

Valid Boolean;I
end record;

Test_-Cases :array(1. .N) of Test CaseType
(1=> (Test Image => ?"

Valid => ?

N=> (TestImage => ?,

Valid =>?);
begin

-- Canned Testing Loop
for I in Test Cases'First TestCases'Last loop

-- Symbolic Image Testing3
begin

-- start symbolic image testing with the test symbolic image
CheckSI :- <Type>_Typecaster.Check (Test -Cases (I).TestImage);
TestValue -SI :-<Type> _Typecaster.Value (TestCases(I).TestImage);
Test-SI =- <Type> _Typecaster. Image (TestValue-s!);

-- if symbolic image we started with is not what we have now, FAIL
if Test SI /- Test Cases (I).Test_-Image then

raise UnknownSymbolicailure;
end if;3

exception
when Constraint Error =

if Test Cases (I).Valid then

Notify tester a valid test case has failed in symbolic image testing
Show tester Test Cases (I) .Test image that failed
Show tester validfty indicator Check SI

end if;
when Unknown-Symbolic Failure -

Notify tester an unJiown failure has occurred in symbolic image testing

an;Show tester Test-Cases (1) .Test-image that failed

Figure 7-15: Composite Typecaster Template, Test PDL for Symbolic Images
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I -- Natural Image Testing
begin

3 -- start natural image testing with value from symbolic image testing
TestNI := <Type>_Typecaster.Image(TestValue_S);
Check NI :- <Type>_Typecaster.Check (Test NI);3 Test Value NI := <Type>_Typecaster.Value (Test NI);

-- if value we started with is not what we have now, FAIL
if Test Value NI /= Test Value SI then

raise Unknown .Natural rail:re;
end if;

exception
when ConstraintError =>

if Test Cases (I).Valid then
Notify tester a valid test case has failed in natural image testing
Show tester Test Cases (1) . Test_Image that failed
Show tester validity indicator CheckNI

end if;
when Unknown Natural Failure =>

Notify tester an unknown failure has occurred in natural image testing
Show tester TestCases (I) . Test_Image that failed

end;
end loop;

if Errors occurred then
Notify tester canned testing completed unsuccessfully
Notify tester canned testing completed successfully

end if;

3 end <Type> Composite Typecaster Test;

Figure 7-16: Composite Typecaster Template, Test PDL for Natural Images

I
I
I
I

I
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7.3. EXR TV Model Solution

The EXR TV model provides the functionality described in Chapter 4. In this section the

acronym ICD (i.e., Interface Control Document) is used in the same context as EXR
descriptions. An ICD contains textual EXR descriptions, and ICD formatted messages are
EXts.

7.3.1. Foundation Utilities: Field Utilities Package
The FieldUtilities package provides the capability to convert between an EXR and a LUNR of

a field (of a message). The following functionality is provided: n
* Extract a character or bit-based field from an EXR, based upon the EXR

description, and insert it into a UNR.

" Extract an element from a LJNR and insert it into a character or bit-based field
in an EXR, based upon an EXR description.

" Convert from an EXR ordering of information to a UTNR ordering of information.

* Convert from a UNR ordering of information to an EXR ordering of information.

" Check an EXR at the indicated position for a specified separator based on an 3
EXR description.

" Check an EXR at the indicated position for an end-of-message indicator.

The procedure ExtractField_Image.FromlCD provides the capability to extract U
character-based or bit-based fields from EXRs and insert them into UNRs. This is
accomplished by slicing the field out of the appropriate positions of the EXR based upon the 3
EXR description of the field, and inserting it into the appropriate elemental slice of the UNR
based upon the UNR description.

The procedure InsertFieldImage.jnto.JCD provides the capability to extract
character-based or bit-based elements from UNRs and insert them into EXRs. This is
accomplished by slicing the elemental symbolic image out of the LUNR, based on the UNR
description, and inserting it into the appropriate field positions of the EXR, based upon the
EXR description of the field.

The procedure PutArray.Image_In_ElementOrder provides the capability to rearrange

selected fields in a symbolic image from a field-ordered to an element-ordered orientation.
The procedure is passed the symbolic image in field-order, the number of elements in each3
field, and the size of the elements in each field. The reordering is accomplished in two loops.
An inner loop extracts, one at a time, an elemental image from each field in the symbolic

image and inserts it into an element-ordered symbolic image. The outer loop iterates until i
all of the field-ordered elements have been extracted and placed in the element-ordered

symbolic image.

The procedure PutArray~jmage_inFieldOrder provides the capability to rearrange

selected fields in a symbolic image from an element-ordered to a field-ordered orientation.

The procedure is passed the symbolic image in elemental-order, the number of elements in
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each field, and the size of the elements in each field. The reordering is accomplished in two
loops. An inner loop extracts one at a time an elemental image for each field in the symbolic
image and inserts it into a field-ordered symbolic image. The outer loop iterates until all of
the element-ordered elements have been extracted and placed in the field-ordered symbolic
image.

The function Separator_Is_InPosition checks an EXR at the indicated position for a

specified separator based on an EXR description.

The function EO_Text_IsValid checks an EXR at the indicated position for a specified

separator based on an EXR description. It checks to see if the end of the EXR has been
reached and also checks if the indicated EoText marker for the EXR is at the indicated
position.

7.3.2. Foundation Utilities: ICDUtilities Generic Package
The ICD-Utilities generic package provides the capability to convert between an EXR and a

UNR of a message. The following functionality is provided:

e Construct an EXR of a message from a UNR.
*Construct a LJNR of a message from an EXR while checking the EXR for

syntactic validity based on the EXR description.

3 * Check an EXR of a message for validity based upon the EXR description.

The function ConstructlCD constructs an EXR from a UNR (symbolic image). This is
accomplished by making any necessary cuts to the LTNR and then inserting the LNR of each

field into the EXR one at a time based upon the EXR and UNR descriptions. After all of the
fields have been inserted into the EXR, an end-of-text marker i a added.

I The function ExtractUniversal.Image constructs the UNR (symbolic image) from an EXR.
This is accomplished by extracting each field one at a time from the EXR and inserting it
into a UTNR based on the EXR and UNR descriptions. Once the last field has been extracted,

and if the the end of the EXR has been reached, then any necessary cuts are performed. If
end of text has not been reached, then a Constraint_Error is explicitly raised.

I The procedure Check_lCD checks an EXR to see if it is syntactically valid based on the EXR

description stored in Fields. This is accomplished by calling the ExtractUniversal_Image
function. If the UTNR is extracted from the EXR with no problems, then it is valid. If,

however, a Constraint_Error is raised, then each field of the EXR is reprocessed individually
until the invalid field in the EXR is located. A pointer indicating where the bad field is
located represents the validity indicator and is returned.

I

3 CMUISEI-89-TI- 12. 105



I
I

7.3.3. Building Block: MessagejCD Template
This is the building block for the EXR Translation and Validation model solution. The
MessageICD template contains an Ada package specification and body based upon the EXR
Translation and Validation model described in Chapter 4, and a test procedure for testing
instances of the Message-JCD template.

The Ada code for the message ICD template is shown in Appendix Section C.5. 3
The MessageICD template provides a mapping between the EXRs and LTNRs of a message.
The MessageICD template exists for a number of reasons:

" To facilitate the generation of code to convert between EXRs and UTNRs.

" To aid the designers in codifying the EXR of a message in a form expected by the
model solution. I

" To facilitate the testing of instances of the MessagejICD template.

Two example instances of the MessageICD template exist. These are the I
FooBarMessage.ICD, found in Appendix Section D.3.1 and the FooBarBitMessage_.CD,

found in Appendix Section D.3.2.

Figure 7-17 shows the <MsgId>jCD Ada package specification template PDL. Figure 7-18
shows the <MsgId>_ICD Ada package body template PDL. These are two of three separate

code modules found in the MessageICD template.

The <Msg.Id>_ICD packages provide the following abstract capabilities:

" Convert from an EXR to a UNR of a message.
" Convert from a UNR to an EXR of a message.

I
" Check an EXR for syntactic validity based upon the EXR description.

" An exception is raised if conversion from an EXR to U5NR fails.

* Provide descriptions of the fields within the EXR of a message. 3
* Provide positions of the elements within the UNR of a message.

The abstractions make up the EXR TV model described in Chapter 4. I
To instantiate the Message_ICD template, some information must be provided. The first is

the name of the message. This is used to name the package, <Msg.jd>jCD. The next piece I
of information is names of the fields, <NZ>..<Nn>, taken from textual EXR description,
followed by the width of the symbolic image, <Symbolic.jmageWidth>. Last is the number

of cuts, Number_OfCuts, that need to be performed on a message.

The SymbolicJmageWidth is defined as an integer constant. Its value is based on the
textual EXR description of the message, with all of the separators stripped out. I
Symbolic-image (UNR) is the type used to hold a symbolic image and is defined as an array
of bytes of length Symbolic.ImageWidth. The type that defines an array of bytes comes

from CCT.ByteArray.
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EXRs are stored using the CCT.Icd_MessageType type. CCT.Icd_MessageType is a record
that consists of a string for holding the EXR of the message and an integer for holding the
message length.

I The EXR description is captured formally in Fields. Fields is of type
IcdUtil.DescriptionArray and consists of an array of records, each of which describes one
field. Fields is indexed by the field names that are enumerated in the FieldNames type,
given by <N1>..<Nn>. The symbolic image description (UNR description) is also captured
formally in Fields. This description is based on the EXR description, where punctuation has
been stripped out and varying length fields padded to their maximum width.

EoText is defined as a constant of type CCT.LittleStringType, and represents the1 end-of-text marker for an EXR of a message. Some predefined values can be found in CCT.

Cuts is defined as a variable of type ICDUtil.CutArray, and it holds the starting and
stopping positions of the cuts that need to be made to a message. The information for
defining Cuts is obtained by examining the textual EXR description and the INR selected.

The function Construct_lIcd provides the capability to convert from a symbolic image to an
EXR. The basic underlying algorithm is to first perform any cuts that need to be made to the
element-ordered symbolic image. After the cuts have been made, the elements are then
extracted from the field-ordered symbolic image and inserted into the EXR one at a time.
After all the elements have been inserted into the message, the end-of-text marker is added
to the end of the message and the EXR is returned.

The function ExtractUniversal_.jmage provides the capability to convert from an EXR to a
symbolic image. The basic underlying algorithm is to extract the fields from the EXR and
insert them into a field-ordered symbolic image. When the current field being processed can
be the last field and the end-of-text marker is found, then any cuts that need to be done are
performed. Following the completion of the cuts the element-ordered symbolic image is
returned.

The procedure Checkjcd provides the capability to check an EXR for syntactic validity based
upon the EXR description in Fields. The basic underlying algorithm is to pass the EXR to
the ExtractUniversal.Image to check if a symbolic image can be extracted from it. If the
EXR does not contain a valid symbolic image, a Constraint_-Error is trapped and the EXR is
parsed to find the position in the message where the error occurs. The status of the message
and the position where the message goes bad are reported back by the procedure.

Figure 7-19 shows the PDL for the <Msgjd>jCDTest procedure. This is the third of three
separate code modules found in the MessageICD template. The 1/0 portions of the code that
deal with notifying the tester of some error with the test are bolded.

The test procedure, <MsgId>_ICDTest, tests the instance of the <MsgId>_ICD package
generated during template instantiation. It uses predefined test cases based on EXRs
specified by the detailed designer when the instance of the template was created. The
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detailed designer also specifies whether each EXR test case is valid or invalid, and if invalid,
also specifies the position where the message is invalid, so that the test routine can
determine if the expected results were obtained. The entire range of functionality provided
by the EXR TV for the message is tested based on the EXR test cases. This type of testing is
considered canned testing.

The following steps are performed for canned testing: 3
1. Apply CheckJCD procedure to predefined test EXR, i.e., check the EXR for

validity.

2. If CheckJCD procedure reports the validity as not equal to the specified 3
validity of the test case, or if the test case is invalid and the specified bad
position is not equal to the returned bad position, then notify the tester of EXR
test case failure. 3

3. Apply the ExtractUniversaljmage function to predefined test EXR, i.e.,
convert the EXR to a symbolic image.

4. If ExtractUniversal-image function raises a constraint error then notify the I
tester of EXR test case failure.

5. Apply the ConstructJCD function to the symbolic image from Step 3, i.e.,
convert the symbolic image to an EXR.I

6. If the resulting EXR is not equal to the original EXR test case, then notify the
tester of EXR test case failure. 3

This form of canned testing allows testing based on a valid or invalid EXR. The specification
of the validity of each individual test case allows the test procedure to pass even though the

EXR TV may fail because of an invalid test case.

These templates are used by the detailed designer to build an instance of the EXR TV model
solution for a particular message. The implementation the template provides must be
understood when modifications or enhancements to the model solution are necessary.

I
I
I
U
U
I
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with Cast ing_Cmon Type s;
with ICD UtIlities;

pazage <Kag Id>_lCD is

pa ckage Cct renames Casting_ommon _Types;

3Srpmboli..._Image_ Width :constant Integer :=<Symbolic-Image_ Width>;

-- Names of the fields
type FieldNames is (<Nl>, <N2>,..)

NumberOfCuts :constant Integer := N~mberOfCuts>;

-To obtain operations to convert between the UNK (symbolic image)U -- and the EXR (lCD format) Of a Message.
package ICD Util is new ICD Utilities(I SymbolicImage_ Width => Symbolic_ImageWidth,

FieldNames => FieldNames,
NumberOfCuts => NumberOfCuts);

3 subtype Symbolic-Image is lCDUtil.Symbolic Image;

-- End of text marker.
EoText :constant Cct.Little String Type :=CCT.<EOT>;

Fields : CDUtil.Description Array := IBased on the textual EX? description I

-Pointers to the cut positions for the ICD message
Based on info given in the textualEX

Cuts :ICD-Util.CutArray := description and the 12VR descriptionm]

-Functions for converting between a UNR (symbolic image) and
-an EXR (lCD formatted message).
-- Also a procedure for checking the validity ol an EXR.Ifunction Construct lCD (Universal_-Image :in Symbolicimage)

return Mc.c-ess.t e Type;
function ExtractUniversal-image (lcd :in Cct. lcd Mess ageType)

return Symbolic Image;

procedure CheckIcd(Icd :in Cct.IcdMessageType;
lcdId Ok :out Boolean;
BadPosition :out Integer);

pragma inline (Construct lcd, Extract Universal Image);

and Olag_14>_lCD;

Figure 7-17: Message LCD Template Package Spec PDL
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package body <(sg_Id>_ICD isI

function ConstructIc (UniversalImage :in Symbolic Image)

return Cct. IcdMdessage Type i.s
begin

return lCD -Util.Construct-lcd
universal-Image => UniversalImage,
Fields -> Fields,
Cuts => Cuts,
ZoText => Zo Text);

end Construct-lcd;

function Zxtract Universal 1 Image (lcd :in Cct.IcdMessageType)
return SymbolicImage is9

beginI
return lCDUtil Extract -Unxiversal Iage(

lcd => Icd,
Fields => Fields,
Cuts => Cuts,U
Zo -Text => Zo-Text);

end Extract UniversalImage;

procedure Check-lcd (lcd :Cct.Icd Message-Type,
lcd Is Ok :out Boolean;

begin Bad7Po-sition :out Integer) is

ICDUti.l.Check lcd(
lcd => lcd,

Fields => Fields,I

Zo Text => No Text,
lcd Is Ok => Tcd Is Ok,

BadPosition => Bad Position);
end Check-lcd;

begin3

ICD tUtil. Initialize (Fields, Cuts, Symbolic-ImageWidth);

end <Msg 14> lCD;

Figure 7-18: Message 1CD Template Package Body PDL
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with <NEsg Id>_l cd;
with Text Io0;
with Casting qC~on -Types;
with UncheckedConversion;I Procedure <Msg Id> lIcd Test is

package Cct renass Casting_qCamon _Types;
package ByteIc is new TextIo.Integerlo(Cct.Byte);

type TestCase_Type is record
Test lcd :Cct.IcdMessage-Type;
Bad Position: Integer;
Vald Boolean;

end record;

N :Integer := <NmberOfTestCases>;
TestCases : array (1. .N) of TestCaseType :=Test case descriptions

begin
-- Canned Testing Loop: loop through test cases

for I in Test Cases'First .. Test Cases'Last 1oop
begln

cbfsg Id>_Icd.CheckIcd(TestCases(I).TestlIcd,
Resulti.ng_Check,
Position-Pointer);

If Test Case(I) .Valid /= Resulting_.Check thenI raise UnknownError;
elsif not TestCases (I).Valid then

if Test_Cqases(I).Bad -Position /= Position-Pointer thenI raise Unknown Error;
end if;

else
Test-UI := <1sg_Id> _lcd. Extract Universal-Image(I TestCases (X) . Test_lcd);
Resultinglcd := 4sgId> Icd.ConstructIcd(TestUl);
if Resulting lcd /= TestCases (I).Test lcd then

raise Unknown-Failure;enIf
nd if;

exception
when UnknownError =>

if Test Cases(I).Valid then
NoIfy tester a valid test case has failedI Show tester TestCases (1) .Test-Icd that failed

end if;
when others>

Notify tester a test case Itas failed and for an unknown reason
Show tester TestCases (1) .Test-lcd that failed

end;
end loop;

end <Nag Id> lcd Test;

Figure 7-19: Message 1CD Template Test PDL
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8. MTV Model Solution Adaptation Description

I
3 This chapter discusses issues related to enhancing or modifying the MTV model solution.

Three classes of modifications are addressed:

* ction 8.1 addresses whole-scale replacement of either the EXR TV or the
Typecaster model solution.

e Section 8.2 addresses enhancement and extension of either the EXR TV or the
Typecaster model solution.

e Section 8.3 addresses alternative software architectures (i.e., reorganization of
component parts) for the Typecaster model solution.

i This chapter is targeted for the maintainer and model adapter. It is expected that the
maintainer and adapter have read Chapters 1 through 7, thus sufficiently understanding-

s what concepts are embodied in and provided by the model

* how to apply the model solution

* how the model is implemented

8.1. Replacing Whole Parts of the MTV Model Solution

It is important to remember that the MTV model solution consists of two parts:

1. the EXR TV model

2. the Typecaster model

These two models share a common interface, the UNR. Because of this common interface,
either model solution can be replaced with another solution as long as the interface stays the

same.

Therefore, if a table-driven parsing approach is better suited to the EXRs found in a message
set or the table-driven approach shows better performance based upon the message set, then
the EXR TV model solution could be replaced with a table-driven solution provided the

table-driven solution can supply UNRs to the Typecaster model solution.

I
3 CMU/SEI-89-TR- 12 113



8.2. Enhancement and Extension of the MTV Model
Solution

The following are suggested enhancements and extensions to each of the two major parts of

the MTV model solution: the EXR TV model solution and the Typecaster model solution. I
Extensions to the model solution are modifications made to enlarge the scope of applicability
of the model solution. The modifications usually entail adding new components (generics
and/or templates) in a style compatible with existing components. The components are
added to increase the scope of applicability of the model solution, thus enabling it to be used
to translate and validate messages that the original solution could not. Enhancements to the

model solution are modifications made to improve the performance of the model solution.
The modifications usually entail modifying the algorithms or the interface to access the
functionality provided. The algorithms or interface are changed to increase the
attractiveness of the model solution. Examples of why these changes might be made include:
increased speed, decreased size, increased usability and understandability, etc.

8.2.1. EXR TV Model Solution
If new field types are found in a message set that cannot be defined using the

CCT.Field_DescriptionType, and thus the field cannot be described by the instantiator of I
the MsgICD template, modifications to the types used to define the elements in the
CCT.FieldDescriptionType may be necessary. These type definitions are also found in CCT

and they include Base_Type, Field_Types, Odd_Description, etc. There may also be the need I
to add new elements to the CCT.Field_Description_ Type. Any of these modifications also
require modification of the ICD_Utilities generic package, and possibly the Field_Utilities

package. These are packages where parsing decisions are made based on the description of
the field.

Another issue pertaining to the EXR TV model solution that was mentioned in a previous I
chapter is the fact that the only reordering of information from the EXR format to the order
defined by the INR is via cutting. If the ordering constraint is not acceptable, then another

type of information movement can be specified and added to the solution. This would involve
moving information from an EXR order to an INR order. The mapping could be specified by
placing the field names in an array in the desired INR order, similar to the way Cuts is

defined, and would require modifying the parsing algorithm in the ICD_Utilities generic
package to initiate the move similar to the way cutting is initiated. The utilities for
performing movement would be added to the Field-Utilities package, as are the utilities for

performing cutting.

I
I
I
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8.2.2. Typecaster Model Solution
The enhancements and extensions for discrete and composite typecasters are discussed

separately below.

8.2.2.1. Discrete Typecasters

The two issues of extension and enhancement are discussed for the discrete typecasters. The
first issue deals with why a developer would want to extend the discrete typecaster portion of

the solution and some suggestions on how to extend it. The second issue deals with general
enhancements to the discrete portion of the Typecaster model solution.

I If conversion requirements exist between the types of fields in the message (EXR) and the
desired scalar Ada types (INR) that are not handled by the solution as is shown in Figure

6-8, then new discrete typecaster generics and the corresponding discrete typecaster
templates need to be developed. This should be done to allow the Typecaster model solution
to be applicable to a wider variety of EXR and INR relationships. For example, if a message
set has fields that represent fixed point numbers, then a Fixed_Point.T-ypecaster generic

package and template must be generated. This example is used to describe the modification
process.

IThe interface provided by all discrete typecasters is the same. How the interface is
implemented is what changes from one discrete typecaster generic to the next. Section 7.2.1
(specifically Figures 7-2 and 7-3) describes the portions of the discrete typecaster generics

that are different from generic to generic and need to be customized based on the type and
the mapping information. The following is a high-level description of the steps that must be
taken to add a new discrete typecaster generic:

1. Start by making a copy of an existing discrete typecaster generic (e.g., the
EnumerationTypecaster) and rename it Fixed_PointTypecaster.

2. Modify the generic formal parameter to capture the possible range of fixed-point
types and the types and/or objects needed to perform the mapping between
symbolic images and values. That is, the INR and UNR should be defined.

3. Preserve the generic package specification interface with an exception for how

the length of the symbolic image is determined.

4. Modify the bodies of the functions for converting between symbolic images and
values to reflect the mapping functions chosen.

5. Preserve the bodies of the functions for converting between natural images and
values since these are based upon the Ada 'Image and 'Value functions.

Next, the model adapter needs to create a new template that instantiates the new
FixedPoint_Typecaster generic package. Section 7.2.2 (specifically Figures 7-5, 7-6, and 7-7)
describes the portions of the discrete typecaster templates that are different from one
discrete typecaster template to the next, and need to be customized based on the tupe and
mapping information. The following is a high-level description of the steps that must be

taken to add a new discrete typecaster template:

1. Start with an existing discrete typecaster template (e.g., the Enumeration
Typecaster Template) and rename it.
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2. Define placeholders based upon the generic formal parameters needed by the
generic at instantiation time. These placeholders provide an interface for
instantiating the generic and thus specify the Ada type and the mapping
between values and symbolic images. Placeholders are inserted into the
package specification at the appropriate places and the remainder of the
package specification stays the same.

3. Distribute placeholders throughout the test procedure. This mainly involves
adding code to instantiate a different I/O package for performing 1/0 operationson the Aria type defined.

4. Test the new typecaster thoroughly before release for use.

The second issue deals with a general enhancement to all discrete typecasters that allows
greater flexibility for specifying the natural images.

The Ada language supplies the 'Image and 'Value functions for converting between strings
and Ada values. The MTV model solution uses these functions, by default, as the mapping

functions for natural images. The authors assumed that the implementors of C31 systems
would specify the discrete Ada types (INR) in a more natural fashion, (i.e., using more
meaningful names) than is represented in the EXR. For example, the Direction field of the

Foobar message is represented in the EXR by the symbolic images N, E, S, and W, whereas it
is represented in the INR by the Ada type:

type DirectionType is (North, South, East, West).
Therefore, the solution assumes that the INR specified by the developer and mapping
function chosen by the solution for natural images (i.e., USR) is appropriate.

If this is not the case, then there is a need to specify a mapping function for conversion
between natural images and Ada values. The mapping can be achieved in a manner similar
to the way the mapping between symbolic images and Ada values is achieved. Modifications
to all discrete typecaster generic packages and templates would be necessary. This also
raises alternative packaging considerations that are discussed in Section 8.3.

8.2.2.2. Composite Typecasters
The two issues of extension and enhancement are discussed for the composite typecasters.
The first issue deals with why a developer would want to extend the composite typecaster
portion of the solution and some suggestions on how to extend it. The second issue deals
with general enhancements to the composite portion of the Typecaster model solution.

If a new logical grouping of fields in a message (EXR) is desired that is not currently
available with the existing composite typecasters, then new composite typecaster templates
need to be developed. This should be done to allow the Typecaster model solution to be
applicable to a wider variety of logical groupings of information.

The interface provided by all composite typecasters is exactly the same. How the interface is
implemented is what changes from one composite typecaster to the next. Section 7.2.3
(specifically Figures 7-9, 7-10, 7-11, 7-12, 7-15, and 7-16) describes the portions of the
composite typecasters that are variable and need to be customized based on a new logical
grouping.
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An example of a general enhancement to the composite portion of the Typecaster model

solution would be to simplify the access to elements within the symbolic images and natural
images. Currently, the developer must use the position arrays,
The_Symbolic..Image_Positions and The Natural.image_Positions, and the name of the

element defined in the enumeration type, <Type> Element_Names, to obtain the slice of the'
symbolic or natural image in which the element resides. For example, to obtain the natural

image of the reporting location from the natural image of the Foobar message, the following

command is issued:

Rep_Loc NI :=
roosarNI (The Natural_ImagePositions (ReportingLocation) . Start..

The Natural_ImagePositions (Reporting_Location) Stop) ;

This can be tedious if done often, so enhancing the composite portion of the Typecaster model
solution to include the procedures GetElement, SetElement, and ElementLength may be
desirable. This would result in the following code for accessing a natural image element:

Rep_Loc NI := GetElement (FooBar_NI, Reporting_Location);

* Also note that the same function can be used to access the validity indicator corresponding to
the natural image element:

Rep_Loc VI := GetElement (FooBarVI, Reporting_Location);

If this enhancement of the Typecaster model is desirable, all composite typecasters must be

modified, but the modifications are the same for all:

1. Add the functions GetElement, Set-Element, and Element-Length to the
composite typecaster package specifications.

2. Move the position arrays, ThSymbolicJimagePositions and
TheNaturalImagePositions to the composite typecaster package bodies to
account for the new procedural interface added above and thus to hide the
slicing concept.

3. Add the implementations of the functions GetElement, SetElement, and
ElementLength to the package bodies. These implementations should use the
position arrays.

4. Modify the test procedures to include testing of the new functionality.

I
I
I
I
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8.3. Alternative Packaging Strategies

Based on feedback from reviewers and users of the MTV model solution, some discussion on
other packaging strategies is in order. These strategies affect only the Typecaster model
solution. The changes focus on the best way to either package the use of the foundation I
utilities, or package the functionality found in the foundation utilities. That is, the generics
do not change, but how the templates group instances of generics and other templates does
change. Each packaging strategy is shown graphically in figures based on a portion of the I
FooBar message. The figures show the software architecture that will result if the new
packaging strategy is applied. Figure 6-13 shows the current software architecture of the
FooBar message and can be used as a point of reference.

8.3.1. Packaging Strategy #1: Removing Types from Typecasters
The first packaging strategy is based upon removing the Ada types and mapping information
from the typecaster packages. There are two possible approaches:

1. Move the type declarations (INR) and mapping information (UNR <--> INR) I
from the typecaster packages into individual packages, one package for each
type declaration and its corresponding mapping information. See Figure 8-1.

2. Move all type declarations and mapping information for a particular message I
from the typecaster packages into a single package. See Figure 8-2.

Both approaches allow other portions of the application to access the types without accessing
the typecaster functionality. The first approach has the advantage of allowing other
operations on the type to be defined and located in the package with the type, e.g., an
imaginary arithmetic type may have some operations defined for imaginary arithmetic. The I
second approach has the advantage of having all types and mapping information about the
message being present in a single place. This may make comprehension of the message
specification easier.

Either approach would require modification of the typecaster templates to handle this
packaging approach. The discrete typecaster generic templates would be reduced to a I
generic instantiation and test procedure since the only reason for the package specification in

the past was to hold the type and mapping information. In both the discrete and composite
typecaster templates, new placeholders must be defined that will specify the name of the I
package where the type and mapping reside.

1
I
I
I
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8.3.2. Packaging Strategy #2: Separating Typecaster Functionality
Removing the types and mappings from the typecaster packages also leads to a second
packaging strategy. This strategy separates the two sets of functionality provided by the
typecasters, symbolic image, and natural image into individual packages. See Figures 8-3
and 8-4. This strategy stems from the original concepts of the UNK TV model and USR TV
model described in Chapter 4. These two models were merged into the Typecaster model for3 implementation reasons.

The advantage of separating the Typecaster model into two models is to allow the developer

to instantiate only that functionality that is needed. We have seen cases where only

symbolic images and Ada values for a message are needed by an application and other cases
where only the natural images and Ada values are needed. Because the separation forces

the types to be separate, as described above, another advantage is the availability of the
types to other parts of the application.

The disadvantage of separating the Typecaster models is an increase in the number of
packages needed to translate and validate a message by a factor of two to three, depending
upon which type and mapping packaging strategy is selected, i.e., type and mapping in the
typecasters, one package per type and mapping, or one package per message for all types and
mappings).

1
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8.3.3. Packaging Strategy #3: Conglomeration of Typecasters
Finally, the third packaging strategy is based upon having one composite typecaster package I
per message. The types and mappings for the elements of the message are declared in the

composite typecaster package for the message. All discrete typecaster generics are I
instantiated in the package.

One advantage of this approach is that there is only one package per message, thus all

information regarding the Ada types and mapping information is in one place. The
understandability of this information regarding a message is probably increased for smaller

messages that might not have many logical groupings, but the authors suspect that the I
understandability decreases as the messages become more complicated. Another advantage
that stems from the absence of composite-level template nesting is that this approach

provides a flatter software architecture, thus fewer procedure calls and potentially more I
efficient code.

But the absence of composite-level template nesting also creates a disadvantage. The 3
message composite typecaster will have all types, mappings and generic instantiations

defined in the same package, thus making the code more complicated as the message size
grows since no logical groupings are possible. In summary, the abstraction mechanism I
provided by Ada - composite types - is not being used. Also, the discrete type, mapping
information, and generic instantiation can still be made a template, but these templates

must be copied into the composite template on an as needed basis. This implies that the
simple process of instantiating templates has gotten more complicated and thus more prone
to specifier error. Other disadvantages include the loss of reuse of discrete typecaster

instances already created for fields that are common across many messages.

Finally, the other packaging strategies can also be developed using combinations of this third

strategy with the first two. These strategies will not be discussed.

1I
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18.4. Model Adaptations Performed to Date

The following are enhancements and modifications to the MTV model solution that have
been made by various projects based on their requirements.

The initial version of the MTV model solution did not handle bit-based messages. Both parts

of the solution were extended to handle bit-based fields. This was a cooperative effort of the

I authors and Granite Sentry Phase II personnel. The field description data structure in the
EXR TV model solution was updated to allow specification of bit-based fields and the

algorithms were modified to extract the bit-based fields, and place them into a UNR form.

Two new typecasters were added to the Typecaster model solution: Integer..Bit__Typecaster
and EnumerationBitTypecaster. Also, Granite Sentry Phase II recently extended the EXR

parsing capabilities to better handle variable-length, character-based fields. These

modifications have all been incorporated into the MTV model solution.

Two new discrete typecasters have been created by Granite Sentry Phase II. The first,

Fixed_Point_ ypecaster, handles conversions between strings representing fixed-point

numbers and Ada values of the Fixed_Point type. The second, String _ypecaster, handles
conversions between strings and Ada values of the String type. This typecaster allows

strings to pass through the typecasters, and validation is based on the presence of printable
characters.

Granite Sentry Phase II has also created extended versions of the composite record
typecaster to handle 20 element records and 32 elements records. This work was given to,

Sand performed by, technical writers, not programmers.

Finally, the Rapier program has chosen to change the packaging strategy to the third
packaging strategy listed above. Their analysis and evaluation is documented in a report

entitled "Typecaster Use Prototype Technical Report" by Djoef Woessner and Bill
Schmidt [Woessner 89].

1
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I i 9. Open Issues

This chapter discusses unresolved issues pertaining to the performance, limitations, testing,
automation, and building upon the MTV model solution.

U 9.1. Real-Time Performance

Performance statistics are available with all engineering models. But because of the

different hardware platforms combined with the different Ada compilers available for the
various hardware platforms, the general performance characteristics of the model solution
cannot be defined. Instead, this document provides timing performance characteristics of the

MTV model solution based upon the sample messages found in this document. These
performance measurements were taken on a MicroVAX II running Version 5.1 of the
VAX/VMS operating system and compiled under Version 1.5 of the VAX Ada compiler. A
description of these timing measurements is in Section 5.5.

The provided performance characteristics tell little about the performance of the model
solution on different hardware using a different Ada compiler, and applied to a specific
message set. But one can easily measure the performance characteristics of the solution.

1. Identify a small set of messages that are characteristic of those required to be
translated and validated.

2. Create the software for the reduced message set. Note that it is
straightforward to instantiate the software to translate and validate a message
using the templates available and following the steps described in Chapter 6.

3. Run the test procedures and use them as a basis for obtaining performance
information by adding the calls to obtain the time before and after the calls to
the typecaster functions.

SThe above steps allow measurement of the timing performance. Sizing performance (i.e., size
of the resulting object code) can also be examined. Page faults, memory size, and other
system parameters may also need to be examined. All results can then be extrapolated to

determine the performance estimates for the rest of the system.

I
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9.2. Limitations I
The following programming constructs are used in the MTV model solution and are
considered implementation-dependent features of the Ada language. This is based upon

Chapter 13 of the Ada Language Reference Manual (Ada LRM),
ANSLMIL-STD-1815A-1983 [Ada 83]. Thus, their use in the solution will be briefly

discussed.

The length clause attribute 'size (Ada LRM, Section 13.2) is used to define a Byte as 8 bits
whose values are natural integers that can range from 0..255. It is also used to define a Bit, 3
with a size of one bit, whose values are Boolean.

type Byte is new Natural range 0..255;
for Byte'size use 8;

type Bit is new Boolean;
for Bit'size use 1; 3

These definitions are in the package CastingCommon_Types. They support the bit-based
EXR TV and typecasting algorithms.

The representation attribute 'size (Ada LRM, Section 13.7.2) is used to obtain the number of
bits allocated to the bit-based objects being translated and validated. It is also used to

determine how many bits are needed to hold bit-based objects. This attribute supports the I
bit-based EXR TV and typecasting algorithms. The 'size attribute can be found in the

following packages:

" Casting-CommonTypes (package specification) I
" Integer.BitTypecaster (generic package specification and body)

_ I
" Enumeration BitTypecaster (generic package specification and body)

* lCD_Utilities (generic package body)

" Field_Utilities (package body) 3
The unchecked programming function, Unchecked_Conversion, (Ada LRM, Section 13.10.2) is
used to convert between Byte and Character types. This was done to support the bit-based

EXR TV and typecasting algorithms that comprise the MTV model solution. This function is
used throughout the solution.

Running the MTV model solution on a Rational machine has been problematic because of the
use of the Unchecked_Conversion function for converting between an array of bytes and a
character string. The Rational machine does not store characters in 8-bit bytes. It optimizes 5
and stores them in a reduced format. The MTV model solution assumes that characters are

stored in 8-bit bytes.

Bytes were used instead of characters to allow the solution to support bit-based typecasting

of UNRs. Characters in Ada are defined as having an ASCII value between 0 and 127.

Using the Character type would have limited the solution to using only 7 of the 8 bits I
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available for bit-based representations. Thus, bytes are used and character-based
typecasters, initially, convert from the bytes to characters.

9.3. Testing Philosophy

Although the inclusion of test drivers in each template is a step in the right direction, the
testing philosophy used leaves room for improvement. This section describes those areas
where improvement is needed.

I 9.3.1. Discrete Typecaster Testing
The interactive portions of the tests for discrete typecasters lead the tester through the
functions exported by the typecasters one at a time in a predefined order, first prompting for
a symbolic image, then a value, etc.24 If at any point the tester enters a bad test case (which
is the intended use of the interactive portion of testing) the predefined order is repeated from

I the beginning. It would be more desirable to allow the tester to select the function to test.

All symbolic images (UNR) and natural images (USR) are, by definition, fixed-length. The
interactive portions of the tests for discrete typecasters give no indication of how long the
input string should be. This problem could easily be solved by informing the tester up front
of how many characters are expected for symbolic images or natural images. It could also be
solved graphically, by printing the ;roper number of dashes above the input prompt. For
example, the symbolic image for an hour value is two characters, so the prompt could look
something like:

I Enter Hour Symbolic_Imnge =>

Finally, the possibility of creating a generic test driver for all discrete typecasters has been
informally examined but a conclusion has not yet been reached. The advantage of having a
generic test driver becomes evident when the testing philosophy changes, as described above.
Currently, all test procedures it, all templates would need to be changed, and test driver
consistency would be a manually enforced responsibility. If a generic were developed, the
test driver could be changed in one place, and the instantiation of the test driver in the3 discrete templates would stay the same.

9.3.2. Composite Typecaster Testing1 The canned testing of composite typecasters step through the functions exported by the
typecasters one at a time in a predefined order, testing each function based on the result of
the previous function. 25 Testing the first function is based on a predefined (at templateIinstantiation) symbolic image. If this symbolic image is bad, the natural image functions are
not tested correctly because they depend upon the symbolic image testing to produce a valid

24See Figure 7-7 for the PDL describing the discrete typecaster test.

2 5See Figures 7-15 and 7-16 for the PDL describing the composite typecaster test.
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Ada value. Therefore, it is impossible to test the natural image functions based upon an

invalid natural image. This approach should be changed to allow testing of invalid natural I
images.

9.4. Building Upon the MTV Model Solution - User U
Scenarios !

The Typecaster model solution provides the UNR and USR of a message along with

descriptors that describe the format of the representation, i.e., pointers to the elements

within the LUNR and USR. Also provided are the validity indicators that indicate whether m
the UNR and USR are valid. The validity indicators are also described by the same

descriptors as the USR and UNR, i.e., pointers to the validity indicators for the elements

within the UNR and USR.

These descriptions support a user interface because the information provided by the MTV

model is in a form that can be manipulated by a user interface model. Also, the interface to I
the MTV model is defined and stabilized.

Further user interface work (i.e., another model solution) is currently being investigated by U
Granite Sentry Phase II. This solution will use the information provided by the MTV model
solution, along with the X-Toolkit interface, to automate the production of user interface

code. This will be done in a style similar to the MTV code to ensure consistency and support
automation. I
9.5. Automated Code Generation
The MTV model solution is "automated." That is, all that needs to be done to create software 3
to perform message translation and validation is select templates and do editor substitutions

based upon the EXR and INR. This process is described in Chapter 6. 3
One can certainly envision a tool that requires the user to specify the format of the EXR and

the desired INR. Based upon this information, the tool would select the appropriate

templates and create the software for translating and validating the message.

Changes in message formats would require changes in specifications of the EXR and/or INR,
and the code would be regenerated.

This approach is possible because a reliable, tested model solution exists. As other model
solutions become available, they can be added to a library and selected based on their I
appropriateness to the C3I problem specified.

1
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3 Appendix A. Definitions

I
3 The following terms are defined for use in this report. We are not trying to define terms

gratuitously, but we need a common vocabulary for discussing the work. Terms in boldface
within the definitions are also defined.

Bit String
A contiguous set of bytes where each byte is interpreted as a stream of bits.

Character String
A contiguous set of bytes where each byte is interpreted as an ASCII character.

Cut
The act of converting between a field-oriented format and an element-oriented format.
The field-oriented format is described by the external representation description
and the element-oriented format is that format in the universal represeqtation that
is converted directly into an internal representation.

Designer
The person responsible for analyzing the user's needs with the intent of generating
solutions (designs) from existing solutions (models).

I Detailed Designer
The person responsible for transforming the design (i.e., models) into a detailed
specification that can be built by implementors.

3 Element
An Ada typed value in an internal representation that represents a piece of
information. An element may be of a discrete or composite type. There is at least one3 element for each field in an external representation of a message.

EXR
External Representation.

IExternal Representation
A string representation of a message. The format i° described by an external
representation description. The external representation is comprised of fields and
punctuation. The external representation can be represented as either character
strings and/or bit strings. External representations are received from (or sent to)
systems outside the C31 system being developed.

I
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External Representation Description
A textual description of the external representation format of a message. It defines
the size and location of the fields and punctuation. It also describes the information I
found in the message and how to interpret the information. The external representation
description is defined outside the scope of the C3I system being developed and becomes
part of the requirements levied upon the system. For the Granite Sentry Program, the I
document is the ICD.i

Field
A string in an external representation that stands for a piece of information. Fields
may contain a single piece of data or several pieces of data. Fields that are represented
as character strings are said to be character-based fields. Character-based fields may
be variable length, including null length. Fields that are represented as bit strings are
said to be bit-based fields. I

1CD
Interface Control Document.

Image
A string representing a value. There are two types of images: symbolic images and
natural images. Values are created from valid images by the typecasters. In
addition, the typecasters create valid images from values.

Implementor
The person responsible for building the system (coding) as per the detailed specifications
supplied by the detailed designer.

InR
Internal Representation.

Internal Representation

Ada typed values representing a message. The types are described by an internal
representation description. The internal representation is comprised of elements.
Internal representations of a message are used by the C31 system being developed.

Internal Representation Description
Ada type declarations needed to define an internal representation format of a
message. Each Ada type defines the type of an element. The internal representation
description (Ada type) is defined during system design.

Maintainer
The person responsible maintaining all aspects of the system (models, detailed
specification, code, etc.) after it has been delivered to the user.

Message
Pieces of related information.

Messages are a means of passing information from one system to another. For C3 I I
systems, the other systems that it must communicate with tend to be geographically
separated and are heterogeneous in nature.

The external format of the information is described by an external representation I
description. The internal format of the information is described by an internal
representation description. The information is represented as an external
representation, a universal representation, an internal representation, and a I
user representation.

1
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Model
To quote from Webster's:

" ...a pattern of something to be made...
...an example for imitation or emulation...
...a description or analogy used to help visualize something (as an atom) that
cannot be directly observed..."

Models are used by the designer to specify a solution to a problem (design).I Model Adapter

The person who enhance existing models that can not be used, as is, to solve a problem.
Enhancements can take the form of added functionality or better resource utilization.

* MTV
Message Translation and Validation.

Natural Image
A character string equivalent of a value. A natural image is the character string
created by applying the Ada 'image (tick-image) attribute function directly to a value.
For example, for the Ada value North, the natural image would be be the character string
"North". The user representation of a message is a character string containingnatural images of each of the elements. Natural images are validated and converted
into values by typecasters. Typecasters also convert values into natural images.

Non-Real-Time
A system or part of a system whose operation is not considered real-time.

Placeholders
Replaceable snippets of code in templates that stand for Ada types, names, and values.
There are two types of placeholders:

1. The first is of the form <Type> or <First>, i.e., a phrase enclosed in brackets.
The entire phrase (including the brackets) must be replaced. For example,<Type>_Type becomes Hourjype for all instances of <Type>_Type in a file
when <Type> is replaced by "Hour".

2. The second form is the double question mark, ??. This form means that
some special action must be taken by the user. For example, this form is
used for those places in the code that the user needs to supply a function
body, supply test cases, or remove some lines from the template, e.g., the
instructions at the beginning of each template.

Punctuation
Character strings or bit strings that separate fields in an external representation.
For character-based fields, punctuation may be a single character, several characters, or
absent. End-of-message punctuation occurs at the end of some external
representations.

Real-Time
Pertaining to a system or part of a system whose operation can be characterized by the
following:

S"When it is done is as important as what is done."26

String
A contiguous set of bytes. Two types of strings exist for the message translation and
validation model, character strings and bit strings.

3~~"Quote from Robert Firth, Senior Member of the Technical Staff at the Software Engineering Institute.
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Symbolic Image I
A string containing a codification of information that represents a value. For example,
for the Ada value North, the symbolic image might be the character string "N". The
universal representation of a message is a string containing symbolic images of each
of the fields. Symbolic images are validated and converted into values by typecasters. I
Typecasters also convert values into symbolic images.

Template
A file containing an Ada package specification, package body, and test procedure. The
file contains placeholders for the name of the package, the Ada type used in the
template, and so on. The placeholders must be globally replaced with their appropriate
values using an editor. Global replacement of the placeholders affects the specification,
the body, and the test procedure. The template with the placeholders replaced is called I
a typecaster. All templates contain instructions in the first few lines of the template.
The instruction lines are to be removed when the template has become a typecaster.

TV Translation and Validation.
Typecaster

A compilable package specification and package body. A typecaster is generated from a
template by substituting all placeholders with appropriate Ada types, names, or I
values. A typecaster is specific for the Ada type that was used in its generation and
provides the capability to convert between symbolic images and values of that type.
The typecaster also provides a diagnostic routine for checking the validity of a symbolic I
image. Any value outside the range of the Ada type causes the Ada runtime
environment to raise a ConstraintError exception. It also provides the capability to
convert between natural images and values of that type, and provides a diagnostic
routine for checking the validity of a natural image.

Typecasting
The act of converting between an image (symbolic image or natural image) and a
value. The implementation of the typecasting operations mimics the Ada attribute I
functions 'image (tick-image) and 'value (tick-value). The functions defined in the
typecasters for performing the typecasting operations are called Image and Value.

Universal Representation
An internal view of an external representation. The universal representation is a
fixed length string, containing a symbolic image for each field in the external
representation, with punctuation removed, variable length, null, and optional
character-based fields padded with blanks to their maximum length, and bit-based I
fields expanded to multiples of byte lengths. The information is cut to match the
internal representation, if necessary.

Universal Representation.

The person whose job can be performed more effectively using the completed C3I system.

User Representation
A user-readable view of an internal representation. The user representation is a
fixed-length string, containing a natural image for each element of the internal I
representation.

USR
User Representation.

Value
An Ada typed value representing an image. Values are created from valid images by
the typecasters. Typecasters also create valid images from values.
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3Appendix B: Detailed Description of the Templates

I
3 This appendix is a reference manual for the MTV model solution, whose application was

described in Chapter 6. It describes all templates individually, in detail. This appendix is
for the detailed designer and implementor. For the duration of this appendix, they are
addressed as users of the templates.

The Ada code templates can be found in Appendix C.

B.1. Format of the Template Descriptions

i The sections of this appendix describe the discrete typecaster templates, composite

typecaster templates, and ICD template. Each template description -ontains the following
I information:

* capabilities provided by an instance of a typecaster template

* when to use a particular typecaster template

* how to generate an instance of a typecaster from a typecaster template

* how to use the generated typecaster

Before looking at the discrete and composite typecaster templates individually, the following

describes the above points in general for all typecaster templates.

U Capabilities

Typecasters provide the capability to convert between strings representing
discrete/composite values (symbolic images) and discrete/composite Ada values.

Typecasters provide the capability to convert between character string images of a
discrete/composite value (natural images) and discrete/composite Ada values.

Typecasters provide the capability to check strings for symbolic image validity and
natural image validity.

3 The Ada type checking insures the validity of discrete/composite values.
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When to Use the Templates 3
The templates described in this appendix should be used when the detailed designers
wish to generate Ada software to translate and validate externally formatted bit-based

or character-based messages.

How to Generate an Instance of a Typecaster I
Once the detailed designer decides which typecaster template to use, the template

must then be copied into an empty file and editor substitutions must be performed.

These substitutions are based on the placeholders found in the header comments at the
beginning of the template. Also, any special instructions, indicated by the "?r

placeholder, should be followed. I
One test procedure is provided in each template.

" For discrete typecasters the test procedure first does an exhaustive test on
the entire range of values and then allows interactive testing by prompting
for symbolic images, natural images and values.

" For composite typecasters the test procedure does testing based on a set of
canned test cases that are supplied before compilation.

All test procedures report on testing problems, e.g., unexpected results.

How to Use the Typecaster

Each typecaster package exports a set of types, constants and functions that support i
the capabilities listed above. Sample uses are shown.

I
I
I
I
I
U
I
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3 B.2. Template Naming Conventions

It is critical that the user of these templates be aware of the naming conventions enforced by
the templates.

All typecasters are named via a substitution for the <Type> placeholder. A suffix is hard

coded into the templates. The name of the type to be cast, which is exported by the
typecaster, is handled similarly.

For example, for any character-based discrete typecaster, the name of the typecaster and the
type it exports will look like:

suffix provided suffix provided

I I I I
<Type> -Typecaster <Type> -Type

whereas for bit-based discrete typecasters, the name of the typecaster and the type it exports

will look like:

suffix provided suffix provided

II I I I
<Type>_Bit_Typecaster <Type> _Bit Type

3 The composite typecasters and the type they export have different suffixes depending on the
composite type:

suffix provided suffix provided

I I I I
<Type>_{ :oposite }Typecaster <Type> {composite} _Type

where (composite) will be "Array" in the Array typecaster template, "PrivateRecord" in the
Private Record typecaster template, and so on.

1 In all cases it is only necessary to substitute for the <Type> placeholder, e.g., replacing
<Type> with Hour results in3 <Type> Typecaster => HourTypecaster

<Type>_Type => HourType

5 It is also necessary to know the names of the elemental typecasters when generating a
composite typecaster. The names without the _Typecaster and _Type suffixes should be
specified. The suffixes are provided throughout the composite typecaster templates for each

elemental reference.

I
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B.3. Discrete Typecaster Templates

The discrete typecaster templates are the building blocks of the typecaster model solution.
The following is a list of the discrete typecaster templates: 3

1. Integer Typecaster Template

2. Integer_-Bit Typecaster I
3. Math.OnInteger Typecaster Template

4. Enumeration Typecaster Template

5. Enumeration.Bit Typecaster Template

6. MathOnEnumeration Typecaster Template

7. String..Map Typecaster Template 3
All discrete typecaster templates are based upon the typecaster model described in Chapter
4. Figure 7-5 shows the incomplete Ada package specification that is representative of all
discrete typecaster templates.

Each discrete typecaster template is customized based upon the incomplete Ada package 3
specification shown in Figure 7-5. The customization entails specifying those portions of the
incomplete Ada package specification that are in bold, italics and boxed These

customizations are either in the form of compilable Ada code or code template placeholders
that the detailed designer must specify when instantiating the template. The customizations
are specific to the typecaster operations provided by individual discrete typecaster templates. 3

1
I
I
I
S
I
I
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B.3.1. Integer Typecaster Template
The Integer Typecaster Template is shown in Appendix C.3.1 and resides in the file named

I The name of a typecaster generated from the Integer typecaster template will result from

substitution of the placeholder <Type> as in

<Type>_Typecaster => Hour Typecaster

The name of the Integer type, generated in the Integer typecaster, will result from3 substitution of the placeholder <Type> as in

<Type>_Type => HourType

I Capabilities
The generated package will provide the capability to convert between character strings

representing integers (symbolic images) and integer values (values) of a specified integer

range. The strings representing integers are zero padded and can be signed or unsigned. It
also provides the capability to check character strings for symbolic image validity. The Ada3 type checking insures the validity of integer values.

The generated package will also provide the capability to convert between character strings
images of integers (natural images) and integer values (values) of a specified integer range.

It also provides the capability to check character strings for natural image validity.

When to Use the Template
Use this template to create a typecaster for casting between character-based symbolic images
and values of a specified integer range, and also for casting between character-based natural3 images and values of a specified integer range.

It handles integers in the range <First>.. <Last>. Type <Type>_Type will specify the integer3 range for instantiating the Integer..Typecaster generic.

An implicit mapping between both the symbolic images and natural images, and the values
in the range specified by the type <Type>jype must exist, e.g.,

subtype Hour_Type is Integer range 0..23;

symbolic natural
image <=> value image <=> value

00" <=> 0 " 0" <=> 0

"23" <=> 23 " 23" <=> 23
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How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of an Integer typecaster from the I
Integer typecaster template.

The following global placeholder substitutions need to be made: i
*Replace the placeholder <Type> with the integer type, e.g., Hour. It is not

necessary to append -Type to the placeholder <Type>, the template contains
_Type in the correct places. See section B.2 for more details.

" Replace <First> with the starting value of the range of the integer type, e.g., "0".

" Replace <Last> with the ending value of the range of the integer type, e.g., "23". 3
" Replace <Is-Signed> with "True" if the symbolic image is signed, otherwise

replace it with "False". 3
One test procedure is provided in the template, <Type>_Typecaster_Test. The test procedure
first does an exhaustive test on the entire range of values for the type <Type>_Type. Then,

the procedure allows interactive testing by prompting for symbolic images, natural images $
and values of integers.

Appendix D.1.3 shows an example instance (HourTypecaster) of the Integer typecaster 3
template.

How to Use the Typecaster I
The Integer typecaster can be used by providing the following statements and declarations

within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type> I
placeholder, shown below, with the proper Ada type.

with <Type>_Typecaster; 3
An_Integer : <Type>._Typecaster. <Type>.Type;
IntegerSymbolic_Image : <Type>_Typecaster. SymbolicImage;
CheckSymbolicImage : <Type>_Typecaster. Symbolic_Image;
IntegerNaturalImage : <Type>_Typecaster. NaturalImage;
CheckNaturalImage : <Type>_Typecaster. Natural Image;

The functions available in the Integer typecaster are used as follows:

An_Integer := <Type>_Typecaster.Value (Integr._SymbolicImage);

IntegerSymbolicImage : <Type> Typecaster. Image (AnInteger);

CheckSymboliImage :=
<Type>_Typecaster. Check (IntegerSymbolic-Image)

AnInteger :- <Type>_Typecaster.Value (IntegerNatural Image);

Intag"_Natural_Image :- <Type>_Typecaster. Image (AnInteger); 3
Check Natural_Image :=

<Typ>_Typecaster. Check (IntegerNaturalImage) ; 3
142 CMU/SEI-89-TR- 12 I



B.3.2. lntegerBit Typecaster TemplateI ~The Integer-Bit Typecuster Tomplate in shown in Appendix C.3l.2 5.11( resides in the file
na med3 INTRQIR_§1T_TWW4LAT3t_ -ADA

The name of a typecanter generated from the Integer-Bit typecaster template will result3 from substitution of the placeholder <Ty7' a in

<Type>_fit_Typecaster -> Julian_-Day_flit__Typecaster

3 The name of the Integer type, generated in the Integer_Bit typecanter. will result from
substitution of the placeholder <Ty.PC> 1114 In3 <Type> flit_Type -> Julian Day-flitType

Capabilities
The generated package will provide the capability to convert between hit strings

representing integers (symbolic images) and integer values (values) of a specified integer
range. It also provides the capability to check hit strings for symbolic imnge validity. The3 Ado type checking insures the validity of integer value.

The generated package will also provide the capability to convert between character string3 image. of integers (natural images) and integer values (values) of a specified integer rainge.
It also provides the capability Wo check character strings for natural image validity.

3 When to Use the Template
Use thin template to create a typecaster for canting between bit-based symbolic images and
values of a specified integer range, and also for canting between character- based natural

images and values of a specified integer range.

It handles integers in the range <First>.. <Last>. Type <T'ype>_Bit_,7ype will specify theU integer range for instantiating the Integer-Bit Typecanster generic.

An implicit mapping between both the symbolic images and natural images, and the value,3 ~in the range specified by the type <7 Tye i yems xse. 27.

subtype JulianDayBitType Is Integer range l. .366;

3symbolic natural
image <-> value image <-> value

316#01#,l6#000 <-n> 1 " 11 <in> 1

316#69#,16#01# <-> 366 '366" <=n> 366

I "Tho mymbolic imago in two hyte. becmime it takes two bytes to reprosent.a number from 1.166
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How to Generate an Instance of a Typecaster 3
The following lines describe how to create an instance of an Integer_-Bit typecaster from the

Integer_Bit typecaster template.

The following global placeholder substitutions need to be madte:

" Replace the placeholder <Type> with the integer type, e.g., Judian,_Day. It is not
necessary to append _BiLType to the placeholder <Type>, the template contains I
_Rikype in the correct places. See Section B.2 for more details.

" Replace <First> with the starting value of the range of the integer type, e.g., "1".

" Replace <Last> with the ending value of the range of the integer type, e.g., "366".

One test procedure is provided in the template, <Type>Bi..LTypecasterTest. The test

procedure first does an exhaustive test on the entire range of values for the type
<Type>.BitType. Then, the procedure allows interactive testing by prompting for symbolic
images, natural images and values of integers. 3
Appendix D.1.11 shows an example instance (JulianDayBitTypecaster) of the Integer_-Bit
typecaster template. 3
How to Use the Typecaster
The Integer-Bit typecaster can be used by providing the following statements and

declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>

placeholder, shown below, with the proper Ada type. I
with <Type>..lit_Typecast.e;

An_Integer : <Type> fit_Typecaste:.<Type>_Bit_Type; 3
Integer_Symbolic Image : <Type>_Bit_Typecaste:. Symbolic Image;
Check_Symbolic_Image <Type>._fit_-Typecaste.. Symbolic_Image; I
Integeo._Natural._mage <Type>_Blit Typecaste.. NaturalImage;
CheckNatural image : <Type>_fitTypecaste. Natural_Image;

The functions available in the Integer_.Bit typecaster are used as follows: I
AnInteger : = <Type>_Bit Typecaste:. Value (Integer_SymbolicImage)

IntegerSymbolicImage :- <Type>_Blit_Typecaste:. Image (An Integer); I
Check_Symbolic_Image :=

<Type>fitTypcast.r. Check (IntegeSymbolicImage)

An_Integer :- <Type>_flitTypecaste:.Value (Intege:_Natural-image); 3
Integer_Natural_Image : <Type>_BitTypecaste.. Image (An Integer);

CheckNaturalImage : I
<Type>_Bit_Typecaster. Check (IntegerNatural Image) ; 1
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B.3.3. Math_Onjnteger Typecaster Template
The Math.OnInteger Typecaster Template is shown in Appendix C.3.3 and resides in the

file named

)aT -N lTZGM ZR !UL=-.3D&

The name of a typecaster generated from the Math.OnInteger typecaster template will

result from substitution of the placeholder <Type> as in

<Type> _Typecaster => Scaled Integer_100_500 Typecaster

The name of the Integer type, generated in the MathOnjnteger typecaster, will result from

substitution of the placeholder <Type> as in
<Type> Type => ScaledInteger 100 500 Type

I Capabilities
This generated package provides the capability to convert between character strings

representing integers (symbolic images) and scaled integers (values). The strings

representing integers are zero padded and can be signed or unsigned. It also provides the

capability to check character strings for symbolic image validity. The Ada type checking3 insures the validity of integer values.

The generated package will also provide the capability to convert between character string

images of the scaled integers (natural images) and scaled integers (values). It also provides

the capability to check character strings for natural image validity.

3 When to Use the Template
Use this template to create a typecaster for casting between character-based symbolic images
and values of a specified integer, where the value is a scaled integer. Also for casting

between charactP---qqed nqtural images and vqlues of a scaled integer.

This package handles strings representing integers whose values are in the range3 <First>/ <Factor>..<Last>/ <Factor>. Type <Type>..Type specifies the range of scaled values
for instantiating the MathOnjnteger..Typecaster generic.

3 An implicit mapping (after applying the scale factor) between both the symbolic images and

natural images, and the values (scaled integers) in the range specified by the type

<Type>_T- ype must exist, e.g.,

factor : Integer :- 100;
subtype ScaledInteger..100_500_Type is Integer range 100..500;

3 symbolic natural
image <=> value image <=> value

1 "I" <=> 100 " 100" <=> 100

3 "5" <=> 500 " 500" <-> 500
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How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a Math_Onnteger Typecaster from

the MathOnInteger typecaster template.

The following global placeholder substitutions need to be made: 3
*Replace the placeholder <Type> with the scaled integer type, e.g.,

ScaiedjntqgerJO0_500. It is not necessary to append -Type to the placeholder
<Type>, the template contains _Type in the correct places. See Section B.2 for I
more details.

* Replace <First> with the starting value of the range of the scaled integer type
<Type> Type,, e.g., "100". I

*Replace <Last> with the ending value of the range of the scaled integer type
<Type>_Type,, e.g., "500".

eReplace <Is-Sgned> with "True" if the symbolic image is signed, otherwise I
replace it with "False".

• Replace <Factor> with the scaling factor. The default factor is 100.

One test procedure is provided in the template, <Type>_TypecasterTest. The test procedure
first does an exhaustive test on the entire range of values for the type <Type>jType. Then,

the procedure allows interactive testing by prompting for symbolic images, natural images
and scaled values of integers.

Appendix D.4.1 shows an example instance (ScaledInteger100-500_Typecaster) of the 1
MathOnInteger-typecaster template.

How to Use the Typecaster I
The MathOn-Integer typecaster can be used by providing the following statements and

declarations within a compilable unit: 3
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>
placeholder, shown below, with the proper Ada type.

with <Type>_Typecaster;

AnScaledInteger : <Type>_Typecaster.<Type>_Type;

ScaledInteger_SymbolcImage : <Type>_Typecaster. SymbolicImge;
Check_Symbolic_Iaage <Tpe>_Typecaster.Symbolic Imae;

Scaled Integer _Natural-Imge :<Type>_Typecaster .Natural Imge;3
CheckNatural Image : <Type>_Typcaster. NaturalImage;

I
I
I
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A.he functions available in the Math-.On.Integer typecaster are sdas follows:

A ScaledInteger:-
<Type>_Typecaste.Value (ScaledInteger _SymbolicImage);

ScldItgrSm lcag:<Type> _Typecaste.. mge (A Scaled Integer);

CheckSymbolicImage :=

<Type> _Typecat. Check (ScaledInteger_Symibolic Image);

AScaledInteger :3<Type>_Typecaste. Value (Scaled Integer _Natural Image);

Scaled xnt eq.:_NaturalImage :=I <Type>_Typecast er. Image (AScaled Integer);

CheckNaturalimage =3 <Type> Typecaste:. Check (ScaledIntege: _Natural-Image) ;
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B.3.4. Enumeration Typecaster Template 3
The Enumeration Typecaster Template i. shown in Appendix C.3.4 and resides in the file
named

The name of a typecaster generated from the Enumeration typecaster template will result
from substitution of the placeholder <7ype> as in 3

<Type>_Typecast.: -> DirectionTypecaste.

The name of the discrete type generated in the Enumeration typecaster will result from
substitution of the placeholder <Type> as in I

<Type>_.Ty e => DirectionType

Capabilities I
This generated package provides the capability to convert between character strings
representing discrete values (symbolic images) and discrete values (values). It also provides 3
the capability to check character strings for symbolic image validity. The Ada type checking
insures the validity of the discrete values. g
The generated package also provides the capability to convert between character string
images of discrete values (natural images) and discrete values (values). It also provides the
capability to check character strings for natural image validity. 3
When to Use the Template
Use this template to create a typecaster for casting between character-based symbolic I
images, which can be represented as an enumerated type, and discrete values of the specified
discrete type, <Type>_Type. Also for casting between character-based natural images and

and discrete values of the specified discrete type.

Type <Type>_-Type will specify the discrete values, and the type <Type>jMap specifies the
symbolic images and the mapping between the symbolic images and the values. These are I
for instantiating the EnuwmerationTypecaster generic.

There must be an explicit one-to-one positional mapping between the enumerated values
specified by <Type>-Map, which are the enumerated values representing valid symbolic
images, and the discrete values specified. There is an implicit mapping between natural

images and the discrete values, e.g.,

type Direction_Type is (North, South, East, West);
type Direction Map is (N, S, 1, W); 3
symbolic natural
image <-> value image <=> value i

"N" <-> North "NORTH" <-> North
"S" <=> South "SOUTH" <-> South
"E" <=> East " EAST" <=> East
"W" <=> West " WEST" <-> West I
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How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a Enumeration Typecaster from the

Enumeration typecaster template.

The following global placeholder substitution needs to be made:

" Replace the placeholder <Type> with the Enumeration type, e.g., Direction. It is
not necessary to append _7 pe to the placeholder <Type>, the template contains
_2ype in the correct places. See Section B.2 for more details.

* Do a search for ?? and fill in the necessary information:

- the definition of <Type>_ Type, the meaning of the symbolic images.
remember that the natural images are derived from the values, e.g.,
("North", ...).

I the definition of <Type>..Map, the symbolic images expressed as an
enumeration type, e.g., (N, ...).

I One test procedure is provided in the template, <Type>_ TypecasterTest. The test procedure
first does an exhaustive test on the entire range of values for the type <Type>_ype. Then,
the procedure allows interactive testing by prompting for symbolic images, natural images

and values.

Appendix D.1.2 shows an example instance (Direction_Typecaster) of the Enumeration
typecaster template.

How to Use the Typecaster
The Enumeration typecaster can be used by providing the following statements and
declarations within a compilable unit:
NOTE: Prior to placing the following lines within the compilable unit, replace the <Type>

placeholder, shown below, with the proper Ada type.

with <Type>._Typecastex;

ADiscrete : <Type>_Typecaster.<Type>_Type;

Discrete Symbolic Image : <Type> _Typecaster. SymbolicImage;
CheckSymbolicpmage : <Type> Typecaster.Symbolic_mage;

Discrete Natural_mage : <Type>_Typecaster. NaturalImage;
CheckNatural_Image : <Type>_Typecaster. NaturalImage;

1
I
I
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The functions available in the Enumeration typecaster are used as follows:

ADiscrete :- <Type> _Typecaster.Value (Discrete SymibolicImge);

DiscreteSymbolic-Image :- <Type>_Typecastesr Image (ADiscrete);3

CheckSymbolic Image :=

<Type> _Typecaster.Check (Discrete_Symbolicimage);

A-Discrete :- <Type>_Typecaster.Value (Discrete Natural Image);

DiceeNtua-mg := <Type> _Typecaster.Imge (A Discrete);

Check -Natural -Image :=

<Typ> Typecaster .Check (Discrete Natur;AllImage);3
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B.3.5. EnumerationBit Typecaster Template
The EnumerationBit Typecaster Template is shown in Appendix C.3.5 and resides in the
file named3ZNDDURATZON _TZ 1-_. A MZ

The name of a typecaster generated from the EnumerationBit typecaster template will3 result from substitution of the placeholder <Type> as in

<Type>_BitTypecaster => DirectionBitTypecaste:

3 The name of the discrete type generated in the EnumerationBit typecaster will result from
substitution of the placeholder <Type> as in3 <Type> Type => Direction-BitType

Capabilities
This generated package provides the capability to convert between bit strings representing
enumerated values (symbolic images) and discrete values (values). It also provides the
capability to check bit strings for symbolic image validity. The Ada type checking insures3 the validity of the discrete values.

The generated package also provides the capability to convert between character string
images of enumerated values (natural images) and discrete values (values). It also provides
the capability to check character strings for natural image validity.

3 When to Use the Template
Use this template to create a typecaster for casting between bit-based symbolic images ani
enumeration values of the specified enumeration type, <Type>_BitType, and also for casting
between character-based natural images and enumeration values of the specified
enumeration type.

3Type <Type>_BitType will specify the values and TheMap will specify the mapping
between bit-based symbolic images and the values. These are for instantiating the
EnumerationBit_Typecaster generic.

There must be an explicit one-to-one mapping between the bit-based symbolic images and
enumerated values. Type <Type>_BitType will specify the values and3Symbolicimage.Range will specify the range of integer values possible for the bit-based
symbolic images. The.Map explicitly defines the mapping between bit-based symbolic images
and the values. There is an implicit mapping between natural images and the discrete

!values, e.g.,28

3 2 5 rhe symbolic image is one byte because it takes one byte to represent a number from 0..3.
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type Direction BitType is (North, South, East, West); 3
subtype SymbolicImageRange is Integer range 0..3;
The_ ap : TheMapType "=-

North > 0,
South => 1,
East -> 2,
West > 3);

symbolic natural I
image <=> value image <-> value

16#00# <-> North "NORTH" <-> North
16#01# <-> South "SOUTH" <i> South I
16#02# <=> East " EAST" <=> East
16#03# <i> West WEST" <=> West 3

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a EnumerationBit Typecaster from

the Enumeration_Bit typecaster template.

The following global placeholder substitution needs to be made: 3
" Replace the placeholder <Type> with the EnumerationBit type, e.g., Direction.

It is not necessary to append _BitType to the placeholder <Type>, the template
contains _BiType in the correct places. See Section B.2 for more details. 3

" Do a search for ?? and fill in the necessary information:

" the definition of <Type>_BitType, the meaning of the symbolic images,
remember that the natural images are derived from the values, e.g., I
("North", ... )

• the definition of <SymbolicjmageRange>, the range of integer values
expected in the bit-based symbolic images, e.g., "0..3" I

" the definition of <TheMap>, the mapping between enumeration values
and the bit-based symbolic images, e.g., "North => 0" 3

One test procedure is provided in the template, <Type>BitTypecaster_Test. The test
procedure first does an exhaustive test on the entire range of values for the type

<Type>_BitType. Then, the procedure allows interactive testing by prompting for symbolic I
images, natural images and values.

Appendix D.1.8 bhows an example instance (DirectionBitTypecaster) of the 3
Enumeration-Bit typecaster template.

How to Use the Typecaster I
The Enumeration-Bit typecaster can be used by p. iding the following statements and

declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type> I
placeholder, shown below, with the proper Ada type.

I
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3 with <Type>_Bit_Typecaster;

AnEnumeration :<Type>_BitTypcastor.<Type> Bit Type;

EnumerationSymbolicImage :<Type> Bit Typecaster.SymbolicImage;
Check_Symbolic Imac <Type>_BitTypecaster.SymbolicImage;

EnumerationNaturalImage :<Type>_Bit_Typecaster.NaturalImage;

ChockNatural_Image : <Type>__BitTypecaster Natural_mage;

The functions available in the EnumerationBit typecaster are used as follows:

An Enumeration :
<Type>_BitTypecaster.Value(Enumeration SymbolicImage);

3EnumrationSymbolic -Image :=
<Type>_it_Typecaster. Image (AnEnumerat ion);

CheckSymbolicImage :zU <Type>_BitTypecaster.Check (EnumrationSymbolic Image);

An Enumration :-
<Type>BitTypecaster. Value (En-m rat ionNaturalImage);

EnimirationNaturalImage :=

<Type>_BitTypecaster. Image (AnEnumeration);

CheckNatural -Imago :=3 <Type> Bi.. yecaster.Chck(Eni-rationNaturalImage);
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B.3.6. MathOnEnumeration Typecaster Template
The Math_On_Enumeration Typecaster Template is shown in Appendix C.3.6 and resides in I
the file named

M)Tl!B UMERATON TWL =TE ADA I

The name of a typecaster generated from the Math_On_Enumeration typecaster template
will result from substitution of the placeholder <Type> as in 3

<Type> Typecaster -> Scaled_Integer_00_1000_Typecaster

The name of the scaled integer type, generated in the Math_On_Enumeration typecaster, 3
will result from substitution of the placeholder <Type> as in

<Type> Type => ScaledInteger 100_1000_Type i

Capabilities
This generated package provides the capability to convert between character strings

representing enumerated values (symbolic images) and scaled integers (values). It also I
provides the capability to check character strings for symbolic image validity. The Ada type

checking insures the validity of the scaled integer values. 3
The generated package will also provide the capability to convert between character string

images of the scaled integers (natural images) and scaled integers (values). It also provides

the capability to check character strings for natural image validity.

When to Use the Template
Use this template to create a package for casting between character-based symbolic images, I
which can be represented as an enumerated type, and values of a specified integer range,

where the value is a scaled integer. Also for casting between character-based natural images

and values of a scaled integer.

Type <Type>_Type will specify the integer range of the scaled integer values. Type
<Type>_Map will specify the enumerated values corresponding to the symbolic images. I
These are for instantiating the MathOnEnumeration_Typecaster generic.

There must be an explicit one-to-one positional mapping between the character-based I
symbolic images and scaled integer values after the factor is applied. Valid symbolic images
are expressed by the type <Type>_Map and are mapped positionally to the to the range of

scaled integer values specified by <Type>_Type after the factor is applied. There is an
implicit mapping between natural images and the discrete values, e.g.,

1
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subtype ScaledIznteger_100 1000 is integer range 100..1000;
type TheMap is (A,B,,D,E,F,G,H,I,J);

symbolic natural
image <=> value image <-> value

"A" <-f> 100 "100" <=> 100

"Jot <-> 1000 " 1000" <-> 1000

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a MathOnEnumeration3 Typecaster from the MathOnEnumeration typecaster template.

The following global placeholder substitutions need to be made:

o Replace the placeholder <Type> with the scaled integer type, e.g.,
Scaled Integer_100_1000. It is not necessary to append Type to the placeholder
<Type>, the template contains _Type in the correct places. See Section B.2 for
more details.

a Replace <First> with the starting value of the range of the scaled integer type
<Type>_Type, e.g., "100".
Replace <Last> with the ending value of the range of the scaled integer type
< Type>_ Type, e.g., "1000".

3a Replace <Factor> with the scaling factor. The default factor is 100.

9 Do a search for ?? and fill in the necessary information:

the definition of <7ype>_Map, the symbolic images expressed as an
enumeration type, e.g., (A, ...).

One test procedure is provided in the template, <Type>_TypecasterTest. The test procedure
first does an exhaustive test on the entire range of values for the type <Type>_Type. Then,

the procedure allows interactive testing by prompting for symbolic images, natural images
and scaled values of integers.

Appendix D.4.2 shows an example instance (ScaledInteger_100_OOQTypecaster) of the

MathOnEnumeration typecaster template.

How to Use the Typecaster
The MathOnEnumeration typecaster can be used by providing the following statements

and declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>U placeholder, shown below, with the proper Ada type.

I
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with <Type> _Typecaster;3

AScaled Integer: <Type> _Typecaster.<Type>_Type;

Scaled Integezr Symbolic Image: <Type> Typecaster. SymbolicImage;3
Check_Symbolic Image: <Type>_Typecaster. Symbolic-Image;

Scaled ItgrNatural Image : <Type> _Typecaster.NaturalImage;3
CheckNaturalImage: <Type> _Typecaster.Nat ural Image;

The functions available in the MathOn.Enumeration typecaster are used as follows:

AScaled Integer:=3
<Type> _Typecaster.Value (Scaled Integer _SymbolicImge);

Scaled Int eger _Symbolic 'Image:=
<Type> -Typecaster. Imge (AScaledInteger);

Check-Symbolic Image :=

<Type> _Typecaster.Check (Scaled Integer _SymbolicImage);

A-ScaledInxteger:-
TyeTypcar.Value (aldInteger _Natural Image);

Scaled IntegerNatural Image:=
<Type>Typecaxter. Image (AScaledInteger);

Check Natural Imag := I
<Type> _Typecaster.Check (Scaled Integer_.NaturalImage);
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B.3.7. String_Map Typecaster Template
The String-Map Typecaster Template is shown in Appendix C.3.7 and resides in the file

named3SThZ1N" ISP ULLM AD

The name of a typecaster generated frcm the String-Map typecaster template will result3 from substitution of the placeholder <Type> as in

<Type> Typecaster => StatusTypecaster

3 The name of the discrete type generated in the String-Map typecaster will result from

substitution of the placeholder <ype> as in3 <Type>_Type => StatusType

Capabilities
This g,.neratzd package provides the capability to convert between character strings
representing discrete values (symbolic images), as defined in <Type>.Map, and discrete
values (values). It also provides the capability to check character strings for symbolic image3 validity. The Ada type checking insures the validity of discrete values.

The generated package will also provides the capability to convert between character string
images of discrete values (natural images), as defined in <ype>_ype, and discrete values

(values). It also provides the capability to check character strings for natural image validity.

3 When to Use the Template
This template is primarily used when:

1. The user wishes to map from character-based integer symbolic images to
enumeration values.

2. One of the possible character-based symbolic images is an Ada key word, e.g.,
"do" or "if'.

3. The possible character-based symbolic images are case sensitive, i.e., "AA" and
"aa" are valid symbolic images with different meanings, or one is legal and the
other is not.

It is also important to note that this template can be used to replace all other

character-based discrete typecasters templates. The reason the other generic typecasters

exist is because less is involved to define the mapping. Performance studies may indicate

that this typecaster should be used in preference to the other character-based typecasters.

3 This typecaster handles discrete types with a range specified by the type <Type> Type. The

symbolic image portion of the mapping information is defined in <ype>_Map. These are for

instantiating the StingMapTypecaster generic.

To provide the above mentioned capability the user must explicitly define the map between

the symbolic images and the discrete values. There is an implicit mapping between natural

images and the discrete values, e.g.,

3 CMU/SEI-89-TR- 12 157



I
U

type StatusType is (Operational, Non Operational);
Status _Map : StatusMap Type = ( I

Operational => "0"
NonOperational => "1");

symbolic natural I
image <=> value image <> value

"0" <=> Operational Operational" <-> Operational
"1" <=> NonOpeational "Non Operational" <-> Non_0perational

How to Generate an Instance of a Typecaster3
The following lines describe how to create an instance of a String-Map Typecaster from the
String.Map typecaster template.

The following global placeholder substitutions need to be made:

" Replace the placeholder <Type> with the String_Map type, e.g., Sttus. It is not
necessary to append Type to the placeholder <Type>, the template contains I
*Type in the correct places. See Section B.2 for more details.

" Replace <Length> with the length of the string images, e.g., "1".

" Do a search for ?? and fill in the necessary information: I
" the definition of <Type>_ Type, range of discrete values, e.g., "(Operational,

Non.Operational)"

" the definition of <Type>..Map, .e.g, Operational => "0"...

One test procedure is provided in the template, <Type>_ Typecaster_Test. The test procedure 3
first does an exhaustive test on the entire range of values for the type <Type>_Type. Then,
the procedure allows interactive testing by prompting for symbolic images, natural images
and discrete values.

Appendix D.1.6 shows an example instance (Statusjypecaster) of the String_Map typecaster I
template.

How to Use the Typecaster
The StingMap typecaster can be used by providing the following statements and I
declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>

placeholder, shown below, with the proper Ada type.

with <Type>_Typecaster;

A-Discrete : <Type>_Typecaster.<Type>_Type;

Discrete SymbolicImage : <Type>_Typecaster.SymbolicImage;
CheckSymbolicImage : <Type>_Typecaster. SymbolicImage; I
DiscreteNaturalImage : <Type>_Typecaster.Natural Image;
Check NaturalImage : <Type>_Typecaster.NaturalImage; 3
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The functions available in the String-Map typecaster are used as follows:I ADiscrete :- <Type> _Typekcaster.Value (Discrete Symbolic Image) ;

3 Discrete Symbolic_Image :- <Type> _Typecaster. Image (A_DiLscrete);

Check Symbolic Image:=

<Type> _Typecaster. Check (DiscreteSymboliLc mge) ;

ADiLscrete :=<Type> _Typecaster Value (Discrete -Natural_-Image);

3 DiscreteNatural-Image :-<Type> -Typecast or.Imge (A Discrete);

CheckNatural Image :=

3 <Ty pe> Typecaster .Check (Discrete-Natural mage);
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B.4. Composite Typecaster Templates 3
The composite typecaster templates are the building blocks of the typecaster model solution.
The following is a list of the composite typecaster templates: 3

1. Array Typecaster Template

2. PrivateArray Typecaster Template

3. Record Typecaster Template i
4. Private-Record Typecaster Template

5. Wrapper Typecaster Template

All composite typecaster templates are based upon the typecaster model described in
Chapter 4. Figures 7-9 and 7-10 show the incomplete Ada package specification that is I
representative of all composite typecaster templates.

Each composite typecaster template is customized based upon the incomplete Ada package 3
specification shown in Figures 7-9 and 7-10. The customization entails specifying those
portions of the incomplete Ada package specification that are in I bod italics and boxed t

These customizations are either in the form of compilable Ada code or code template
placeholders that the detailed designer must specify when instantiating the template. The

customizations are specific to the typecaster operations provided by individual composite
typecaster templates. I
All composite typecasters are capable of grouping one or any combination of the following. 3

* an instance of a character-based discrete typecaster

* an instance of a bit-based discrete typecaster 3
* an instance of a composite typecaster

Therefore, in this section, when the authors refer to strings, the reader may substitute bit

string and/or character string.

Another item to note is that symbolic images and natural images for composites are defined
as the concatenation of the symbolic and natural images of the elements that they group.

II
I
I
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B.4.1. Array Typecaster Template
The Array Typecaster Template is shown in Appendix C.4.3 and resides in the file named

The name of a typecaster generated from the Array typecaster template will result from

substitution of the placeholder <Type> as in

<Type>_Array_Typecaster => BarrierSegment Array_Typecaster

The name of the Array type generated in the Array typecaster will result from substitution of

the placeholder <Type> as in

<Type>ArrayType => BarrierSegment_ArrayType

I Capabilities
This package provides the capability to convert between strings representing values of the3 type <Type>_ArrayType (symbolic images) and values of the type <Type>-ArrayType
(values). It also provides the capability to check strings for symbolic image validity. The

Ada type checking insures the validity of the values.

The package also provides the capability to convert between character string images of
values of the type <Type>_ArrayType (natural images) and values of the type

<Type>_.Array_.ype (values). It also provides the capability to check character strings
natural image validity.

3 When to Use the Template
Use when the symbolic image is a string representing an array of elements of type3 <Type>_ArrayType.

This package depends on a typecaster being defined for the element type,
<Tc>_Typecaster.<Tc>jype. This is necessary to access the type of the array elements,

Symbolicjmage and Natural-Image for the elements, and the Value, Image and Check
functions.

3 How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of an Array Typecaster from the Array3 typecaster template.

The following global placeholder substitutions need to be made:

* Replace the placeholder <Type> with the Array type, e.g., Barrier.Segment. It isnot necessary to append _Array- ype to the placeholder <Type>, the template
contains -Arrayype in the correct places. See Section B.2 for more details.

" Replace the placeholder <First> with the number of the first element of the
array, e.g., 1.

" Replace the placeholder <Last> with the number of the last element of the array,3 e.g., 8.
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" Replace the placeholder <Tc> with the type of the elements of the array, e.g.,
BarrierSegment_Record. It is not necessary to append _Type or _Typecaster to
the placeholder <Tc>, the template contains -Type and _Typecaster in the correct
places. See Section B.2 for more details.

" Do a search for ?? and fill in the necessary information:

" If the number of elements in the array is less than 8, some lines must be
removed. Conversely, if the array has more than 8 elements, equivalent 1
lines must be added to the typecaster template.

" the canned test cases

" selection of proper output format (bit or character based) to support test
case failure processing

One test procedure is provided in the template, <Type>_Arrayypecaster_Test. The test 

procedure does testing based on a set of canned test cases that the user supplies before
compilation. The test procedure reports on testing problems, e.g., unexpected results. 3
Appendix D.4.3 shows an example instance (BarrierSegmenLArrayjTypecaster) of the
Array typecaster template. 3
How to Use the Typecaster
The Array typecaster can be used by providing the following statements and declarations

within a compilable unit: m
NOTE: prior to placing the following lines within the compilable unit, replace the <7ype>
placeholder, shown below, with the proper Ada type.

with <Type>_ArrayTypecaster;

An_Array : <Type>_ArrayTypecaster.<Type>_ArrayType; 3
ArraySymbolic-Image <Type>_Array Typecast r .SymbolicImage;

ArraySymbolicImage <Type>_Array_Typecaster. SymbolicImage;

Array.Natural Image <Type>_Array_Typecaster.Natural_Image;
CheckNaturalimage: <Type>_rrayTypecaster. Natural_Image;

The functions available in the Array typecaster are used as follows: 1

AnArray := <Type>_Array_Typecaster .Value (Array_SymbolicImage);

RecordSymbolic_Image = <Type>_ArrayTypecaster. Image (AnArray); 1
Check SymbolicImage :

<Type>.ArrayTypecaster. Check (ArraySymbolicImage);

An Array := <Type>_ArrayTypecaster .Value (Array_Natural_Image); 3
RecordNaturalImage = <Type>_Array_Typecaster. Imare (An Array);

Check Natural Image:
<Type>_ArrayTypecaster. Check (ArrayNaturalImage); 1
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B.4.2. Private-Array Typecaster Template
The PrivateArray Typecaster Template is shown in Appendix C.4.4 and resides in the file

named3? 1_M P RTAY_TM1 M!U Z. ADA

The name of a typecaster generated from the Private-Array typecaster template will result3 from substitution of the placeholder <Type> as in

<Type> _Private_Array_Typecaster =>3 Probability_PrivateArrayTypecaster

The name of the PrivateArray type generated in the Private_Array typecaster will result

from substitution of the placeholder <Type> as in

<Type>_Private_Array_Type => ProbabilityPrivate-ArrayType

Capabilities
This package provides the capability to convert between strings representing values of the
type <Type>_Private-ArrayType (symbolic images) and values of the private type
<Type>_PrivateArray Type (values). It provides the capability to check strings for symbolic

image validity. The Ada type checking insures the validity of the values. It also provides the
capability to convert between the public type, <Type>PublicArrayType, and the private

type, <Type>_PrivateArrayType.

The package also provides the capability to convert between character string images of
values of the type <Type>_PrivateArrayType (natural images) and values of the type

<Type>_PrivateArrayType (values). It also provides the capability to check character
strings for natural image validity.

When to Use the Template
Use when the symbolic image is a string representing an array of elements of type

<Type>_Public_ArrayType and inter-element dependencies exist. The private type
<Type>_PrivateArrayType is a private instance of the public type
<Type>_Public-ArrayType.

This package depends on a typecaster being defined for the elements type
<Tc>_Typecaster.<Tc>_ype. This is necessary to access the type of the array elements,

Symbolic_Image and Natural-Image for the elements, and the Value, Image and Check
functions.

3 The type <Type>_PrivateArrayType is private because there are dependencies among the

elements of the array. The data being private allows only this package to monitor and

enforce the inter-element dependencies of the array. The public type,
<Type>_PublicArray Type, provides access to a readable and writable copy of the data.
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How to Generate an Instance of a Typecaster 3
The following lines describe how to create an inztance of a Private-Array Typecaster from
the Private-Array typecaster template.

The following global placeholder substitutions need to be made:

* Replace the placeholder <Type> with the PrivateArray type, e.g.,
Probability-Wrapper. It is not necessary to append _PrivateArrayType to the
placeholder <Type>, the template contains _PrivateArray-Type in the correct
places. See Section B.2 for more details.

* Replace the placeholder <First> with the numbsr of the first element of the 3
private array, e.g., 1.

*Replace the placeholder <Last> with the number of the last element of the
private array, e.g., 8. I

*Replace the placeholder <Tc> with the type of the elements of the private array,
e.g., Probability-Wrapper. It is not necessary to append _Type or _Typecaster to
the placeholder <Tc>, the template contains Type and Typecaster in the correct I
places. See Section B.2 for more details.

Do a search for ?? and fill in the necessary information: 3
* If the number of elements in the array is less than 8, some lines must be

removed. Conversely, if the array has more than 8 elements, equivalent
lines must be added to the typecaster template. 3

" the Is_-Consistent function body for maintaining inter-element
dependencies

" the canned test cases 3
* selection of proper output format (bit or character based) to support test

case failure processing

One test procedure is provided in the template, <Type>_Private_ArrayTypecasterTest. The

test procedure does testing based on a set of canned test cases that the user supplies before

compilation. The test procedure reports on testing problems, e.g., unexpected results.

Appendix D.4.4 shows an example instance (ProbabiityPrivateArrayypecaster) of the

Private-Array typecaster template. i
How to Use the Typecaster
The Private Array typecaster can be used by providing the following statements and i
declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>

placeholder, shown below, with the proper Ada type. Also note that the Ada type that
specifies the value in all typecasting operations is of the type <Type>.Private ArrayType
and not <Type>_PublicArrayype. The reason for this is that the typecaster must

maintain the validity of the object (i.e., enforce inter-element dependencies).
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3 with <Type> PrivateArrayTypecaster;

An _Array, Private-Array:
<Type>_PrivateArrayTypecaster.<Type> Private ArrayType;

Public Array:
-p>_piaeArray Typecaster.<Type>_PublicArrayType;

Array .Synboliq-_ ge<Type>_PrivateArrayTypecast er.Symboliclge

ArrayNaturalIae <ye PitaeAryTpcse.aua-~e3Check-NaturalImage <Type> PrivateArray_Typecaster.NaturalImage;

The functions available in the Private Array typecaster are used as follows:InAra :=
<Type> PrivateArrayTypecaster .Value (ArraySymbolic Image);

ArraySymbolic -Image :=I <Type> PrixvateArrayTypecaster. Image (An _Array);

Chec-kSymbcliclImage :=
<T>_PrivateArray_Typecaster.Check (Array_Symbolic Imge);

Private Ar ray :=<Type>_Private Array-Tyecaster.3 Mxake Private (PublicAray);-

Public Array := <Tp>PiaeAra-yeatr
Make Public (Private-Array);,

AnArray :
<Type>_PrivateArrayTypecaster .Value (ArrayNatuxalImage);

ArrayNatural Image:=
<Type> Privat. _Array_Typecaster. Image (An _Array);

3 Check Natural Image :=
<Type> Private_ArrayTypecaster.Check (Array_N;aturalImage);
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B.4.3. Record Typecaster Template
The Record Typecaster Template is shown in Appendix C.4.1 and resides in the file named

RZCORD TPLA . 3J
The name of a typecaster generated from the Record typecaster template will result from
substitution of the placeholder <Type> as in

<Type>_Record_Typecaster => JulianDate Time Record Typecaster

The name of the Record type generated in the Record typecaster will result from substitution

of the placeholder <Type> as in

<Type>_RecordType => JulianDateTimeRecord_Type

Capabilities
This package provides the capability to convert between strings representing values of the

type <Type>_RecordType (symbolic image3) and values of the type <Type>_RecordType I
(values). It also provides the capability to check strings for symbolic image validity. The
Ada type checking insures the validity of record values. 3
The package also provides the capability to convert between character string images of
values of the type <Type> Record _ype (natural images) and values of the type

<Type>_RecordType (values). It also provides the capability to check character strings for I
natural image validity.

When to Use the Template I
Use when the symbolic image is a string representing a record of type <Type->_Record_Type.

<Type>_RecordType is a record containing the following elements: I
<El>
<E2>
<E3>
<Z4>

<E5>
<z 6>
<E7>
<E8>

This package depends on typecasters being defined for all elementb, <En>, of the Ada record 3
<Type>_RecordType. This is necessary to access the types of the elements, SymbolicImage
and Natural-Image for the elements, and Value, Image and Check functions.

The record elements are defined by the following Ada types:

<Tl> Typecaster. <Tl>_Tpe -
<T2>_Typecaster.<T2>_Type
<T3>_Typecaster.<T3>_Type
<T4>_Typecaster.<T4>_Type
<T5>_Typecaster.<T5>_Type
<T6>_Typecaster. <T6>_Type
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<T7>_Typecaster.<T7>_Type
<TS>_Typecaster <TS>_Type

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a Record Typecaster from the
Record typecaster template.

I The following global placeholder substitutions need to be made:

" Replace the placeholder <Type> with the Record type, e.g., JulianDate_Time. It
is not necessary to append _Record_-Type to the placeholder <Type>, the template
contains Record-Type in the correct places. See Section B.2 for more details.

" Do the following loop until all record elements are defined:
- replace <En> with the name of the nTH element of the record, e.g., replace

<El> with Julian.Day

I replace <Tn> with the type of the nTH element of the record, e.g., replace
<Ti> with JulianjDay

" Search for and remove lines and code blocks with <Tn>'s and <En>'s remaining,
e.g., if the record has 5 elements, then lines containing <T6>..<T8> and<E6>..<E8> must be removed. Conversely, if the record has more than 8
elements, equivalent lines must be added to the typecaster template.

9 Do a search for ?? and fill in the necessary information:

" the canned test cases

" selection of proper output format (bit or character based) to support test
case failure processing

One test procedure is provided in the template, <Type>_Record_TypecasterTest. The test
procedure does testing based on a set of canned test cases that the user supplies before
compilation. The test procedure reports on testing problems, e.g., unexpected results.

Appendix D.2.1 shows an example instance (JulianjDateTimeRecordTypecaster) of the
Record typecaster template.

How to Use the Typecaster
The Record typecaster can be used by providing the following statements and declarations
within a compilable unit:

NOTE: prior to placing the following lines within the compilable unit, replace the <Type>
placeholder, shown below, with the proper Ada type.

with <Type>_RecordTypecaster;

A Rocord : <Type>_Record .Typecaster. <Type>_Record._Type;

3 RecordSymbolic Image <Type>_Record_Typecaster.SymbolicImage;
Check_SymbolicImage <Type>_Record_Typecaster. Symbolic image;
Record NaturalImage <Type> Record Typecaster.Natural_Image;

Check_-atural_Image : <Type>Record_Typecaster.Natural Iage;
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The functions available in the Record typecaster are used as follows:3

A-Record := <Type> _Record _Typecaster Value (Record-SymbolicImage);

RecordSymbolic Image =<Type>_Record,_Typecaster. Image (ARecord);3

Check Symbolic Image=

<Type> Record_Typecaster.Check (RecordSynubolic Image);3

ARecord := <Type>_Record _Typecaster.Value (RecordNatural Image) ;

RecordNatural Image =<Type>_Record_Typecaster. Image (A _Record);

CheckNaturalImage

<Type> Record _Typecaster .Check (Record NaturalImage);U
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B.4.4. PrivateRecord Typecaster Template
The PrivateRecord Typecaster Template is shown in Appendix C.4.2 and resides in the file
named

1?R1V1!Z_RUcORD TM~LA=E AD

The name of a typecaster generated from the Private-Record typecaster template will result3 from substitution of the placeholder <Type> as in

<Type>_Private_RecordTypecaster =>
FooBarMessagePrivate_RecordTypecaster

The name of the private record type generated in the Private_Record typecaster will result
from substitution of the placeholder <Type> as in

<Type> Private_RecordType =>
FooBarMes sage _Private_Record_Type

I Capabilities
This package provides the capability to convert between strings representing values of the
private type <Type>_Private_Record_Type (symbolic images) and values of the private type

<Type>_PrivateRecord_Type (values). It provides the capability to check strings for
symbolic image validity. The Ada type checking insures the validity of record values. It also
provides the capability to convert between the public type <Type>-PublicRecord_Type and

the private type <Type>_PrivateRecordType.

The package also provides the capability to convert between character string images of
values of the type <Type>_PrivateRecordType (natural images) and values of the type
<Type> PrivateRecord_Type (values). It also provides the capability to check character
strings for natural image validity.

When to Use the Template
Use when the symbolic image is a string representing a record of type
<Type>_Public_RecordType and inter-element dependencies exist.

The private type <Type>jPrivate_RecordType is a private instance of the public type
<Type>_PublicRecord.Type. <Type>_PublicRecord_Type is a record containing the

following elements:I I11
<12>
<Z3>
<Z4>
,Z5>
<z6>
<Z7>
<18>

This package depends on typecasters being defined for all elements of the Ada record3 <Type>_Public_Record_Type. This is necessary to access the types of the elements,
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Symbolc_Image and Natural Image for the elements, and Value, Image and Check
functions.

The public record elements are defined by the following Ada types: 3
<Ti>_Typecaster . <Tl>_Type
<T2>_Tpecaster.<T2>_Type
<T3>.Typecaster. <T3>_Type
<T4>Typecaste:. <T4>.Type
<T5>._Typecaster. <T5>..Type
<T6>._Typcaste=. <T6>.Type
<T7>_Typecaster.<T7> _Type 3
<T8>_Typecaster. <Ts>_Type

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a PrivateRecord Typecaster from

the Private Record typecaster template.

The following global placeholder substitutions need to be made: I
* Replace the placeholder <Type> with the Private record type, e.g.,
FooBarMessage. It is not necessary to append _PrivateRecord_Type to the
placeholder <Type>, the template contains _PrivateRecordype in the correct

places. See Section B.2 for more details.

* Do the following loop until all record elements are defined 3
" Replace <En> with the name of the nTH element of the record, e.g., replace

<El> with DetectionConfidence.
" Replace <Tn> with the type of the nTH element of the record, e.g., replace
<Ti> with DetectionConfidence.

* Search for and remove lines and code blocks with <Tn>'s and <En>'s remaining,
e.g., if the record has 5 elements, then lines containing <T6>..<T8> and
<E6>..<E8> must be removed. Conversely, if the record has more than 8
elements, equivalent lines must be added to the typecaster template. I

• Do a search for ?? and fill in the necessary information:

" the Is-Consistent function body for maintaining inter-element
dependencies

" the canned test cases

" selection of proper output format (bit or character based) to support test
case failure processing

One test procedure is provided in the template, <Type>_PrivateRecord_Typecaster_Test.
The test procedure does testing based on a set of canned test cases that the user supplies I
before compilation. The test procedure reports on testing problems, e.g., unexpected results.

Appendix D.2.2 shows an example instance (FooBarMessagePrivate-RecordTypecaster) of 3
the PrivateRecord typecaster template.

l
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How to Use the TyrpecasterI The Private Record typecaster can be used by providing the following statements and
declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <7 Wp>

placeholder, shown below, with the proper Ada type. Also note that the Ada type that
specifies the value in all typecasting operations is of the type <1Type>_Private_Recordjype3 and not <Type>..PublicRecord T~e The reason for this is that the typecaster must

mananthe validity of the object (i.e., enforce inter-element dependencies).3 with <Type>_PrivateRecordTypecaster;

ARecord, Private_-Record :<Type> _PrivateRecord_.Typecaster.
<Type>_PrivateRecord_-Type;

PublicRecord :<Type>_PrivateRecordTypecaster.
<Type>_PublicRecord,_Type;-

RecordSymbolic -Image:
<Type*>_PrivateRecord _Typecaster. SymbolicImage;

Check Symbolic Image:
<Type>_PrivateRecord_Typecaster.Symbolic Image;

IRecordNaturalImage :<Type>_Private_-Record_Typecaster .NaturalImage;

CheckNiat uralImage: <Type> PrivateRecordTypecaster.Nat uralImage;

The functions available in the Private Record typecaster are used as follows:

ARecord:=
<Type>_PrivateRecord,_Typecaster .Value (Record SymbolicImage);

I Record_Symbolic Image :
<Type>_PrivateRecordTypecaster. Image (A_Record);

CheckSymbolicImage :=<Type>_Private-Record Typecaster.I Check (Record SymbolicImage);

Public Record :- <Type>_PrivateRecord _Typecaster.SmakePublic:(Private -Record);

Private -Record := <Type> Private_-Record,_Typecaster.
MakePrivate (PublicRecord);

A-Record :
<Type> _PrivateRecord _Typecaster.Value (RecordNatural_Imge);

RecordNaturalImage :=
<Type> _PcivateRecord_Typecaster. Image (A _Record);

CheckNat ural Image :- <Type> _Private Record _Typec-aster.
Check (ordNatural-l~o);
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B.4.5. Wrapper Typecaster Template
The Wrapper Typecaster Template is shown in Appendix C.4.5 and resides in the file named

The name of a typecaster generated from the Wrapper typecaster template will result from

substitution of the placeholder <Type> as in

<Type>_Wrapper._Typecaster => ProbabilityWrapper_Typecaster

The name of the Wrapper type generated in the Wrapper typecaster will result from

substitution of the placeholder <Type> as in

<Type>_WrapperType => Probability_Wrapper_Type

Capabilities I
This package provides the capability to convert between strings representing values of the

discriminant record type <Type>_Wrapper.Type (symbolic images) and values of the
discriminant record type <Type>_Wrpperype (values). It also provides the capability to

check strings for symbolic image validity. The Ada type checking insures the validity of

record values. 3
The package also provides the capability to convert between character string images of

values of the type <Type>_WrapperType (natural images) and values of the type I
<Type>-Wrapper ype (values). It also provides the capability to check character strings for

natural image validity.

When to Use the Template
Use when the symbolic image is a string representing a record of type <Type>_RecorLType

and the presence of the symbolic image is optional.

The discriminant portion of the record is an enumerated type, Availability, whose possible

values are Available or Unavailable. If the information is Available, then the type I
<Type>_ReordType is used for casting. If the information is Unavailable, then the type

UnavailabiityjReason is used for casting.

The Unavailability.Reason portion of the discriminated record <Type>_WrapperType is an

enumerated type whose possible values are Unreported, i.e., no element existed in the report,

or ReportedUnknown, i.e., there was an explicit indication that nothing is known about the I
element.

The <Type> Record_Type portion of the discriminated record <Type>_WrapperType is a I
record containing the following elements:

<tl> I
<12>
<E3>
<14>
<1S>
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<z6>
<Z7>
<18>

This package depends on typecasters being defined for all elements of the Ada record
<Type>.RecordLType. This is necessary to access the types of the elements, Symbolicmage
and Natural_Image for the elements, and Value, Image and Check functions.

The record elements are defined by the following Ada types:

<Tl>_Typecaster.<TI> Type
<T2>_Typecaster.<T2>_Type
<T3>._Typecaster.<T3>._Type
<T4>_Tpecaster . <T4>_Type
<TS>_Typecaster. <T5>..Type
<T6>_Typecaster. <T6>..Type
<T7>_Typecastex.<T7>_Type
<TS>_Typecaster.<T8>._Type

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of a Wrapper Typecaster from the

Wrapper typecaster template.

The following global placeholder substitutions need to be made:

e Replace the placeholder <Type> with the Wrapper type, e.g., Probability. It is
not necessary to append -WrapperType to the placeholder <Type>, the template
contains _Wrapperjype in the correct places. See Section B.2 for more details.

e Do the following loop until all record elements are defined:

replace <En> with the name of the nTH element of the record, e.g., replace
<El> with BeamNumber

* replace <Tn> with the type of the nTH element of the record, e.g., replace
<Ti> with Hour

a Search for and remove lines and code blocks with <Tn>'s and <En>'s remaining,
e.g., if the record has 5 elements, then lines containing <T6>..<T8> and
<E6>..<E8> must be removed. Conversely, if the record has more than 8
elements, equivalent lines must be added to the typecaster template.

* Do a search for ?? and fill in the necessary information:

" The value of the boolean, UnreportedNolmagejossible. If true then the
EXR of the message can have a field where no symbolic image is present.
When nothing in the EXR is present for the field, the symbolic image will
contain UnreportedSymbolicNolmage defined below.

I The value of the boolean, UnreportedImagejossible. If true then the
EXR of the message can have a symbolic image present that indicates that
no information regarding the field is available. The symbolic image that
indicates this is defined by UnreportedSymbolicimage.

" The value of an UnreportedSymbolicNolmage. When it is possible for a
field in the EXR to not be present, this is the what will be placed in the
symbolic image to signify that nothing was present.
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" The value of an Unreporte_SymbolicImage. When it is possible for a
field in the EXR to have a value that signifies that no information
regarding the field is available, this is the what will be found in the
symbolic image.

" the canned test cases

" selection of proper output format (bit or character based) to support test
case failure processing

At least one of the two booleans must be true, otherwise there would be no need to use the
wrapper typecaster.

One test procedure is provided in the template, <Type>_WrapperTypecasterTest. The test I
procedure does testing based on a set of canned test cases that the user supplies before
compilation. The test procedure reports on testing problems, e.g., unexpected results.

Appendix D.4.5 shows an example instance (Probability-WrapperTypecaster) of the
Wrapper typecaster template.

How to Use the Typecaster

The Wrapper typecaster can be used by providing the following statements and declarations

within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <ype>
placeholder, shown below, with the proper Ada type. 3

with <Type> Wrapper_Typecaster;

A_Record : <Type>_Wrapper Typecaster.<Type> Wrapper Type;

RecordSymbolic Image <Type>_WrapperTypecaster.Symbolic Image;
CheckSymbolicImage <Type>_Wrapper_Typecaster. Symbolic-Image;

RecordNaturalImage <Type>_WapperTypecaster. NaturalImage;

Check-Natural Image <Type>._Wrappe _Typecaster.Natural_-mge;

The functions available in the Wrapper typecaster are used as follows:

A-Record : <Type>_Wrapper_Typecaster.Value (RecordSymbolicImage);

Record-Symbollc_Image =<Type> _Wrapper _Typecaster. Imge (A .Record);

Check Symbolic Image :

<Type>_Wrapper _Typecaster .Check (RecordSymbolic Image) ;

A-Record := <Type> WrappeTypecaster. Value (Record Natural-Umge);

RecordNatural Imagt -<Type>_WrapperTypecaster. Image (A_.Record);

Check NaturalImage :

<Type>_WrapperTypecaster. Check (RecordNatural Image);

I
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B.5. External Representation TV Template

The EXR TV model solution is captured in one template, the Msg.ICD Template. Figure

7-17 shows the Ada package specification template for the Msg_ICD Template.

B.5.1. ICDMessage Template
The ICDMessage template is shown in Appendix C.5 and resides in the file named

M1(50_ITAZADA

The name of the package generated from the ICDMessage template will result from
substitution of the placeholder <Msg.jd> as in

IHsgId>_lcd => FooBar_Message lcd

Capabilities
This package provides the capability to convert between strings containing fields and
punctuation (an EXR whose format is described by an EXR description) and a UNR. It also
provides the capability to check an EXR for validity (i.e., can the information be parsed, field
by field, without any problems).

When to Use the Template
Use when there is a need to convert between an EXR, and a UNR.

How to Generate an Instance of a Typecaster
The following lines describe how to create an instance of an EXR TV model solution from the
ICD_Message typecaster template.

The following global placeholder substitutions need to be made:

* Replace the placeholder <Msgjd> with the ICD type, e.g., FooBar_Message. It
is not necessary to append Jcd to the placeholder <Msgjd>, the template
contains _lcd in the correct places. See Section B.2 for more details.

*Replace <En> with the name of the nTH field, e.g., replace <El> with
ReportingLocation.

*Replace <Number_-OfCuts> with the number of cuts that need to be made for
the Icd, e.g., replace <NumberOf Cuts> with "0".

* Replace <SymbolicImageWidth> with the width of the symbolic image (UNR).
Note that this should be the same as the Symbolicjmage_Width on the message
typecariter side. The Symbolic Image is a fixed length image.

I Do a search for ?? and fill in the necessary information:
- eotext character - the end-of-text character appearing at the end of the

EXR.

- Fields - defines the field attributes, either bit-based or character-based,
for the EXR. It also contains information about the symbolic image, but
this is derived from the EXR description and the user need not concern
himself. See Section 6.2.1 for an explanation of how to supply this
information.
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" Cuts - describes which fields to cut in the UNR. See Section 6.2.1 for an
explanation of how to supply this information.

" canned test cases (either bit-based or character based)

" selection of the proper output format (bit-based or character-based) to
support test case failure processing

See Section 6.2.1 for a more detailed description of how to specify Fields and Cuts. I
One test procedure is provided in the template, <Msgjd>_Icd_Test. The test procedure

performs canned tests generated by the user on the <Msgjd>_jcd LCD Message Typecaster. I
Appendix D.3.1 shows an example instance (FooBarMessagejCD) of the ICDMessage
template.

How to Use the Typecaster
The ICD Message typecaster can be used by providing the following statements and
declarations within a compilable unit:
NOTE: prior to placing the following lines within the compilable unit, replace the <Type>

placeholder, shown below, with the proper Ada type.

with <NsgXd> Icd;
with Casting CcmonTypes;

An-Icd : Casting_Cocnon_Types.Icd MessageType;
UnVversal_Image : <Hsg_Id>Icd.Symbolic Image;
IcdCheck : Boolean; I
Bad-Position : Integer;

The functions available in the ICD Message typecaster are used as follows:

<Msg_Id> Icd.ChecklIcd(AnIcd, lcd Check, BadPosition);

Universal Image :-
<MsgId>_Icd.E ZtractUniversalImage (An_Icd);

AnIcd := <MsgId> Icd.Construct Icd(UniversalImage);

I
I
I
I

176 CMU/SEI-89-rR- 12 I



I
SECURITY CLASSIFICATION OF THIS PAGE

REPORT DOCUMENTATION PAGE

ms. REpORT SECURITY CLASSIFICATION lb. RESTRICTIVE MARKINGS

I UNCLASSIFIED NONE

2, SECURITY CLASSIFICATION AUTHORITY 3. OISTRIBUTIONIAVAILA8ILITV OF REPORT

N/A APPROVED FOR PUBLIC RELEASE
2b. OECLASS#FICATIONIOOWNGRAOING SCHEOULE DISTRIBUTION UNLIMITED

N/A
4. PER!OAMjG ORGANIZATION REPORT NUMBER(S) S. MONITORING ORGANIZATION REPORT NUMSER(S)

I CU-SEI-89-TR-12 ESD-89-TR-20

6a, NAME OF PERFORMING ORGANIZATION b. OFFICE SYMBOL 7a. NAME OF MONITORING ORGANIZATION

(IF dpplicable)
SOFTWARE ENGINEERING INST. SEI SEI JOINT PROGRAM OFFICE

6c. ADORESS (City. State and ZIP Code) 7b. AOORESS (City. State and ZIP Code)

CARNEGIE-MELLON UNIVERSITY ESD/XRS1
PITTSBURGH, PA 15213 HANSCOM AIR FORCE BASE

ffAN.qrnm_ mA OT73T
a& NAME OF FUNOING/SPONSORING 8b. OFFICE SYMBOL 9. PROCUREMENT INSTRUMENT IDENTIFICATIOW.NUMBER

ORGANIZATION (If appicabl)

I SEI JOINT PROGRAM OFFICE ESD/XRSI F1962885C0003

Be. ADDRESS (City. State and ZIP Code) 10. SOURCE OF FUNDING NOS.

CARNEGIE-MELLON UNIVERSITY PROGRAM PROJECT TASK WORK UNIT

PITTSBURGH, PA 15213 ELEMENT NO. NO. NO. NO.

I63752F NIA NIA NIA

11. TITLE finciude S curity ClasaficationF

A Model Solution for C31 Message Translatio and Validation
U12. PERSONAL AUTHOR(S)

Charles Plinca, Kenneth Lee, Michael Rissman
13a. TYPE OF REPORT 13b. TIME COVERED 14. OATE OF REPORT (Yr.. Mo.. Day) 15. PAGE COUNT

I FINAL I FF40M TO December 1989 176
16. SUPPLEMENTARY NOTATION

APPENDIX C: MTV Model Solution Ada Code, and APPENDIX D: FooBar Message Ada Code
are bound separately.

17. COSATI CODES 18. SUBJECT TERMS (Continue on reuterse if necesary and identiffy by block number)

FIELD GROUP SUB. GR. I

19. ABSTRACT (Continue on ruerse if necesmary and iden tify by bloci number)

This document describes an artifact, the Message Translation and Validation (MTV)
model solution. The MTV model solution is a general solution, written in Ada,

that can be used in a system required to convert between message representations.
These message representations can be character-based, bit-based, and internal
(i.e., Ada values).

This documeat provides designers with enough information to determine whether this
solution is applicable to their particular problem. It gives detailed designers
the information needed to specify solutions to their particular problem using the
MTV model solution. Finally, it describes the MTV model solution in enough detail
to enable a maintainer or adapter to understand the solution.

20. DISTRIBUTIONIAVAILABILITY OF ABSTRACT 21. ABSTRACT SECURITY CLASSIFICATION

I Ut4CLASSIFIEO/UNLIMITED R3 SAME AS RPT. 0 OTIC USERS UNCLASSIFIED, UNLIMITED DISTRIBUTION

22s. NAME OF RESPONSIBLE INDIVIDUAL 22b. TELEPHONE NUMBER 22c. OFFICE SYMBOL

KARL H. SHINGLER ,tnclude Area Code)

I___412 268-7630 SEI JPO,,

DD FORM 1473. 83 APR EDITION OF I JAN 73 IS OBSOLETE.

SECURITY CLASSIFICATION OF THIS PAG;


